管理员重置域成员用户的密码时"无法重置此用户的密码"
备注
Office 365 ProPlus 正在重命名为 适用于企业的 Microsoft 365 应用。 有关此更改的详细信息, 请阅读此博客文章。
问题
请考虑以下方案:用户无法通过使用以前为单一登录 (SSO) 设置的云服务域成员的用户 ID 登录 Microsoft 云服务,如 Office 365、Microsoft Azure 或 Microsoft Intune。 在此方案中,当云服务管理员尝试使用云服务门户或 Azure Active Directory Module for Windows PowerShell 重置用户密码时,管理员会收到以下错误消息:
无法重置此用户的密码。请稍后重试。
原因
如果用户是以前启用了单一登录 (SSO) 且用户 ID 未转换为使用标准身份验证的云服务域的成员,则会发生此问题。
例如,如果使用了以下 cmdlet,Windows PowerShell会出现此问题:
convert-MSOLDomainToStandard –skipuserconversion:$true
解决方案
若要解决此问题,请将用户 ID 转换为非联盟 (标准) 类型。 为此,请按照下列步骤操作:
- 在用于Windows PowerShell的同一个控制台中,键入以下 cmdlet,然后按 Enter:
Convert-MsolFederatedUser -userprincipalname < user ID >备注
在此 cmdlet 中,<ID > 表示用户 ID。
- 为用户提供临时密码。 用户下次登录云服务时,必须更改临时密码,然后才能访问云服务资源。
详细信息
备注
本文Windows PowerShell cmdlet 需要 Azure Active Directory 模块Windows PowerShell。
仍然需要帮助? 转到 Microsoft 社区或 Azure Active Directory 论坛网站。