Visio 2010 中的更改

 

适用于: Office 2010

上一次修改主题: 2016-11-29

本文列出自 Microsoft Office Visio 2007 以来 Microsoft Visio 2010 中的更改以及迁移注意事项。如果要从 Microsoft Office Visio 2003 进行升级,另请参阅 Office Visio 2007 中的更改 (http://go.microsoft.com/fwlink/?linkid=169007\&clcid=0x80)。

本文内容:

  • 新增功能

  • 更改内容

  • 删除内容

  • 迁移注意事项

新增功能

本节重点介绍 Visio 2010 中的新功能。

Fluent UI

Visio 2010 用户界面已经过重新设计,现在使用 Microsoft Office Fluent 用户界面 (UI)。Fluent UI 是在 2007 Microsoft Office system 中首次引入的,它旨在使用户能够更轻松地查找和使用 Office 应用程序提供的完整功能,并保持工作区的干净整齐。有关 Fluent UI 的详细信息,请参阅 Microsoft Office Fluent 用户界面资源中心(该链接可能指向英文页面) (http://go.microsoft.com/fwlink/?linkid=111045\&clcid=0x80)(该链接可能指向英文页面) 中的资源。

功能区

功能区是 Fluent UI 的一部分,旨在优化关键 Visio 设计方案以使其更易于使用。利用功能区,可以更快地访问 Visio 2010 中的所有命令,并且可以在以后更加轻松地添加内容和进行自定义。还可以自定义功能区。例如,您可以创建自定义选项卡和自定义组来包含常用命令。为帮助在页面上充分编辑演示区,还可以在编写期间隐藏功能区。所有现有 Visio 软件开发工具包 (SDK) 示例应用程序将更改为使用 RibbonX 扩展性框架。

Backstage 视图

Microsoft Office Backstage 是 Fluent UI 的一部分,同时也是功能区的辅助功能。可以从“文件”选项卡访问 Backstage 视图,它可帮助您查找用于管理 Visio 绘图的常用功能。(“文件”选项卡取代了 Microsoft Office 早期版本中使用的 Microsoft Office 按钮和“文件”菜单。)Backstage 视图用于管理文件及有关这些文件的数据,例如创建和保存文件,检查隐藏的元数据或个人信息以及设置文件选项。

ShapeSheet IntelliSense

您可能不熟悉 Visio 中的 ShapeSheet 公式,它们类似于 Excel 中的公式,只是您可以使用它们来计划和重新计算形状。ShapeSheet 电子表格存储每个 Visio 形状的信息。在 ShapeSheet 中,以前版本的 Visio 中的公式仍有效。

IntelliSense 是 Visio 2010 中的新增功能。此功能自动查找并自动完成公式。

下面是 ShapeSheet IntelliSense 的某些优点:

  • 关键字查找

  • 关键字自动完成

  • 关键字定义弹出

  • 函数签名提示弹出

  • 括号匹配

  • 开发人员的多行公式输入

  • 支持本地和交叉工作表引用

更改内容

本节总结 Visio 2010 中的更改。

状态栏

从 Visio 2010 的状态栏中删除了下面的状态项,但它们仍显示在“大小和位置”窗口中:

  • X

  • Y

  • 起点 X

  • 起点 Y

  • 终点 X

  • 终点 Y

自定义墨笔

在 Visio 2010 中删除了“自定义墨笔”对话框,该对话框已替换为艺术字和 OneNote 所用的新墨笔模型。Visio 2010 不再在注册表中保存五种不同墨笔的设置。用户不再可以看到“自定义墨笔”对话框的入口点或通过任何方法访问该对话框。用户可以使用“墨迹书写工具”选项卡上的控件来自定义墨笔属性。

按值显示颜色

“按值显示颜色”加载项不再在 Visio 2010 中运行。它替换为数据图形功能集,后者可提供更多功能。您不再可以在“加载项”分层控件中看到“按值显示颜色”加载项。形状不再包含用于打开该加载项的右键单击操作。从调用旧的“按值显示颜色”加载项的形状进行的对象模型调用会导致出现一条有关新数据图形功能的通知并建议查看数据图形帮助文件。

Visual Studio 外接程序/加载项向导

Visio 2010 SDK 中包括的 Visual Studio 外接程序/加载项向导与早期版本中的不同。Visio 2010 SDK 中的这一向导创建 Visio 加载项项目,但不再创建外接程序项目。Microsoft Visual Studio 2010 本身提供了对 Visio 2010 VSTO 外接程序项目的向导支持。

删除内容

本节提供有关 Visio 2010 中删除的功能的信息。

ShapeStudio

已从 Visio 2010 SDK 中删除以前版本的 Visio SDK 中提供的 ShapeStudio 工具。

状态栏

从 Visio 2010 的状态栏中删除了下面的状态项:

  • 起点

  • 终点

  • Dx

  • Dy

  • 对齐

  • 顶部

  • 底部

  • 左对齐

  • 右对齐

  • 平铺

  • 平铺行

  • 平铺列

  • 上级

Fluent UI 中的状态栏关注优先级较高的状态项,其中许多状态项具有添加的可操作实用工具。

“查找形状”功能

Visio 中以前提供的“查找形状”服务器功能使用户能够搜索 Microsoft 网站上安装的形状。这样,便可将其他形状、新形状和更新的形状与本地计算机上已有的形状一起使用。

“查找形状”功能不再像以前版本中那样连接到 Internet 以查找其他 Visio 形状。“查找形状”功能不再连接到管理员可能设置为承载其他形状的其他 Web 服务器。相反,用户必须从 Office Online 下载内容。用户可以使用“更多形状”菜单上的“联机查找形状”命令来访问下载说明。

通过此更改,“查找形状”功能将显示仅在本地计算机上找到的搜索结果。

在 Visio 2010 中,用户可以通过使用“更多形状”菜单上提供的“搜索形状”切换来切换用户界面状态(打开或关闭)。

模具定位

现在针对窗口的垂直方向优化了 Visio 2010 中重新设计的“形状窗口”。因此,在 Visio 2010 中,模具定位在“形状窗口”的左侧或右侧,不再允许将其定位在顶部和底部位置。

迁移注意事项

本节提供了有关在从 Microsoft Office Visio 2007 迁移到 Microsoft Visio 2010 时管理员应考虑的功能和更改的信息。一个显著的更改是 Visio 已加入其他 Microsoft Office 产品设计过程并使用 Microsoft Office Fluent 用户界面 (UI)。在 Visio 2010 中,可使用功能区、快速访问工具栏和 Microsoft Office Backstage 视图导航各项功能。

流程存储库

在 Visio 2010 中,您可以轻松管理通常存储在网络文件共享位置的流程图集合。您可以确保您在编辑最新版本并在对流程图进行任何更改时更新用户。对于管理这些文档存储库的许多管理员和经理来说,确保流程图符合内部标准并跟踪所涉及的所有流程至关重要。Visio 流程存储库是 Microsoft SharePoint Server 2010 中包括的新网站模板,它使用 SharePoint Server 2010 中的协作功能,其中包括:

  • 签入/签出

  • 版本控制

  • 工作流

这些功能与 Visio 2010 中的几个新流程管理功能相集成。因此,通过单击几下,SharePoint 管理员便可创建已预先配置的 Visio 流程存储库,从而简化 Visio 流程图的存储和管理过程。存储库网站包含文档库、任务列表和讨论板。流程图文档库旨在存储流程并预先填充了几个可用于创建新流程图的模板。

将流程图发布到存储库

在发布流程图之前,您可以使用验证功能来检查流程图是否存在验证问题。在准备好后,可以使用 Backstage 视图中的“保存到 SharePoint”布告栏将文档保存回存储库。若要将文档保存到存储库,请按照下列步骤操作:

  1. 在 Backstage 视图中,单击“文件”选项卡。

  2. 单击“保存并发送”。

  3. 在“保存并发送”下,单击“保存到 SharePoint”。

  4. 选择所需的流程图文档库和文件类型。

  5. 单击“另存为”以保存文档。

  6. 此时,流程图将列在流程图文档库中。该文档库包含两个特殊列:

    1. 关键字   该列显示文档库中每个跨职能流程图的泳道标题。

    2. 类别   该列显示每个文档的验证状态。在与 Visio 2010 中的“图表验证”功能结合使用时,管理员和经理可以更加轻松地监视存储库中的流程是否符合其组织标准。

因为流程存储库是在 SharePoint Server 2010 的基础上构建的,所以您可以利用其他 SharePoint 功能。例如,您可以:

Visio Viewer

Visio Viewer 2002 和 Visio Viewer 2003 已停用。如果您使用的是 Visio Viewer 2007,请确保您具有最新升级或您可以移动到 Visio 2010 (Beta) Viewer。Visio 2010 Viewer 具有以前查看器的所有功能,并包括所有安全修补程序。如果您不希望更新为 Visio 2010 Viewer,则必须按照下列步骤更新您的现有查看器:

  1. 如果您使用的是 Viewer 2002 或 Viewer 2003,请卸载它,然后安装 Visio 2007 Viewer。

  2. 安装 Visio Viewer 2007 Service Pack 1。

  3. 安装 Visio Viewer 2007 的安全更新。有关详细信息,请参阅 Microsoft 知识库文章 973709:Microsoft Office Visio Viewer 2007 安全更新程序 (http://go.microsoft.com/fwlink/?linkid=184092\&clcid=0x80)。

您还可以使用 Microsoft Update 更新查看器。不过,这可能需要多次运行 Microsoft Update 来下载相关更新。

自定义和选项

在 Visio 2010 中,可以进行许多设置和自定义以个性化用户体验。有关详细信息,请参阅 规划 Visio 2010 的自定义和选项

VBA 设置迁移

在 Office 2010 中,Visual Basic for Applications (VBA) 6.0 已更新为 VBA 7.0。迁移后,VBA 7.0 设置被重置为其默认值,而不是自动重新填充。出现这种情况的原因在于,VBA 的注册表设置在 Office 2010 中位于不同的配置单元中,如下表所示。

版本 注册表子项

Office 2000 至 Office 2007

HKEY_CURRENT_USER\SOFTWARE\Microsoft\VBA\6.0\Common

Office 2010

HKEY_CURRENT_USER\SOFTWARE\Microsoft\VBA\7.0\Common

为了纠正此问题,请将 VBA 6.0 注册表项从 6.0 配置单元复制到 7.0 配置单元。

有关详细信息,请参阅要迁移到 Office 2010 的用户注册表设置以及 32 位和 64 位版本 Office 2010 之间的兼容性 (http://go.microsoft.com/fwlink/?linkid=185841\&clcid=0x80)。