Microsoft 安全公告 MS14-057 - 严重

.NET Framework 中的漏洞可能允许远程执行代码 (3000414)

发布日期: 2014 年 10 月 14 日

版本: 1.0

一般信息

摘要

此安全更新可解决 Microsoft .NET Framework 中三个秘密报告的漏洞。如果攻击者将包含国际字符的特制 URI 请求发送到 .NET Web 应用程序,则其中最严重的漏洞可能允许远程执行代码。在 .NET 4.0 及更低版本的应用程序中,容易受到攻击的功能 (iriParsing) 默认情况下被禁用;要利用该漏洞,应用程序必须明确启用此功能。在 .NET 4.5 应用程序中,iriParsing 默认情况下启用,不能被禁用。

对于 Microsoft Windows 所有受影响版本上的 Microsoft .NET Framework 2.0 Service Pack 2、Microsoft .NET Framework 3.5、Microsoft .NET Framework 3.5.1、Microsoft .NET Framework 4 和 Microsoft .NET Framework 4.5/4.5.1/4.5.2,此安全更新的等级为“严重”。有关详细信息,请参阅“受影响的软件”部分。

该安全更新通过改进 Microsoft .NET Framework 与 ClickOnce 安装程序进程通信的方式、更正它处理特制请求的方式,以及帮助确保 Microsoft .NET Framework 的受影响版本正确实施 ASLR 安全功能来解决这些漏洞。有关漏洞的详细信息,请参阅本公告后面特定漏洞的“常见问题 (FAQ)”小节。

建议。 大多数客户均启用了自动更新,他们不必采取任何操作,因为此安全更新将自动下载并安装。有关自动更新中的特定配置选项的信息,请参阅 Microsoft 知识库文章 294871。对于未启用了自动更新的客户,可以使用打开或关闭自动更新中的的步骤启用自动更新。

对于管理员和企业安装,或者想要手动安装此安全更新的最终用户(包括未启用自动更新的客户),Microsoft 建议客户尽早使用更新管理软件来应用此更新,或者使用 Microsoft Update 服务来检查更新。更新也可以通过本公告“受影响的软件”表中的下载链接获取。

另请参阅本公告后面部分中的“检测和部署工具及指导”一节。

知识库文章

  • 知识库文章3000414
  • 文件信息: 是
  • SHA1/SHA2 哈希: 是
  • 已知问题: 无

受影响的软件

以下软件版本会受到影响。未列出的版本的支持生命周期已结束或者不受影响。要确定软件版本的技术支持生命周期,请参阅 Microsoft 技术支持生命周期

操作系统

组件

最大安全影响

综合严重等级

替代的更新

Windows Server 2003

Windows Server 2003 Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

远程执行代码

严重

MS12-016 中的 2633880

Windows Server 2003 Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

特权提升

重要

Windows Server 2003 Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2003 Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2003 x64 Edition Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

远程执行代码

严重

MS12-016 中的 2633880

Windows Server 2003 x64 Edition Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

特权提升

重要

Windows Server 2003 x64 Edition Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2003 x64 Edition Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2003 SP2(用于基于 Itanium 的系统)

Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

远程执行代码

严重

MS12-016 中的 2633880

Windows Server 2003 SP2(用于基于 Itanium 的系统)

Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

特权提升

重要

Windows Server 2003 SP2(用于基于 Itanium 的系统)

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2003 SP2(用于基于 Itanium 的系统)

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Vista

Windows Vista Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

安全功能绕过

重要

Windows Vista Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

远程执行代码

严重

MS12-016 中的 2633874

Windows Vista Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

特权提升

重要

Windows Vista Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Vista Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Vista Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Vista Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

安全功能绕过

重要

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

远程执行代码

严重

MS12-016 中的 2633874

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

特权提升

重要

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Vista x64 Edition Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2008

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

安全功能绕过

重要

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

远程执行代码

严重

MS12-016 中的 2633874

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

特权提升

重要

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Server 2008(用于 32 位系统)Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

安全功能绕过

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

远程执行代码

严重

MS12-016 中的 2633874

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

特权提升

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

安全功能绕过

重要

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

远程执行代码

严重

MS12-016 中的 2633874

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

特权提升

重要

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows 7

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2968294)

安全功能绕过

重要

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2972100)

远程执行代码

严重

MS12-016 中的 2633873

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2979570)

特权提升

重要

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows 7(用于 32 位系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2968294)

安全功能绕过

重要

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2972100)

远程执行代码

严重

MS12-016 中的 2633873

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2979570)

特权提升

重要

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows 7(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2008 R2

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2968294)

安全功能绕过

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2972100)

远程执行代码

严重

MS12-016 中的 2633873

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2979570)

特权提升

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2968294)

安全功能绕过

重要

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2972100)

远程执行代码

严重

MS12-016 中的 2633873

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1

Microsoft .NET Framework 3.5.1
(2979570)

特权提升

重要

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows 8 和 Windows 8.1

Windows 8(用于 32 位系统)

Microsoft .NET Framework 3.5
(2968295)

安全功能绕过

重要

Windows 8(用于 32 位系统)

Microsoft .NET Framework 3.5
(2972101)

远程执行代码

严重

Windows 8(用于 32 位系统)

Microsoft .NET Framework 3.5
(2979571)

特权提升

重要

Windows 8(用于 32 位系统)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

远程执行代码

严重

Windows 8(用于 32 位系统)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

特权提升

重要

Windows 8(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2968295)

安全功能绕过

重要

Windows 8(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2972101)

远程执行代码

严重

Windows 8(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2979571)

特权提升

重要

Windows 8(用于基于 x64 的系统)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

远程执行代码

严重

Windows 8(用于基于 x64 的系统)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

特权提升

重要

Windows 8.1(用于 32 位系统)

Microsoft .NET Framework 3.5
(2968296)

安全功能绕过

重要

Windows 8.1(用于 32 位系统)

Microsoft .NET Framework 3.5
(2972103)

远程执行代码

严重

Windows 8.1(用于 32 位系统)

Microsoft .NET Framework 3.5
(2979573)

特权提升

重要

Windows 8.1(用于 32 位系统)

Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

远程执行代码

严重

Windows 8.1(用于 32 位系统)

Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

特权提升

重要

Windows 8.1(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2968296)

安全功能绕过

重要

Windows 8.1(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2972103)

远程执行代码

严重

Windows 8.1(用于基于 x64 的系统)

Microsoft .NET Framework 3.5
(2979573)

特权提升

重要

Windows 8.1(用于基于 x64 的系统)

Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

远程执行代码

严重

Windows 8.1(用于基于 x64 的系统)

Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

特权提升

重要

Windows Server 2012 和 Windows Server 2012 R2

Windows Server 2012

Microsoft .NET Framework 3.5
(2968295)

安全功能绕过

重要

Windows Server 2012

Microsoft .NET Framework 3.5
(2972101)

远程执行代码

严重

Windows Server 2012

Microsoft .NET Framework 3.5
(2979571)

特权提升

重要

Windows Server 2012

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

远程执行代码

严重

Windows Server 2012

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

特权提升

重要

Windows Server 2012 R2

Microsoft .NET Framework 3.5
(2968296)

安全功能绕过

重要

Windows Server 2012 R2

Microsoft .NET Framework 3.5
(2972103)

远程执行代码

严重

Windows Server 2012 R2

Microsoft .NET Framework 3.5
(2979573)

特权提升

重要

Windows Server 2012 R2

Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

远程执行代码

严重

Windows Server 2012 R2

Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

特权提升

重要

Windows RT 和 Windows RT 8.1

Windows RT

Microsoft .NET Framework 4.5/4.5.1/4.5.2[2]
(2978042)

远程执行代码

严重

Windows RT

Microsoft .NET Framework 4.5/4.5.1/4.5.2[2]
(2979577)

特权提升

重要

Windows RT 8.1

Microsoft .NET Framework 4.5.1/4.5.2[2]
(2978041)

远程执行代码

严重

Windows RT 8.1

Microsoft .NET Framework 4.5.1/4.5.2[2]
(2979576)

特权提升

重要

服务器核心安装选项

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 3.5.1
(2968294)

安全功能绕过

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 3.5.1
(2972100)

远程执行代码

严重

MS12-016 中的 2633873

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 3.5.1
(2979570)

特权提升

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 4[1]
(2972106)

远程执行代码

严重

MS12-016 中的 2633870

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 4[1]
(2979575)

特权提升

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

远程执行代码

严重

2729460MS12-074 中的 2729460

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

特权提升

重要

Windows Server 2012(服务器核心安装)

Microsoft .NET Framework 3.5
(2968295)

安全功能绕过

重要

Windows Server 2012(服务器核心安装)

Microsoft .NET Framework 3.5
(2972101)

远程执行代码

严重

Windows Server 2012(服务器核心安装)

Microsoft .NET Framework 3.5
(2979571)

特权提升

重要

Windows Server 2012(服务器核心安装)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

远程执行代码

严重

Windows Server 2012(服务器核心安装)

Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

特权提升

重要

Windows Server 2012 R2(服务器核心安装)

Microsoft .NET Framework 3.5
(2968296)

安全功能绕过

重要

Windows Server 2012 R2(服务器核心安装)

Microsoft .NET Framework 3.5
(2972103)

远程执行代码

严重

Windows Server 2012 R2(服务器核心安装)

Microsoft .NET Framework 3.5
(2979573)

特权提升

重要

Windows Server 2012 R2(服务器核心安装)

Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

远程执行代码

严重

Windows Server 2012 R2(服务器核心安装)

Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

特权提升

重要

[1].NET Framework 4 和 .NET Framework 4 Client Profile 受影响。两种配置文件中提供 .NET Framework 版本 4 可再次分发程序包: .NET Framework 4 和 .NET Framework 4 客户端配置文件。.NET Framework 4 Client Profile 是 .NET Framework 4 的子集。此更新中解决的漏洞同时影响 .NET Framework 4 和 .NET Framework 4 Client Profile。有关详细信息,请参阅 MSDN 文章“安装 .NET Framework”。

[2]此更新通过 Windows Update 提供。

更新常见问题

我如何确定安装了哪个版本的 Microsoft .NET Framework?
您可以在一个系统上安装和运行多个版本的 .NET Framework,也可以按任何顺序安装各个版本。有多种方式确定当前安装的 .NET Framework 版本。有关详细信息,请参阅 Microsoft 知识库文章 318785

.NET Framework 4 和 .NET Framework 4 客户端配置文件有什么区别?
两种配置文件中提供 .NET Framework 版本 4 可再次分发程序包: .NET Framework 4 和 .NET Framework 4 客户端配置文件。.NET Framework 4 客户端配置文件是针对客户端应用程序进行优化的 .NET Framework 4 配置文件的子集。它提供适用于大多数客户端应用程序的功能,包括 Windows Presentation Foundation (WPF)、Windows Forms、Windows Communication Foundation (WCF) 和 ClickOnce 功能。这可加快针对 .NET Framework 4 客户端配置文件的应用程序的部署速度并减小安装程序包。有关详细信息,请参阅 MSDN 文章“.NET Framework 客户端配置文件”。

.NET 服务终结点之间通信的最佳做法是什么?
Microsoft 的规定最佳做法建议是,.NET 托管的应用程序使用 Windows Communication Foundation (WCF) 将数据作为异步消息从一个服务终结点发送到另一个服务终结点。WCF 包括重要功能、性能和安全改进,我们强烈建议客户在构建面向服务的应用程序时使用 WCF 框架。我们还建议使用较旧的 IPC 技术(如 DCOM 或 Remoting)更新 .NET 托管的现有应用程序以便使用 WCF。

有关 WCF 的其他指导,请访问下列资源:

有多个更新程序包适用于一些受影响的软件。我需要安装“受影响的软件”表中针对该软件列出的所有更新吗?
是。客户应该应用为他们的系统上安装的软件提供的所有更新。

我需要按特定顺序安装这些安全更新吗?
否。给定系统的多个更新可以按任意顺序应用。

我正在使用本安全公告中讨论的软件的较旧版本。我该怎么办?
已对本公告中列出的受影响的软件进行测试,以确定受到影响的版本。其他版本的支持生命周期已结束。有关产品生命周期的详细信息,请参阅 Microsoft 产品技术支持生命周期网站。

使用该软件的较旧版本的客户应优先考虑迁移到受支持的版本,以防止可能会受到新出现漏洞的影响。要确定您的软件版本的技术支持生命周期,请参阅选择一项产品以获取生命周期信息。有关这些软件版本的 Service Pack 的详细信息,请参阅Service Pack 生命周期支持策略

如果用户需要获得较旧软件的定制支持,则必须与其 Microsoft 客服小组代表、其技术客户经理或适当的 Microsoft 合作伙伴代表联系以了解定制支持选项。没有联合合同、优先支持合同或授权合同的客户可与其当地的 Microsoft 销售分支机构联系。有关联系信息,请参阅 Microsoft Worldwide Information 网站,在联系信息列表中选择国家/地区,然后单击“Go”以查看电话号码列表。在拨打电话时,请找当地的“企业技术咨询支持服务”销售经理进行洽谈。有关详细信息,请参阅 Microsoft 技术支持生命周期策略常见问题

严重等级和漏洞标识符

以下严重等级假设漏洞的可能的最大影响。有关此安全公告发布 30 天内,漏洞利用的安全等级和安全影响的可能性的信息,请参阅 10 月份公告摘要中的利用指数。有关详细信息,请参阅 Microsoft 利用指数

按受影响软件列出的漏洞严重等级和最大安全影响

受影响的软件

.NET ClickOnce 特权提升漏洞 - CVE-2014-4073

.NET Framework 远程执行代码漏洞 - CVE-2014-4121

.NET ASLR 漏洞 - CVE-2014-4122

综合严重等级

Microsoft .NET Framework 2.0 Service Pack 2

安装在 Microsoft Windows Server 2003 Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

不适用

严重
远程执行代码

不适用

严重

安装在 Microsoft Windows Server 2003 Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

重要
特权提升

不适用

不适用

重要

安装在 Microsoft Windows Server 2003 x64 Edition Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

不适用

严重
远程执行代码

不适用

严重

安装在 Microsoft Windows Server 2003 x64 Edition Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

重要
特权提升

不适用

不适用

重要

安装在 Microsoft Windows Server 2003(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972105)

不适用

严重
远程执行代码

不适用

严重

安装在 Microsoft Windows Server 2003(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979574)

重要
特权提升

不适用

不适用

重要

Windows Vista Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

不适用

不适用

重要
安全功能绕过

重要

Windows Vista Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

不适用

严重
远程执行代码

不适用

严重

Windows Vista Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

重要
特权提升

不适用

不适用

重要

Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

不适用

不适用

重要
安全功能绕过

重要

Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

不适用

严重
远程执行代码

不适用

严重

Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

重要
特权提升

不适用

不适用

重要

Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

重要
特权提升

不适用

不适用

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

重要
特权提升

不适用

不适用

重要

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2968292)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2972098)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 2.0 Service Pack 2
(2979568)

重要
特权提升

不适用

不适用

重要

Microsoft .NET Framework 3.5

Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2968295)

不适用

不适用

重要
安全功能绕过

重要

Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2972101)

不适用

严重
远程执行代码

不适用

严重

Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2979571)

重要
特权提升

不适用

不适用

重要

Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2968295)

不适用

不适用

重要
安全功能绕过

重要

Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2972101)

不适用

严重
远程执行代码

不适用

严重

Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2979571)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 上的 Microsoft .NET Framework 3.5
(2968295)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2012 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2968295)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2012 上的 Microsoft .NET Framework 3.5
(2972101)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2972101)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 上的 Microsoft .NET Framework 3.5
(2979571)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2979571)

重要
特权提升

不适用

不适用

重要

Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2968296)

不适用

不适用

重要
安全功能绕过

重要

Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2972103)

不适用

严重
远程执行代码

不适用

严重

Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 3.5
(2979573)

重要
特权提升

不适用

不适用

重要

Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2968296)

不适用

不适用

重要
安全功能绕过

重要

Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2972103)

不适用

严重
远程执行代码

不适用

严重

Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5
(2979573)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5
(2968296)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2968296)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5
(2972103)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2972103)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5
(2979573)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5(服务器核心安装)
(2979573)

重要
特权提升

不适用

不适用

重要

Microsoft .NET Framework 3.5.1

Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2968294)

不适用

不适用

重要
安全功能绕过

重要

Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2972100)

不适用

严重
远程执行代码

不适用

严重

Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2979570)

重要
特权提升

不适用

不适用

重要

Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2968294)

不适用

不适用

重要
安全功能绕过

重要

Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2972100)

不适用

严重
远程执行代码

不适用

严重

Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2979570)

重要
特权提升

不适用

不适用

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2968294)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1(服务器核心安装)
(2968294)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2972100)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1(服务器核心安装)
(2972100)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1
(2979570)

重要
特权提升

不适用

不适用

重要

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1(服务器核心安装)
(2979570)

重要
特权提升

不适用

不适用

重要

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1:
(2968294)

不适用

不适用

重要
安全功能绕过

重要

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1:
(2972100)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1:
(2979570)

重要
特权提升

不适用

不适用

重要

Microsoft .NET Framework 4

安装在 Windows Server 2003 Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2003 Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2003 x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2003 x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2003 SP2(用于基于 Itanium 的系统)上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2003 SP2(用于基于 Itanium 的系统)上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

Windows Vista Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

Windows Vista Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 4*
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 4*
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4(服务器核心安装)
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4(服务器核心安装)
(2979575)[1]

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2972106)[1]

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 4
(2979575)[1]

重要
特权提升

不适用

不适用

重要

Microsoft .NET Framework 4.5/4.5.1/4.5.2

安装在 Windows Vista Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Vista Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Vista x64 Edition Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008(用于 32 位系统)Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 4/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 2 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows 7(用于 32 位系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows 7(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2(服务器核心安装)
(2972107)

不适用

严重
远程执行代码

不适用

严重

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979578)

重要
特权提升

不适用

不适用

重要

安装在 Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2(服务器核心安装)
(2979578)

重要
特权提升

不适用

不适用

重要

Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

不适用

严重
远程执行代码

不适用

严重

Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

重要
特权提升

不适用

不适用

重要

Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

不适用

严重
远程执行代码

不适用

严重

Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

重要
特权提升

不适用

不适用

重要

Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

不适用

严重
远程执行代码

不适用

严重

Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

重要
特权提升

不适用

不适用

重要

Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

不适用

严重
远程执行代码

不适用

严重

Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2(服务器核心安装)
(2978042)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2(服务器核心安装)
(2979577)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 R2 上的 Microsoft .NET Framework 4.5.1/4.5.2(服务器核心安装)
(2978041)

不适用

严重
远程执行代码

不适用

严重

Windows Server 2012 R2 上的 Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

重要
特权提升

不适用

不适用

重要

Windows Server 2012 R2 上的 Microsoft .NET Framework 4.5.1/4.5.2(服务器核心安装)
(2979576)

重要
特权提升

不适用

不适用

重要

Windows RT 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2978042)

不适用

严重
远程执行代码

不适用

严重

Windows RT 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2
(2979577)

重要
特权提升

不适用

不适用

重要

Windows RT 8.1 上的 Microsoft .NET Framework 4.5.1/4.5.2
(2978041)

不适用

严重
远程执行代码

不适用

严重

Windows RT 8.1 上的 Microsoft .NET Framework 4.5.1/4.5.2
(2979576)

重要
特权提升

不适用

不适用

重要

[1].NET Framework 4 和 .NET Framework 4 Client Profile 受影响。两种配置文件中提供 .NET Framework 版本 4 可再次分发程序包: .NET Framework 4 和 .NET Framework 4 客户端配置文件。.NET Framework 4 Client Profile 是 .NET Framework 4 的子集。此更新中解决的漏洞同时影响 .NET Framework 4 和 .NET Framework 4 Client Profile。有关详细信息,请参阅 MSDN 文章“安装 .NET Framework”。

.NET ClickOnce 特权提升漏洞 - CVE-2014-4073

Microsoft .NET Framework 中存在一个特权提升漏洞,可能允许攻击者在目标系统上提升特权。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2014-4073

缓解因素

Microsoft 并未发现此漏洞的任何缓解因素。

变通办法

Microsoft 并未发现此漏洞的任何变通办法。

常见问题

这些漏洞的影响范围有多大?
这是一个特权提升漏洞。

造成此漏洞的原因是什么?
当 Microsoft .NET Framework 在验证之前意外地处理数据时,会导致该漏洞。

什么是 ClickOnce?
ClickOnce 是一项部署技术,开发人员可以利用它创建能以最少用户交互安装并运行的自行更新的基于 Windows 的应用程序。

攻击者可能利用此漏洞执行什么操作?
成功利用此漏洞的攻击者可以完全控制受影响的系统。攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

攻击者如何利用此漏洞?
为利用此漏洞,攻击者可能以一种允许 ClickOnce 安装程序进程使用提升特权在保护模式外部运行的方式来破坏 Internet Explorer。

受此漏洞威胁最大的系统有哪些?
运行受影响的 Microsoft .NET Framework 版本的服务器受此漏洞的威胁最大。

此更新有什么作用?
该更新通过改进 Microsoft .NET Framework 与 ClickOnce 安装程序进程进行通信的方式来解决漏洞。

发布此安全公告时,此漏洞是否已公开披露?
否。Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

发布此安全公告时,Microsoft 是否收到任何有关此漏洞已被利用的报告?
否。在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

.NET Framework 远程执行代码漏洞 - CVE-2014-4121

Microsoft .NET Framework 不正确地分析国际化资源标识符的方式中存在一个远程执行代码漏洞。成功利用此漏洞的攻击者可以完全控制受影响的系统。攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。那些帐户被配置为拥有较少系统用户权限的用户比具有管理用户权限的用户受到的影响要小。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2014-4121

缓解因素

缓解是指一种设置、通用配置或者一般的最佳实践,它以默认状态存在,能够降低利用漏洞的严重性。以下缓解因素在您遇到的情形中可能会有所帮助:

  • 在 .NET 4.0 及更低版本的应用程序中,iriParsing 默认情况下被禁用;要利用该漏洞,应用程序必须通过在 app.config 文件中设置 <iriParsing enabled="true"/> 来明确启用此功能。有关详细信息,请参阅 <iriParsing> 元素(Uri 设置)。在 .NET 4.5 应用程序中,iriParsing 默认情况下启用,不能被禁用。有关详细信息,请参阅 .NET Framework 4.5 中的应用程序兼容性

变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 对于 .NET 4.0 及更低版本的应用程序,禁用 iriParsing

    对于 .NET 4.0 及更低版本的应用程序,将 iriParsing 的设置为“false”。有关详细信息,请参阅 <iriParsing> 元素(Uri 设置)

    注意 对于 .NET 4.5 应用程序,不能禁用此选项。有关详细信息,请参阅 .NET Framework 4.5 中的应用程序兼容性

    变通办法的影响。System.Uri 将无法正确分析国际化资源标识符。

常见问题

这些漏洞的影响范围有多大?
这是一个远程执行代码漏洞。

造成此漏洞的原因是什么?
当 Microsoft .NET framework 未能正确分析特制国际化资源标识符而导致内存损坏时,会导致该漏洞。

攻击者可能利用此漏洞执行什么操作?
成功利用此漏洞的攻击者可以在 .NET Web 应用程序的上下文中运行任意代码。攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。如果 .NET Web 应用程序使用管理用户权限运行,攻击者便可完全控制受影响的系统。配置为拥有较少用户权限的 .NET Web 应用程序比具有管理用户权限的用户受到的影响要小。

攻击者如何利用此漏洞?
为利用此漏洞,攻击者可能会将包含国际字符的特制 URI 请求发送到 .NET Web 应用程序。

受此漏洞威胁最大的系统有哪些?
运行受影响的 Microsoft .NET Framework 版本的服务器受此漏洞的威胁最大。

此更新有什么作用?
此更新通过更正 .NET Framework 处理特制请求的方式来解决此漏洞。

发布此安全公告时,此漏洞是否已公开披露?
否。Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

发布此安全公告时,Microsoft 是否收到任何有关此漏洞已被利用的报告?
否。在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

.NET ASLR 漏洞 - CVE-2014-4122

Microsoft .NET Framework 中存在一个安全功能绕过漏洞,让攻击者能够绕过地址空间布局随机化 (ASLR) 安全功能,该安全功能有助于保护用户免遭多种漏洞攻击。该安全功能绕过本身不允许执行任意代码。但是,攻击者可以将此 ASLR 绕过漏洞与另一个漏洞(如远程执行代码漏洞)组合使用,从而利用 ASLR 绕过漏洞来运行任意代码。

要在“常见漏洞和披露”列表中以标准条目查看此漏洞,请参阅 CVE-2014-4122

缓解因素

Microsoft 并未发现此漏洞的任何缓解因素。

变通办法

变通办法是指一种设置或配置更改,它不能从根本上纠正漏洞,但有助于在应用更新之前封堵已知的攻击源。Microsoft 已测试了以下变通方法,并在讨论中指明了变通方法是否会降低功能性:

  • 安装 Force ASLR 功能修补程序并启用 IFEO 注册表项

    Force ASLR 功能是 Windows 7 或 Windows Server 2008 R2 的 ASLR 功能的补充,使应用程序或许能够强制性地重新定位非使用 /DYNAMICBASE 链接器标志构建的映像。安装后,计算机管理员和软件开发人员可以在注册表中启用映像文件执行选项 (IFEO) 来为非 ASLR 映像强制 ASLR 行为。

    有关详细信息和安装说明,请参阅 Microsoft 知识库文章 2639308

    变通办法的影响。 强制性地重新定位非使用 ASLR 支持构建的映像,这可能导致应用程序兼容性问题。

    如何撤消变通方法。

    注意 有关将 IFEO 注册表项设置为默认设置的信息,请参阅 Microsoft 知识库文章 2639308

常见问题

这些漏洞的影响范围有多大?
这是一个安全功能绕过漏洞。

造成此漏洞的原因是什么?
如果 Microsoft .NET Framework 不使用地址空间布局随机化 (ASLR) 安全功能,此漏洞就存在,从而让攻击者能够更可靠地预测给定调用堆栈中特定指令的内存偏移。

什么是 ASLR?
地址空间布局随机化 (ASLR) 可在系统启动时将可执行映像移动到随机位置,从而帮助防止攻击者利用可预测位置的数据。为使组件支持 ASLR,它加载的所有组件还必须支持 ASLR。例如,如果 A.exe 使用 B.dll 和 C.dll,则所有这三者都必须支持 ASLR。默认情况下,Windows Vista、Windows Server 2008、Windows7、Windows Server 2008 R2、Windows 8、Windows 8.1、Windows RT、Windows RT 8.1、Windows Server 2012 和 Windows Server 2012 R2 将随机化系统 DLL 和 EXE,但是独立软件供应商 (ISV) 创建的 DLL 和 EXE 必须使用 /DYNAMICBASE 链接器选项选择加入才能支持 ASLR。

ASLR 还会随机化堆和堆栈内存:

  • 当应用程序在 Windows Vista、Windows Server 2008、Windows 7、Windows Server 2008 R2、Windows 8、Windows 8.1、Windows RT、Windows RT 8.1、Windows Server 2012 和 Windows Server 2012 R2 中创建堆时,堆管理器将在一个随机位置创建该堆,从而减少尝试利用基于堆的缓冲区溢出而成功的机会。Windows Vista 及更高版本上的所有应用程序默认启用堆随机化。
  • 当线程在与 /DYNAMICBASE 链接的进程中启动时,Windows Vista、Windows Server 2008、Windows 7、Windows Server 2008 R2、Windows 8、Windows 8.1、Windows RT、Windows RT 8.1、Windows Server 2012 和 Windows Server 2012 R2 会将线程的堆栈移动到一个随机位置,以帮助减少利用基于堆栈的缓冲区溢出获得成功的机会。

攻击者可能利用此漏洞执行什么操作?
成功利用此漏洞的攻击者可能会绕过 ASLR 安全功能。该安全功能绕过本身不允许执行任意代码。但是,攻击者可能会将此 ASLR 绕过漏洞与另一个漏洞(例如,可能利用 ASLR 绕过的远程执行代码漏洞)组合使用来运行任意代码。

攻击者如何利用此漏洞?
在基于 Web 的攻击情形中,攻击者可能拥有一个网站用于试图利用此漏洞。另外,接受或宿主用户提供的内容的网站以及受到破坏的网站可能包含可能利用此漏洞的特制内容。攻击者无法强迫用户访问特制的网站。相反,攻击者必须说服用户执行操作。例如,攻击者可能哄骗用户单击链接以使用户链接到攻击者的网站。

当用户使用能够实例化 COM 组件(如 Internet Explorer)的 Web 浏览器访问包含恶意内容的网站时,可以加载受影响的 .NET Framework 组件以绕过 ASLR。

攻击者可以将此安全功能绕过漏洞与其他漏洞(通常是远程执行代码漏洞)结合使用。其他漏洞将利用安全功能绕过发起攻击。例如,被 ASLR 阻止的远程执行代码漏洞在成功绕过 ASLR 之后可能会被利用。

受此漏洞威胁最大的系统有哪些?
在 Web 浏览情形中,要成功利用此漏洞,需要用户登录并运行 Microsoft .NET Framework 的受影响版本。因此,频繁使用 Web 浏览器的系统(如工作站或终端服务器)受此漏洞的威胁最大。如果管理员允许用户浏览并读取服务器上的电子邮件,则服务器可能面临更大风险。不过,最佳做法是不要授予这样的权限。

EMET 是否可帮助缓解试图利用这些漏洞的攻击?
是。Enhanced Mitigation Experience Toolkit (EMET) 使用户能够管理安全风险缓解技术,从而使攻击者更难利用指定软件中的漏洞。对于已经安装了 EMET 并配置为可与 Microsoft Office 软件一起工作的系统,EMET 有助于缓解 Microsoft .NET Framework 中的漏洞。

有关 EMET 的详细信息,请参阅 Enhanced Mitigation Experience Toolkit

此更新有什么作用?
此更新通过帮助确保 Microsoft .NET Framework 的受影响版本正确地实现 ASLR 安全功能来解决漏洞。

发布此安全公告时,此漏洞是否已公开披露?
否。Microsoft 通过协调漏洞披露渠道了解到有关此漏洞的信息。

发布此安全公告时,Microsoft 是否收到任何有关此漏洞已被利用的报告?
否。在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

检测和部署工具及指导

许多资源可帮助管理员部署安全更新。

  • 管理员可使用 Microsoft Baseline Security Analyzer (MBSA) 在本地和远程系统中扫描缺少的安全更新和常见的安全配置错误。
  • Windows Server Update Services (WSUS)、Systems Management Server (SMS) 和 System Center Configuration Manager 帮助管理员分发安全更新。
  • Application Compatibility Toolkit 随附的更新兼容性评估程序组件针对安装的应用程序协助简化 Windows 更新的测试和验证。

有关可用的这些工具和其他工具的信息,请参阅 IT 专业人员安全工具

安全更新部署

Windows Server 2003(所有版本)

参考表

下表包含此软件的安全更新信息。





安全更新文件名

对于 Windows Server 2003 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 2.0 Service Pack 2:
NDP20SP2-KB2972105-x86.exe
NDP20SP2-KB2979574-v2-x86.exe


对于 Windows Server 2003 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x86.exe
NDP40-KB2979575-v2-x86.exe


对于 Windows Server 2003 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 2.0 Service Pack 2:
NDP20SP2-KB2972105-x64.exe
NDP20SP2-KB2979574-v2-x64.exe


对于 Windows Server 2003 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x64.exe
NDP40-KB2979575-v2-x64.exe


对于 Windows Server 2003 的所有受支持的基于 Itanium 的版本上安装的 Microsoft .NET Framework 2.0 Service Pack 2:
NDP20SP2-KB2972105-IA64.exe
NDP20SP2-KB2979574-v2-IA64.exe


对于 Windows Server 2003 的所有受支持的基于 Itanium 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-IA64.exe
NDP40-KB2979575-v2-IA64.exe

安装开关

请参阅 Microsoft 知识库文章 934307

更新日志文件

对于 Microsoft .NET Framework 2.0 Service Pack 2:
Microsoft .NET Framework 2.0-KB2972105_*-msi0.txt

Microsoft .NET Framework 2.0-KB2972105_*.html



Microsoft .NET Framework 2.0-KB2979574_*-msi0.txt
Microsoft .NET Framework 2.0-KB2979574_*.html


对于 Microsoft .NET Framework 4:
KB2972106_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt

KB2972106_*_*.html



KB2979575_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt
KB2979575_*_*.html

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,然后单击“安全”。在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 2.0 Service Pack 2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 2.0 Service Pack 2\SP2\KB2972105

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 2.0 Service Pack 2\SP2\KB2979574v2
"ThisVersionInstalled" = "Y"


对于 Windows Server 2003 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows Server 2003 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows Server 2003 的所有受支持的基于 Itanium 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"

Windows Vista(所有版本)

参考表

下表包含此软件的安全更新信息。





安全更新文件名

对于 Windows Vista 的所有受支持的 32 位版本上的 Microsoft .NET Framework 2.0 Service Pack 2:
Windows6.0-KB2968292-x86.msu

Windows6.0-KB2972098-x86.msu
Windows6.0-KB2979568-x86.msu


对于 Windows Vista 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x86.exe
NDP40-KB2979575-v2-x86.exe


对于 Windows Vista 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x86.exe
NDP45-KB2979578-v2-x86.exe


对于 Windows Vista 的所有受支持的基于 x64 的版本上的 Microsoft .NET Framework 2.0 Service Pack 2:
Windows6.0-KB2968292-x64.msu

Windows6.0-KB2972098-x64.msu
Windows6.0-KB2979568-x64.msu


对于 Windows Vista 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x64.exe
NDP40-KB2979575-v2-x64.exe


对于 Windows Vista 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x64.exe
NDP45-KB2979578-v2-x64.exe

安装开关

请参阅 Microsoft 知识库文章 2844699

更新日志文件

对于 Microsoft .NET Framework 2.0 Service Pack 2:
不适用


对于 Microsoft .NET Framework 4:
KB2972106_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt

KB2972106_*_*.html



KB2979575_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt
KB2979575_*_*.html


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
KB[nnnnnnn]_*_*-Microsoft .NET Framework [.NET 目标版本]-MSP0.txt
KB[nnnnnnn]_*_*.html

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,然后单击“安全”。在“Windows Update”下,单击“查看安装的更新”并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 2.0 Service Pack 2:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。


对于 Windows Vista 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows Vista 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]v2
"ThisVersionInstalled" = "Y"

Windows Server 2008(所有版本)

参考表

下表包含此软件的安全更新信息。





安全更新文件名

对于 Windows Server 2008 Service Pack 2 的所有受支持的 32 位版本上的 Microsoft .NET Framework 2.0 Service Pack 2:
Windows6.0-KB2968292-x86.msu

Windows6.0-KB2972098-x86.msu
Windows6.0-KB2979568-x86.msu


对于 Windows Server 2008 Service Pack 2 所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x86.exe
NDP40-KB2979575-v2-x86.exe


对于 Windows Server 2008 Service Pack 2 所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x86.exe
NDP45-KB2979578-v2-x86.exe


对于 Windows Server 2008 Service Pack 2 所有受支持的基于 x64 的版本上的 Microsoft .NET Framework 2.0 Service Pack 2:
Windows6.0-KB2968292-x64.msu

Windows6.0-KB2972098-x64.msu
Windows6.0-KB2979568-x64.msu


对于 Windows Server 2008 Service Pack 2 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x64.exe
NDP40-KB2979575-v2-x64.exe


对于 Windows Server 2008 Service Pack 2 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x64.exe
NDP45-KB2979578-v2-x64.exe


对于 Windows Server 2008 的所有受支持的基于 Itanium 的版本上的 Microsoft .NET Framework 2.0 Service Pack 2:
Windows6.0-KB2968292-ia64.msu

Windows6.0-KB2972098-ia64.msu
Windows6.0-KB2979568-ia64.msu


对于安装在 Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 Microsoft .NET Framework 4:
NDP40-KB2972106-IA64.exe
NDP40-KB2979575-v2-IA64.exe

安装开关

请参阅 Microsoft 知识库文章 2844699

更新日志文件

对于 Microsoft .NET Framework 2.0 Service Pack 2:
不适用


对于 Microsoft .NET Framework 4:
KB2972106_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt

KB2972106_*_*.html



KB2979575_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt
KB2979575_*_*.html


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
KB[nnnnnnn]_*_*-Microsoft .NET Framework [.NET 目标版本]-MSP0.txt
KB[nnnnnnn]_*_*.html

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,然后单击“安全”。在“Windows Update”下,单击“查看安装的更新 ”并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 2.0 Service Pack 2:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。


对于 Windows Server 2008 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows Server 2008 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows Server 2008 的所有受支持的基于 Itanium 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]v2
"ThisVersionInstalled" = "Y"

Windows 7(所有版本)

参考表

下表包含此软件的安全更新信息。






包括在以后的 Service Pack 中

此问题的更新程序将包含在以后的 Service Pack 或更新汇总中。

安全更新文件名

对于 Windows 7 Service Pack 1 所有受支持的 32 位版本上的 Microsoft .NET Framework 3.5.1:
Windows6.1-KB2968294-x86.msu

Windows6.1-KB2972100-x86.msu
Windows6.1-KB2979570-x86.msu


对于 Windows 7 Service Pack 1 所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x86.exe
NDP40-KB2979575-v2-x86.exe


对于 Windows 7 Service Pack 1 所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x86.exe
NDP45-KB2979578-v2-x86.exe


对于 Windows 7 Service Pack 1 所有受支持的基于 x64 的版本上的 Microsoft .NET Framework 3.5.1:
Windows6.1-KB2968294-x64.msu

Windows6.1-KB2972100-x64.msu
Windows6.1-KB2979570-x64.msu


对于 Windows 7 Service Pack 1 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x64.exe
NDP40-KB2979575-v2-x64.exe


对于 Windows 7 Service Pack 1 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x64.exe
NDP45-KB2979578-v2-x64.exe

安装开关

请参阅 Microsoft 知识库文章 2844699

更新日志文件

对于 Microsoft .NET Framework 3.5.1:
不适用。


对于 Microsoft .NET Framework 4:
KB2972106_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt

KB2972106_*_*.html



KB2979575_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt
KB2979575_*_*.html


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
KB[nnnnnnn]_*_*-Microsoft .NET Framework [.NET 目标版本]-MSP0.txt
KB[nnnnnnn]_*_*.html

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,单击“系统和安全性”,然后在“Windows Update”下单击“查看安装的更新”,并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 3.5.1:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。


对于 Windows 7 的所有受支持的 32 位版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


对于 Windows 7 的所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]v2
"ThisVersionInstalled" = "Y"

Windows Server 2008 R2(所有版本)

参考表

下表包含此软件的安全更新信息。






包括在以后的 Service Pack 中

此问题的更新程序将包含在以后的 Service Pack 或更新汇总中。

安全更新文件名

对于 Windows Server 2008 R2 Service Pack 1 所有受支持的基于 x64 的版本上的 Microsoft .NET Framework 3.5.1:
Windows6.1-KB2968294-x64.msu

Windows6.1-KB2972100-x64.msu
Windows6.1-KB2979570-x64.msu


对于 Windows Server 2008 R2 Service Pack 1 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4:
NDP40-KB2972106-x64.exe
NDP40-KB2979575-v2-x64.exe


对于 Windows Server 2008 R2 Service Pack 1 所有受支持的基于 x64 的版本上安装的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
NDP45-KB2972107-x64.exe
NDP45-KB2979578-v2-x64.exe


对于 Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 3.5.1:
Windows6.1-KB2968294-ia64.msu

Windows6.1-KB2972100-ia64.msu
Windows6.1-KB2979570-ia64.msu


对于安装在 Windows Server 2008 R2(用于基于 Itanium 的系统)Service Pack 1 上的 Microsoft .NET Framework 4:
NDP40-KB2972106-IA64.exe
NDP40-KB2979575-v2-IA64.exe

安装开关

请参阅 Microsoft 知识库文章 2844699

更新日志文件

对于 Microsoft .NET Framework 3.5.1:
不适用


对于 Microsoft .NET Framework 4:
KB2972106_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt

KB2972106_*_*.html



KB2979575_*_*-Microsoft .NET Framework 4 Client Profile-MSP0.txt
KB2979575_*_*.html


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
KB[nnnnnnn]_*_*-Microsoft .NET Framework [.NET 目标版本]-MSP0.txt
KB[nnnnnnn]_*_*.html

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,单击“系统和安全性”,然后在“Windows Update”下单击“查看安装的更新”,并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 3.5.1:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。


对于 Microsoft .NET Framework 4:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2972106

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Updates\Microsoft .NET Framework 4 Client Profile\KB2979575v2
"ThisVersionInstalled" = "Y"


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]

"ThisVersionInstalled" = "Y"



HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft .NET Framework [.NET 目标版本]\KB[nnnnnnn]v2
"ThisVersionInstalled" = "Y"

Windows 8 和 Windows 8.1(所有版本)

参考表

下表包含此软件的安全更新信息。






包括在以后的 Service Pack 中

此问题的更新程序将包含在以后的 Service Pack 或更新汇总中。

安全更新文件名

对于 Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 3.5:
Windows8-RT-KB2968295-x86.msu

Windows8-RT-KB2972101-x86.msu
Windows8-RT-KB2979571-x86.msu


对于 Windows 8(用于 32 位系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
Windows8-RT-KB2978042-x86.msu
Windows8-RT-KB2979577-x86.msu


对于 Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5:
Windows8-RT-KB2968295-x64.msu

Windows8-RT-KB2972101-x64.msu
Windows8-RT-KB2979571-x64.msu


对于 Windows 8(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
Windows8-RT-KB2978042-x64.msu
Windows8-RT-KB2979577-x64.msu


对于 Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 3.5:
Windows8.1-KB2968296-x86.msu

Windows8.1-KB2972103-v2-x86.msu
Windows8.1-KB2979573-x86.msu


对于 Windows 8.1(用于 32 位系统)上的 Microsoft .NET Framework 4.5.1/4.5.2:
Windows8.1-KB2978041-x86.msu
Windows8.1-KB2979576-x86.msu


对于 Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 3.5:
Windows8.1-KB2968296-x64.msu

Windows8.1-KB2972103-v2-x64.msu
Windows8.1-KB2979573-x64.msu


对于 Windows 8.1(用于基于 x64 的系统)上的 Microsoft .NET Framework 4.5.1/4.5.2:
Windows8.1-KB2978041-x64.msu
Windows8.1-KB2979576-x64.msu

安装开关

请参阅 Microsoft 知识库文章 2844699

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,单击“系统和安全性”,然后在“Windows Update”下单击“查看安装的更新”,并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

对于 Microsoft .NET Framework 3.5:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。


For Microsoft .NET Framework 4.5/4.5.1/4.5.2:
注意 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。

Windows Server 2012 和 Windows Server 2012 R2(所有版本)

参考表

下表包含此软件的安全更新信息。








包括在以后的 Service Pack 中

此问题的更新程序将包含在以后的 Service Pack 或更新汇总中。

安全更新文件名

对于 Windows Server 2012 上的 Microsoft .NET Framework 3.5:
Windows8-RT-KB2968295-x64.msu

Windows8-RT-KB2972101-x64.msu
Windows8-RT-KB2979571-x64.msu


对于 Windows Server 2012 上的 Microsoft .NET Framework 4.5/4.5.1/4.5.2:
Windows8-RT-KB2978042-x64.msu
Windows8-RT-KB2979577-x64.msu


对于 Windows Server 2012 R2 上的 Microsoft .NET Framework 3.5:
Windows8.1-KB2968296-x64.msu

Windows8.1-KB2972103-v2-x64.msu
Windows8.1-KB2979573-x64.msu


对于 Windows Server 2012 R2 上的 Microsoft .NET Framework 4.5.1/4.5.2:
Windows8.1-KB2978041-x64.msu
Windows8.1-KB2979576-x64.msu

安装开关

请参阅 Microsoft 知识库文章 2844699

重新启动要求

此更新不需要重新启动。安装程序停止所需的服务,应用此更新,然后重新启动这些服务。但是,如果由于某种原因而无法停止所需服务,或者正在使用所需文件,则此更新需要重新启动。如果发生这种情况,将显示一条消息建议您重新启动。

删除信息

单击“控制面板”,单击“系统和安全性”,然后在“Windows Update”下单击“查看安装的更新”,并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

注册表项验证

注 没有用于验证此更新是否存在的注册表项。使用 WMI 检测此更新是否存在。

Windows RT 和 Windows RT 8.1(所有版本)

参考表

下表包含此软件的安全更新信息。











部署

对于 Windows RT 上的 Microsoft .NET Framework 4.5、4.5.1 和 4.5.2:
2978042 更新通过 Windows Update 提供。
2979577 更新通过 Windows Update 提供。


对于 Windows RT 8.1 上的 Microsoft .NET Framework 4.5.1/4.5.2:
2978041 更新通过 Windows Update 提供。
2979576 更新通过 Windows Update 提供

重新启动要求

是,应用此安全更新后必须重新启动系统。

删除信息

单击“控制面板”,单击“系统和安全”,单击“Windows Update”,然后在“另请参阅”下方单击“安装的更新”,并从更新列表中选择。

文件信息

请参阅 Microsoft 知识库文章 3000414

鸣谢


Microsoft 感谢下列人员或组织与我们一起致力于保护客户的利益:

其他信息

Microsoft Active Protections Program (MAPP)

为改进客户的安全保护,Microsoft 在发布每月安全更新之前将向主要的安全软件供应商提供漏洞信息。然后,安全软件供应商可以使用该漏洞信息通过其安全软件或者设备向客户提供更新的保护,例如防病毒、基于网络的入侵检测系统或者基于主机的入侵防止系统。要确定是否可从安全软件供应商处得到活动保护,请转到计划合作伙伴(在 Microsoft Active Protections Program (MAPP) 合作伙伴中列出)提供的活动保护网站。

支持

如何获取此安全更新的帮助和支持

免责声明

Microsoft 知识库中的信息“按原样”提供,没有任何形式的担保。Microsoft 不作任何明示或暗示保证,包括对适销性和针对特定目的的适用性的保证。Microsoft Corporation 或其供应商不对任何损害(包括直接的、间接的、偶然的、必然的损害,商业利润损失,或特殊损害)承担任何责任,即使 Microsoft Corporation 或其供应商事先已被告知有可能发生此类损害。有些州不允许排除或限制必然或偶然损害的赔偿责任,因此上述限制可能不适用。

修订版本

  • V1.0(2014 年 10 月 14 日): 已发布公告。
  • V1.1(2014 年 12 月 10 日):对公告进行了修订,以更正 Microsoft .NET Framework 4.5/4.5.1/4.5.2(更新 2972107)的更新替换条目。

页面生成时间 2014-12-05 10:24Z-08:00。