Microsoft 安全公告 MS15-066 - 严重

VBScript 脚本引擎中的漏洞可能允许远程执行代码 (3072604)

发布日期:2015 年 7 月 14 日

版本: 1.0

执行摘要

此安全更新可解决 Microsoft Windows 的 VBScript 脚本引擎中一个漏洞。如果用户访问经特殊设计的网站,此漏洞可能允许远程执行代码。成功利用此漏洞的攻击者可以获得与当前用户相同的用户权限。如果当前用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。

对于 Windows Server 2003、Windows Vista、Windows Server 2008 和 Windows Server 2008 R2 的服务器核心安装上 VBScript 脚本引擎受影响的版本,此安全更新等级为“严重”。有关详细信息,请参阅“受影响的软件”部分。

此安全更新通过修改 VBScript 脚本引擎处理内存中对象的方式来解决漏洞。有关该漏洞的详细信息,请参阅“漏洞信息”一节。

有关此更新的详细信息,请参阅 Microsoft 知识库文章 3072604

受影响的软件

以下 VBScript 版本已受到本公告中讨论的漏洞的影响。未列出的早期版本的支持生命周期已结束或者不受影响。以下受影响的软件适用于已安装 Internet Explorer 7 或更早版本的系统和未安装 Internet Explorer 的系统。系统运行 Internet Explorer 8 或更高版本的客户应使用 Internet Explorer 累积更新 3065822 (MS15-065),也可以解决此公告中讨论的漏洞。

受影响的软件

操作系统

组件

最大安全影响

综合严重等级

替代的更新*

Windows Server 2003

Windows Server 2003 Service Pack 2

VBScript 5.6
(3068404)

远程执行代码

严重

MS15-019 中的 3030403

Windows Server 2003 Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2003 x64 Edition Service Pack 2

VBScript 5.6
(3068404)

远程执行代码

严重

MS15-019 中的 3030403

Windows Server 2003 x64 Edition Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2003 SP2(用于基于 Itanium 的系统)

VBScript 5.6
(3068404)

远程执行代码

严重

MS15-019 中的 3030403

Windows Server 2003 SP2(用于基于 Itanium 的系统)

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Vista

Windows Vista Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Vista x64 Edition Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2008

Windows Server 2008(用于 32 位系统)Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2008(用于基于 x64 的系统)Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

服务器核心安装

Windows Server 2008(用于 32 位系统)Service Pack 2(服务器核心安装)

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2008(用于基于 x64 的系统)Service Pack 2(服务器核心安装)

VBScript 5.7
(3068368)

远程执行代码

严重

MS15-019 中的 3030398

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1(服务器核心安装)

VBScript 5.8
(3068364)

远程执行代码

严重

MS15-019 中的 3030630

*在取代的更新链中,“替代的更新”列仅显示最新的更新。有关替代的更新的完整列表,请转到 Microsoft 更新目录,搜索更新知识库编号,然后查看刻度更新详细信息(替代的更新信息位于程序包详细信息选项卡)。

更新常见问题

如何判断我的系统上安装的 VBScript 脚本引擎版本?
VBScript 脚本引擎与 Microsoft Windows 受支持版本一起安装。此外,在系统上安装 Internet Explorer 的较新版本可以更改安装的 VBScript 脚本引擎版本。

要确定您的系统上安装的 VBScript 脚本引擎版本,请执行以下步骤:

  1. 打开 Windows Explorer。
  2. 导航到 %systemroot%\system32 目录。
  3. 右键单击 vbscript.dll,选择“属性”,然后单击“详细信息”。

版本号将在“文件版本”字段中列出。如果您的文件版本以 5.8 开头,例如 5.8.7600.16385,则您的系统上安装了 VBScript 5.8。

在我知道了安装在我系统中的 VBScript 脚本引擎版本之后,我去哪里获得更新?
此公告中受影响的软件适用于未安装 Internet Explorer 的系统和已安装 Internet Explorer 8 或更早版本的系统。系统运行 Internet Explorer 9 或更高版本的客户应使用 Internet Explorer 累积更新 (MS15-065),也可以解决此公告中讨论的漏洞。

下表总结了该公告为 VBScript 和 Internet Explorer 提供的更新。




版本

MS15-066

MS15-065

VBScript 5.6
(Internet Explorer 6)

VBScript 5.6
(3068404)

不适用

VBScript 5.7
(Internet Explorer 6 和 Internet Explorer 7)

VBScript 5.7
(3068368)

不适用

VBScript 5.8
(Internet Explorer 8)

VBScript 5.8
(3068364)
(Windows 服务器核心仅安装在 Windows Server 2008 R2 上)

Internet Explorer 8
(3065822)

VBScript 5.8
(Internet Explorer 9)

不适用

Internet Explorer 9
(3065822)

VBScript 5.8
(Internet Explorer 10)

不适用

Internet Explorer 10
(3065822)

VBScript 5.8
(Internet Explorer 11)

不适用

Internet Explorer 11
(3065822)

严重性级别和漏洞标识符

以下严重等级假设漏洞的可能的最大影响。有关此安全公告发布 30 天内,漏洞利用的安全等级和安全影响的可能性的信息,请参阅 7 月份公告摘要中的利用指数。

按受影响软件列出的漏洞严重性级别和最大安全影响

受影响的软件

VBScript 内存损坏漏洞 - CVE-2015-2372

综合严重等级

VBScript 5.6 (Internet Explorer 6)

Windows Server 2003 Service Pack 2 上的 VBScript 5.6
(3068404)

**严重
**远程执行代码

严重

Windows Server 2003 x64 Edition Service Pack 2 上的 VBScript 5.6
(3068404)

**严重
**远程执行代码

严重

Windows Server 2003 SP2(用于基于 Itanium 的系统)上的 VBScript 5.6
(3068404)

**严重
**远程执行代码

严重

VBScript 5.7 (Internet Explorer 7)

Windows Server 2003 Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Server 2003 x64 Edition Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Server 2003 SP2(用于基于 Itanium 的系统)上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Vista Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Vista x64 Edition Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Server 2008(用于 32 位系统)Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Server 2008(用于 32 位系统)Service Pack 2 上的 VBScript 5.7
(服务器核心安装)
(3068368)


无严重等级

Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

Windows Server 2008(用于基于 x64 的系统)Service Pack 2 上的 VBScript 5.7
(服务器核心安装)
(3068368)


无严重等级

Windows Server 2008(用于基于 Itanium 的系统)Service Pack 2 上的 VBScript 5.7
(3068368)

严重
远程执行代码

严重

VBScript 5.8 (Internet Explorer 8)

Windows Server 2008 R2(用于基于 x64 的系统)Service Pack 1 上的 VBScript 5.8
(服务器核心安装)
(3068364)


无严重等级

漏洞信息

VBScript 内存损坏漏洞 - CVE-2015-2372

当在 Internet Explorer 中显示时,VBScript 引擎处理内存中对象的方式中存在一个远程执行代码漏洞。在基于 Web 的攻击情形中,攻击者可能拥有一个旨在通过 Internet Explorer 利用此漏洞的特制网站,然后诱使用户查看该网站。攻击者也可能在宿主 IE 呈现引擎的应用程序或 Microsoft Office 文档中嵌入标有“安全初始化”的 ActiveX 控件。攻击者还可能利用受到破坏的网站以及接受或宿主用户提供的内容或广告的网站。这些网站可能包含可利用此漏洞的经特殊设计的内容。

成功利用此漏洞的攻击者可以获得与当前用户相同的用户权限。如果当前用户使用管理用户权限登录,成功利用此漏洞的攻击者便可完全控制受影响的系统。攻击者可随后安装程序;查看、更改或删除数据;或者创建拥有完全用户权限的新帐户。此更新通过修改 VBScript 脚本引擎处理内存中对象的方式来解决漏洞。

Microsoft 通过协同的漏洞披露渠道了解到此漏洞的信息。在最初发布此安全公告时,Microsoft 未收到任何表明此漏洞已公开用于攻击用户的信息。

缓解因素

Microsoft 并未发现此漏洞的任何缓解因素

变通办法

以下变通办法在您遇到的情形中可能会有所帮助:

  • 限制对 VBScript.dll 的访问

    • 对于 32 位系统,在管理命令提示符后面输入以下命令:

          takeown /f %windir%\system32\vbscript.dll cacls %windir%\system32\vbscript.dll /E /P everyone:N
      
    • 对于 64 位系统,在管理命令提示符后面输入以下命令:

          takeown /f %windir%\syswow64\vbscript.dll cacls %windir%\syswow64\vbscript.dll /E /P everyone:N
      

    变通办法的影响。使用 VBScript 的网站可能未正常运行。

    如何撤消变通办法。

    • 对于 32 位系统,在管理命令提示符后面输入以下命令:

          cacls %windir%\system32\vbscript.dll /E /R everyone
      
    • 对于 64 位系统,在管理命令提示符后面输入以下命令:

          cacls %windir%\syswow64\vbscript.dll /E /R everyone
      

安全更新部署

有关安全更新部署信息,请参阅执行摘要中此处引用的 Microsoft 知识库文章。

鸣谢

Microsoft 通过协调漏洞披露渠道认可在安全社区中帮助我们对客户进行保护的人们所做出的努力。有关详细信息,请参阅鸣谢

免责声明

Microsoft 知识库中的信息“按原样”提供,没有任何形式的担保。Microsoft 不作任何明示或暗示保证,包括对适销性和针对特定目的的适用性的保证。Microsoft Corporation 或其供应商不对任何损害(包括直接的、间接的、偶然的、必然的损害,商业利润损失,或特殊损害)承担任何责任,即使 Microsoft Corporation 或其供应商事先已被告知有可能发生此类损害。有些州不允许排除或限制必然或偶然损害的赔偿责任,因此上述限制可能不适用。

修订版本

  • V1.0(2015 年 7 月 14 日):公告已发布。

页面生成时间:2015-07-10 13:25Z-07:00。