"错误:404 文件/页面未找到"位于OneDrive或SharePoint

症状

当您尝试访问 Microsoft SharePoint 或 OneDrive 中的网站、文件或组时,会收到以下错误消息:

错误 404:未找到文件/页面

原因

发生此错误是因为网站、文件或组被重命名、移动或删除。

解决方案

如果找不到要查找的内容,请与管理员SharePoint联系。 有关详细信息,请参阅如何查找我的Microsoft 365管理员?。

管理员操作

请尝试通过以下方法查找站点或文件:

还原已删除的主页

如果网站主页已删除,请按照以下步骤操作:

  1. 通过在此浏览器中粘贴此 URL 浏览到网站回收站: https://<tenantname>.sharepoint.com/sites/<sitename>/_layouts/15/RecycleBin.aspx?view=5

    重要 提示:在路径中,将 tenantname 替换为组织名称和 sitename, 并替换为缺少主页的网站名称。

    注意: 页面的默认名称为 Home.aspx。 但是,如果已替换默认主页,则可能会有所不同。

  2. 突出显示文件,然后选择"还原 "。

如果在回收站中找不到该文件,它可能已移动到第 二阶段回收站

  1. 应该 会看到找不到要查找的内容?检查回收站页面 底部的第二阶段回收站。 选择 "第二阶段回收站"。
  2. 突出显示文件,然后选择"还原 "。

如果在第二阶段回收站中找不到页面,则表明该页面已永久删除。

对于可能已删除的文件或其他页面,请参阅在回收站中还原从回收站中删除SharePoint或Teams。

有关详细信息,请参阅以下页面:


检查网站是否已删除

For SharePoint

网站可能已删除。 如果是这样,请从新的管理中心还原SharePoint网站。

  1. 转到已删除网站页面。
  2. 选择要还原的网站。
  3. 选择"还原"。

重要 提示:如果删除的网站是根 (顶级) SharePoint 网站,则首先必须还原该网站,然后使用替换根网站 中的步骤替换

For OneDrive

有关详细信息,请参阅还原已删除OneDrive。


检查网站是否已重定向

如果用户尝试从保存的网站 URL 或指向特定网站 URL 的链接访问网站,则有可能更改了网站 URL 或者移动或删除了网站。

如果更改了网站 URL,应已创建网站重定向页面。 有关详细信息,请参阅管理 网站重定向

重要提示:

  • 如果使用删除重定向中的步骤删除网站,则可能会发生"404"错误。
  • 若要确定哪些网站具有新的 URL,请参阅管理网站重定向的"获取所有重定向 的列表"部分

如果网站已删除,可以从管理中心SharePoint网站。 有关详细信息,请参阅 还原已删除的网站