服务记录的孤立PowerPivot记录应用数据库

本文由高级支持升级工程师 Zakir Haveliwala编写。

症状

在 ULS 记录日志中,Windows事件查看器SharePoint统一日志记录服务 (出现) 错误:

无法打开登录 请求的数据库"PowerPivot服务 应用程序的数据库名称"。 登录失败。 用户"用户名"登录失败。

原因

这表示有关服务中的服务PowerPivot孤立应用数据库记录SharePoint。 在删除服务应用程序后,PowerPivot发生此问题。 已删除的 PowerPivot 服务应用数据库记录有时不会从SharePoint数据库中删除。 因此,SharePoint无法打开 PowerPivot 服务,应用数据库它不再存在时将引发错误。

解决方案

若要解决此问题,请删除这些孤立记录。 可以在命令行管理SharePoint上打开 SharePoint 命令行管理程序,并运行以下命令:

Get-SPDatabase |其中 {$_.exists -eq $false}

这将显示数据库中不再存在的数据库SharePoint 数据库服务器。 上PowerPivot中引用的数据库应该会显示在此列表中。 确认这一点后,可以通过运行以下命令删除孤立记录:

Get-SPDatabase |其中 {$.exists -eq $false} | foreach {$.delete () }

然后,将删除指向旧 PowerPivot服务的孤立应用数据库,并且您之前注意到的错误将停止发生。