SharePoint Online 和 OneDrive 中的“访问被拒绝”或“需要访问此站点的权限”错误

症状

当用户尝试访问 SharePoint Online 或 OneDrive for Business 站点时,会收到以下错误消息:

  • 访问被拒绝
  • 你需要访问此站点的权限
  • 目录中未找到用户

当用户尝试从 SharePoint Online 或 OneDrive 站点访问其他用户共享的文件或文件夹的链接时,会收到以下错误消息:

此链接不可用。
很抱歉,你当前已登录,但该帐户不在安全用户列表中。 要尝试其他电子邮件,请注销并再次打开链接。

原因

出现这些错误的原因有多种,例如:

  • 未正确配置受影响用户的权限。
  • 用于访问共享链接的帐户不同于向其发送共享邀请的帐户。
  • 站点用户 ID 不匹配。 如果从 Microsoft 365 管理中心删除用户帐户,然后使用已删除帐户使用的用户主体名称 (UPN) 创建新帐户,则通常会出现 ID 不匹配情况。 即使 UPN 相同,也会为新帐户分配新的 ID 值。 如果用户已登录到 SharePoint 并稍后移动到其他 OU,则 Active Directory 组织单位 (OU) 和 SharePoint 之间的目录同步期间也可能出现不匹配。

解决方案选项 1:运行“检查用户访问诊断”

注意

此诊断不适用于 GCC High 或 DoD 环境,也不适用于由世纪互联运营的 Microsoft 365。

Microsoft 365 管理员可以在租户中运行诊断,以确定可能影响用户访问的问题。

选择以下“运行测试”按钮以填充 Microsoft 365 管理中心中的诊断:

该诊断为尝试访问 SharePoint 和 OneDrive 站点的内部用户或来宾执行大量的验证。

解决方法选项 2:手动修复

要手动修复访问问题,请按照相关方案的步骤进行操作。

用户无法访问 SharePoint 站点或其他用户的 OneDrive 站点

  1. 确定用户在网站上应该拥有的权限级别

  2. 使用检查权限功能来验证权限:

    1. 对于 SharePoint 站点,选择“设置”>“站点权限”。 对于 OneDrive 站点,选择“设置”>“站点设置”>“站点权限”
    2. 在功能区中,选择“检查权限”
    3. 用户/组字段中,输入用户名,然后选择立即检查
    4. 查看用户在网站上拥有的权限,并检查相关的安全组(如果适用)。
  3. 如果用户没有相应的权限,请授予用户对文件网站的权限。

  4. 如果用户继续收到错误消息,请将用户从网站中删除。 然后,向用户授予对文件或网站的权限。

    备注:如果错误继续影响来宾帐户,我们建议从 Microsoft 365 管理中心彻底删除来宾帐户。 确保用户从网站集中删除。 然后,向用户授予对文件或网站的权限。

用户无法访问自己的 OneDrive 站点

此问题通常是由站点用户 ID 不匹配引起的。

要修复此问题,检查是否存在新的 UPN。 如果存在,请删除新的 UPN,并还原原始 UPN

如果不习惯使用此过程,请参阅修复 SharePoint 或 OneDrive 中的站点用户 ID 不匹配,以获取修复此问题的自动化解决方案。

              从网站中删除受影响的用户,然后再次共享文件或文件夹。