在 Azure Active Directory 同步工具配置向导中输入企业管理员凭据后,出现错误(LogonUser ()失败,错误代码:1789)

原始产品版本:  云服务(Web 角色/工作角色)、Azure Active Directory、Microsoft Intune、Azure Backup、Office 365 身份管理
原始 KB 数:  2508225

症状

在 Microsoft Azure Active Directory 同步工具配置向导中输入企业管理员凭据后,会收到以下错误消息:

LogonUser ()失败,错误代码:1789

原因

当运行目录同步工具的计算机无法通过 Active Directory 进行身份验证时,通常会出现此问题。

解决方案

若要解决此问题,请使用以下一种或多种方法:

  • 重新启动计算机。
  • 将计算机加入到工作组,然后将计算机重新加入域。
    1. 选择 "开始",右键单击 "计算机",然后选择 "属性"。
    2. 在 "计算机名称、域和工作组设置" 下,选择 "更改设置"。
    3. 选择 "计算机名称" 选项卡,然后选择 "更改"。
    4. 选择 "工作组" 选项,然后在 "工作组" 对话框中键入工作组。
    5. 重新启动计算机。
    6. 重复步骤1到3。
    7. 选择 "" 选项,然后在 "" 对话框中键入域名,以将计算机添加回域中。
    8. 重新启动计算机。

更多信息

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