排查在 Azure 中重启现有 Windows VM 或调整其大小的部署问题

尝试启动已停止的 Azure 虚拟机 (VM) ,或调整现有 Azure VM 的大小时,遇到的常见错误是分配失败。 当群集或区域没有可用的资源或不支持请求的 VM 大小时,会出现此错误。

如果本文未解决 Azure 问题,请访问 MSDN 和 Stack Overflow 上的 Azure 论坛。 你可以在这些论坛中发布你的问题,也可以在 Twitter 上发布到@AzureSupport。 还可以提交Azure 支持请求。 若要提交支持请求,请在“Azure 支持”页上,选择“获取支持”。

收集活动日志

若要开始故障排除,请收集活动日志以确定与问题关联的错误。 以下链接包含有关该过程的详细信息:

查看部署操作

查看活动日志以管理 Azure 资源

问题:启动已停止的 VM 时出错

尝试启动已停止的 VM,但出现分配失败。

原因

必须在托管云服务的原始群集上尝试启动已停止的 VM 的请求。 但是,群集没有可用于满足请求的可用空间。

解决方案

  • 停止可用性集中的所有 VM,然后重启每个 VM。

    1. >>单击资源组“资源>可用性集>虚拟机>虚拟机>停止”。
    2. 所有 VM 停止后,选择每个已停止的 VM,然后单击“启动”。
  • 稍后重试重启请求。

问题:调整现有 VM 的大小时出错

尝试调整现有 VM 的大小,但出现分配失败。

原因

必须在托管云服务的原始群集上尝试重设 VM 大小的请求。 但是,群集不支持请求的 VM 大小。

解决方案

  • 使用较小的 VM 大小重试请求。

  • 如果请求的 VM 大小无法更改:

    1. 停止可用性集中的所有 VM。

      • >>单击资源组“资源>可用性集>虚拟机>虚拟机>停止”。
    2. 所有 VM 停止后,将所需的 VM 大小调整为更大的大小。

    3. 选择已调整大小的 VM,并单击“ 启动”,然后启动每个已停止的 VM。

停止、启动、重启或重新部署现有 VM 时出错

尝试停止、启动、重启或重新部署现有 VM 时,该过程会失败,并且你会收到“处理 VM 的网络配置文件时发生意外错误”。 请稍后重试“错误消息。 发生此错误时,VM 将进入失败状态。

原因

如果在分配或更新网络资源时遇到问题,则会出现此问题。

解决方案

尝试重新应用虚拟机状态。 此操作将重新运行 VM 预配,并帮助解决在运行上一个 VM 操作时 VM 预配失败时发生的 VM 状态故障。

  1. 导航到停滞在失败状态的 VM。
  2. “帮助”下,选择“ 重新部署 + 重新应用”。
  3. 选择“ 重新应用” 选项。

后续步骤

如果在 Azure 中创建新的 Windows VM 时遇到问题,请参阅 排查在 Azure 中创建新 Windows 虚拟机的部署问题

联系我们寻求帮助

如果你有任何疑问或需要帮助,请创建支持请求联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。