在 Microsoft Dynamics 365中测试和启用邮箱时,发送电子邮件时出现未知错误

本文提供了在 Microsoft Dynamics 365中尝试测试和启用邮箱时发生的错误的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 数: 4092733

症状

尝试在 Microsoft Dynamics 365 中测试和启用邮箱时,会收到以下错误:

“发送电子邮件”你的邮箱现已连接到Dynamics 365“时出现未知错误。 邮箱 <邮箱名称> 未同步。 已通知关联的电子邮件服务器配置文件 <名称> 的所有者。”

如果选择“ 详细信息 ”部分,则可能还会看到更多详细信息,例如以下文本:

“错误:System.Net.Mail.SmtpException:语法错误,命令无法识别。 服务器响应为:
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End (IAsyncResult 结果)
at System.Net.Mail.SmtpTransport.EndGetConnection (IAsyncResult 结果)
at System.Net.Mail.SmtpClient.ConnectCallback (IAsyncResult 结果) ”

原因

如果电子邮件服务器配置文件的“高级”部分中的“传出端口”值不正确,则会发生此错误。

解决方案

若要解决此问题,请执行以下步骤:

  1. 导航到“设置”Email“配置”,然后选择“Email服务器配置文件”。

  2. 打开邮箱会议使用此错误的 Email 服务器配置文件。

    注意

    还可以在错误消息中选择Email服务器配置文件的名称。 它显示为超链接,将打开正确的Email服务器配置文件记录。

  3. 选择“高级”

  4. 更正 “传出端口 ”值,然后选择“ 保存”。

    注意

    有关连接到 SMTP 服务时要使用的正确端口,请参阅电子邮件提供商的文档。 对于 Gmail ,端口为 587。

  5. 选择“ 邮箱 ”,然后选择收到错误的邮箱。

  6. 选择“ 测试 & 启用邮箱 ”按钮。

  7. 测试完成后,如果结果未显示为“成功”,请打开邮箱记录并查看 “警报 ”部分。