在 Microsoft Dynamics CRM 中导入组织时,无法使用 DistinguishedName 错误添加用户

本文针对在 Microsoft Dynamics CRM 中导入组织时可能会收到“无法使用 DistinguishedName 添加用户”错误的问题提供了解决方法。

适用范围:Microsoft Dynamics CRM 2011
原始 KB 编号: 2714506

症状

将组织导入Microsoft Dynamics CRM时,部署管理员可能会在映射用户时收到错误:

未能使用 DistinguishedName = CN=CName,OU>=<OU Name,DC>=<DC Name,DC>=<Domain>, Account Name = Domain\User System.Reflection.TargetInvocationException 添加用户:调用的目标引发了<异常。 >--- System.UnauthorizedAccessException:拒绝访问。 (HRESULT 异常:0x80070005 (E_ACCESSDENIED) )

原因

执行导入的部署管理员可能对Microsoft Dynamics CRM安全组驻留在 Active Directory 中的组织单位 (OU) 没有适当的权限。

解决方案

验证部署管理员对Microsoft Dynamics CRM安全组所在的 OU 具有足够的权限。

更多信息

导入日志中可能会出现以下错误: (默认位置:%appdata%\Microsoft\MSCRM\Logs)

未能使用 DistinguishedName = CN=CName,OU>=<OU Name,DC>=<DC Name,DC>=<Domain>, Account Name = Domain\User System.Reflection.TargetInvocationException 添加用户:调用的目标引发了<异常。 >--- System.UnauthorizedAccessException:拒绝访问。 (HRESULT 异常:0x80070005 (E_ACCESSDENIED) )

填充 Microsoft CRM 用户组时出错。 确保可从当前域访问 CRM 用户帐户,并再次运行向导。System.Reflection.TargetInvocationException:调用的目标引发了异常。 >--- System.UnauthorizedAccessException:拒绝访问。 (HRESULT 异常:0x80070005 (E_ACCESSDENIED) )