Exchange 2013 必要條件

適用於: Exchange Server 2013

本主題提供安裝必要的 Windows Server 2012 R2、Windows Server 2012 和 Windows Server 2008 r2 Service Pack 1 (SP1) Microsoft Exchange 2013 信箱、用戶端存取及 Edge Transport Server role 的步驟。 此外,它還提供在 Windows 8、Windows 8.1 和 Windows 7 用戶端電腦上安裝 Exchange 2013 管理工具所需的必要條件。

開始之前有哪些須知?

  • 本主題中的資訊適用于 Service Pack 1 和更新版本的 Exchange 2013。

  • 可以從 Exchange 2013 SP1 開始使用 Edge Transport server role。

  • 請確定樹系的功能層級至少為 Windows Server 2003,而且架構主機執行 Windows server 2003 Service Pack 2 或更新版本。 如需 Windows 功能層級的詳細資訊,請參閱管理網域和樹系。

  • Windows Server 2012 R2、Windows Server 2012 及 Windows Server 2008 R2 SP1 的完整安裝選項必須用於所有執行 Exchange 2013 Server role 或管理工具的伺服器。

  • 您必須首先將您的電腦加入相應的內部 Active Directory 樹系和網域。

  • 一些先決條件要求您重新開機伺服器以完成安裝。

    • 在您的電腦上安裝最新的 Windows 更新。如需詳細資訊,請參閱<部署安全性檢查清單>。

      注意

      若要安裝信箱伺服器角色,且想要讓伺服器成為資料庫可用性群組的成員 (DAG) ,您必須執行 Windows Server 2012 R2 Standard 或 datacenter edition,Windows Server 2012 Standard 或 datacenter edition,或 Windows server 2008 R2 SP1Enterprise Edition。 Windows Server 2008 R2 SP 1 Standard Edition 不支援 DAGs 所需的功能。
      當您在伺服器上安裝 Exchange 時,無法升級 Windows。
      若要升級至 Microsoft 整合通訊 Managed API (UCMA) 4.0,您必須先卸載使用 [ 新增/移除程式] 安裝的任何舊版 UCMA。

提示

有問題嗎?請在 Exchange 論壇中尋求協助。請造訪下列論壇:Exchange Server

Active Directory 準備

您要用來準備 Exchange 2013 之 Active Directory 的電腦具有必須滿足的特定必要條件。

依顯示的順序,在用來準備 Active Directory 的電腦上,安裝下列軟體:

  1. .NET Framework 4.7.2

  2. Windows Management Framework 4.0 (隨附 Windows Server 2012 R2)

在您安裝完上述軟體後,請完成下列步驟,安裝 Remote Tools Administration Pack。安裝 Remote Tools Administration Pack 之後,您就可以使用此電腦來準備 Active Directory。如需有關準備 Active Directory 的詳細資訊,請參閱<準備 Active Directory 及網域>。

  1. 開啟 [Windows PowerShell]。

  2. 安裝遠端工具管理元件套件。

    • 在 Windows Server 2012 R2 或 Windows Server 2012 電腦上,執行下列命令。

      Install-WindowsFeature RSAT-ADDS
      
    • 在 Windows Server 2008 R2 SP1 電腦上,執行下列命令。

      Add-WindowsFeature RSAT-ADDS
      

Windows Server 2012 R2 及 Windows Server 2012 必要條件

在 Windows Server 2012 R2 或 Windows Server 2012 電腦上安裝 Exchange 2013 所需的必要條件,取決於您要安裝哪些 Exchange 角色。 請閱讀下一節,以符合您要安裝的角色。

信箱或用戶端存取伺服器角色

依照本節的指示,在您想要執行下列其中一項的 Windows Server 2012 R2 或 Windows Server 2012 電腦上安裝必要條件:

  • 只安裝電腦上的信箱伺服器角色。

  • 在電腦上只安裝 Client Access server role。

  • 在同一部電腦上同時安裝信箱和用戶端存取伺服器角色。

執行下列操作來安裝所需的 Windows 角色和功能:

  1. 開啟 [Windows PowerShell]。

  2. 執行下列命令來安裝所需的 Windows 元件。

    Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
    

安裝作業系統角色與功能後,請依照以下顯示順序安裝軟體:

  1. .NET Framework 4.7.2

    重要

    Exchange 2013 CU23 需要.NET Framework 4.7.2 版。 在安裝 Exchange 2013 CU23 之前,請將伺服器升級至 .NET Framework 4.7.2 版,否則會收到錯誤。 如果您正在執行 .NET Framework 4.7.1,請升級至 Exchange 2013 CU22,再安裝 .NET Framework 4.7.2 版。 如果您正在執行 .NET Framework 4.6.2,請升級至 Exchange 2013 CU20,再安裝 .NET Framework 4.7.1。

  2. Windows Management Framework 4.0 (隨附 Windows Server 2012 R2)

  3. Microsoft Unified Communications Managed API 4.0,Core Runtime 64 位元

  4. 適用於 Visual Studio 2012 的 Visual C++ 可轉散發套件

  5. C++ 可轉散發套件 Visual Studio 2013 套件

注意

您可以在這裡找到最新支援的Visual c + + 轉散發版本概觀

安裝 Edge Transport server role

依照本節的指示,在您想要在電腦上安裝 Edge Transport Server role Windows Server 2012 R2 或 Windows Server 2012 電腦上安裝必要條件。

執行下列操作來安裝所需的 Windows 角色和功能:

  1. 開啟 [Windows PowerShell]。

  2. 執行下列命令來安裝所需的 Windows 元件。

    Install-WindowsFeature ADLDS
    

安裝對應于您要安裝之 Exchange 2013 版本的 Microsoft .NET Framework 版本:

  1. .NET Framework 4.7.2

    重要

    Exchange 2013 CU23 需要.NET Framework 4.7.2 版。 在安裝 Exchange 2013 CU23 之前,請將伺服器升級至 .NET Framework 4.7.2 版,否則會收到錯誤。 如果您正在執行 .NET Framework 4.7.1,請升級至 Exchange 2013 CU22,再安裝 .NET Framework 4.7.2 版。 如果您正在執行 .NET Framework 4.6.2,請升級至 Exchange 2013 CU20,再安裝 .NET Framework 4.7.1。

  2. Windows Management Framework 4.0 (隨附 Windows Server 2012 R2)

  3. 適用於 Visual Studio 2012 的 Visual C++ 可轉散發套件

注意

您可以在這裡找到最新支援的Visual c + + 轉散發版本概觀

Windows Server 2008 R2 SP1 必要條件

在 Windows Server 2008 R2 SP1 電腦上安裝 Exchange 2013 所需的必要條件,取決於您要安裝哪些 Exchange 角色。 請閱讀下一節,以符合您要安裝的角色。

用戶端存取或信箱伺服器角色

依照本節的指示,在您想要執行下列其中一項的 Windows Server 2008 R2 SP1 電腦上安裝必要條件:

  • 只安裝電腦上的信箱伺服器角色。

  • 在電腦上只安裝 Client Access server role。

  • 在同一部電腦上同時安裝信箱和用戶端存取伺服器角色。

執行下列操作來安裝所需的 Windows 角色和功能:

  1. 開啟 [Windows PowerShell]。

  2. 執行下列命令以載入 [伺服器管理員] 模組。

    Import-Module ServerManager
    
  3. 執行下列命令來安裝所需的 Windows 元件。

    Add-WindowsFeature Desktop-Experience, NET-Framework, NET-HTTP-Activation, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Web-Server, WAS-Process-Model, Web-Asp-Net, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, RSAT-ADDS
    

安裝作業系統角色與功能後,請依照以下顯示順序安裝軟體:

  1. .NET Framework 4.7.2

    重要

    Exchange 2013 CU23 需要.NET Framework 4.7.2 版。 在安裝 Exchange 2013 CU23 之前,請將伺服器升級至 .NET Framework 4.7.2 版,否則會收到錯誤。 如果您正在執行 .NET Framework 4.7.1,請升級至 Exchange 2013 CU22,再安裝 .NET Framework 4.7.2 版。 如果您正在執行 .NET Framework 4.6.2,請升級至 Exchange 2013 CU20,再安裝 .NET Framework 4.7.1。

  2. Windows Management Framework 4。0

  3. Microsoft Unified Communications Managed API 4.0,Core Runtime 64 位元

  4. 適用於 Visual Studio 2012 的 Visual C++ 可轉散發套件

  5. C++ 可轉散發套件 Visual Studio 2013 套件

    注意

    您可以在這裡找到最新支援的Visual c + + 轉散發版本概觀

  6. Microsoft 知識庫文章 KB974405 (Windows 身分識別基礎)

  7. 知識庫文章 KB2619234 (啟用 rpc over HTTP 所使用的關聯 Cookie/GUID,也可用於 Windows 7 和 Windows Server 2008 R2 中的 rpc 層)

  8. 知識庫文章 KB2533623 (不安全的文件庫載入可能會允許遠端程式碼執行)

    注意

    如果您已設定 Windows 更新安裝電腦上的安全性更新,則可能已安裝此修復程式。

Edge Transport server role 安裝

依照本節的指示,在您想要在電腦上安裝 Edge Transport Server role Windows Server 2008 R2 SP1 電腦上安裝必要條件。

執行下列操作來安裝所需的 Windows 角色和功能:

  1. 開啟 [Windows PowerShell]。

  2. 執行下列命令以載入 [伺服器管理員] 模組。

    Import-Module ServerManager
    
  3. 執行下列命令來安裝所需的 Windows 元件。

    Add-WindowsFeature NET-Framework, ADLDS
    

安裝作業系統角色與功能後,請依照以下顯示順序安裝軟體:

  1. .NET Framework 4.7.2

    重要

    Exchange 2013 CU23 需要.NET Framework 4.7.2 版。 在安裝 Exchange 2013 CU23 之前,請將伺服器升級至 .NET Framework 4.7.2 版,否則會收到錯誤。 如果您正在執行 .NET Framework 4.7.1,請升級至 Exchange 2013 CU22,再安裝 .NET Framework 4.7.2 版。 如果您正在執行 .NET Framework 4.6.2,請升級至 Exchange 2013 CU20,再安裝 .NET Framework 4.7.1。

  2. Windows Management Framework 4。0

  3. Microsoft Unified Communications Managed API 4.0,Core Runtime 64 位元

  4. 適用於 Visual Studio 2012 的 Visual C++ 可轉散發套件

    注意

    您可以在這裡找到最新支援的Visual c + + 轉散發版本概觀

Windows 7 先決條件 (僅限系統管理工具)

依照本節的指示,在您想要安裝 Exchange 管理工具的已加入網域的 Windows 7 64 位電腦上安裝必要條件。

  1. 開啟 [ 控制台],然後選取 [ 程式]。

  2. 按一下 [開啟或關閉 Windows 功能]。

  3. 流覽至 Internet Information Services > Web 管理工具 > IIS 6 管理相容性

  4. 選取 [ IIS 6 管理主控台] 的核取方塊,然後按一下 [確定]

安裝作業系統功能之後,請依顯示的順序安裝下列軟體:

  1. .NET Framework 4.7.2

  2. Windows Management Framework 4。0

  3. KB974405 (Windows 身分識別基礎的知識庫文章)

僅 (系統管理員工具 Windows 8 和 Windows 8.1 必要條件)

.NET Framework 4.7.2