使用 OData 資料摘要建立 Excel Services 儀表板Create an Excel Services dashboard using an OData data feed

摘要:了解如何建立可發佈至 SharePoint Server 2013 中的文件庫的 Excel Services 儀表板。Summary: Learn how to create an Excel Services dashboard that can be published to a library in SharePoint Server 2013.

本文逐步說明如何使用 Excel 2016 建立基本儀表板包含兩個報表及兩個篩選器。本文所述的範例儀表板的格式類似於下列影像:This article describes, step by step, how to use Excel 2016 to create a basic dashboard that contains two reports and two filters. The example dashboard described in this article resembles the following image:

圖: 基本 Excel Services 儀表板包含兩個報表及兩個交叉分析篩選器Figure: Basic Excel Services dashboard that contains two reports and two slicers

基本的 Excel Services 儀表板

範例儀表板使用匯入 Excel 中使用 OData 資料摘要的資料。這會使可能將活頁簿發佈至 SharePoint Server 2013 中的文件庫。遵循本文中的步驟,您將了解如何將 Excel 資料匯入、 使用該資料工作表中建立報表和篩選連線至這些報告。Our example dashboard uses data that is imported into Excel using an OData data feed. This makes it possible to publish the workbook to a library in SharePoint Server 2013. By following the steps in this article, you'll learn how to import data into Excel, use that data to create reports in a worksheet, and connect filters to those reports.

開始之前Before you begin

開始這項作業之前,請先檢閱下列先決條件的相關資訊:Before you begin this operation, review the following information about prerequisites:

規劃儀表板Plan the dashboard

開始建立儀表板之前,建議您建立儀表板計劃。此計劃不需要過於廣泛或複雜。但是,應針對儀表板需包含的項目提供建議。為了協助您準備儀表板計劃,請考慮類似如下的問題:Before you begin to create a dashboard, we recommend that you create a dashboard plan. The plan does not have to be extensive or complex. However, it should give you an idea of what you want to include in the dashboard. To help you prepare a dashboard plan, consider questions such as the following:

  • 誰會使用儀表板?Who will use the dashboard?

  • 他們想查看哪類資訊?What kinds of information do they want to see?

  • 是否存在可用來建立儀表板的資料?Does data exist that you can use to create the dashboard?

是您可以使用以了解如何建立及發佈 Excel Services 儀表板原型而設計範例儀表板。若要顯示我們可能會建立類似的儀表板的儀表板計畫的方式,請參閱下表。Our example dashboard is designed to be a prototype that you can use to learn how to create and publish Excel Services dashboards. To show how we might create a dashboard plan for a similar dashboard, see the following table.

表: 範例儀表板的基本計畫Table: Basic plan for our example dashboard

問題Question 回應Response
誰會使用儀表板?Who will use the dashboard?
儀表板的適用對象是對虛構公司 Adventure Works Cycles 之銷售資訊感興趣的業務代表、業務經理、公司主管及其他專案關係人。The dashboard is intended for use by sales representatives, sales managers, corporate executives, and other stakeholders who are interested in sales information for the fictitious company Adventure Works Cycles.
如何使用儀表板?換句話說,儀表板使用者想查看哪類資訊?How will the dashboard be used? That is, what kinds of information do the dashboard consumers want to see?
銷售代表、經理、行政人員及其他儀表板使用者想使用儀表板檢視、探索及分析資料。儀表板使用者至少想查看下列資訊類型:Sales representatives, managers, executives, and other dashboard consumers want to use the dashboard to view, explore, and analyze data. At a minimum, the dashboard consumers want to see the following kinds of information:
不同地理區域的銷售金額Sales amounts across different geographical areas
不同地理區域的銷售金額Sales amounts across different geographical areas
不同年度的的銷售金額Sales amounts for different years
不同業務代表的銷售金額Sales amounts for different sales representatives
儀表板使用者想使用儀表板檢視、探索及分析資料,以取得特定問題的答案。Dashboard consumers want to use the dashboard to view, explore, and analyze data to obtain answers to specific questions.
儀表板使用者也想能夠使用篩選,以專注於更特定的資訊,例如特定年度或特定業務代表的銷售量。The dashboard consumers also want to be able to use filters to focus on more specific information, such as sales for a particular year or a particular sales representative.
是否存在可用來建立儀表板的資料?Does data exist that we can use to create the dashboard?
[是]。我們將使用 Adventure Works 範例資料庫包含我們可以使用儀表板的資料。Yes. The Adventure Works sample database that we'll use contains the data that we can use for the dashboard.
儀表板應該包含哪些項目?What items should the dashboard contain?
範例儀表板包含下列項目:Our example dashboard includes the following items:
使用 OData 資料摘要所匯入的資料Data that is imported by using an OData data feed
顯示不同地理區域之產品銷售資訊的圖表A chart showing product sales information for different geographical areas
顯示不同地理區域之銷售資訊的圖表A chart showing sales information for different geographical areas
可讓儀表板使用者用來檢視特定年度資訊的交叉分析篩選器A slicer that dashboard consumers can use to view information for a particular year
可讓儀表板使用者用來檢視特定銷售代表資訊的交叉分析篩選器A slicer that dashboard consumers can use to view information for a particular sales representative
儀表板將發佈到哪裡?Where will the dashboard be published?
因為範例儀表板在 Excel 中使用原生資料、 儀表板可發佈至 SharePoint Server 2013 或 SharePoint Online 中的 SharePoint 文件庫。這可讓內部或透過網際網路連線使用儀表板內容的人員。它也可讓使用行動裝置,例如 Apple iPad 或 Windows 8 平板電腦檢視儀表板的人員。Because our example dashboard uses native data in Excel, the dashboard can be published to a SharePoint library in SharePoint Server 2013 or in SharePoint Online. This enables people to consume the dashboard content internally or via an Internet connection. It also enables people to view the dashboard by using a mobile device, such as Apple iPad or Windows 8 tablet.

建立儀表板計劃之後,即可開始建立儀表板。Now that we have created our dashboard plan, we can begin to create the dashboard.

建立儀表板Create the dashboard

若要建立儀表板,請先建立資料連線。然後,我們會將 Excel 資料匯入使用該資料連線。接下來,我們建立報表與我們想要使用的篩選。之後,我們會將活頁簿發佈至 SharePoint Server 2013。To create the dashboard, we begin by creating a data connection. Then, we use that data connection to import data into Excel. Next, we create the reports and the filter that we want to use. After that, we publish the workbook to SharePoint Server 2013.

第一部分:將資料匯入 ExcelPart 1: Get data into Excel

範例儀表板使用透過 OData 資料摘要來連線至 Adventure Works 範例資料匯入 Excel 的資料。如需詳細資訊,請參閱AdventureWorks OData 摘要 (在 CodePlex)。請先將 Excel 資料匯入。Our example dashboard uses data that is imported into Excel via an OData data feed to connect to Adventure Works sample data. For more information, see AdventureWorks OData Feed (on CodePlex). We begin by importing data into Excel.

將 Excel 資料匯入使用 OData 資料摘要To import data into Excel by using an OData data feed

  1. 開啟 Microsoft Excel。Open Microsoft Excel.

  2. 選擇 [空白活頁簿]建立活頁簿。Choose Blank workbook to create a workbook.

  3. 在 [資料] 索引標籤上選擇 [取得外部資料] 群組,並選擇 [從其他來源],然後選擇 [從 OData 資料摘要On the Data tab, choose Get External Data group, choose From Other Sources, and then choose From OData Data Feed.

    [資料連線精靈] 隨即開啟。The Data Connection Wizard opens.

  4. 在 [連接至資料庫伺服器] 頁面上的資料摘要的位置] 方塊中,指定資料摘要的網址 (URL)。On the Connect to Database Server page, in the Location of the data feed box, specify the website address (URL) for the data feed.

    在我們用於範例儀表板http://services.odata.org/AdventureWorksV3/AdventureWorks.svc。For our example dashboard, we used http://services.odata.org/AdventureWorksV3/AdventureWorks.svc.

  5. 在 [登入認證] 區段中,執行下列任一下列步驟:In the Log on credentials section, take one of the following steps:

    • 選擇 [使用開啟此檔案者的登入資訊],然後選擇 [下一步] 按鈕。Choose Use the sign-in information for the person opening this file, and then choose the Next button.

    • 選擇 [使用此名稱和密碼、 指定適當的使用者名稱和密碼,然後選擇 [下一步] 按鈕。Choose Use this name and password, specify an appropriate user name and password, and then choose the Next button.

      提示

      如果您不知道要選擇哪個選項,請連絡 SharePoint 管理員。If you don't know which option to choose, contact a SharePoint administrator.

  6. 在 [選取表格] 頁面上選擇 [ CompanySalesTerritorySalesDrilldown資料表。然後選擇 [下一步] 按鈕。On the Select Tables page, choose the CompanySales table and the TerritorySalesDrilldown table. Then choose the Next button.

  7. 在 [儲存資料連線檔案和完成] 頁面上選擇 [完成] 按鈕。On the Save Data Connection File and Finish page, choose the Finish button.

  8. 在 [匯入資料] 頁面上執行下列步驟:On the Import Data page, take the following steps:

  9. 選取 [資料表] 選項。Select the Table option.

  10. 請確定已選取 [新增此資料至資料模型] 選項。Make sure the Add this data to the Data Model option is selected.

  11. 選擇[確定]按鈕。Choose the OK button.

    Sheet2Sheet3含有資料會新增至活頁簿。Sheet2 and Sheet3 that contain data are added to the workbook.

  12. 保持開啟 Excel。Keep Excel open.

此時我們匯入資料匯入 Excel 使用 OData 資料摘要。下一步是建立資料的資料表之間的關係。若要這樣做,我們將 excel 使用 Power Pivot 增益集。如果在 Excel 中看不到 [ PowerPivot ] 索引標籤,使用下列程序啟用增益集。At this point, we have imported data into Excel by using an OData data feed. The next step is to create a relationship between the tables of data. To do that, we'll use the Power Pivot Add-In for Excel. If the PowerPivot tab is not visible in Excel, enable the add-in by using the following procedure.

若要啟用的 PowerPivot 增益集的 ExcelTo enable the PowerPivot add-in for Excel

  1. 在 Excel 中,在 [檔案] 索引標籤上選擇選項In Excel, on the File tab, choose Options.

  2. 在 [ Excel 選項] 對話方塊中,選擇 [增益集In the Excel Options dialog box, choose Add-Ins.

  3. 在 [管理] 清單中選擇 [ COM 增益集],然後按移至] 按鈕開啟 [ COM 增益集] 對話方塊。In the Manage list, choose COM Add-Ins, and then choose the Go button to open the COM Add-Ins dialog box.

  4. 選取 [ Microsoft Office PowerPivot for Excel 2013、,,然後選擇[確定]。在 Excel 中顯示現稱為 [ PowerPivot ] 索引標籤。Select Microsoft Office PowerPivot for Excel 2013, and then choose OK. The PowerPivot tab is now visible in Excel.

  5. 保持開啟 Excel。Keep Excel open.

既然 Power Pivot 增益集的 Excel 已啟用下, 一步是建立資料的資料表之間的關係。這可讓我們建立報表和篩選使用兩個資料表的資料。Now that the Power Pivot add-in for Excel is enabled, the next step is to create a relationship between the tables of data. This will enable us to create reports and filters using data from the two tables.

若要建立資料模型中的資料表之間的關係To create a relationship between tables in a Data Model

  1. 在 Excel 中,在 [ PowerPivot ] 索引標籤的 [資料模型] 群組中選擇 [管理。Excel 的 power Pivot 隨即開啟。In Excel, on the PowerPivot tab, in the Data Model group, choose Manage. Power Pivot for Excel opens.

  2. 在 [ PowerPivot for Excel ] 視窗的 [設計] 索引標籤的 [關係] 群組中選擇 [建立關係In the PowerPivot for Excel window, on the Design tab, in the Relationships group, choose Create Relationship.

  3. 在 [建立關係] 對話方塊中,指定下列設定:In the Create Relationship dialog box, specify the following settings:

    • 在 [資料表] 清單中,確認已選取 [ CompanySalesIn the Table list, verify that CompanySales is selected.

    • [] 清單中選擇 [識別碼]。In the Column list, choose ID.

    • 在 [相關查閱表格] 清單中選擇 [ TerritorySalesDrilldown]。In the Related Lookup Table list, choose TerritorySalesDrilldown.

    • 在 [相關欄查閱] 清單中,確認已選取 [識別碼In the Related Column Lookup list, verify that ID is selected.

      然後選擇 [建立] 按鈕。Then choose the Create button.

  4. 關閉 [ PowerPivot for Excel ] 視窗中,但是讓 Excel 保持開啟。Close the PowerPivot for Excel window, but keep Excel open.

此時我們已將 Excel 匯入兩個資料表的資料。我們也已建立資料表之間的關係,因此我們可以建立報表和兩個資料表作為單一資料來源的篩選器。At this point, we have imported two tables of data into Excel. We have also created a relationship between the tables so that we can create reports and filters that use the two tables as a single data source.

第 2 部分:建立報表Part 2: Create reports

我們將為範例儀表板建立兩個報表,如下表所述:For our example dashboard, we'll create two reports, as described in the following table:

表: 儀表板報表Table: Dashboard reports

報告類型Report Type 報表名稱Report Name 描述Description
樞紐分析圖PivotChart report
ProductSalesProductSales
顯示跨不同產品類別之銷售金額的橫條圖。Bar chart that shows sales amounts across different product categories.
樞紐分析圖PivotChart report
GeoSalesGeoSales
顯示跨不同銷售地理區域之銷售金額的橫條圖。Bar chart that shows sales amounts across different sales geographical areas.

第一步是建立 ProductSales 報表。We begin by creating the ProductSales report.

若要建立 ProductSalesReport 圖表To create the ProductSalesReport chart

  1. 在 Excel 中,選取 [ Sheet1]。In Excel, select Sheet1.

  2. 在 [插入] 索引標籤上的 [圖表] 區段中選擇 [樞紐分析圖]。建立樞紐分析圖] 對話方塊隨即出現。On the Insert tab, in the Charts section, choose PivotChart.The Create PivotChart dialog box appears.

  3. [選擇您想要分析的資料] 區段中選擇 [使用外部資料來源] 選項,然後按 [選擇連線] 按鈕。In the Choose the data that you want to analyze section, choose the Use an external data source option, and then choose the Choose Connection button.

    [現有連線] 對話方塊隨即出現。The Existing Connections dialog box appears.

  4. 在 [資料表] 索引標籤上選取 [活頁簿資料模型中的表格] 選項,然後選擇 [開啟] 按鈕。On the Tables tab, select the Tables in Workbook Data Model option, and then choose the Open button.

  5. 在 [建立樞紐分析圖] 對話方塊中,選擇 [現有工作表] 選項,然後選擇[確定]按鈕。In the Create PivotChart dialog box, choose the Existing Worksheet option, and then choose the OK button.

    Chart1開啟供編輯。Chart1 opens for editing.

  6. 在 [樞紐分析圖欄位] 清單中,指定下列選項:In the PivotChart Fields list, specify the following options:

    • 從 [ CompanySales ] 區段中,將[productcategory] 拖曳至 [圖例 (數列) ] 欄位。From the CompanySales section, drag ProductCategory to the Legend (Series) field well.

    • 在 [ CompanySales ] 區段中,選取 [銷售] 旁的核取方塊。In the CompanySales section, select the check box next to Sales.

      圖表更新,以顯示跨不同產品類別的銷售金額。The chart updates to display sales amounts across different product categories.

  7. 移動樞紐分析圖,以靠近工作表左上角。若要執行此動作,請拖曳報表,使左上角對齊工作表儲存格 D1 的左上角。Move the PivotChart report closer to the upper-left corner of the worksheet. To do this, drag the report so that the upper-left corner aligns with the upper-left corner of cell D1 in the worksheet.

  8. 為了避免報表名稱在稍後混淆,我們將為報表指定新名稱。若要執行這項操作,請執行下列步驟:To avoid confusion about report names later, we'll specify a new name for the report. To do that, take the following steps:

  9. 樞紐分析圖報表中某處按一下滑鼠右鍵,然後選擇 [樞紐分析圖選項Somewhere in the PivotChart report, right-click, and then choose PivotChart Options.

  10. 在 [樞紐分析圖選項] 對話方塊的 [樞紐分析圖名稱] 方塊中輸入 ProductSalesReport。In the PivotChart Options dialog box, in the PivotChart Name box, type ProductSalesReport.

    提示

    確定您指定的名稱僅包含英數字元 (不含空白)。Make sure that the name that you specify contains only alphanumeric characters (no spaces).

  11. 選擇[確定]按鈕。Choose the OK button.

  12. 使用 Adventure Works 銷售報表之類的檔案名稱儲存活頁簿。Save the workbook by using a file name such as Adventure Works Sales Reports.

  13. 保持開啟此活頁簿。Keep the workbook open.

現在我們已經建立顯示產品銷售量的樞紐分析圖。下一步是建立顯示跨不同地理位置之銷售金額的樞紐分析圖。At this point, we have created a PivotChart report showing product sales. The next step is to create a PivotChart report that shows sales amounts across different geographical locations.

若要建立 GeoSalesReport 圖表To create the GeoSalesReport chart

  1. 在 Excel 中,用來建立 ProductSales 報表的相同工作表上選擇儲存格 B17。In Excel, on the same worksheet that was used to create the ProductSales report, choose cell B17.

  2. 在 [插入] 索引標籤上選擇 [樞紐分析圖]。On the Insert tab, choose PivotChart.

  3. [選擇您想要分析的資料] 區段中選擇 [使用外部資料來源] 選項,然後按 [選擇連線] 按鈕。In the Choose the data that you want to analyze section, choose the Use an external data source option, and then choose the Choose Connection button.

    [現有連線] 對話方塊隨即出現。The Existing Connections dialog box appears.

  4. 在 [資料表] 索引標籤上選取 [活頁簿資料模型中的表格] 選項,然後選擇 [開啟] 按鈕。On the Tables tab, select the Tables in Workbook Data Model option, and then choose the Open button.

  5. 在 [建立樞紐分析圖] 對話方塊中,選擇 [現有工作表] 選項,然後選擇[確定]按鈕。In the Create PivotChart dialog box, choose the Existing Worksheet option, and then choose the OK button.

    PivotChart2隨即開啟供編輯。PivotChart2 opens for editing.

  6. 在 [樞紐分析圖欄位] 清單中,指定下列選項:In the PivotChart Fields list, specify the following options:

    • 在 [ CompanySales ] 區段中選取 [銷售]。In the CompanySales section, select Sales.

    • 在 [ TerritorySalesDrilldown ] 區段中將[territoryname] 拖曳至 [圖例 (數列) ] 欄位。In the TerritorySalesDrilldown section, drag TerritoryName to the Legend (Series) field well.

      更新報表,以顯示圖表,其中會顯示不同地理區域的銷售金額。The report updates to display a chart showing sales amounts for different geographical areas.

  7. 移動報表,使其左上角對齊儲存格 D16 的左上角。Move the report so that its upper-left corner aligns with the upper-left corner of cell D16.

  8. 若要指定報表的名稱,請遵循下列步驟:To specify a name for the report, take the following steps:

  9. 中某處報表上按一下滑鼠右鍵,然後選擇 [樞紐分析圖選項Somewhere in the report, right-click and then choose PivotChart Options.

  10. 在 [樞紐分析圖名稱] 方塊中輸入 GeoSalesReport。In the PivotChart Name box, type GeoSalesReport.

  11. 選擇 [確定]。Choose OK.

  12. 在 [檔案] 索引標籤上選擇 [儲存] 按鈕。On the File tab, choose the Save button.

  13. 保持開啟此活頁簿。Keep the workbook open.

現在我們已經為基本儀表板建立兩個報表。下一步是建立篩選。At this point, we have created our two reports for our basic dashboard. The next step is to create filters.

第三部分:新增篩選Part 3: Add filters

使用 Excel、 數種不同類型的我們可以建立並新增至儀表板篩選。例如,我們可以建立簡單的篩選器將欄位放到 [篩選] 區段中的 [欄位] 清單中。我們可以開始建立交叉分析篩選器,或如果我們使用 Analysis Services 之類的多維度資料來源,我們可以建立時間表控制項。此範例儀表板中,我們將建立兩個交叉分析篩選器。此篩選將會啟用以檢視特定年度或特定銷售代表資訊的人員。Using Excel, there are several different kinds of filters we can create and add to a dashboard. For example, we can create a simple filter by putting a field in the Filter section of the Fields list. We can create a slicer, or, if we are using a multidimensional data source such as Analysis Services, we can create a timeline control. For this example dashboard, we'll create two slicers. This filter will enable people to view information for a particular year or a particular sales representative.

若要新增至儀表板的交叉分析篩選器To add slicers to the dashboard

  1. 在 Excel 中,用來建立報表的相同工作表上選擇儲存格 A1。In Excel, on the same worksheet that was used to create the reports, choose cell A1.

  2. 在 [插入] 索引標籤上的 [篩選] 群組中選擇 [交叉分析篩選器]。On the Insert tab, in the Filter group, choose Slicer.

    [現有連線] 對話方塊隨即顯示。The Existing Connections dialog box appears.

  3. 在 [資料模型] 索引標籤上選取 [活頁簿資料模型中的表格] 選項,然後選擇 [開啟] 按鈕。On the Data Model tab, select the Tables in Workbook Data Model option, and then choose the Open button.

  4. 在 [插入交叉分析篩選器] 對話方塊中,執行下列步驟:In the Insert Slicers dialog box, take the following steps:

  5. 在 [ CompanySales ] 區段中,選擇 [ orderyear]In the CompanySales section, choose OrderYear.

  6. 在 [ TerritorySalesDrilldown ] 區段中,選擇 [ employeelastname]In the TerritorySalesDrilldown section, choose EmployeeLastName.

  7. 選擇[確定]按鈕。Choose the OK button.

  8. 移動交叉分析篩選器使OrderYear交叉分析篩選器的左上角對齊儲存格 A1 的左上角和EmployeeLastName交叉分析篩選器會置於立即OrderYear交叉分析篩選器。Move the slicers so that the upper-left corner of the OrderYear slicer aligns with the upper-left corner of cell A1, and the EmployeeLastName slicer is positioned immediately below the OrderYear slicer.

  9. 遵循下列步驟,將交叉分析篩選器連接至報表:Connect the slicers to the reports by following these steps:

  10. 選取 [ OrderYear交叉分析篩選器。Select the OrderYear slicer.

  11. 在 [選項] 索引標籤上 [交叉分析篩選器] 群組中,選擇 [回報連線] 工具列命令。On the Options tab, in the Slicer group, choose the Report Connections toolbar command.

  12. 在 [回報連線] 對話方塊中,選擇 [ ProductSalesReport ] 和 [ GeoSalesReport ] 核取方塊,然後選擇[確定]按鈕。In the Report Connections dialog box, choose the ProductSalesReport and GeoSalesReport check boxes, and then choose the OK button.

  13. 針對 [ EmployeeLastName交叉分析篩選器重複這些步驟。Repeat these steps for the EmployeeLastName slicer.

  14. 在 [檔案] 索引標籤上選擇 [儲存] 按鈕。On the File tab, choose the Save button.

  15. 保持開啟 Excel 活頁簿。Keep the Excel workbook open.

此時我們已經建立儀表板。下一步是將它發佈至 SharePoint Server 2013,其中它可供其他人。At this point, we have created a dashboard. The next step is to publish it to SharePoint Server 2013, where it can be used by others.

發佈儀表板Publish the dashboard

若要將活頁簿發佈至 SharePoint Server 2013,我們將遵循兩步驟程序。首先,我們進行活頁簿的顯示方式會影響某些調整。然後,我們將活頁簿發佈至 SharePoint 文件庫。To publish the workbook to SharePoint Server 2013, we'll follow a two-step process. First, we make some adjustments that affect how the workbook is displayed. Then, we publish the workbook to a SharePoint library.

請先進行調整的活頁簿。根據預設,範例儀表板會包含儀表板的工作表上顯示格線。此外,根據預設,工作表會呼叫 Sheet1。我們可以進行儀表板顯示的方式將可改善一些次要調整。We begin by making adjustments to the workbook. By default, our example dashboard displays gridlines on the worksheet that contains our dashboard. In addition, by default, the worksheet is called Sheet1. We can make some minor adjustments that will improve how the dashboard will be displayed.

若要改善活頁簿的次要刻度的顯示方式To make minor display improvements to the workbook

  1. 在 Excel 中,選擇 [檢視] 索引標籤。In Excel, choose the View tab.

  2. 若要從檢視中,[檢視] 索引標籤的 [顯示] 群組中移除格線清除 [格線] 核取方塊。To remove gridlines from the view, on the View tab, in the Show group, clear the Gridlines check box.

  3. 若要移除列名和欄名,在 [檢視] 索引標籤上的 [顯示] 群組中,清除 [標題] 核取方塊。To remove row and column headings, on the View tab, in the Show group, clear the Headings check box.

  4. 若要重新命名工作表、 其用來指出Sheet1中,其] 索引標籤上按一下滑鼠右鍵,然後選擇重新命名。立即輸入 [SalesInfo,例如於工作表的新名稱,然後按下 Enter 鍵。To rename the worksheet, right-click its tab where it says Sheet1, and then choose Rename. Immediately type a new name for the worksheet, such as SalesInfo, and then press the Enter key.

  5. 在 [檔案] 索引標籤上選擇 [儲存]。On the File tab, choose Save.

  6. 關閉 Excel。Close Excel.

下一步是將活頁簿發佈至 SharePoint 文件庫。活頁簿會使用我們匯入 Excel 的原生資料這表示我們可以將它發佈至 SharePoint Server 2013 中的文件庫。發佈活頁簿中使用下列程序之一。The next step is to publish the workbook to a SharePoint library. The workbook uses native data that we imported into Excel, which means that we can publish it to a library in SharePoint Server 2013. Use one of the following procedures to publish the workbook.

若要將活頁簿發佈至 SharePoint Server 2013 中的文件庫To publish the workbook to a library in SharePoint Server 2013

  1. 開啟網頁瀏覽器。Open a web browser.

  2. 在位址行中,輸入 SharePoint Server 2013 中的文件庫的 SharePoint 位址。In the address line, type the SharePoint address to a library in SharePoint Server 2013.

    我們的範例中,我們使用商務智慧中心網站中的預設是由提供的文件庫。我們使用的 SharePoint 位址的格式類似於http://servername/sites/bicenter/documents。For our example, we used the Documents library that is available by default in a Business Intelligence Center site. The SharePoint address we used resembles http://servername/sites/bicenter/documents.

    提示

    如果不知道您可以使用之文件庫的 SharePoint 位址,請連絡 SharePoint 管理員。Contact a SharePoint administrator if you do not know the SharePoint address for a library that you can use.

  3. 文件庫中,按一下 [ + 新增文件以開啟 [新增文件] 對話方塊。In the Documents library, click + New Document to open the Add a Document dialog box.

  4. 選擇 [瀏覽],並選取 [Adventure Works 銷售報表活頁簿然後使用 [選擇要上傳檔案] 對話方塊。然後選擇 [開啟Choose Browse, and then use the Choose File to Upload dialog box to select the Adventure Works Sales Reports workbook. Then choose Open.

  5. 在 [新增文件] 對話方塊中,選擇[確定]。活頁簿會新增至文件庫。In the Add a document dialog box, choose OK. The workbook is added to the library.

建立及發佈儀表板之後,即可使用此儀表板探索資料。Now that we have created and published the dashboard, we can use it to explore data.

使用儀表板Use the dashboard

儀表板發佈至 SharePoint Server 2013 之後,它是可供其他人檢視並使用它。After the dashboard was published to SharePoint Server 2013, it is available for people to view and use it.

若要開啟 [儀表板To open the dashboard

  1. 開啟網頁瀏覽器。Open a web browser.

  2. 在網址列中,輸入發佈儀表板之商務智慧中心網站的網址。In the address bar, type the address to the Business Intelligence Center site where the dashboard was published.

  3. 選擇[網站內容],然後再選擇 [文件Choose Site Contents, and then choose Documents.

  4. 選擇 [ Adventure Works 銷售報表的儀表板]。儀表板隨即開啟供瀏覽器視窗中檢視。Choose the Adventure Works Sales Reports dashboard. The dashboard opens for viewing in a browser window.

此時會開啟儀表板以供檢視,然後即可使用儀表板取得特定問題的答案,如下表所述。Now that the dashboard is open for viewing, we can use it to obtain answers to specific questions, such as those that are described in the following table.

表: 使用儀表板取得特定問題的答案Table: Using the dashboard to obtain answers to specific questions

問題Question 動作Action
在 2005 年,哪種產品類別的銷售量最高?In 2005, which product category had the most sales?
在 [ OrderYear交叉分析篩選器,選擇 [2005年。請注意 [ ProductSalesReport ] 圖表中 「 自行車 」 產品類別具有銷售金額最高。In the OrderYear slicer, choose 2005. Notice that in the ProductSalesReport chart, the Bikes product category has the highest sales amount.
哪一年「自行車」產品類別的銷售金額最高?Which year had the highest amount of sales for the Bikes product category?
若要尋找答案,我們將使用 「 快速探索 」 功能。請遵循下列步驟:To find the answer, we'll use the Quick Explore feature. Follow these steps:
清除 [OrderYear 交叉分析篩選器。在 [ProductSalesReport] 圖表中,選取 [自行車長條圖。顯示快速探索] 按鈕。按一下 (或點選) 若要開啟 [探索] 對話方塊的 [快速探索 」] 按鈕。依序展開 [CompanySales、 選擇 [orderyear],並再選擇 [向下切入至 orderyear]。[ProductSalesReport] 圖表更新,顯示 「 自行車 」 產品類別的銷售金額。根據 [ ProductSalesReport ] 圖表,2007年經過年是一年此公司 「 自行車 」 類別的銷售金額最高。Clear the OrderYear slicer. In the ProductSalesReport chart, select the Bikes bar. The Quick Explore button appears. Click (or tap) the Quick Explore button to open the Explore dialog box. Expand CompanySales, choose OrderYear, and then choose Drill To OrderYear. The ProductSalesReport chart updates to show sales amounts for the Bikes product category. According to the ProductSalesReport chart, 2007 was the year in which this company had the highest sales amounts for the Bikes category.
在法國,哪項產品子類別的銷售金額最高?In France, which product subcategory has the highest amount of sales?
若要尋找答案,我們將使用 「 快速探索 」 功能。請遵循下列步驟:To find the answer, we'll use the Quick Explore feature. Follow these steps:
重新整理瀏覽器視窗,將儀表板還原至其預設檢視。Refresh the browser window to restore the dashboard to its default view.
在 [ GeoSalesReport ] 圖表中,選取 [法國] 長條圖,以顯示快速探索] 按鈕。In the GeoSalesReport chart, select the France bar to display the Quick Explore button.
按一下 (或點選) [快速探索] 按鈕。Click (or tap) the Quick Explore button.
依序展開 [ CompanySales,並選擇 [ ProductSubCategory,然後選擇 [向下切入至 ProductSubCategory。圖表更新以顯示大量的產品。Expand CompanySales, choose ProductSubCategory, and then choose Drill To ProductSubCategory. The chart updates to display lots of products.
指向最高的長條圖。註標隨即出現,指出該長條圖對應至「公路自行車」子類別。Point to the tallest bar. A callout appears that indicates that bar corresponds to the Road Bikes subcategory.
根據 GeoSalesReport 圖表,此公司在法國的「公路自行車」銷售金額最高。According to the GeoSalesReport chart, Road Bikes has the highest amount of sales in France for this company.

另請參閱See also

概念Concepts

商務智慧功能的 Excel Service (SharePoint Server 2013)Business intelligence capabilities in Excel Service (SharePoint Server 2013)

建立 Excel Services 儀表板使用資料模型 (SharePoint Server 2013)Create an Excel Services dashboard using a Data Model (SharePoint Server 2013)