Active Directory 中的使用者帳戶上存在 msExchMasterAccountSID 屬性時,Outlook 發生問題

原始 KB 編號:  2996202

徵狀

移動或遷移信箱後,可能會出現下列一或多項問題:

  • 有些信箱會顯示為連結或共用,而不是使用者信箱。

  • Microsoft Outlook 或 Outlook Web App (OWA)中重複的信箱認證提示

  • 非預期的延遲或暫停的郵件流程。

  • 存取公用資料夾的問題,有時會導致下列錯誤:

    無法展開資料夾。 無法使用 Microsoft Exchange。 網路問題或 Exchange 伺服器已停機,無法進行維護。

原因

當一般使用者帳戶已 msExchMasterAccountSID 在 Active Directory 中填入屬性時,就會發生此行為。

解決方案

若要修正此問題,請從 Exchange 管理命令介面執行下列 PowerShell 命令:

Set-User -Identity useraddress -LinkedMasterAccount $null

例如:

Set-User -Identity user@fabricam.com -LinkedMasterAccount $null

這個命令會 msExchMasterAccountSID 從使用者的帳戶移除屬性。

詳細資訊

msExchMasterAccountSID 屬性不應該存在於 Active Directory 中的一般使用者帳戶。 一般使用者會被視為 msExchRecipientTypeDetails 屬性值為1 (1 = 正常信箱,2 = 連結的信箱)。

如果msExchRecipientTypeDetails = 1,則不 msExchMasterAccountSID 應該存在於 Active Directory 中的帳戶。

如需有關屬性可能值的詳細資訊 msExchRecipientTypeDetails ,請參閱下列 Office 365 博客文章:

O365: Exchange 和 AD-msExchRecipientDisplayType 和 msExchangeRecipientTypeDetails 與您的 On-Premises 的關聯方式