如何診斷及修正公用資料夾許可權問題

症狀

在 Exchange Online 中,您無法執行特殊的工作,例如建立或刪除公用資料夾中的專案或子資料夾。 此外,您可能會收到錯誤訊息,指出這是許可權相關的問題。

原因

發生此問題的原因通常是公用資料夾階層複寫未完成或有問題。

疑難排解步驟

  1. 驗證指派給使用者的公用資料夾信箱。 若要這麼做,請執行下列命令(例如):

    Get-Mailbox -Identity User1 | Format-List *public*
    
  2. 確認公用資料夾許可權已複寫至指派給使用者的公用資料夾信箱。 若要這樣做,請執行下列步驟:

    a)請先檢查主要階層公用資料夾信箱的許可權。 若要這麼做,請執行下列 Cmdlet (例如):

    Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq "True"}).Name
    

    b)針對您在步驟1中取得的公用資料夾信箱,檢查該使用者資料夾的許可權(例如)。

    Get-PublicFolderClientPermission "\puf1" -User1 -Mailbox pubmbx1
    

    此 Cmdlet 會傳回下列輸出:

    There is no existing permission entry found for user: user1.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolderClientPermission], UserNotFoundInPermissionEntryExcep
       tion
        + FullyQualifiedErrorId : [Server=DM6PR01MB4009,RequestId=2559dc80-9fa2-42d6-bf86-fac92f561891,TimeStamp=3/19/2020
        5:22:40 AM] [FailureCategory=Cmdlet-UserNotFoundInPermissionEntryException] 91D3F338,Microsoft.Exchange.Managemen
      t.StoreTasks.GetPublicFolderClientPermission
    + PSComputerName        : outlook.office365.com
    

    輸出指出尚未將許可權複寫至指派給使用者的公用資料夾信箱。 在某些情況下,許可權可能會出現,但是會與步驟2b 中傳回的許可權不同。

解決方案

若要修正此問題,請執行下列 Cmdlet 以手動方式將許可權複寫至使用者指派的公用資料夾信箱(例如):

Update-PublicFolderMailbox pubmbx1 -InvokeSynchronizer

然後,重複此 Cmdlet 以驗證許可權:

Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox pubmbx1

注意

可能需要幾分鐘的時間,才會顯示許可權變更。

詳細資訊

如果許可權仍未同步處理,或是當您強制階層同步處理時符合錯誤,請遵循下列步驟取得階層同步處理記錄:

  1. 比較公用資料夾信箱的階層:

    $P=Get-PublicFolderMailboxDiagnostics <Primary_pfmailboxname> -IncludeHierarchyInfo
    $S= Get-PublicFolderMailboxDiagnostics <pfmailboxname_notreceiving_hierarchy> -IncludeHierarchyInfo
    
  2. 比較兩個信箱的 "HierarchyInfo" 的輸出:

    $p.HierarchyInfo
    $s.HierarchyInfo
    
  3. 如果您判斷階層資訊不相同,請執行下列命令,以查看上次同步處理的時間:

    $S.AssistantInfo.LastAttemptedSyncTime.LocalTime
    

    此命令會指出同步處理失敗的最後時間。 無意義的值表示同步處理永不失敗。

    $s.AssistantInfo.LastFailedSyncTime.LocalTime
    

    下列命令提供來自上一個同步處理失敗的詳細失敗訊息。 空白輸出會指出同步處理從未失敗:

    $s.AssistantInfo.LastSyncFailure
    

    您也可以流覽 AssistantInfo 的其他值,例如 SyncInfo 和 HierarchyInfo 區塊。

如果您必須聯繫 Microsoft 支援人員,請將報告匯出為 XML 格式,然後將其傳送給支援代理程式。 若要匯出報告,請執行下列命令(例如):

Get-PublicFolderMailboxDiagnostics <pf mailbox failing to sync> -IncludeHierarchyInfo |Export-Clixml epf.xml