Teams 缺少撥號鍵台

Microsoft Teams 使用者無法撥打外撥電話,因為 Teams 中 [通話] 畫面中的撥號鍵台已遺失。

原因

在 Teams 用戶端中,撥號鍵台可讓使用者存取公用交換電話網路(PSTN)功能。 只要使用者已正確設定電話系統授權,撥號鍵台便可供使用者使用。 必須符合下列所有條件,撥號鍵台才會出現:

  • 使用者已獲指派 Teams 授權。
  • 使用者已獲指派 Teams 電話系統 (MCOEV) 授權。
  • 使用者使用 Microsoft 通話方案、操作員連線或啟用直接路由。
  • 使用者已啟用企業語音。
  • 使用者位於線上,而不是內部部署商務用 Skype。
  • 使用者已啟用使用 AllowPrivateCalling = True 的 Teams 通話原則。

解決方案

請參閱 撥號鍵台設定 ,以瞭解如何針對 Teams PSTN 通話正確設定使用者。

請使用下列其中一種診斷工具:

  • Microsoft 遠端連線分析程式工具

    Microsoft 365 系統管理員使用者可以在遇到徵狀的使用者內容中執行 Teams PSTN 通話撥號鍵台 測試。

  • Microsoft 365 支援自我診斷工具

    Microsoft 365 系統管理員使用者可以存取可在租用戶內執行的診斷,以確認影響撥號鍵台可能存在的問題。

    注意事項

    這項功能不適用於 Microsoft 365 政府、由 21Vianet 運作 Microsoft 365 或 Microsoft 365 Germany。

    選取 [執行測試] 連結。 其將在 Microsoft 365 系統管理中心填入診斷。

企業語音顯示已停用

如果其中一個工具的診斷結果顯示使用者未啟用企業語音,但使用者帳戶顯示已在 Teams PowerShell 中啟用,則租用戶系統管理員必須關閉並重新開啟設定,以強制更新後端,如下列範例所示:

Set-CsPhoneNumberAssignment -Identity "Ken Myer" -EnterpriseVoiceEnabled $False
Set-CsPhoneNumberAssignment -Identity "Ken Myer" -EnterpriseVoiceEnabled $True

啟用直接路由的使用者遺失撥號鍵台

如果其中一個工具的診斷結果顯示使用者未使用路由原則正確設定,租用戶系統管理員必須移除使用者的 OnlineVoiceRoutingPolicy 值,然後設定原則的正確值,如下列範例所示:

Grant-CsOnlineVoiceRoutingPolicy -Identity "Ken Myer" -PolicyName $Null
Grant-CsOnlineVoiceRoutingPolicy -Identity "Ken Myer" -PolicyName "RedmondOnlineVoiceRoutingPolicy"

這些動作會在 Teams 的後端環境中強制更新原則。 進行這項變更之後,使用者應該會在一小時內看到撥號鍵台出現在 [呼叫] 底下。

其他相關資訊

是否仍需要協助? 前往 Microsoft Community