Outlook add-in API requirement set 1.1

The Outlook add-in API subset of the Office JavaScript API includes objects, methods, properties, and events that you can use in an Outlook add-in. Outlook JavaScript API 1.1 (Mailbox 1.1) is the first version of the API.

Note

This documentation is for a requirement set other than the latest requirement set.

What's new in 1.1?

Requirement set 1.1 includes all of the Common API requirement sets supported in Outlook. It added the ability for add-ins to access the body of messages and appointments and the ability to modify the current item.

Change log

See also