使用標籤來建立檔案的快照

標籤可讓您建立檔案的快照,方便日後回頭參考該快照。 透過使用標籤,您可以檢視、建置或甚至將大量檔案復原至套用標籤時的狀態。

必要的權限

若要套用標籤,您必須將 [標籤] 權限設定為 [允許]。 若要尋找、列出或檢視標籤,您必須將 [讀取] 權限設定為 [允許]。 若要修改或刪除標籤,您必須擁有該標籤或將 [管理標籤] 權限設定為 [允許]。

本文內容

  • 使用標籤

  • 套用標籤

  • 重新命名標籤

  • 列出、尋找、檢視、編輯和移除標籤

  • 將檔案的標籤版本下載到工作區

  • 使用標籤視窗處理標籤

  • 將檔案復原為標籤版本

  • 從命令提示字元工作

使用標籤

在許多軟體專案中,當程式碼已達到合理的品質等級和穩定度時,專案小組便會建置並發行產品的新版本。 專案小組必須標記每個檔案目前的版本,因此即使檔案繼續變更,專案小組仍然可以取得並建置其專案中每個檔案的新版本。

理論上,您可以手動記錄每個檔案的每個變更集 ID,但這種程序顯然不切實際。 Team Foundation 版本控制簡化了這項工作:您可將標籤套用到包含檔案的資料夾、分支或 Team 專案。 您可以依個人偏好,使用任何一種命名慣例為標籤命名。 標籤名稱的範例包括:"Sprint 5"、"M1"、"Beta2" 和 "Release Candidate 0"。

套用標籤之後,您可以使用標籤來限定作業,例如建置、分支、合併、比較和取得特定版本的檔案或資料夾。

有時候您會在套用標籤後才決定要變更標籤。 Team Foundation 版本控制可讓您將標籤套用到其他檔案、從特定檔案移除標籤,甚至是修改套用標籤的特定檔案版本。

提示

套用標籤提供了許多與建立分支相同的優點,但是通常成本較低且比較不複雜。

套用標籤

提示

當您使用 Visual Studio 套用已經存在的標籤時,這項作業會從所有的檔案版本移除標籤,然後再套用標籤。不過,命令列提示字元中的標籤作業會累加。請參閱 Label Command

套用標籤

  1. 在 [原始檔控制總管] 中,開啟要套用標籤之集合、Team 專案、分支、資料夾或檔案的捷徑功能表,並選擇 [進階]、[套用標籤]。

    [新增標籤] 對話方塊隨即出現。

  2. 在 [名稱] 方塊中,輸入標籤的名稱。

  3. (選用) 在 [註解] 方塊中輸入您的註解。

  4. 在 [版本] 清單中,預設會選取 [最新的版本]。 這個選項最常用,不過,如果您需要讓標籤以特定的版本做為目標,請選取:

    • 變更集:在 [變更集] 方塊中指定變更集的編號。 或者,選擇省略符號 (...) 開啟 [尋找變更集] 對話方塊。 如需詳細資訊,請參閱尋找和檢視變更集

    • 日期:在 [日期] 方塊中指定日期,或從下拉式功能表的日曆選取日期。

    • 標籤:指定要做為新標籤之基礎的現有標籤。 在 [標籤] 方塊中輸入標籤名稱,或選擇省略符號 () 開啟 [尋找標籤] 對話方塊。 如需詳細資訊,請參閱尋找、編輯和移除標籤。

    • 工作區版本:為工作區中的版本建立標籤。

  5. 當您對設定感到滿意時,請執行下列其中一個步驟:

    • 若要套用標籤,請選擇 [建立]。

    • 若要套用標籤,然後在套用之後進行修改,請選擇 [建立並編輯]。 這會套用標籤,然後顯示 [標籤] 視窗。 如需使用 [標籤] 視窗編輯標籤的詳細資訊,請參閱使用標籤視窗處理標籤。

注意事項注意事項

當您使用已經存在的名稱套用標籤時,系統會發出警告並詢問您是否要繼續。如果您選擇 [確定] 繼續作業,任何未包含在要套用標籤之路徑中的項目,都將不再具有該標籤。

重新命名標籤

雖然您不能修改現有標籤的名稱,但是可以輕易地將新標籤套用到與其他標籤套用目標完全相同的檔案和相同的版本。

根據現有標籤套用標籤

  1. 在 [原始檔控制總管] 中,開啟專案集合節點 (根節點) 的捷徑功能表,然後選擇 [進階]、[套用標籤]。

    [新增標籤] 對話方塊隨即出現。

  2. 在 [名稱] 方塊中,輸入標籤的名稱。

  3. (選用) 在 [註解] 方塊中輸入註解。

  4. 在 [版本] 清單中,選取 [標籤]。

    [標籤] 方塊隨即出現。

  5. 請執行下列其中一個步驟:

    • 輸入現有標籤的名稱。

    • 如果您不確定現有標籤的名稱,請選擇 [標籤] 方塊旁,具有省略符號 (…) 的瀏覽按鈕。

      [尋找標籤] 對話方塊隨即出現。

      使用 [尋找標籤] 對話方塊中的選項來篩選標籤清單,並尋找要套用新標籤的現有標籤(如需詳細資訊,請參閱尋找、編輯和移除標籤)。

  6. 選擇 [建立]。

  7. (選用) 建立新標籤之後,您可以移除舊標籤。如需詳細資訊,請參閱尋找、編輯和移除標籤。

列出、尋找、檢視、編輯和移除標籤

列出及尋找標籤的途徑有兩個:一個是 [尋找標籤] 對話方塊,另一個是 [記錄] 視窗中的 [標籤] 索引標籤。 在您找到所需的標籤之後,便可檢視、編輯、移除該標籤,或是使用套用該標籤的檔案。

使用尋找標籤對話方塊尋找及使用標籤

  1. 在 [原始檔控制總管] 中的功能表列上,依序選擇 [檔案]、[原始檔控制]、[尋找]、[尋找標籤]。

    [尋找標籤] 對話方塊隨即出現。

  2. (選用) 執行下列一個或多個步驟,限定您的搜尋範圍:

    • 在 [名稱] 文字方塊中,輸入標籤的名稱。

    • 在 [專案] 清單中,選取包含您要尋找之標籤的 Team 專案。

    • 在 [擁有者] 文字方塊中,輸入標籤擁有者的名稱或別名。

  3. 選擇 [尋找]。

    [結果] 清單隨即顯示符合所輸入搜尋準則的標籤。

  4. (選擇性) 請執行下列其中一個步驟:

    • 若要檢視或編輯標籤,請選取該標籤,然後選擇 [編輯]。

      [標籤] 視窗隨即出現。 如需詳細資訊,請參閱使用標籤視窗處理標籤。

    • 若要刪除標籤,請選取該標籤,然後選擇 [刪除]。

    • 選擇 [關閉]。

有時候,您可能不確定標籤的名稱,但是知道標籤已套用到受到版本控制的特定項目。 下列程序說明如何在這種情況下尋找標籤並使用標籤。

列出並使用套用到特定項目的標籤

  1. 在 [原始檔控制總管] 中,開啟套用所要尋找標籤之項目的捷徑功能表,然後選擇 [檢視記錄]。

    [記錄] 視窗隨即出現。

  2. 選擇 [標籤] 索引標籤,顯示套用至此項目的標籤清單。

  3. (選擇性) 請執行下列其中一個步驟:

    • 若要檢視或編輯標籤,請開啟標籤的捷徑功能表,並選擇 [編輯標籤]。

      [標籤] 視窗隨即出現。 如需如何使用此視窗的詳細資訊,請參閱使用標籤視窗處理標籤。

    • 若要刪除標籤,請開啟標籤的捷徑功能表,並選擇 [刪除標籤]。

    • 開啟標籤的捷徑功能表並選擇其他動作,例如 [取得這個版本] 和 [比較]。

如需如何使用 [記錄] 視窗中 [標籤] 索引標籤的詳細資訊,請參閱 取得項目的歷程記錄

將檔案的標籤版本下載到工作區

將一組檔案加上標籤的程序就像是建立這些檔案在特定時間點的快照一樣。 在建立這個快照的幾週或幾個月後,您可能需要檢視或使用存在該快照中的檔案。 下列程序說明如何將一組檔案的標籤版本下載到工作區中。

將檔案的標籤版本下載到工作區

  1. 在 [原始檔控制總管] 中,開啟包含您要下載之項目的專案集合、Team 專案、分支或資料夾的捷徑功能表,然後選擇 [進階]、[取得特定版本]。

    [取得] 對話方塊隨即出現。

  2. 從 [類型] 清單選取 [標籤],然後在 [標籤] 方塊中輸入標籤名稱,或選擇省略符號 () 開啟 [尋找標籤] 對話方塊。 如需如何使用此對話方塊的詳細資訊,請參閱尋找、編輯和移除標籤。

  3. 檢閱並視情況選取 [取得] 對話方塊中的其他選項。

  4. 選擇 [取得]。

使用標籤視窗處理標籤

使用上述其中一個程序開啟 [標籤] 視窗之後,您就可以準備開始處理標籤。 視窗頂端有一個顯示註解的方塊,您可以視需要編輯此註解。

您可以使用 [標籤] 視窗執行下列工作:

  • 將項目加入至標籤

  • 從標籤移除項目

  • 變更檔案的版本

  • 在項目上執行其他動作

將項目加入至標籤

  1. 在 [標籤] 視窗中,選擇 [加入項目]。

    [選擇項目版本] 對話方塊隨即出現。

  2. 在 [選擇項目版本] 對話方塊中,巡覽並選取您要加入的項目。

    提示

    您可以按住 CONTROL 或 SHIFT 鍵,然後選取多個項目。

  3. (選擇性) 如果您需要讓標籤以特定的版本做為目標,請從 [版本] 清單選取:

    • 最新的版本:標籤將套用至版本控制中最新的版本。

    • 變更集:在 [變更集] 方塊中指定變更集的編號。 或者,選擇省略符號 (...) 開啟 [尋找變更集] 對話方塊。 如需詳細資訊,請參閱尋找和檢視變更集

    • 日期:在 [日期] 方塊中指定日期,或從下拉式功能表的日曆選取日期。

    • 標籤:指定要做為新標籤之基礎的現有標籤。 在 [標籤] 方塊中輸入標籤名稱,或選擇省略符號 () 開啟 [尋找標籤] 對話方塊。 如需詳細資訊,請參閱尋找、編輯和移除標籤。

    • 工作區版本:為工作區中的版本建立標籤。

  4. 選擇 [確定]。

  5. 選擇 [檔案]、[儲存]。

從標籤移除項目

  1. 在 [標籤] 視窗中,找出您要從這個標籤移除的集合、Team 專案、分支、資料夾或檔案。

  2. 開啟項目的捷徑功能表並選擇 [從標籤移除]。

    標籤隨即從項目中移除。 如果項目是專案集合、Team 專案、分支或資料夾,則標籤也會從其內含的所有項目移除。

  3. 選擇 [檔案]、[儲存]。

變更檔案的版本

  1. 在 [標籤] 視窗中,找出您要修改的檔案。

  2. 開啟檔案的捷徑功能表並選擇 [變更標記版本]。

  3. [變更標記版本] 對話方塊隨即出現。

  4. 選取:

    • 最新的版本:將標籤套用至版本控制中最新的版本。

    • 變更集:在 [變更集] 方塊中指定變更集的編號。 或者,選擇省略符號 (...) 開啟 [尋找變更集] 對話方塊。 如需詳細資訊,請參閱尋找和檢視變更集

    • 日期:在 [日期] 方塊中指定日期,或從下拉式功能表的日曆選取日期。

    • 標籤:指定要做為新標籤之基礎的現有標籤。 在 [標籤] 方塊中輸入標籤名稱,或選擇省略符號 () 開啟 [尋找標籤] 對話方塊。 如需詳細資訊,請參閱尋找、編輯和移除標籤。

    • 工作區版本:為工作區中的版本建立標籤。

  5. 選擇 [檔案]、[儲存]。

在標籤項目上執行其他動作

您在 [標籤] 視窗中開啟項目的捷徑功能表時,也可以選擇下列其中一個命令:

從命令提示字元工作

  • Label Command:套用或移除標籤。

    提示

    當您使用這個命令套用標籤時,可以指定 Team 專案以外的範圍。

  • Labels Command:列出標籤。

請參閱

概念

尋找和檢視變更集

建立和使用工作區

Team Foundation Server 的權限參考

使用原始檔控制總管來管理版本控制下的檔案

其他資源

在 Team Foundation 版本控制中使用分支隔離風險