Word 2010 中的變更

 

適用版本: Office 2010

上次修改主題的時間: 2016-11-29

自 Microsoft Office Word 2007 發行之後,Microsoft Word 2010 進行了一些變更,另外也納入新的移轉考量。如果您是從 Microsoft Office Word 2003 升級,請參閱 Office Word 2007 的變更 (http://go.microsoft.com/fwlink/?linkid=169004\&clcid=0x40)。

本文內容:

  • 新功能

  • 變更的功能

  • 移除的功能

  • 移轉考量

新功能

本節重點在於說明 Word 2010 中的新功能。

Fluent UI

Word 2010 使用者介面已經過重新設計,改用 Microsoft Office Fluent 使用者介面 (UI)。Fluent UI 於 2007 Microsoft Office 系統 中推出,其設計目的在讓使用者能夠更快速地找到並使用 Office 應用程式所提供的各項功能,而於此同時仍能保持工作區的有條不紊。如需 Fluent UI 的詳細資訊,請參閱 Microsoft Office Fluent 使用者介面資源中心 (可能為英文網頁) (http://go.microsoft.com/fwlink/?linkid=111045\&clcid=0x40)(可能為英文網頁) (可能為英文網頁) 內的資源。

功能區

功能區是 Fluent UI 的一部分,其設計目的是要最佳化主要 Word 2010 文件案例,以更便於使用。利用功能區可更快速地存取 Word 2010 中的所有命令,且讓後續的新增與自訂更加簡便。您亦可自訂功能區,例如,建立自訂的索引標籤以及自訂含有常用命令的自訂群組。若要將頁面中文件的空間放到最大,在撰寫時也可隱藏功能區。

Backstage 檢視

Microsoft Office Backstage 是 Fluent UI 的一部分,也是功能區的附加功能。您可從 [檔案] 功能表存取 Backstage 檢視,此檢視有助於您找到管理 Word 文件檔案的常用功能。([檔案] 索引標籤已取代 [Microsoft Office] 按鈕與 Microsoft Office 較早版本中所使用的 [檔案] 功能表。) Backstage 檢視可用以管理檔案以及檔案相關資料,如建立及儲存檔案、檢查隱藏的中繼資料或個人資訊,以及設定選項。

檔案格式

Word 2010 檔案格式能使用如共同撰寫、新圖形與文字效果,以及新編號格式等新功能。Word 2010 可搭配 Office Word 2007 文件使用。

受保護的檢視

位於可能不安全之位置 (例如網際網路或電子郵件附件) 的檔案,或包含主動式內容的檔案 (例如巨集、資料連線或 ActiveX 控制項),會經過驗證並可在 [受保護的檢視] 中開啟。當您在 [受保護的檢視] 模式中開啟檔案時,會停用編輯功能。您可以按一下 [啟用編輯],從信任的來源開啟及編輯檔案。您也可以在 Backstage 檢視中,瀏覽檔案的相關資料。

共同作業與共用功能

Word 2010 支援共同撰寫功能。共同撰寫功能可簡化共同作業,讓多位使用者在同一份文件上工作,而不會影響或封鎖其他人。Office 2010 支援在 Microsoft SharePoint Server 2010 上的 Word 2010、Microsoft PowerPoint 2010 及 Microsoft OneNote 2010 文件共同撰寫功能。Microsoft Excel Web App 及 Microsoft OneNote Web App 亦支援新的共同撰寫功能。若使用非位於執行 SharePoint Server 2010 之伺服器上的文件時,Word 2010 就僅支援單一使用者編輯。這些變更包括:

  • 新內容會自動反白顯示。

  • 顯示作者縮寫的色彩編碼橫條,可識別任何新增或共用內容的作者資訊。

  • 版本支援能讓使用者查看文件變更的時間與作者,且會自動反白顯示相較於文件舊版的變更。

  • 更快速地同步處理頁面,以幾近即時地對所有作者顯示變更。

文件撰寫與圖形增強功能

Word 2010 提供改良的編輯工具與新的圖片工具,能讓您將文件轉換成具美術效果的文件。新編輯工具如下:

  • 圖片校正選項

  • 美術效果選項

  • 背景移除

  • 圖片版面配置選項

變更功能

本節摘要 Word 2010 中的變更。

XML 檔案格式的自訂 XML 標記

Word 2010 無法再讀取 .DOCX, .DOCM, .DOTX, .DOTM 或 .XML 檔案內包含的自訂 XML 標記。Word 2010 仍然能夠開啟這些檔案,但是會移除任何自訂 XML 標記。如需詳細資訊,請參閱 KB #2445060

剪下、複製與貼上

剪下、複製與貼上是在應用程式間移動內容最常見的方式。Word 2010 可在許多格式中複製與貼上內容。Word 2010 提供從貼上前的預覽到貼上之許多選項。貼上選項包括下列:

  • 保留來源格式設定

  • 合併格式設定

  • 使用目的地佈景主題

  • 僅保留文字

文件引導模式

撰寫體驗業已經改良,您可以用新的方式,依據標題、頁面或物件瀏覽內容。瀏覽窗格已取代了文件引導模式,因此使用者將會看到新的瀏覽窗格。使用者可以看到文件的所有標題、其相關位置與目前的位置。這樣一來,您只需要按一下窗格,就能在不同標題間移動。大綱可以摺疊以隱藏大型複雜文件的巢狀標題。使用者再也不會看到引導標題中的修訂標記,而只會在窗格中看到修訂的最終結果。

這項變更的整體好處是能讓介面更整齊,且與功能區的外觀相符。使用者也可以存取下列的一些新功能:

  • 管理窗格中的標題以重新排列文件內容。

  • 與「尋找」功能互動,反白顯示尋找結果的標題。

可調整大小的窗格包含以下:

  • 新「尋找」功能文字方塊

  • 可變更檢視類型的檢視切換器

  • 跳至「上一個」或「下一個」項目的按鈕

  • 主要區域 (可巡覽項目的清單) 在需要時可加以捲動

預設會顯示窗格,但也可以用捲軸頂端的切換鈕、[檢視] 索引標籤,或閱讀模式的導覽控制項,將之隱藏。存取瀏覽窗格的核取方塊與之前文件引導模式的相同,只是名稱有所變更。

預覽列印

預覽列印體驗與 [列印] 對話方塊已合併至 Backstage 檢視的「列印區」。所有 Office 應用程式都能使用此功能,且可用協力廠商開發人員的物件模型加以呼叫,並建立 Word 2010 的增益集。工作流程處理仍是按下 CTRL+P 鍵或選取 Backstage 的 [列印]。「預覽列印編輯模式」則是已完全遭取代。

RTF 檔案格式

已不再加強 RTF 檔案格式以包含新的用法及功能,儲存為 RTF 格式時,Word 2010 與後續版本 Word 的新用法及功能都將遺失。此外,Word 2010 支援以 Open XML 格式為基礎的新式轉換器介面。

智慧標籤

智慧標籤識別規則已不會再自動識別文字,也不會再顯示紫色的虛線底線。反之,使用者可以按一下快顯功能表上的 [其他動作],觸發識別並檢視與文字相關的自訂動作。一旦使用者將 IP 移至目前段落以外,即清除該段落的文字標籤。文件中不會儲存物件模型以反映智慧標籤識別規則所標記的文字變更。

檢視

在 Word 2010 中,當您按一下 [檢視] 索引標籤時,會有下列選項:

  • 預覽列印

  • 閱讀版面配置

  • Web 版面配置

  • 大綱

  • 草稿 (一般)

移除的功能

本節提供 Word 2010 中已移除之功能的相關資訊。

移除人名智慧標籤

人名 (Outlook 電子郵件連絡人) 智慧標籤將予移除,改由使用 Microsoft Office Communicator 的全域通訊清單 (GAL) 功能取代。而 Word 中的該項功能會由本文上述的 [其他動作] 功能所取代,但在 Excel 中,則會完全移除該功能。2007 Office System 將是支援此功能的最後版本。

自動摘要

自動摘要是會列出標題、主旨、作者、關鍵字與註解的功能。以往,您可在 [工具] 功能表中使用此功能。但在 Word 2010 中,已不再使用此功能。若您在文件中插入摘要,也不會有自動摘要資料。但是,若文件是在摘要檢視中儲存,其開啟後也不會是摘要資料。

Microsoft Office Document Imaging (MODI)

MODI 提供 Office 的一般文件圖像與掃描解決方案,原先也是 Office 的基礎傳真功能。安裝 MODI 之後,其為 .tif, .tiff, 及 .mdi 檔的預設處理程式。在 Office 2010 中,則已完全取代 MODI。這項變更也導致設定的樹狀結構不再顯示 [工具] 功能表上的 MODI 說明、OCR 或索引服務篩選節點。Office 2010 中的網際網路傳真功能會使用 Windows Fax 印表機驅動程式,產生固定的檔案格式 (TIF)。64 位元 Office 2010 的 MODI 及其所有元件皆已被取代。

參考及參照窗格

Windows Internet Explorer 7 的 [研究參考資料] 窗格已遭移除。因此,Microsoft Word 2010 的快速鍵「Alt+按一下」已不會再跳至該窗格。[研究參考資料] 功能會開啟用以搜尋所有近端 (Intranet) 網站及入口的搜尋窗格。

使用 Works 資料庫合併列印

因為物件模型有所變更,所以使用者無法在 Microsoft Word 2010 或 Microsoft Publisher 2010 中使用 Works 資料庫執行合併列印。其主要會影響已設定讀取來自 Works 資料庫的內容時要重複出現合併列印的使用者。建議您使用 Works 匯出資料然後建立新的資料來源,以執行合併列印操作。

搜尋文件庫按鈕

[搜尋組件庫] 按鈕已從 [插入引文] 功能表 (於 [參照] 索引標籤上) 移除。

WLL (Word 增益集庫)

32 位元 Office 2010 的 WLL 檔已遭取代,且不再支援 64 位元 Office 2010。WLL 是 Microsoft Word 的增益集,您可以使用任何支援建置 DLL 的編譯器加以建置。

移轉考量

本節說明當您從 Office Word 2007 移轉至 Word 2010 時要考量的變更。

移轉 Word 檔案

Microsoft Office 2010 的預設檔案格式沒有變更。2007 Microsoft Office 系統 已引進以 XML 為基礎的檔案格式,且可持續使用。若要檢閱 XML 檔案格式,請參閱 2007 Office system 的 XML 檔案格式概觀 (可能為英文網頁) (http://go.microsoft.com/fwlink/?linkid=182085\&clcid=0x40)(可能為英文網頁) (可能為英文網頁)。

當您以 Word 2010 開啟文件時,會以下列三個模式之一加以開啟:

  • Word 2010

  • Word 2007 相容模式

  • Word 97-2003 相容模式

若要判斷文件處於哪個模式,請按一下文件的標題列。若檔案名稱之後出現 [(相容模式)],則文件應是 Word 2007 相容模式或 Word 97-2003 相容模式。您可以繼續在相容模式中工作,或是將文件轉換為 Word 2010 檔案格式。

  1. 按一下 [檔案] 索引標籤。

  2. 執行下列其中一項操作:

    • 若要轉換文件而不儲存複本,請按一下 [資訊],然後按一下 [轉換]。

    • 若要在 Word 2010 模式中建立文件的新複本,請按一下 [另存新檔],並在 [檔案名稱] 方塊中輸入文件的新名稱,然後按一下 [檔案類型] 清單中的 [Word 文件]。

  3. 按一下 [資訊],然後按一下 [轉換]。

相容性檢查程式

相容性檢查程式會列出文件中不支援或在 Word 2007 或 Word 97-2003 格式中行為有所不同的元素。這些功能的一部分可能會永久變更,且當您稍後將文件轉換成 Word 2010 格式時,也不會轉換為 Word 2010 元素。

內嵌 Word 2010 物件

Open XML 內嵌物件可加以轉換,以利舊版 Word 使用者能對其進行變更。

  1. 用滑鼠右鍵按一下內嵌物件。

  2. 指向 [文件物件],然後按一下 [轉換]。

  3. 在 [轉換] 對話方塊中,按一下 [轉換至]。

  4. 在 [物件類型] 清單中,選取 [Microsoft Word 97-2003 文件]。

方程式

若您將文件儲存為 Word 97-2003 格式,方程式會轉換成您無法編輯的圖片。但若您稍後將此文件轉換成 Word 2010 檔案格式,而在舊版中的方程式圖片上無任何變更時,方程式就會變成文字,讓您可以進行變更。

SmartArt 圖形

當您將含有 SmartArt 圖形的文件儲存為 Word 97-2003 格式時,圖形會轉換成靜態圖像。因此,您將無法變更圖形中的文字、版面配置或一般外觀。但若您稍後將文件轉換成 Word 2010 檔案格式,而在舊版中的方程式圖片上無任何變更時,圖形就會變回 SmartArt 圖形。

從 Office 97-2003 到 Office 2010 的移轉考量

從 Office 97-2003 到 Office 2010 的許多變更都與從 Office 97-2003 到 2007 Office System 相同。

如需從 Office 97-2003 到 2007 Office System 的移轉考量清單,請參閱 Word 2007 的移轉考量 (http://go.microsoft.com/fwlink/?linkid=182089\&clcid=0x40)。

Word 2010 的下列變更可能會影響移轉:

  • 自動圖文集已移回 Normal.dotm 以讓自動完成功能更加完善。我們建議從 Office Word 2003 移轉到 Word 2010 的使用者,先將文件移到 %AppData%\Word\Startup,然後按照下列步驟升級文件。Office Word 2007 使用者會發現其自動圖文集已自動移動。

  • 「自訂快速組件庫」中現在已提供「自動圖文集庫」。因此,使用者不必再將「自動圖文集」移動至「自訂快速組件庫」了。

  • 當您第一次啟動應用程式時,Word 會自動將建置組塊移轉為 Word 2010。其會建立現有建置組塊的複本,並將之放置於新的目錄:%AppData%\Document Building Block\{||cc}\14 中,然後去除檔案中 Office Word 2007 提供的建置組塊。

  • 與 Word 2007 相似,在第一次啟動時,Word 2010 會給您新的 Normal.dotm,而將舊的 normal 檔案命名為 normalold.dotm。若您想要從 Word 2007 還原設定,請以滑鼠右鍵按一下檔案,然後按一下 [開啟]。若是在 Word 中,您應該使用 Backstage 檢視的 [轉換] 按鈕,將 normal 檔案轉換為 Word 2010 格式。

VBA 設定移轉

在 Office 2010 中,Visual Basic for Applications (VBA) 6.0 已更新為 VBA 7.0。VBA 7.0 設定在移轉之後會重設回其預設值,而不會自動重新填入值。這是因為 VBA 的登錄設定,在 Office 2010 中位於不同的登錄區,如下表所示。

版本 登錄子機碼

Office 2000 到 Office 2007

HKEY_CURRENT_USER\SOFTWARE\Microsoft\VBA\6.0\Common

Office 2010

HKEY_CURRENT_USER\SOFTWARE\Microsoft\VBA\7.0\Common

若要更正此問題,請將 VBA 6.0 登錄機碼從 6.0 登錄區複製到 7.0 登錄區。

如需詳細資訊,請參閱<移轉至 Office 2010 的使用者登錄設定>及 32 位元與 64 位元版本 Office 2010 的相容性 (可能為英文網頁) (http://go.microsoft.com/fwlink/?linkid=185841\&clcid=0x40)(可能為英文網頁) (可能為英文網頁)。