建立新文件或專案

建立新文件

  1. 在 [檔案] 功能表上,按一下 [新增項目],然後執行下列一項動作:

    • 按一下 [視窗],將最上層視窗或對話方塊新增至 WPF 專案。

    • 按一下 [UserControl] 可定義可內嵌於 WPF 專案其他部分內的介面元件。

    • 按一下 [網頁] 可包含位於 WPF 專案中,而可在瀏覽器主控的應用程式或導覽視窗中導覽的專案部分。

    • 按一下 [資源字典] 可儲存資源並且在專案的各部分間共用資源。

    • 按一下 [場景],為 Microsoft Silverlight 1.0 專案建立新的介面元件。

  2. 若要重新命名檔案,請在 [名稱] 方塊中輸入文件的名稱。

  3. 若要產生新文件的程式碼後置檔案,請選取 [包含程式碼檔案] 核取方塊 (僅限 WPF)。

Cc295275.7e183f1f-37d8-4dcb-980c-19a5d61ca087(zh-tw,Expression.10).gif回到頁首

建立新的 WPF 專案

  1. 在 [檔案] 功能表上,按一下 [新增專案]。

  2. 在 [建立新專案] 對話方塊的 [選取專案類型] 下,按一下 [ WPF應用程式 (.exe)] 或 [WPF 控制項程式庫]。

  3. 在 [名稱] 方塊中輸入專案名稱。

  4. 在 [位置] 方塊中,輸入或瀏覽要用於儲存專案的資料夾。根據預設值,這個資料夾名為 [Blend Projects],且位於 [我的文件] 資料夾。

    Cc295275.alert_note(zh-tw,Expression.10).gif注意事項:

    在 [選項] 對話方塊 ([工具] 功能表) 的 [專案] 索引標籤中,選取 [將新專案儲存到 Expression Blend Projects 資料夾] 選項時,才可以使用 [位置] 方塊。

  5. 在 [語言] 功能表中,選取程式設計語言 (Visual C# 或 Visual Basic)。

    Cc295275.alert_note(zh-tw,Expression.10).gif注意事項:

    一般而言,您可以略過選取程式設計語言的動作,使用預設的程式設計語言 C# (使用 C# 則會建立 .cs 檔案)。不過,有時設計應用程式的開發人員可能會想要指定特定的程式設計語言,例如 Microsoft Visual Basic (會產生 .vb 檔案),原因可能是為了容易使用、熟悉或使專案檔更容易與傳統程式碼整合。

  6. 按一下 [確定],Microsoft Expression Blend 會建立新專案並將其開啟以進行編輯,視 [選項] 對話方塊 ([工具] 功能表) 的 [專案] 索引標籤中選取的下列設定而定:

    • 將新專案儲存到 Expression Blend Projects 資料夾   此設定會自動將新專案儲存到磁碟的 Expression Blend Projects 資料夾,或是儲存到在 [建立新專案] 對話方塊的 [位置] 方塊中所指定的資料夾。在專案尚未儲存到磁碟之前,專案是暫存狀態,而且無法使用部分功能 (例如檢視事件或瀏覽專案) 。

    • 啟動時建立暫存專案   這個設定會在啟動 Expression Blend 時自動建立暫存的空專案。這個暫存專案將不會儲存到磁碟,無論之前的設定為何。

    • 使用 [格線] 面板作為新項目的預設版面配置   這個設定使用 Grid 元素作為文件中的根版面配置元素。如果您未選取這個設定,Canvas 元素可以作為文件的根版面配置元素。

Cc295275.7e183f1f-37d8-4dcb-980c-19a5d61ca087(zh-tw,Expression.10).gif回到頁首

建立新的 Silverlight 1 專案

Cc295275.7e183f1f-37d8-4dcb-980c-19a5d61ca087(zh-tw,Expression.10).gif回到頁首

建立新的 Silverlight 2 專案

Cc295275.7e183f1f-37d8-4dcb-980c-19a5d61ca087(zh-tw,Expression.10).gif回到頁首