開啟、檢視及列印死結檔案 (SQL Server Management Studio)Open, view, and print a deadlock file (SQL Server Management Studio)

適用於: 是SQL Server 是Azure SQL Database 否Azure SQL 資料倉儲 否平行處理資料倉儲 APPLIES TO: yesSQL Server yesAzure SQL Database noAzure SQL Data Warehouse noParallel Data Warehouse

SQL Server ProfilerSQL Server Profiler 產生死結時,您可以擷取死結資訊並將資訊儲存至檔案。When SQL Server ProfilerSQL Server Profiler generates a deadlock, you can capture and save the deadlock information to a file. 在儲存死結檔案之後,您可以在 SQL Server Management StudioSQL Server Management Studio 中開啟檔案,再檢視或列印它。After you've saved the deadlock file, you can open it in SQL Server Management StudioSQL Server Management Studio to view it or print it.

開啟和檢視死結檔案Open and view a deadlock file

  1. SQL Server Management StudioSQL Server Management Studio 的 [檔案] 功能表上,指向 [開啟] ,然後選取 [檔案] 。On the File menu in SQL Server Management StudioSQL Server Management Studio, point to Open, and then select File.

  2. 在 [開啟檔案] 對話方塊中,從 [檔案類型] 方塊中選取 .xdl 檔案類型。In the Open File dialog box, select the .xdl file type in the Files of type box. 您現在會有一份只有死結檔案的篩選清單。You now have a filtered list of only deadlock files.

  1. SQL Server Management StudioSQL Server Management Studio 的 [檔案] 功能表上,指向 [開啟] ,然後選取 [檔案] 。On the File menu in SQL Server Management StudioSQL Server Management Studio, point to Open, and then select File.

  2. 在 [開啟檔案] 對話方塊中,從 [檔案類型] 方塊中選取 .xdl 檔案類型。In the Open File dialog box, select the .xdl file type in the Files of type box. 您現在會有一份只有死結檔案的篩選清單。You now have a filtered list of only deadlock files.

  3. 選取您要列印的死結檔案,然後選取 [開啟] 。Select the deadlock file you want to print, and select Open.

  4. 在 [檔案] 功能表上,選取 [列印] 。On the File menu, select Print.

另請參閱See also

儲存 Deadlock Graph (SQL Server Profiler)Save deadlock graphs (SQL Server Profiler)