複製資料表Duplicate Tables

本主題適用於: 是SQL Server (從 2016 開始)是Azure SQL Database是Azure SQL 資料倉儲 是平行處理資料倉儲 THIS TOPIC APPLIES TO: yesSQL Server (starting with 2016)yesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse

您可以使用 SQL Server 2016SQL Server 2016Transact-SQLSQL Server Management Studio 來建立新的資料表,然後從現有的資料表複製資料行資訊,藉以在 Transact-SQLTransact-SQL 中複製現有的資料表。You can duplicate an existing table in SQL Server 2016SQL Server 2016 by using Transact-SQLSQL Server Management Studio or Transact-SQLTransact-SQL by creating a new table and then copying column information from an existing table.

重要

這個作業只會複製資料表的結構,不會複製任何資料表資料列。This operation duplicates only the structure of a table; it does not duplicate any table rows.

本主題內容In This Topic

開始之前 Before You Begin

安全性 Security

Permissions Permissions

需要目的地資料庫中的 CREATE TABLE 權限。Requires CREATE TABLE permission in the destination database.

使用 SQL Server Management Studio Using SQL Server Management Studio

若要複製資料表To duplicate a table

  1. 請確定已連接至要建立資料表的資料庫,以及已在 [物件總管] 中選取資料庫。Make sure you are connected to the database in which you want to create the table and that the database is selected in Object Explorer.

  2. 在 [物件總管] 中,以滑鼠右鍵按一下 [資料表],再按一下 [新增資料表]。In Object Explorer, right-click Tables and click New Table.

  3. 在 [物件總管] 中,以滑鼠右鍵按一下您要複製的資料表,然後按一下 [設計]。In Object Explorer right-click the table you want to copy and click Design.

  4. 選取現有資料表中的資料行,再從 [編輯] 功能表中按一下 [複製]Select the columns in the existing table and, from the Edit menu, click Copy.

  5. 切換回新的資料表,並選取第一列。Switch back to the new table and select the first row.

  6. [編輯] 功能表中,按一下 [貼上]From the Edit menu, click Paste.

  7. 從 [檔案] 功能表中,按一下 [儲存] table nameFrom the File menu, click Savetable name.

  8. [選擇名稱] 對話方塊中,輸入新資料表的名稱,並按一下 [確定]In the Choose Name dialog box, type a name for the new table and click OK.

使用 Transact-SQL Using Transact-SQL

若要在查詢編輯器中複製資料表To duplicate a table in Query Editor

  1. 請確定已連接至要建立資料表的資料庫,以及已在 [物件總管] 中選取資料庫。Make sure you are connected to the database in which you want to create the table and that the database is selected in Object Explorer.

  2. 以滑鼠右鍵按一下您想要複製的資料表,並依序指向 [編寫資料表的指令碼為] 和 [CREATE 至],然後選取 [新增查詢編輯器視窗]。Right-click the table you wish to duplicate, point to Script Table as, then point to CREATE to, and then select New Query Editor Window.

  3. 變更資料表的名稱。Change the name of the table.

  4. 移除新資料表不需要的任何資料行。Remove any columns that are not needed in the new table.

  5. 按一下 [執行] 。Click Execute.