當您使用 Active Directory 診斷範本執行 Perfmon.exe,以在域控制器上產生報告時,報表產生程式可能會停止回應

本文提供協助以修正當您使用 Active Directory 診斷範本執行 Perfmon.exe 以產生報告時,報表產生程式停止響應的問題。

適用:Windows Server 2012 R2
原始 KB 編號: 971714

徵狀

當您使用 Active Directory 診斷範本執行 Perfmon.exe,以在 Windows Server 域控制器上產生報告時,進程可能會停止回應。

原因

發生此問題的原因是執行 TraceRpt.exe 工具的可靠性和 效能監視器 (Perfmon.exe) 主控台在報告產生程式期間耗用太多記憶體和 CPU 資源。 如果 Windows Server 忙碌且缺少資源,報表產生程式將會停止回應。

解決方案

若要解決此問題,請將檔案複製到具有相同伺服器角色且有足夠的硬體資源的不同計算機。 然後,使用檔案執行 TraceRpt.exe。 如果要執行這項操作,請依照下列步驟執行:

  1. 在 [可靠性與 效能監視器 (Perfmon.exe) 控制台中,按兩下 [資料收集器集合],然後按兩下 [系統]

  2. 以滑鼠右鍵按兩下 [Active Directory 診斷],然後按兩下 [ 啟動]。 檔案收集程式會在 Windows Server 域控制器上啟動。

  3. 當報表狀態變更為 產生報表 而無法 收集數據一<段時間>之後**,請將檔案複製到第二個 Windows Server 域控制器。

    注意事項

    您可以在下列位置找到檔案: %systemdrive%\Perflogs\ADDS\ date report generation run \*

    Ths “-df” 參數是指定使用 Perfmon 產生的 Microsoft 特定計數/報告架構檔案。 此檔名名為 report.xsl

  4. 找出檔案,然後在第二個 Windows Server 域控制器的命令行執行下列命令:

    tracerpt *.blg *.etl -df *PerfmonSchemaFileName.xsl* -report *your_report.html* -f html **** ****
    
  5. 使用 Windows Internet Explorer 來檢視所產生的 .html 檔案。