一般調試選項General debugging options

若要設定 Visual Studio 偵錯工具選項,請選取 [工具 > 選項],然後在 [調試 程式] 底下選取或取消選取 [一般] 選項旁的方塊。To set Visual Studio debugger options, select Tools > Options, and under Debugging select or deselect the boxes next to the General options. 您可以使用 [工具 匯 > 入和匯出設定] 來還原所有預設設定,以 > 重設所有設定You can restore all default settings with Tools > Import and Export Settings > Reset all settings. 若要重設設定子集,請先使用 [匯 入和匯出設定] 嚮導 來儲存您的設定,然後再進行要測試的變更,然後在之後匯入儲存的設定。To reset a subset of settings, save your settings with the Import and Export Settings Wizard before making the changes that you want to test, then import your saved settings afterward.

您可以設定下列 一般 選項:You can set the following General options:

刪除所有中斷點之前請先詢問:在完成 [ 刪除所有中斷點 ] 命令之前需要確認。Ask before deleting all breakpoints: Requires confirmation before completing the Delete All Breakpoints command.

當一個進程中斷時中斷所有進程:中斷時,會同時中斷附加偵錯工具的所有進程。Break all processes when one process breaks: Simultaneously breaks all processes to which the debugger is attached, when a break occurs.

中斷跨 AppDomain 或 managed/原生界限的例外 狀況:在 managed 或混合模式的偵錯工具中,當下列條件成立時,common language runtime 可以攔截跨應用程式域界限或 managed/原生界限的例外狀況:Break when exceptions cross AppDomain or managed/native boundaries: In managed or mixed-mode debugging, the common language runtime can catch exceptions that cross application domain boundaries or managed/native boundaries when the following conditions are true:

  1. 當機器碼使用 COM Interop 呼叫受控程式碼,且受控程式碼擲回例外狀況時。When native code calls managed code by using COM Interop and the managed code throws an exception. 請參閱 COM Interop 簡介See Introduction to COM Interop.

  2. 當在應用程式定義域 1 中執行的受控程式碼呼叫應用程式定義域 2 中的受控程式碼,且應用程式定義域 2 中的程式碼擲回例外狀況時。When managed code running in application domain 1 calls managed code in application domain 2, and the code in application domain 2 throws an exception. 請參閱使用應用程式定義域設計程式See Programming with application domains.

  3. 當程式碼使用反映呼叫函式時,該函式會擲回例外狀況。When code calls a function by using reflection, and that function throws an exception. 請參閱 反映See Reflection.

在條件2和3中,例外狀況有時候是由 managed 程式碼攔截, mscorlib 而不是由 common language runtime 所捕捉。In conditions 2 and 3, the exception is sometimes caught by managed code in mscorlib rather than by the common language runtime. 這個選項不會影響被 mscorlib 攔截之例外狀況的中斷。This option does not affect breaking on exceptions caught by mscorlib.

啟用位址層級的偵錯工具:啟用 在 [反 組解碼] 視窗、[緩存 器] 視窗 和位址中斷點) 的位址層 (級進行偵錯工具的 advanced 功能。Enable address-level debugging: Enables advanced features for debugging at the address level (the Disassembly window, the Registers window, and address breakpoints).

  • 如果無法使用來源,則顯示 反組解碼:當 您對無法 使用來源的程式碼進行偵錯工具時,會自動顯示 [反組解碼] 視窗。Show disassembly if source is not available: Automatically shows the Disassembly window when you debug code for which the source is unavailable.

啟用中斷點篩選:可讓您在中斷點上設定篩選,使其只會影響特定的進程、執行緒或電腦。Enable breakpoint filters: Enables you to set filters on breakpoints so that they will affect only specific processes, threads, or computers.

使用新的例外 狀況協助程式:啟用取代例外狀況小幫手的例外狀況協助程式。Use the new Exception Helper: Enables the Exception Helper that replaces the exception assistant. 從 Visual Studio 2017 開始支援 (的例外狀況協助程式) (Exception Helper is supported starting in Visual Studio 2017)

注意

針對 managed 程式碼,此選項先前稱為「 啟用例外狀況助理 」。For managed code, this option was previously called Enable the exception assistant .

啟用 Just My Code:偵錯工具只會在使用者程式碼中顯示 ( "My Code" ) ,忽略系統程式碼和其他已優化或沒有偵錯工具代碼的程式碼。Enable Just My Code: The debugger displays and steps into user code ("My Code") only, ignoring system code and other code that is optimized or that does not have debugging symbols.

  • 如果啟動時沒有使用者程式碼 (僅限受管理的):從啟用 Just My Code 開始時,此選項會警告您,指出沒有任何使用者程式碼 ( "My Code" ) 。Warn if no user code on launch (Managed only): When debugging starts with Just My Code enabled, this option warns you if there is no user code ("My Code").

啟用 .NET Framework 的來源逐步 執行:讓偵錯工具逐步執行 .NET Framework 來源。Enable .NET Framework source stepping: Allows the debugger to step into .NET Framework source. 啟用此選項會自動停用 Just My Code。Enabling this option automatically disables Just My Code. .NET Framework 的符號將會下載至快取位置。.NET Framework symbols will be downloaded to a cache location. 使用 [ 選項 ] 對話方塊的 [ 調試 類別目錄]、[ 符號 ] 頁面來變更快取位置。Change the cache location with the Options dialog box, Debugging category, Symbols page.

不進入 屬性和運算子 (managed):防止偵錯工具逐步執行 managed 程式碼中的屬性和運算子。Step over properties and operators (Managed only): Prevents the debugger from stepping into properties and operators in managed code.

啟用屬性評估及其他隱含函式呼叫:在變數視窗和 [ 快速 監看式] 對話方塊中開啟屬性的自動評估和隱含函式呼叫。Enable property evaluation and other implicit function calls: Turns on automatic evaluation of properties and implicit function calls in variables windows and the QuickWatch dialog box.

  • 變數 (視窗中的物件上呼叫字串轉換函式(僅限 c # 和 JavaScript)):在變數視窗中評估物件時執行隱含字串轉換呼叫。Call string conversion function on objects in variables windows (C# and JavaScript only): Executes an implicit string conversion call when evaluating objects in variables windows. 結果會顯示為字串,而不是類型名稱。The result is displayed as a string instead of the type name. 只適用於偵錯 C# 程式碼時。Only applies while debugging in C# code. DebuggerDisplay 屬性可能會覆寫此設定 (請參閱 使用 DebuggerDisplay 屬性) 。This setting may be overridden by the DebuggerDisplay attribute (see Using the DebuggerDisplay attribute).

啟用來源伺服器支援:告知 Visual Studio 偵錯工具,從執行 SrcSrv () 通訊協定的來源伺服器取得來源檔案 srcsrv.dllEnable source server support: Tells the Visual Studio debugger to get source files from source servers that implement the SrcSrv (srcsrv.dll) protocol. Team Foundation Server 和 Windows 偵錯工具這兩個來源伺服器會實作通訊協定。Team Foundation Server and the Debugging Tools for Windows are two source servers that implement the protocol. 如需有關 SrcSrv 設定的詳細資訊,請參閱 SrcSrv 檔。For more information about SrcSrv setup, see the SrcSrv documentation. 此外,請參閱 指定符號 ( .pdb) 和來源檔案。In addition, see Specify symbol (.pdb) and source files.

重要

因為讀取 .pdb 檔案可以執行檔案中的任意程式碼,請確定您信任伺服器。Because reading .pdb files can execute arbitrary code in the files, make sure that you trust the server.

  • 來源伺服器診斷訊息列印到輸出視窗:啟用來源伺服器支援時,此設定會開啟診斷顯示。Print source server diagnostic messages to the Output window: When source server support is enabled, this setting turns on diagnostic display.

  • 允許部分信任元件的來源伺服器僅 (受控):啟用來源伺服器支援時,此設定會覆寫不會針對部分信任元件的來源進行的預設行為。Allow source server for partial trust assemblies (Managed only): When source server support is enabled, this setting overrides the default behavior of not retrieving sources for partial trust assemblies.

  • 一律執行不受信任的來源伺服器命令而不提示:啟用來源伺服器支援時,此設定會覆寫執行未受信任命令時提示的預設行為。Always run untrusted source server commands without prompting: When source server support is enabled, this setting overrides the default behavior of prompting when running an untrusted command.

啟用來源連結支援:告知 Visual Studio 偵錯工具下載包含來源連結資訊之 .pdb 檔案的來源檔案。Enable Source Link support: Tells the Visual Studio debugger to download source files for .pdb files that contain Source Link information. 如需來源連結的詳細資訊,請參閱 來源連結規格For more information about Source Link, see the Source link specification.

重要

由於來源連結會使用 HTTP 或 HTTPs 下載檔案,因此請確定您信任 .pdb 檔。Because Source Link will download files using http or https, make sure you trust the .pdb file.

  • 切換回 Git 認證管理員所有來源連結要求的驗證:當啟用來源連結支援,且來源連結要求驗證失敗時,Visual Studio 接著會呼叫 Git 認證管理員。Fall back to Git Credential Manager authentication for all Source Link requests: When Source Link support is enabled, and a Source Link request fails authentication, Visual Studio then calls the Git Credential Manager.

反白顯示中斷點的整個原始程式列及目前的語句 (c + + 僅):當偵錯工具反白顯示中斷點或目前的語句時,它會反白顯示整行。Highlight entire source line for breakpoints and current statement (C++ only): When the debugger highlights a breakpoint or current statement, it highlights the entire line.

要求原始程式檔必須完全符合原始版本:指示偵錯工具確認原始程式檔是否符合用來建立您正在進行偵錯工具之可執行檔的原始程式碼版本。Require source files to exactly match the original version: Tells the debugger to verify that a source file matches the version of the source code used to build the executable you are debugging. 當版本不相符時,系統會提示您尋找相符的來源。When the version does not match, you're prompted to find a matching source. 如果找不到相符的原始程式檔,偵錯期間將不會顯示原始程式碼。If a matching source is not found, the source code will not be displayed during debugging.

所有輸出視窗文字重新導向到 [即時運算] 視窗:將通常出現在 [輸出] 視窗中的所有偵錯工具訊息傳送到 [即時運算 ] 視窗。Redirect all Output window text to the Immediate window: Sends all debugger messages that would ordinarily appear in the Output window to the Immediate window instead.

在變數視窗中顯示物件的原始結構:關閉所有物件結構視圖自訂。Show raw structure of objects in variables windows: Turns off all object structure view customizations. 如需有關視圖自訂的詳細資訊,請參閱 建立受控物件的自訂視圖For more information about view customizations, see Create custom views of managed objects.

在模組載入時隱藏 JIT 優化 (僅限 Managed):當載入模組且在附加偵錯工具時編譯 jit 時,停用 managed 程式碼的 jit 優化。Suppress JIT optimization on module load (Managed only): Disables the JIT optimization of managed code when a module is loaded and JIT is compiled while the debugger is attached. 停用最佳化可更容易偵錯一些問題,但消耗較多效能。Disabling optimization may make it easier to debug some problems, although at the expense of performance. 如果正在使用 Just My Code,隱藏 JIT 最佳化會使非使用者程式碼顯示為使用者程式碼 ("My Code")。If you are using Just My Code, suppressing JIT optimization can cause non-user code to appear as user code ("My Code"). 如需詳細資訊,請參閱 JIT 優化和調試程式。For more information, see JIT optimization and debugging.

啟用 ASP.NET (Chrome、Microsoft Edge 和 IE) 的 JavaScript 調試 程式:啟用 ASP.NET apps 的腳本偵錯工具。Enable JavaScript debugging for ASP.NET (Chrome, Microsoft Edge, and IE): Enables the script debugger for ASP.NET apps. 第一次在 Chrome 中使用時,您可能需要登入瀏覽器,以啟用您已安裝的 Chrome 擴充功能。On first use in Chrome, you may need to sign into the browser to enable Chrome extensions that you have installed. 停用此選項可還原為舊版行為。Disable this option to revert to legacy behavior.

使用多目標 javascript 偵錯工具來偵測適用目標中的 javascript (需要重新開機偵錯工具) 可同時連線至瀏覽器和後端,讓您可以在用戶端和伺服器中,直接從編輯器進行程式碼的偵錯工具。Enable using the multi-target JavaScript debugger for debugging JavaScript in applicable targets (requires debugging restart) Enables connection to the browser and back-end simultaneously, allowing you to debug your code running in the client and server right from the editor.

載入 dll 匯出 (僅限原生):載入 dll 匯出資料表。Load dll exports (Native only): Loads dll export tables. 若您使用 Windows 訊息、Windows 程序 (WindowProc)、COM 物件、封送處理或是任何您沒有其符號的 dll,則 dll 匯出資料表的符號資訊會很有幫助。Symbol information from dll export tables can be useful if you are working with Windows messages, Windows procedures (WindowProcs), COM objects, or marshaling, or any dll for which you do not have symbols. 讀取 dll 匯出資訊會產生一些額外負荷。Reading dll export information involves some overhead. 因此,這項功能預設為關閉。Therefore, this capability is turned off by default.

若您想知道 dll 匯出表中可使用的符號,請使用 dumpbin /exportsTo see what symbols are available in the export table of a dll, use dumpbin /exports. 這些符號適用於任何 32 位元系統 dll。Symbols are available for any 32-bit system dll. 讀取 dumpbin /exports 輸出時,您可以看到確實的函式名稱,包含非英數字元。By reading the dumpbin /exports output, you can see the exact function name, including non-alphanumeric characters. 這對設定函式的中斷點來說很有幫助。This is useful for setting a breakpoint on a function. dll 匯出表中的函式名稱在偵錯工具中的其他位置可能會顯示為已被截斷。Function names from dll export tables might appear truncated elsewhere in the debugger. 這些呼叫都按呼叫順序列出,目前的函式 (巢狀最深處) 列在頂端。The calls are listed in the calling order, with the current function (the most deeply nested) at the top. 如需詳細資訊,請參閱 dumpbin /exportsFor more information, see dumpbin /exports.

顯示平行堆疊圖表下圖:控制堆疊在 [ 平行堆疊 ] 視窗中顯示的方向。Show parallel stacks diagram bottom-up: Controls the direction in which stacks are displayed in the Parallel Stacks window.

如果寫入的資料未變更值,請忽略 GPU 記憶體存取例外 狀況:如果資料未變更,會忽略在調試期間偵測到的競爭條件。Ignore GPU memory access exceptions if the data written didn't change the value: Ignores race conditions that were detected during debugging if the data didn't change. 如需詳細資訊,請參閱將 GPU 程式碼進行調試程式。For more information, see Debugging GPU Code.

使用 Managed 相容性模式:將預設的調試引擎取代為舊版,以啟用這些案例:Use Managed Compatibility Mode: Replaces the default debugging engine with a legacy version to enable these scenarios:

  • 您使用的是 c #、Visual Basic 或 F # 以外的 .NET 語言,其提供自己的運算式評估工具 (這包括 c + +/CLI) 。You are using a .NET language other than C#, Visual Basic, or F# that provides its own Expression Evaluator (this includes C++/CLI).

  • 您想要在混合模式偵錯工具期間啟用 c + + 專案的 [編輯後繼續]。You want to enable Edit and Continue for C++ projects during mixed mode debugging.

注意

選擇 [Managed 相容性模式] 會停用某些只在預設的偵錯工具中執行的功能。Choosing Managed Compatibility mode disables some features that are implemented only in the default debugging engine. 舊版的偵錯工具引擎已在 Visual Studio 2012 中取代。The legacy debugging engine was replaced in Visual Studio 2012.

使用舊版 c # 和 VB 運算式評估 工具:偵錯工具將使用 Visual Studio 2013 c # 或 Visual Basic 運算式評估工具,而不是 Visual Studio 2015 Roslyn 為基礎的運算式評估工具。Use the legacy C# and VB expression evaluators: The debugger will use the Visual Studio 2013 C# or Visual Basic expression evaluators rather than the Visual Studio 2015 Roslyn-based expression evaluators.

針對可能不安全的進程使用自訂偵錯工具視覺化程式時發出警告, (僅限 Managed):當您使用的自訂偵錯工具視覺化程式在已調試的進程中執行程式碼時,Visual Studio 警告您,因為它可能正在執行 unsafe 程式碼。Warn when using custom debugger visualizers against potentially unsafe processes (Managed only): Visual Studio warns you when you are using a custom debugger visualizer that is running code in the debugged process, because it could be running unsafe code.

啟用 windows 偵錯工具堆積配置器 (僅限原生):啟用 windows 偵錯工具堆積來改善堆積診斷。Enable Windows debug heap allocator (Native only): Enables the windows debug heap to improve heap diagnostics. 啟用此選項會影響偵錯效能。Enabling this option will impact debugging performance.

啟用 XAML 的 UI 偵錯工具:當您開始 (F5) 支援的專案類型進行偵錯工具時,將會出現即時視覺化樹狀結構和即時屬性流覽視窗。Enable UI Debugging Tools for XAML: The Live Visual Tree and the Live Property Explore windows will appear when you start debugging (F5) a supported project type. 如需詳細資訊,請參閱 在偵錯工具時檢查 XAML 屬性For more information, see Inspect XAML properties while debugging.

  • 在 [即時視覺化樹狀結構] 中預覽選取的元素:也會在 [ 即時視覺化樹狀 ] 視窗中選取其內容已選取的 XAML 元素。Preview selected elements in Live Visual Tree: The XAML element whose context is selected is also selected in the Live Visual Tree window.

  • 顯示應用程式中的執行時間工具:在正在進行調試的 XAML 應用程式主視窗上,顯示工具列中的 即時視覺化樹狀 命令。Show runtime tools in application: Shows the Live Visual Tree commands in a toolbar on the main window of the XAML application that is being debugged. 此選項是在 Visual Studio 2015 Update 2 中引進。This option was introduced in Visual Studio 2015 Update 2.

  • 啟用 XAML 熱重新載入:可讓您在應用程式執行時,將 XAML 熱重新載入功能與 XAML 程式碼搭配使用。Enable XAML Hot Reload: Allows you to use the XAML Hot Reload feature with XAML code when your app is running. (這項功能先前稱為「XAML 編輯後繼續」 ) (This feature was previously called "XAML Edit and Continue")

  • 只啟用我的 XAML:從 Visual Studio 2019 16.4 版開始, 即時視覺化樹狀結構 預設只會顯示分類為使用者程式碼的 xaml。Enable Just My XAML: Starting in Visual Studio 2019 version 16.4, the Live Visual Tree by default shows only XAML that is classified as user code. 如果您停用此選項,則工具中會顯示所有產生的 XAML 程式碼。If you disable this option, all generated XAML code is shown in the tool.

  • 選取元素時關閉選取模式 從 Visual Studio 2019 16.4 版開始,應用程式內工具列元素選取器按鈕 (啟用選取專案) 在選取元素時關閉。Turn off selection mode when an element is selected Starting in Visual Studio 2019 version 16.4, the in-app toolbar element selector button (Enable selection) switches off when an element is selected. 如果您停用此選項,則在您再次按一下 [應用程式內] 工具列按鈕之前,元素選取會保持開啟。If you disable this option, element selection stays on until you click the in-app toolbar button again.

  • 將檔儲存 XAML 熱重新載入 從 Visual Studio 2019 16.6 版開始,會在您儲存檔時套用 XAML 熱重新載入。Apply XAML Hot Reload on document save Starting in Visual Studio 2019 version 16.6, applies XAML Hot Reload when you save your document.

在進行 調試時啟用診斷工具:當您進行調試時,會出現 診斷工具 視窗。Enable Diagnostic Tools while debugging: The Diagnostic Tools window appears while you are debugging.

顯示調試 程式時所經過的時間 PerfTip:程式碼視窗會在您進行偵錯工具時,顯示指定方法呼叫的經過時間。Show elapsed time PerfTip while debugging: The code window displays the elapsed time of a given method call when you are debugging.

啟用 [編輯後繼續]:在進行調試時啟用 [編輯後繼續] 功能。Enable Edit and Continue: Enables the Edit and Continue functionality while debugging.

  • 啟用原生編輯後繼續:您可以在對原生 c + + 程式碼進行偵錯工具時,使用編輯後繼續功能。Enable Native Edit and Continue: You can use the Edit and Continue functionality while debugging native C++ code. 如需詳細資訊,請參閱 (c + +) 的 [編輯後繼續]。For more information, see Edit and Continue (C++).

  • 在 [繼續 (僅限原生) 上套用變更: Visual Studio 自動編譯,並套用您從中斷狀態繼續程式時所做的任何未處理常式代碼變更。Apply changes on continue (Native only): Visual Studio automatically compiles and applies any outstanding code changes you have made when continuing the process from a break state. 如果未選取,您可以選擇使用 [調試 程式] 功能表下的 [套用程式 代碼變更] 專案套用變更。If not selected, you can choose to apply changes using the Apply Code Changes item under the Debug menu.

  • 警告過時的程式碼 (僅限原生):取得過時程式碼的警告。Warn about stale code (Native only): Get warnings about stale code.

當偵錯工具時,在編輯器中顯示執行以按一下按鈕:當選取這個選項時,會在進行偵錯工具時顯示 [執行到按一下] 按鈕。Show Run to Click button in editor while debugging: When this option is selected, the Run to Click button will be shown while debugging.

當偵錯工具停止時,自動關閉主控台:告知 Visual Studio 關閉偵錯工具結束時的主控台。Automatically close the console when debugging stops: Tells Visual Studio to close the console at the end of a debugging session.

啟用快速運算式評估 (僅限 Managed):讓偵錯工具透過模擬簡單屬性和方法的執行,以嘗試更快的評估。Enable fast expression evaluation (Managed only): Allows the debugger to attempt faster evaluation by simulating execution of simple properties and methods.

在外部進程中載入 debug 符號 (僅限原生) 啟用此 記憶體優化 ,同時進行調試。Load debug symbols in external process (Native only) Enables this memory optimization while debugging.

在偵錯工具中中斷時將 Visual Studio 帶入前景 當您在偵錯工具中暫停時,將 Visual Studio 切換至前景。Bring Visual Studio to the foreground when breaking in the debugger Switches Visual Studio to the foreground when you pause in the debugger.

舊版 Visual Studio 中的可用選項Options available in older versions of Visual Studio

如果您使用較舊版本的 Visual Studio,可能會有一些額外的選項。If you're using an older version of Visual Studio, some additional options might be present.

啟用適用于 Uwp JAVAscript 應用程式的 Edge 開發人員工具 (實驗性):在 Microsoft Edge 中啟用 uwp javascript 應用程式的開發人員工具。Enable Edge Developer Tools for UWP JavaScript Apps (Experimental): Enables developer tools for UWP JavaScript apps in Microsoft Edge.

針對 ASP.NET 啟用舊版 Chrome javascript 偵錯工具:啟用適用于 ASP.NET 應用程式的舊版 chrome javascript 腳本偵錯工具。Enable legacy Chrome JavaScript debugger for ASP.NET: Enables the legacy Chrome JavaScript script debugger for ASP.NET apps. 第一次在 Chrome 中使用時,您可能需要登入瀏覽器,以啟用您已安裝的 Chrome 擴充功能。On first use in Chrome, you may need to sign into the browser to enable Chrome extensions that you have installed.

啟用 [例外狀況助理]:針對 managed 程式碼,啟用 [例外狀況助理]。Enable the exception assistant: For managed code, enables the exception assistant. 從 Visual Studio 2017 開始,例外狀況協助程式會取代例外狀況小幫手。Starting in Visual Studio 2017, the Exception Helper replaced the exception assistant.

在未處理的例外狀況回溯呼叫堆疊:讓 [ 呼叫堆疊 ] 視窗將呼叫堆疊復原到未處理的例外狀況發生之前的時間點。Unwind the call stack on unhandled exceptions: Causes the Call Stack window to roll back the call stack to the point before the unhandled exception occurred.

系統管理員身分執行 Visual Studio 時,請使用實驗性的方式啟動 Chrome JavaScript 調試:告知 Visual Studio 嘗試在 JavaScript 調試過程中啟動 chrome 的新方式。Use experimental way to launch Chrome JavaScript debugging when running Visual Studio as Administrator: Tells Visual Studio to try a new way to launch Chrome during JavaScript debugging.

如果啟動時沒有符號 (原生):當您在偵錯工具沒有符號資訊的程式時,顯示警告對話方塊。Warn if no symbols on launch (native only): Displays a warning dialog box when you debug a program for which the debugger has no symbol information.

如果啟動時停用腳本調試 程式,就會發出警告:當偵錯工具啟動時,如果停用腳本偵測,則會顯示警告對話方塊。Warn if script debugging is disabled on launch: Displays a warning dialog box when the debugger is launched with script debugging disabled.

使用原生相容性模式:選取此選項時,偵錯工具會使用 Visual Studio 2010 原生偵錯工具,而不是新的原生偵錯工具。Use Native Compatibility Mode: When this option is selected, the debugger uses the Visual Studio 2010 native debugger instead of the new native debugger.

  • 當您正在進行 .NET c + + 程式碼的偵錯工具時,請使用這個選項,因為新的偵錯工具引擎不支援評估 .NET c + + 運算式。Use this option when you are debugging .NET C++ code, because the new debugging engine does not support evaluating .NET C++ expressions. 然而,啟用 [原生相容性模式] 會停用許多相依於目前偵錯工具實作以進行運作的功能。However, enabling Native Compatibility Mode disables many features that depend on the current debugger implementation to operate. 例如,舊版引擎缺少許多內建類型的視覺化檢視,例如 std::string Visual Studio 2015 專案。For example, the legacy engine lacks many visualizers for built-in types like std::string in Visual Studio 2015 projects. 在這些情況下,請使用 Visual Studio 2013 專案,以獲得最佳的偵錯工具體驗。Use Visual Studio 2013 projects for the optimal debugging experience in these cases.

另請參閱See also