開始使用 Visual Studio 和 UnityGet started with Visual Studio and Unity

注意

本指南假設您已使用 Unity 中樞程式安裝 Unity。This guide assumes you already have installed Unity using the Unity Hub program. 如果您是 Unity 新手,建議先造訪 Unity 學習,並 使用 unity 教學 課程完成消費者入門。If you are new to Unity, we recommend visiting Unity Learn and complete the Getting Started with Unity tutorial first.

安裝 Visual Studio 的 Unity 支援Install Unity support for Visual Studio

Visual Studio Tools for Unity 是免費的延伸模組,可支援撰寫和偵測 c # 和其他更多的功能。Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. 請流覽適用 于 Unity 的工具總覽 ,以取得延伸模組包含內容的完整清單。Visit the Tools for Unity overview for a complete list of what the extensions includes.

注意

本安裝指南適用于 Visual Studio。This installation guide is for Visual Studio. 如果您是使用 Visual Studio Code,請流覽 Unity 開發與 VS Code 檔If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. 下載 Visual Studio 安裝程式,或在已安裝的情況下執行。Download the Visual Studio installer, or run it if already installed.

  2. 針對您想要的 Visual Studio 版本按一下 (若已安裝) 或 [安裝] (針對新安裝)。Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. 在 [ 工作負載 ] 索引標籤上,選取 [ 遊戲 ] 區段,然後選取 [ 使用 Unity 工作負載進行遊戲開發 ]。On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    安裝程式中使用 Unity 的遊戲開發工作負載方塊

注意

本安裝指南適用于 Visual Studio for Mac。This installation guide is for Visual Studio for Mac. 如果您是使用 Visual Studio Code,請流覽 Unity 開發與 VS Code 檔If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

適用于 Unity 的工具隨附于安裝 Visual Studio for Mac,且不需要個別的安裝步驟。Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. 您可以在 Visual Studio for Mac > 擴充功能 > 遊戲開發 功能表中確認這項功能。You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. 應啟用 適用于 Unity 的 Visual Studio for Mac 工具Visual Studio for Mac Tools for Unity should be enabled.

顯示已啟用 Visual Studio for Mac Tools for Unity 的 [擴充管理員] 視圖

檢查更新Check for updates

建議您保持 Visual Studio 並 Visual Studio for Mac 更新,以取得最新的 bug 修正、功能和 Unity 支援。It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. 這不需要更新 Unity 版本。This doesn't require an update of Unity versions.

  1. 按一下 [說明] > 檢查 [更新 ] 功能表。Click the Help > Check for Updates menu.

    Visual Studio 2019 中的 [檢查更新] 功能表

  2. 如果有可用的更新,Visual Studio 安裝程式將會顯示新的版本。If there is an update available, the Visual Studio Installer will show a new version. 按一下 [更新] 按鈕。Click the Update button.

  1. 按一下 [ Visual Studio for Mac] > 檢查更新 ... 功能表以開啟 Visual Studio 更新 ] 對話方塊。Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. 如果有可用的更新,請按一下 [ 安裝 ] 按鈕。If there is an update available, click the Install button.

設定 Unity 以使用 Visual StudioConfigure Unity to use Visual Studio

根據預設,Unity 應該已設定為使用 Visual Studio 或 Visual Studio for Mac 作為腳本編輯器。By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. 您可以從 Unity 編輯器確認這項變更,或將外部腳本編輯器變更為特定版本的 Visual Studio。You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. 在 Unity 編輯器中,選取 [ 編輯 > 喜好 設定] 功能表。In the Unity Editor, select the Edit > Preferences menu..

  2. 選取左側的 [ 外部工具 ] 索引標籤。Select the External Tools tab on the left.

  3. [ 外部腳本編輯器 ] 下拉式清單提供一種方式,讓您選擇不同的 Visual Studio 安裝。The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. 您也可以按一下下拉式清單中的 [流覽 ...] ,以新增未列出的版本。You can also click Browse... from the dropdown list to add an unlisted version.

    Windows 上 Unity 編輯器中的 [外部工具喜好設定] 功能表

  4. 若已選取 [瀏覽],請瀏覽到您 Visual Studio 安裝目錄中的 Common7/IDE 目錄,然後選取 [devenv.exe]。If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. 然後按一下 [ 開啟]。Then, click Open.

  5. 在 [External Script Editor] (外部指令碼編輯器) 清單中選取 Visual Studio 之後,請確認已選取 [Editor Attaching] (編輯器附加) 核取方塊。Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. 關閉 [喜好設定] 對話方塊以完成設定程序。Close the Preferences dialog to complete the configuration process.

  1. 在 Unity 編輯器中,選取 [ unity > 喜好 設定] 功能表。In the Unity Editor, select the Unity > Preferences menu..

  2. 選取左側的 [ 外部工具 ] 索引標籤。Select the External Tools tab on the left.

  3. [ 外部腳本編輯器 ] 下拉式清單提供一種方式,讓您選擇不同的 Visual Studio 安裝。The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. 您也可以按一下下拉式清單中的 [流覽 ...] ,以新增未列出的版本。You can also click Browse... from the dropdown list to add an unlisted version.

    MacOS 上 Unity 編輯器中的 [外部工具喜好設定] 功能表

  4. 關閉 [喜好設定] 對話方塊以完成設定程序。Close the Preferences dialog to complete the configuration process.

後續步驟Next steps

若要瞭解如何在 Visual Studio 中使用和偵測您的 Unity 專案,請流覽 使用 Visual Studio Tools for UnityTo learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.