將 Visual Studio IDE 個人化Personalize the Visual Studio IDE

您可以使用各種不同的方法來個人化 Visual Studio,以最佳方式支援您自己的開發風格與需求。You can personalize Visual Studio in various ways to best support your own development style and requirements. 您的許多設定可在 Visual Studio 執行個體之間漫遊 — 請參閱同步設定Many of your settings roam with you across Visual Studio instances—see Synchronized settings. 本文簡要描述各種不同的個人化設定,以及何處可找到詳細資訊。This article briefly describes different personalizations and where you can find more information.

注意

本主題適用於 Windows 上的 Visual Studio。This topic applies to Visual Studio on Windows. 針對 Visual Studio for Mac,請參閱自訂 Visual Studio for Mac IDEFor Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

預設設定Default settings

您可以選擇預設的設定集合,以針對您的開發類型最佳化 Visual Studio。You can choose a default collection of settings that optimizes Visual Studio for your type of development. 如需詳細資訊,請參閱環境設定For more information, see Environment settings.

一般環境選項General environment options

許多個人化選項會透過環境選項對話方塊來公開。Many personalization options are exposed through the Environment Options dialog box. 有兩種方法可以存取此對話方塊:There are two ways to access this dialog box:

  • 在功能表列上選擇 [工具 > 選項],如果尚未展開,請展開 [環境] 節點。On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • 在搜尋方塊中按下 Ctrl + Q,輸入 環境,然後從結果中選擇 [環境 > 一般]。Press Ctrl+Q, type environment in the search box, and then choose Environment > General from the results.

提示

當 [選項] 對話方塊出現時,您可以在該頁面上按 F1,以取得各種不同設定的說明。When the Options dialog box appears, you can press F1 for help on the various settings on that page.

環境色彩佈景主題Environment color themes

若要在 [淺色]、[深色] 和 [藍色] 之間變更色彩主題,請在 [搜尋] 方塊中輸入 環境 ,然後選擇 [ 環境 > 一般]。To change the color theme between light, dark and blue, type environment in the search box, and then choose Environment > General. 在 [選項] 對話方塊中,變更 [色彩佈景主題] 選項。In the Options dialog box, change the Color theme option.

若要變更編輯器中的顏色標示選項,請在 [搜尋] 方塊中輸入 環境 ,然後選擇 [ 環境 > 字型和色彩]。To change colorization options in the editor, type environment in the search box, and then choose Environment > Fonts and Colors. 請參閱如何:變更字型和色彩See How to: Change fonts and colors.

您可以變更主功能表的下列兩種大小寫設定:[字首大寫] ("File") 與 [全部大寫] ("FILE")。You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). 在 [搜尋] 方塊中輸入 環境 ,選取 [環境 > 一般],然後將 [ 套用標題案例樣式] 變更為 [功能表列 ] 選項。Type environment in the search box, select Environment > General, and then change the Apply title case styling to menu bar option.

自訂功能表與工具列Customize menus and toolbars

若要新增或移除功能表或工具列項目,請參閱如何:自訂功能表和工具列To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

起始頁Start page

若要為您和小組建立自訂起始頁,請參閱自訂起始頁To create a custom start page for you and your team, see Customize the Start page.

視窗配置Window layouts

您可以定義和儲存多個視窗配置,並在其間切換。You can define and save multiple window layouts and switch between them. 例如,您可以定義程式碼撰寫時的版面配置,還有用於偵錯的版面配置。For example, you can define one layout for coding and one for debugging. 若要排列視窗位置與行為並儲存自訂版面配置,請參閱自訂視窗版面配置To arrange window positions and behavior and save custom layouts, see Customize window layouts.

外部工具External tools

您可以自訂 [工具] 功能表來啟動外部工具。You can customize the Tools menu to launch external tools. 如需詳細資訊,請參閱管理外部工具For more information, see Manage external tools.

另請參閱See also