How to:使用 Visual Studio 共同作業

準備在 Visual Studio 中使用 Live Share 進行共同作業了嗎? 如果是這樣,您來對地方了! 在本文中,我們將逐步引導您了解如何使用適用於 Visual Studio 的 Visual Studio Live Share 擴充的特定功能。

請注意,這裡描述的所有共同作業活動都牽涉到單一 共同作業工作階段主持人 和一或多個 來賓。 主持人是啟動共同作業工作階段的人員,而來賓是加入的任何人。

正在尋找縮減摘要嗎?請改為查看 共用加入 快速入門。

提示

您知道您可以「加入自己的共同作業工作階段」嗎? 這讓您可以自行試用 Live Share,或是啟動 Visual Studio 或 VS Code 的執行個體,並從遠端連線到該執行個體! 您甚至可以在這兩個執行個體上使用相同的身分識別。 趕緊去瞧一瞧!

安裝

在開始之前,您需要在 Windows 7、8.1 或 10 上安裝 Visual Studio 2019Visual Studio 2017 15.6 或更高版本不過,建議您使用 Visual Studio 15.7+,因為此版本提供本機復原/取消復原支援。

開始使用很簡單:

針對 Visual Studio 2019

  1. 安裝任何版本的Visual Studio 2019
  2. 安裝支援的工作負載 (例如 ASP.NET、.NET Core、C++、Python 及/或 Node.js)。
  3. Visual Studio Live Share 預設已安裝這些工作負載。

針對 Visual Studio 2017

  1. 安裝任何版本的Visual Studio 2017 15.6 版 +。
  2. 安裝支援的工作負載 (例如 ASP.NET、.NET Core、C++ 及/或 Node.js)。
  3. 從 marketplace下載並安裝 Visual Studio Live Share 擴充功能。

下載並使用 Visual Studio Live Share 即表示您同意授權條款隱私權聲明。 如果您遇到問題,請參閱疑難排解

下載 Live Share

登入

為了進行共同作業,您需要登入 Visual Studio Live Share,這樣每個人才都知道您的身分。 這只是安全性措施,並 會將您加入任何行銷或其他研究活動。 您可以使用 Microsoft 個人帳戶 (例如 @outlook.com)、Microsoft 支援的公司或學校帳戶 (AAD),或是 GitHub 帳戶。 登入很簡單。

根據預設,Visual Studio 會使用您的個人化帳戶,因此如果您已登入 Visual Studio,就可以略過此步驟。 否則就以一般方式登入。

VS [登入] 按鈕

如果您想要使用與 Visual Studio 個人化帳戶不同的登入資訊,請前往 [工具] > [選項] > [Live Share] > [使用者戶帳戶],以切換認證。

VS 工具選項 Live Share

選取 [外部帳戶] 可讓您選取不支援 Visual Studio 個人化功能的帳戶,如 GitHub 帳戶。 您第一次使用 Live Share 功能時,瀏覽器會自動顯示以讓您完成登入。

提示

您知道可以在 [工具] > [選項] > [Live Share] > [一般] 中,檢視所有預設的 Live Share 設定嗎? 自訂符合需求的共同作業體驗! 您也可以選擇 [進階] > [功能] > [測試人員],在 [一般] Live Share 設定中嘗試所有新的 Live Share 功能!

如果您遇到問題,請參閱疑難排解以取得其他提示。

共用專案

下載並安裝 Visual Studio Live Share 之後,請遵循這些步驟來啟動共同作業工作階段,並邀請同事與您合作。

  1. 登入

    登入後,即可開始您自己的共同作業工作階段。 尚未登入? 請參閱登入,以取得詳細資料。

  2. 開啟解決方案、專案或資料夾

    使用您的一般工作流程來開啟您希望與來賓共用的資料夾、專案或方案。

  3. [選擇性] 更新隱藏或排除的檔案

    根據預設,Live Share 會對來賓 隱藏 您的專案中 .gitignore 檔案所參考的任何檔案/資料夾。 隱藏 檔案可防止它出現在檔案樹狀目錄,而 排除 則會停止傳輸檔案,即使在偵錯等作業期間亦然。 如果您希望隱藏/排除不同的檔案,您可以使用這些設定將 .vsls.json 檔案新增至您的專案。 請參閱控制檔案存取權和可見性以取得詳細資料。

  4. 開始共同作業工作階段

    現在,按一下右上角的 [Live Share] 按鈕,開始 Live Share 工作階段。 共同作業工作階段的可共用連結會自動複製到剪貼簿。

    VS 共用按鈕

    第一次啟動共同作業工作階段時,您會看到 Live Share 工具視窗。 請務必固定此視窗,確保在您下次啟動 Live Share 工作階段時出現。

    VS Live Share 工具視窗

    注意

    桌面防火牆軟體可能會要求您允許 Live Share 代理程式在您第一次共用時開啟連接埠。 這完全是選擇性的,但是當您與一起工作的人員位於相同網路時,可提供安全的「直接模式」來改善效能。 請參閱變更連線模式以取得詳細資料。

  5. [選擇性] 啟用唯讀模式

    一旦您啟動共同作業工作階段,您可以將工作階段設定為唯讀,以防止來賓對正在共用的程式碼進行編輯。

    共用之後,您會收到通知指出邀請連結已複製到剪貼簿。 您隨即可以選取選項來將工作階段設為唯讀。

    VS 唯讀模式

  6. 將連結傳送給某人

    透過電子郵件、Slack、Skype 等將連結傳送給您希望邀請的人員。 請注意,考慮到 Live Share 工作階段所能為來賓提供的存取層級,您應該只與您信任的人共用,並考量共用這些內容的影響。

    安全性秘訣: 想要瞭解某些 Live Share 功能的安全性含意嗎? 請參閱安全性一文。

    如果您邀請的來賓有問題,請參閱「快速入門:加入您的第一個會話」一文,以取得如何以來賓的形式啟動及執行的詳細資訊。

  7. [選擇性] 核准來賓

    根據預設,來賓會自動加入您的共同作業工作階段,當他們準備好要與您共同作業時,您會收到通知。 雖然此通知提供您將他們從工作階段移除的選項,但您也可以選擇改為要加入的任何人都需要明確地「核准」。

    只要將 [工具] > [選項] > [Live Share] > [需要來賓核准] 變更為 [True],就能啟用此功能。 一旦您開啟此設定,系統會通知您進行核准,來賓才能加入。

    Visual Studio 加入核准要求

    如需邀請安全性考量的其他詳細資料,請參閱邀請和加入存取權

  8. 管理您的 Live Share 工作階段

    一旦您的來賓在 VS Code 或 Visual Studio 中開啟您的共用工作階段連結,您就會在 Live Share 工具視窗的參與者中看到他們。 您現在可以從來賓名稱旁邊的檔案,知道他們目前使用的是哪個檔案。

    顯示參與者的 VS Live Share 工具視窗

    Live Share 工具視窗可讓您存取所有重大功能,在一個地方管理您的工作階段。

    提示

    工作階段期間沒有看到 Live Share 工具視窗? 您可以隨時移至 [檢視] > [其他視窗] > [Live Share] 找到!

結束共同作業工作階段

身為主持人,您可以按一下共用 / 工作階段狀態按鈕 (在右上角),然後選取 [結束共同作業工作階段],以完全停止共用並結束共同作業工作階段。

停止共用

系統會通知所有來賓工作階段已經結束。 工作階段結束之後,來賓將不再能夠存取內容,且系統會清除任何暫存檔。

有共用的問題嗎? 請參閱疑難排解

加入共同作業工作階段

下載並安裝 Visual Studio Live Share 之後,來賓只需要幾個步驟就能加入主持人主持的共同作業工作階段。 有兩種方式可以加入:透過瀏覽器手動

安全性秘訣: 當來賓加入共同作業會話時,請務必瞭解主機可能會限制您對特定檔案或功能的存取權。 想要了解 Live Share 功能和設定的一些安全性影響嗎? 請參閱安全性一文。

透過瀏覽器加入

加入共同作業工作階段最簡單的方式,是在網頁瀏覽器中直接開啟邀請連結。 當您遵循此流程時,預期的情況如下。

  1. 登入

    安裝 Live Share 擴充之後,您會想要登入,讓其他的共同作業者知道您的身分。 根據預設,Visual Studio 會使用您的個人化帳戶,因此您可以完全略過此步驟。

    請參閱登入,以取得詳細資料。

  2. 按一下邀請連結/在您的瀏覽器中開啟邀請

    現在,請在瀏覽器中開啟 (或重新開啟) 邀請連結。

    注意:如果您尚未安裝 Live Share 擴充功能,您將會看到延伸模組 marketplace 的連結。 安裝擴充並重新啟動您的工具,然後重試。

    您應該會收到通知,指出瀏覽器想要啟動提供 Live Share 的工具。 如果您讓其啟動所選的工具,則在啟動後您將連線至共同作業工作階段。

    加入頁面

    如果主持人已離線,則會改為在此時收到通知。 您可以連絡主持人,並要求再次共用。

    注意

    仍然遇到問題嗎? 請參閱手動加入

  3. 共同作業

    就這麼容易! 稍後會建立連線,您就可以開始共同作業。

    您將會看到 [Live Share] 按鈕發生轉換以表示「工作階段狀態」。 如需按鈕的外觀,請參閱下面的工作階段狀態資訊。

    完成加入之後,系統會自動帶您到主持人目前在編輯的檔案。

手動加入

您也可以手動加入,而不使用網頁瀏覽器。此方式在下列情況可能很有用:您想要使用的工具已經在執行、您想要使用其他工具而非平常使用的工具,或您可能因某些原因而無法取得邀請連結。 流程很簡單:

  1. 登入

    安裝 Live Share 擴充之後,您會想要登入,讓其他的共同作業者知道您的身分。 根據預設,Visual Studio 會使用您的個人化帳戶,因此您可以完全略過此步驟。

    請參閱登入,以取得詳細資料。

  2. 使用加入命令

    只要前往 [檔案 ] > [加入Live Share 工作階段]

    VS 加入功能表

  3. 貼上邀請連結

    貼上您收到的邀請 URL 並確認。

  4. 合作!

    這樣就完成了! 您應該很快就會連線到共同作業工作階段。

    您將會看到 [Live Share] 按鈕發生轉換以表示「工作階段狀態」。 如需按鈕的外觀,請參閱下面的工作階段狀態資訊。

    完成加入之後,系統會自動帶您到主持人目前在編輯的位置。

離開共同作業工作階段

身為來賓,您只要將工具關閉,或按一下共用 / 工作階段狀態按鈕並選取 [離開共同作業工作階段],就可以離開共同作業工作階段而不會結束其他人的工作階段。

離開時的 VS 聯結功能表

系統會自動清除任何暫存檔,所以您無須採取進一步動作。

有加入的問題嗎? 請參閱疑難排解

共同編輯

來賓加入共同作業工作階段之後,所有共同作業者都能立刻即時地看到其他人所編輯和選取的項目。 您只需要從 [檔案總管] 中挑選檔案並開始編輯。 當您在編輯時,主持人和來賓都能查看,並且能親自參與,使逐一查看變得簡單,而且很快就能找出解決方案。

注意

加入唯讀共同作業工作階段會防止來賓對檔案進行編輯。 主持人可以在共用時啟用唯讀模式。 身為來賓,您可以查看您的工作階段狀態,以分辨您是否已加入唯讀工作階段。

顯示共同編輯的螢幕擷取畫面

注意

對於特定語言,共同編輯有幾項限制。 如需依語言列出功能的狀態,請參閱平台支援

除了游標和編輯之外,在相同檔案中的參與者也能看到您所選取的項目。 這可以讓您輕鬆反白顯示問題的可能位置或傳達想法。

顯示反白顯示的螢幕擷取畫面

更棒的是,您和其他參與者可以瀏覽至共用專案中的任何檔案。 您可以一起或獨立地編輯,這表示您可以流暢地切換進行調查、做小型調整,以及完全共同作業編輯。

注意

根據預設,Live Share 會共用在所共用解決方案外部開啟的檔案。 如果您想要停用此功能,請將 [工具] > [選項] > [Live Share] 中的 [共用外部檔案] 更新為 [False]。

編輯的結果會於儲存時保留在主持人的機器上,因此當您完成編輯時,不需要互相同步、推送或傳送檔案。 您所做的編輯都會「直接保留」。

安全性秘訣: 假設所有參與者都可以獨立地以主機的形式來流覽和編輯檔案,您可能會想要透過檔案 .vsls.js,限制來賓可以在專案中存取的檔案。 身為來賓,請務必了解到因為這些設定,您可能不會看到特定檔案。 請參閱控制檔案存取權和可見性以取得詳細資料。

變更參與者旗標行為

根據預設,當暫留在參與者的指標上時,或當參與者編輯、反白顯示或移動其指標時,Visual Studio Live Share 會自動在其指標旁邊顯示「旗標」。 在某些情況下,您可能會想要變更此行為。 操作方法:

  1. 請移至 [工具] > [選項] > [Live Share]
  2. 將 [旗標可見度] 選項變更為下列其中一個值:
選項 行為
OnHoverOnly 只有當您暫留在指標上時旗標才可見。
OnHoverOrActivity 此為預設值。 暫留在指標上時,或當參與者編輯、反白顯示或移動其指標時,旗標才為可見。
一律 旗標一律為可見。

追蹤中

只要您是在共同作業工作階段中,您就可以在編輯器的右上角 [登入] 按鈕旁邊看到每個參與者的姓名縮寫。 暫留在姓名縮寫上會顯示參與者的完整資訊。

顯示使用者的螢幕擷取畫面

您有時可能需要說明橫跨多個檔案或程式碼中多個位置的問題或設計。 在這些情況下,暫時追蹤同事在專案中的動作可能會很有用。 因此,身為來賓,當您加入共同作業工作階段時,您會自動「追蹤」主持人。 在追蹤參與者時,您的編輯器會與他們目前開啟的檔案、指標和捲動位置保持同步。

注意

根據預設,Live Share 會共用在所共用解決方案外部開啟的檔案。 如果您想要停用此功能,請將 [工具] > [選項] > [Live Share] 中的 [共用外部檔案] 更新為 [False]。

為了方便切換離開「追蹤模式」並開始自行編輯,如果發生下列情況,您就會停止追蹤:

  1. 您進行編輯、移動游標,或進行選取
  2. 您選取另一個檔案

您隨時可以在右上角按一下您正在追蹤之人員的姓名縮寫來停止追蹤。 參與者的姓名縮寫周圍表示您正在追蹤他們的圓圈隨即消失。

被追蹤的 Visual Studio 參與者 沒有被追蹤的 Visual Studio 參與者

您可以在相同位置按一下任何姓名縮寫,以追蹤共同作業工作階段中的任何主持人或來賓。 請注意,如果您只想要跳到某人的位置,而不是追蹤他們,只要按兩下他們的姓名縮寫。

聚焦

有時候,您可能想要共同作業工作階段中的每個人都來查看您在處理的項目。 Live Share 可讓您要求所有人都將其注意力「聚焦」於您,並發出通知讓他們輕鬆回頭追蹤您。

您可以直接按一下右上角的工作階段狀態 / 共用按鈕並選取 [與會者請注意]。

「請注意」功能表選項

共同作業工作階段中的每個人就都會收到通知,指出您需要他們注意

「請注意」快顯通知

當他們準備好要聚焦在您身上時,便可以直接按一下通知中的 [追蹤]。

共同偵錯

Visual Studio Live Share 的共同作業偵錯功能是功能強大且獨特的偵錯問題方式。 除了提供對問題進行偵錯的共同作業體驗之外,它也藉由在主持人的機器上提供共用偵錯工作階段,讓您和工作階段中的其他參與者有能力調查可能是環境特定的問題。

安全性秘訣: 假設所有參與者都可以獨立地以主機的形式來流覽和編輯檔案,您可能會想要透過檔案 .vsls.js,限制來賓可以在專案中存取的檔案。 您也應該留意到,主控台/REPL 存取表示參與者可以在您的機器上執行命令,因此您只應該與信任的人員進行共同偵錯。 身為來賓,請務必了解到因為這些設定,所以當偵錯工具進入某些受限的檔案時,您可能無法追蹤它。 請參閱控制檔案存取權和可見性以取得詳細資料。

使用它很簡單。 共同作業工作階段主持人在 Visual Studio 中,只需要透過一般方式就能啟動偵錯。

VS 偵錯按鈕

偵錯工具附加在主機端之後,所有來賓會也都會自動附加。 有一個偵錯「工作階段」在主持人的機器上執行的同時,所有參與者都會連線到該偵錯工作階段,且有他們自己的檢視。

提示

如果您想要變更共同偵錯發生的時機與方式,您可以透過 [工具] > [選項] > [Live Share] 中的設定來變更預設行為。

VS 偵錯工具已附加

任何人都可以逐步查看偵錯程序,這樣就能在共同作業者之間順暢地切換,而不需要交涉控制權。

注意

如需依語言或平台列出偵錯功能的狀態,請參閱平台支援

每個共同作業者都可以調查不同變數、跳到呼叫堆疊中的不同檔案、檢查變數,甚至新增或移除中斷點。 共同編輯功能接著會允許每個參與者追蹤其他人的所在位置,以提供在「同時調查問題不同層面」與「共同作業偵錯」之間順暢切換的獨特功能。

注意

不過,來賓在唯讀共同作業工作階段中將無法逐步執行偵錯程序。 但他們仍然可以新增或移除中斷點,及檢查變數。

提示

您也可以從 Visual Studio 參與 VS Code 偵錯工作階段,反之亦然! 如需詳細資訊,請參閱共同偵錯的 Visual Studio 指示

自動 Web 應用程式共用

更棒的是,針對 ASP.NET Web 應用程式的預設設定,如果主持人的專案設定為在偵錯時會自動啟動瀏覽器來連線到執行中的 Web 應用程式,則 Live Share 也會在來賓機器上這這麼做! 這是以安全的方式進行,而且根據預設,來賓只有在偵錯工作階段期間才能使用遠端 Web 應用程式。

如需如何為其他專案類型和/或為工作階段期間共用伺服器存取的詳細資訊,請參閱共用伺服器

提示

如果您不喜歡自動瀏覽器共用的行為,並且想要變更它,您可以在 [工具] > [選項] > [Live Share] 中更新設定。

並行偵錯的動畫

變更 Visual Studio 加入偵錯工作階段的時機

根據預設,當主持人共用偵錯工作階段時,來賓會自動附加到該偵錯工作階段。 不過,在某些情況下,您可能覺得此行為造成干擾。 幸運的是,您可以按照下列步驟來變更它:

  1. 請移至 [工具] > [選項] > [Live Share]
  2. 將 [加入偵錯工作階段選項] 變更為下列其中一個值:
選項 行為
自動 預設值。 身為來賓,您會自動加入主持人啟動的任何偵錯工作階段。
提示 身為來賓,當主持人啟動共用偵錯工作階段時,您會收到提示詢問您是否要加入。
手動 身為來賓,您將需要手動加入任何偵錯工作階段。 請參閱中斷連結與重新附加

中斷連結與重新附加

身為來賓,您可能會想要暫時停止偵錯。 幸運的是,您可以直接按一下偵錯工具列中的「停止」圖示來將偵錯工具中斷連結,而不會影響主持人或其他來賓。

如果您已經更新設定為不再自動附加,或者只想要稍後再附加,則您可以從 [選取啟動項目] 下拉式清單選取想要附加的執行中偵錯工作階段...

卸離時的 VS Debug 按鈕

...然後按一下它來附加。

重新附加時的 VS Debug 按鈕

共用伺服器

身為共同作業工作階段主持人,您可能偶爾會想要與來賓共用其他本機伺服器或服務。 這可能是 RESTful 端點、資料庫或其他伺服器等。 Visual Studio Live Share 可讓您指定本機連接埠號碼,選擇性地為它命名,然後將它與所有來賓共用。

然後來賓將能夠從其本機機器的相同連接埠存取您在該連接埠上共用的伺服器。 例如,如果您共用的 Web 伺服器 是在連接埠 3000 上執行,則來賓也能在 自己的機器上 於 http://localhost:3000 存取相同的執行中 Web 伺服器! 這是透過主持人與來賓之間的 SSH 或 SSL 通道來達成,並且透過服務進行驗證,因此您可確定只有共同作業工作階段中的人員有存取權。

安全性秘訣: 作為主機,您應該對與來賓共用的埠具有相當的選擇,並在應用程式埠 (而不是共用系統埠) 。 對於來賓,共用連接埠的行為就如同該伺服器/服務是在他們自己的機器上執行。 這非常有用,但如果共用不適當的連接埠,也可能有風險。

基於安全性考量,其他來賓只能使用在您所指定的連接埠上執行的伺服器。 幸運的是,將人員加入為共同作業工作階段 主持人 很簡單。 其做法如下:

  1. 按一下右上角的共用 / 工作階段狀態按鈕並選取 [管理共用的本機伺服器]

    管理共用的本機伺服器

  2. 在出現的對話方塊中,按一下 [新增] 並輸入本機上伺服器正在上面執行的連接埠號碼、輸入名稱、按 Enter,然後 [確定]。

    新增共用伺服器

這樣就完成了! 您所指定連接埠上的伺服器,現在會對應到每個來賓 localhost 上的相同連接埠 (除非該連接埠已被占用)!

如果來賓機器上的該連接埠已經使用,系統會自動選取其他連接埠。 幸運的是,身為來賓,您可以按一下右上角的共用 / 工作階段狀態按鈕並選取 [檢視共用的本機伺服器],以查看目前共用之連接埠的清單 (若指定則可依名稱查看)。

檢視共用的本機伺服器

請注意,基於安全性考量,「來賓無法」控制在主持人機器上要共用哪個連接埠。

若要 停止 共用本機伺服器,主持人只需要按一下右上角的共用 / 工作階段狀態按鈕、選取 [管理共用的本機伺服器],並選取適當的連接埠,然後按一下 [移除]。

共用終端機

新式開發經常會運用各種命令列工具。 幸運的是,Live Share 可讓身為主持人的您選擇與來賓「共用終端機」。 共用的終端機可以是唯讀或完全共同作業,因此您和您的來賓都能執行命令並看到結果。 您可以讓來賓看得到終端機輸出,或讓他們操作或執行測試、建置,或甚至將只發生在您機器上的環境特定問題分級。

不過,根據預設 共用終端機,因為它們至少提供來賓您所執行命令之輸出的唯讀存取權 (若他們無法自行執行命令)。 這樣一來,您可以沒有風險地自由在本機終端機上執行命令,並且只在需要時進行共用。 此外,只有主持人可以啟動共用終端機,這可以防止來賓啟動共用終端機並進行您未預期或您看不到的操作。

身為主持人,您可以按一下右上角的工作階段狀態 / 共用按鈕,並選取 [共用的終端機] 其中一個功能表項目來共用終端機。

終端機功能表

此時,您可以從功能表中選取唯讀或讀取/寫入終端機。 當終端機是讀取/寫入時,包括主持人在內的每個人都可以在終端機中輸入,這樣當來賓在進行您不希望的操作時,您輕鬆就能介入。 不過,為了安全起見,您應該 只在確定來賓確實需要讀取/寫入存取權時才提供此權限,並在您只想要來賓查看您執行之任何命令的輸出時提供唯讀終端機。

注意

如果共同作業工作階段是處於唯讀模式,主持人就只能共用唯讀終端機。

一旦您選取要啟動之類型的共用終端機,系統就會為所有參與者顯示新的共用終端機,且都有正確的權限。

終端機安裝快顯通知

若要結束您的終端機工作階段,請直接輸入 exit 或關閉終端機視窗,然後每個人就都會中斷連線。

工作階段狀態

當您已經啟動或加入共同作業工作階段,並且可存取共用內容之後,右上角的 [Live Share] 按鈕就會更新其外觀,以反映使用中共同作業工作階段的狀態。

下列是您通常會看到的狀態:

State 按鈕 描述
非使用中 VS 狀態:非使用中 沒有任何作用中的共同作業工作階段,且未共用任何項目。
主機:共用 In-Progress VS 狀態:共用正在進行中 正在啟動共同作業工作階段,且共用內容很快就會開始。
主機:共用 VS 狀態:共用作用中 共同作業工作階段已啟動,且已共用內容。
主機:共用唯讀 VS 狀態:正在共用唯讀 正在共用唯讀共同作業工作階段。
Guest:加入會話 VS Code 狀態:正在加入 正在加入現有共同作業工作階段。
來賓:已加入 VS 狀態:已加入 已加入且連線至使用中的共同作業工作階段,並接收共用內容。
Guest:已加入唯讀 VS 狀態:已加入唯讀 已加入且連線至使用中的唯讀共同作業工作階段。

來賓限制

雖然目前來賓在使用上述功能時會遇到一些缺點,但共同作業工作階段主持人會保有所選工具的完整功能。 如需詳細資訊,請參閱下列主題:

後續步驟

請查看下列其他文章以取得詳細資訊。

有問題嗎? 請參閱疑難排解提供意見反應