Visual Studio 2017 15.3 版-Preview 版本資訊Visual Studio 2017 version 15.3 - Preview Release Notes


開發人員社群 | 系統需求 | 相容性 | 可散發程式碼 | 授權條款 | 部落格 | 已知問題Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


注意

這不是 Visual Studio 的最新版本。This is not the latest version of Visual Studio. 若要查看 Visual Studio 2019 最新版本的資訊,請瀏覽目前的版本資訊 (機器翻譯) 頁面。To see information on the latest version, Visual Studio 2019, please visit the current Release Notes page.


在本文中,您將找到 Visual Studio 2017 15.3 版之預覽版本的相關資訊。In this article, you will find information regarding the Preview releases for Visual Studio 2017 version 15.3.

注意

此版本未正式運作,而不適用於實際執行電腦,或建立實際執行程式碼。This release is not "go-live" and not intended for use on production computers or for creating production code.

若要深入了解其他相關下載,請參閱下載頁面。To learn more about other related downloads, see the Downloads page.

意見反應與建議Feedback & Suggestions

請提供您的意見!We’d love to hear from you! 您可以透過安裝程式或 Visual Studio IDE 本身右上角的回報問題選項來回報問題。You can report a problem via the Report a Problem option in the upper right hand corner of either the installer or the Visual Studio IDE itself. 您可在開發人員社群入口網站追蹤您的意見反應。You can track your feedback in the Developer Community portal.

已知問題Known Issues

請參閱已知問題一節。Please refer to the Known Issues section.


發行日期:2017年8月18日-Visual Studio 2017 15.3.1 版 Preview 1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1 Preview 1

本版已修正的問題Issues Fixed in this Release

這些是此版本中已解決的客戶回報問題:These are the customer-reported issues addressed in this version:


發行日期:2017年8月11日-Visual Studio 2017 15.3.0 版 Preview 7。1Release Date: August 11, 2017 - Visual Studio 2017 version 15.3.0 Preview 7.1

本版已修正的問題Issues Fixed in this Release

這些是此版本中已解決的客戶回報問題:These are the customer-reported issues addressed in this version:


發行日期:2017年8月1日-Visual Studio 2017 15.3.0 版 Preview 7Release Date: August 1, 2017 - Visual Studio 2017 version 15.3.0 Preview 7

本版已修正的問題Issues Fixed in this Release

這些是此版本中已解決的客戶回報問題:These are the customer-reported issues addressed in this version:


發行日期:2017年7月26日-Visual Studio 2017 15.3.0 版 Preview 6Release Date: July 26, 2017 - Visual Studio 2017 version 15.3.0 Preview 6

本版已修正的問題Issues Fixed in this Release

這些是此版本中已解決的客戶回報問題:These are the customer-reported issues addressed in this version:


發行日期:2017年7月24日-Visual Studio 2017 15.3.0 版 Preview 5Release Date: July 24, 2017 - Visual Studio 2017 version 15.3.0 Preview 5

本版已修正的問題Issues Fixed in this Release

這些是此版本中已解決的客戶回報問題:These are the customer-reported issues addressed in this version:


發行日期:2017年7月12日-Visual Studio 2017 15.3.0 版 Preview 4Release Date: July 12, 2017 - Visual Studio 2017 version 15.3.0 Preview 4

更新摘要Summary of Updates

本版修正的前幾個主要問題Top Issues Fixed in this Release

我們重視開發人員社群的意見反應。The Developer Community spoke and we listened. 此清單會提供收到最高票數並已在此版本中修正的問題。This list provides the issues that received your highest votes and were fixed in this release.


本版 Visual Studio 2017 15.3.0 Preview 4 版本的新功能What's New in this Release of Visual Studio 2017 version 15.3.0 Preview 4

Visual Studio IDE 改進 Visual Studio IDE Improvements

  • 我們在 [說明] 功能表下方新增了 [鍵盤協助工具] 功能表命令。We added the Keyboard Accessibility menu command under the "Help" menu. 此命令提供您協助工具祕訣和訣竅相關線上文件的捷徑。This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • vswhere.exe可執行檔預設不會再顯示預覽實例。The vswhere.exe executable file no longer shows preview instances by default. 若要搜尋預覽版或其他發行前版本的執行個體,您必須在命令列上傳遞 -prereleaseTo search preview or other prerelease instances, you must pass -prerelease on the command line.
  • 診斷系統現在會透過資訊列通知您可能涉及 Visual Studio 非預期終止的延伸模組。The diagnostic system will now inform you via InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio. [ 圖 1] (圖 1) 提供終止的相關資訊,並且會詢問您是否要停用可疑的延伸模組。The InfoBar (Figure 1) provides information about the termination and will ask if you would like to disable the suspected extension.
Info Bar Image
(圖 1) 資訊列(Figure 1) InfoBar

C++ 語言服務 C++ Language Services

  • 已重寫數個專案和程式碼精靈的簽章對話方塊樣式。Several project and code wizards have been rewritten in the signature dialog style.
  • [加入類別] 現在會直接啟動 [加入類別精靈]。Add Class now launches the Add Class wizard directly. 之前在這裡的所有其他項目,現在會在 [新增] > [新增項目] 下提供。All of the other items that were previously here are now available under "Add > New Item".
  • Win32 專案現在會在 [新增專案] 對話方塊的 [Windows Desktop] 類別下。Win32 projects are now under the Windows Desktop category in the New Project dialog.
  • Windows 主控台和傳統型應用程式範本現在會建立專案,而不顯示精靈。The Windows Console and Desktop Application templates now create the projects without displaying a wizard. 相同類別下有新的 [Windows Desktop 精靈],顯示與之前相同的選項。There's a new Windows Desktop Wizard now under the same category that displays the same options as before.
  • 針對以 GCC 型編譯器(例如 MinGW 和 Cygwin)建立的可執行檔,改善「開啟資料夾」中的偵錯工具支援。Improved debugging support in "Open Folder" for executables built with GCC based compilers such as MinGW and Cygwin.
  • 已新增在 "CppProperties.json" 和 "CMakeSettings.json" 中定義全域和組態特定環境變數的支援。Added support to define global and configuration specific environment variables in "CppProperties.json" and "CMakeSettings.json". 這些環境變數可供 "launch.vs.json" 中定義的偵錯組態和 "tasks.vs.json" 中的工作取用。These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • 已改善針對 CMake Ninja 產生器的支援,包括能夠輕鬆以 64 位元平台作為目標的能力。Improved support for CMake's Ninja generator, including the ability to easily target 64-bit platforms.

C# 7.1 語言支援C# 7.1 Language Support

  • 新增使用 c # 7.1 語言功能的功能。Adds the ability to use C# 7.1 language features.
  • C # 7.1 新增非同步主要方法的支援、搭配泛型的模式比對、"default" 常值和 推斷的元組名稱C# 7.1 adds support for async Main methods, pattern-matching with generics, “default” literals, and inferred tuple names.
  • 當您在專案中使用 C# 7.1 功能時,燈泡會提供專案語言版本的升級,可升級為 “C# 7.1” 或「最新版」。When you use C# 7.1 features in your project, lightbulb will offer to upgrade your project’s language version, either to “C# 7.1” or “latest”.

發行日期:2017年6月26日-Visual Studio 2017 15.3.0 版 Preview 3Release Date: June 26, 2017 - Visual Studio 2017 version 15.3.0 Preview 3

更新摘要Summary of Updates

本版修正的前幾個主要問題Top Issues Fixed in this Release

我們重視開發人員社群的意見反應。The Developer Community spoke and we listened. 此清單會提供收到最高票數並已在此版本中修正的問題。This list provides the issues that received your highest votes and were fixed in this release.


本版 Visual Studio 2017 版本 15.3.0 Preview 3 的新功能What's New in this Release of Visual Studio 2017 version 15.3.0 Preview 3

.Net Core 和 ASP.NET Core 改進 .NET Core and ASP.NET Core improvements

  • .NET Framework 和 .NET Standard/核心 interop:使用者現在可以更順暢地從 .NET Framework 專案安裝或參考 .NET Core/.NET Standard 程式庫,反之亦然。.NET Framework and .NET Standard/Core interop: Users can now more seamlessly install or refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. 不需要手動新增 interop NuGet 套件–系統會自動為您執行此操作。No need to manually add interop NuGet packages – system does this for you automatically.
  • 組建: .NET Core 的累加組建現在預設為開啟。Build: Incremental builds for .NET Core is now turned ON by default.
  • Live Unit Testing: Live Unit Testing 現在適用于以多個目標 Framework 為目標的 .NET Core 專案。Live Unit Testing: Live Unit Testing now works for .NET Core projects that target multiple Target Frameworks.
  • ASP.NET Core:除了 IIS Express 之外,我們現在也針對 ASP.NET Core 專案支援 IIS 的 F5。ASP.NET Core : In addition to IIS Express, we now also support F5 with IIS for ASP.NET Core projects.
  • 支援 .NET Core 2.0 和 ASP.NET Core 2.0:此預覽版本的 Visual Studio,會持續支援建立和執行 .NET Core 2.0 應用程式(如果已另外安裝 2.0 SDK)。Support for .NET Core 2.0 and ASP.NET Core 2.0: This preview release of Visual Studio, continues to support creating and running .NET Core 2.0 apps if the 2.0 SDK is installed separately. 您可以下載 .NET Core 2.0 SDK 的最新公開預覽。Latest public preview of .NET Core 2.0 SDK is available for you to download.
    • 如果您想要試驗 .NET Core Preview 每日組建,您可以安裝 .NET Core SDK的最新每日組建。If you would like to experiment with .NET Core Preview daily builds, you can install the latest daily build of the .NET Core SDK. 從安裝程式和二進位檔資料表中選擇適當的封裝。Choose the appropriate package from the Installers and Binaries table. 這些每日組建可搭配 Visual Studio 的預覽版本使用。These daily builds will work with this preview release of Visual Studio.
  • 如需詳細資料,請參閱 .NET Core 2.0 部落格See .NET Core 2.0 blog for more details.

NuGet 改進 NuGet improvements

  • 安裝不相容的套件或新增不相容的專案對專案參考時,NuGet 現在會顯示改良的警告和錯誤。NuGet now displays improved warnings and errors when installing packages or adding project-to-project references that are not compatible.
  • NuGet 現在可讓您隱藏特定或所有警告,或是透過組建屬性將警告提升為錯誤。NuGet now allows you to suppress specific or all warnings or elevate them to errors via Build properties.

Visual Studio IDE 改進 Visual Studio IDE improvements

  • Visual Studio 安裝程式現在支援不超過 150% 的高 DPI 縮放層級。Visual Studio Installer now supports high-DPI scaling at levels less than 150%.

  • 在開啟資料夾的情況下,您可以透過專用的 UI 來選取所需的偵錯工具。In open folder scenarios, you can select your desired debugger via dedicated UI.

  • 我們藉由將 “%userprofile%\Documents\Visual Studio 2017\Settings” 中的 “CurrentSettings.vssettings” 檔案位置變更為類似 “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings” 的安裝特定資料夾,來停止在 Visual Studio 2017 的並存安裝之間共用特定設定,例如工具視窗配置。We’ve stopped sharing certain settings, like tool window layout, between different side by side installations of Visual Studio 2017 by changing location of “CurrentSettings.vssettings” file in “%userprofile%\Documents\Visual Studio 2017\Settings” to an installation specific folder that looks like “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings”.

    注意: 只有在全新安裝的情況下才會使用新的安裝特定設定位置。NOTE: The new installation specific settings location is used only in case of a fresh installation. 將現有的 Visual Studio 2017 安裝升級為此更新會導致使用現有的共用位置。Doing an upgrade of an existing Visual Studio 2017 installation to this update will result in using the existing shared location. 如果您目前有 Visual Studio 2017 的並存安裝,並決定升級且希望 Visual Studio 使用新的安裝特定設定檔案位置,請參閱下列步驟:If you currently have side by side installations of Visual Studio 2017 and decide to upgrade and wish to make Visual Studio use the new installation specific settings file location, see following steps:

    1. 升級後,使用 [匯入\匯出設定精靈] 將您所有現有的設定匯出至 “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx” 資料夾外的某個位置。After the upgrade use the Import\Export settings wizard to export all your existing settings to some location outside of “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx” folder.
    2. 開啟已升級 Visual Studio 安裝的開發人員命令提示字元,並從中執行 devenv resetuserdataOpen the developer command prompt of the upgraded Visual Studio installation and run devenv resetuserdata from it.
    3. 啟動 Visual Studio,並從匯出的設定檔匯入儲存的設定。Launch Visual Studio and import the saved settings from the exported settings file.

    輕量型解決方案負載Lightweight Solution Load

  • 已新增方案總管搜尋的檔案搜尋結果,可尋找延後的專案 (而不只是載入的專案)。Added file search results for Solution Explorer search for deferred projects, instead of just for loaded projects.

    • 對此有些限制:There are some limits to this:
      • 搜尋不會延伸到檔案內,而且不會包含漸進式結果,例如類別、方法等。Search does not extend to within the file and does not include progressive results, i.e. classes, methods, etc.
      • 屬於專案的檔案會顯示為一般清單。Files belonging to a project are shown as a flat list. 當檔案屬於資料夾時,則會顯示相對路徑,而不只是檔案名稱。When files belong to a folder, the relative path is shown instead of just the file name.
      • 搜尋檢視中的檔案項目沒有操作功能表。There are no context menus for the file items in the search view.
    • 當您載入專案時,所有現有的搜尋都會重新整理以新增進展結果。When you load a project, all existing searches will be refreshed to add progression results.
  • [移至所有] 和 [移至檔案] 現在會顯示工作區中外部項目的內容。GoTo All and GoTo Files now show content from external items in the workspace.

  • 我們已修正專案中使用 LSL 的批次建置。We fixed Batch build in projects using LSL.

    安裝程式Setup

  • CLI 可以處理 --verify--fix--cleanCLI is able to handle --verify, --fix and --clean.

    • --verify 會驗證配置,並在承載遺漏和無效時通知您。--verify verifies layout and informs you of missing and invalid payloads.
    • --fix 會驗證配置,並重新下載遺漏或無效的套件。--fix will verify the layout and re-download the packages that are either missing or invalid.
    • --clean 會刪除已淘汰的套件,並讓您將配置修剪為特定版本範圍。--clean will delete obsolete packages and allows you to trim layout to a specific version range.

發行日期:2017年6月20日-Visual Studio 2017 15.3.0 版 Preview 2。1Release Date: June 20, 2017 - Visual Studio 2017 version 15.3.0 Preview 2.1

本版修正的前幾個主要問題Top Issues Fixed in this Release


發行日期:2017年6月8日-Visual Studio 2017 15.3.0 版 Preview 2Release Date: June 8, 2017 - Visual Studio 2017 version 15.3.0 Preview 2

更新摘要Summary of Updates

本版修正的前幾個主要問題Top Issues Fixed in this Release

我們重視開發人員社群的意見反應。The Developer Community spoke and we listened. 此清單會提供收到最高票數並已在此版本中修正的問題。This list provides the issues that received your highest votes and were fixed in this release.


本版 Visual Studio 2017 版本 15.3.0 Preview 2 的新功能What's New in this Release of Visual Studio 2017 version 15.3.0 Preview 2

.NET Framework 4.7 .NET Framework 4.7

Visual Studio 2017 15.3 Preview 2 現在提供 .NET Framework 4.7 開發工具給所有支援的平臺,並包含4.7 執行時間。Visual Studio 2017 15.3 Preview 2 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. .NET Framework 4.7 提供數項新功能和改善,並且大幅度修正可靠性、穩定性、安全性和效能。The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. 您可以在下列位置檢視 .NET 4.7 的更多詳細資料:You can view more details about .NET 4.7 here:

Visual Studio IDE 改進 Visual Studio IDE improvements

登入/已連線的服務Sign-In/Connected Services

  • 我們新增了支援條件式存取和授權失敗。We've added support conditional access and authorization failure.
    • 使用者現在可以登入 Visual Studio,即使他們只針對 Visual Studio 登入流程中使用的某些資源開啟多重要素驗證。Users can now sign into Visual Studio even if they have Multifactor authentication turned on only for some resources used in the Visual studio sign in flow.
  • 已連線的服務] 索引標籤會顯示已設定的服務。Connected Services tab shows which services have already been configured.
    • 您現在可以在 [已連線的服務] 索引標籤中看到已設定的已聯機服務的視覺化指標 (圖 2)You can now see visual indicator for configured connected service in Connected Service tab (Figure 2).
  • 新增了新增 ADFS azure stack 和政府雲端的 UI 支援。Added UI support for adding of ADFS azure stacks along with government clouds.
Connected Services with Configured badge
(圖 2) 已設定徽章的已連線的服務(Figure 2) Connected Services with Configured badge
  • 已解決舊帳戶會顯示在帳戶選擇器中的 bug。Resolved a bug where old accounts would show up in the Account Picker.

Visual Studio IDEVisual Studio IDE

  • 主控台 > 卸載/變更程式中的 Visual Studio 2017 專案現在支援修改。Visual Studio 2017 entry in Control Panel -> Uninstall/Change Programs now supports Modify.
    • 在先前的版本中,您只能從主控台卸載。In previous versions, you could only uninstall from Control Panel.
  • 我們已新增「取得工具和功能 ...」專案到工具功能表的頂端,讓您更輕鬆地新增更多元件, (圖 3)We've added a "Get Tools and Features..." item to the top of your Tool menu to make it easier to add more components (Figure 3).
    • 這將會在修改畫面上啟動安裝程式,以協助您快速新增所需的工具和功能。This will launch the installer on the Modify screen to help you quickly add the tools and features you need.
Menu item to add more tools and features
([圖 3]) 功能表項目,以新增更多的工具和功能(Figure 3) Menu item to add more tools and features
  • 解決在 [檔案] 索引標籤之間切換時所發生的停止回應。Solved a hang that was occurring when switching between file tabs.
  • 我們已新增新的啟動顯示畫面 ([圖 4])We've added a new Splash Screen (Figure 4).
    • 而且,如果版本是預覽版本,則會顯示此畫面。As well, this screen will display if the version is a Preview version.
Splash Screen with Preview Badge
(圖 4) 具有預覽的啟動顯示畫面徽章(Figure 4) Splash Screen with Preview Badge
  • 已修正導致監視器在 Intel 膝上型電腦上中斷連線的快捷方式問題。Fixed a shortcut issue causing monitors to disconnect on Intel laptops.
    • 在舊版中,推播未發行的認可 (Ctrl + Alt + F8) 與在 Intel 膝上型電腦上與監視器中斷連線的快捷方式相同。In previous versions, the default shortcut to push unpublished commits (Ctrl + Alt +F8) was the same as the shortcut to disconnect monitors on Intel laptops. 我們已變更 Ctrl + E、Ctrl + C 的快捷方式來修正此問題。We've changed the shortcut to Ctrl + E, Ctrl + C to fix this.

方案總管Solution Explorer

  • 已啟用檔案的 camelCase 比對。Enabled camelCase matching for files.
  • 開啟資料夾現在支援 MinGW 和 Cygwin 偵錯工具。Open folder now supports MinGW and Cygwin debuggers.
  • 阻礙到不必要的檔案在方案總管內移動時,現在提示會在檔案移動時要求確認。As a deterrent to unwanted file moves inside the Solution Explorer, a prompt now asks for confirmation whenever files are moved. 使用者可以停用提示,然後前往 [工具/選項] 重新啟用。Users can disable the prompt and re-enable by going to Tools / Options… /專案和方案 (圖 5)/ Projects and Solutions (Figure 5).
Warning when moving files in Solution Explorer
(圖 5) 在方案總管中移動檔案時發生警告(Figure 5) Warning when moving files in Solution Explorer

編輯器Editor

  • 燈泡中快速修正和重構的不同圖示。Different icons for quick fixes and refactorings in Lightbulb.

安裝程式Setup

  • Visual Studio 的安裝程式已經根據您目前選取和先前安裝的專案,改善了安裝大小估計的精確度。Visual Studio’s Installer program has improved our install size estimation to be more accurate based on what you have currently selected and previously installed.
  • Visual Studio 更新現在會顯示新的版本格式,讓您更容易瞭解您所取得的更新。Visual Studio updates will now display a new version format to make it easier to understand what updates you are getting.
    • 此版本將會顯示在安裝程式應用程式中 ([圖 6])、[說明] > 對話方塊和更新通知,例如:This version will show in the installer application (Figure 6), Help > About dialog and updates notifications, for example:
About dialog with Version
(圖 6) 有關版本的對話方塊(Figure 6) About dialog with Version
  • --layout 項功能現在可讓您修改或升級現有的版面配置、確認和修正損毀的配置,以及不再需要的較舊組建版面配置。The --layout feature now includes the ability to modify or upgrade existing layouts, verify and fix corrupted layouts, and clean layouts of older builds no longer needed. 此外,建立部分版面配置時,會使用預設值來建立中的 response.js,以安裝部分配置中所包含的工作負載和元件。Additionally, when creating partial layouts a response.json is created with defaults to install the workloads and components that were included in the partial layout.

偵錯與診斷 Debugging and Diagnostics

Visual Studio Team Services 符號伺服器的偵錯工具支援Debugger Support for Visual Studio Team Services Symbol Servers

您現在可以從 Visual Studio Team Services 符號伺服器查詢並下載符號 (圖 7) , (目前處於個人預覽版) 。You can now query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers (currently in private preview). 您可以使用 [工具]->[選項]->[偵錯工具]->[符號] 頁面,選取 Visual Studio Team Services 符號路徑並新增至 Visual Studio 環境。You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. 若要設定 Visual Studio Team Services 符號伺服器, 請遵循這些指示 來註冊私人預覽。To set up a Visual Studio Team Services Symbol Server follow these instructions to sign up for the private preview.

Add VSTS Symbol Server
(圖 7) 新增 VSTS 符號伺服器(Figure 7) Add VSTS Symbol Server

指向並按一下以設定下一個陳述式Point and Click to Set Next Statement

您現在可以按住 Ctrl 鍵,並在調試時于中斷點停止。You can now hold down the Ctrl key while stopped at a breakpoint when debugging. 您的程式碼行旁的執行至所按處 (執行到這裡) 圖示會變更為 [設定下一個陳述式] 功能 (圖 8)。The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). 按一下此功能以將黃色指令指標移至該行,並設定偵錯工具要執行的下一個陳述式。Click on it to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to Set Next Statement
(圖 8) 按一下以設定下一個語句(Figure 8) Click to Set Next Statement

Windows PDB (可攜式 PDB 除外) 現在支援來源連結。Source Link is now supported for Windows PDBs (in addition to Portable PDBs). 支援的編譯器可以將必要資訊放在 Windows PDB 中,而偵錯工具可以根據該資訊擷取來源檔案。Compilers that support it can put the necessary information in the Windows PDB and debugger can retrieve source files based on that information.

「開啟資料夾」偵錯改善Open Folder Debugging Improvements

您現在可以在使用 [開啟資料夾] 時,更輕鬆地選擇您的偵錯工具體驗。You can now more easily choose your debugging experience when using Open Folder. 利用開啟資料夾體驗的新範本,如果您已安裝核心偵錯工具體驗,您現在可以從 [選取偵錯工具] 對話方塊中,選擇您要使用的偵錯工具類型 (管理、原生或混合) ,方法是透過方案總管中的 [偵錯工具和啟動設定] 功能表選項來存取。With the new templates for the Open Folder experience, if you have the core debugger experience installed you can now choose the type of debugger you want to use (Managed, Native, or Mixed) from the "Select a Debugger" dialog accessed through the "Debug and Launch Settings" menu option in Solution Explorer. 如果您已安裝 C++ MDD 體驗 (Android C++、Linux 偵錯等),您現在會在相同的功能表選項中,看到使用 GDB 附加和啟動的 MinGW 和 Cygwin 支援選項。If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you will now see options for MinGW and Cygwin support using GDB for attach and launch within the same menu option.

在變數視窗中重新整理所有巢狀值Refresh All Nested Values in Variable Windows

現在當您在 [監看式]、[自動變數] 和 [區域變數] 視窗中,針對變數或運算式的父節點按一下 [重新整理] 按鈕時,也會重新整理並重新評估該節點子系的所有可見變數和運算式。Now when you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node will also be refreshed and re-evaluated. 您不再需要針對每個子系按一下 [重新整理] 按鈕。You no longer have to click on the refresh button for each of the children.


發行日期:2017年5月11日 Visual Studio 2017 Preview 版本 15.3 (26510.00-預覽) Release Date: May 11, 2017 - Visual Studio 2017 Preview version 15.3 (26510.00 - Preview)

本版修正的前幾個主要問題Top Issues Fixed in this Release

  • 已修正使用 RS3 UWP 專案在標記中產生波浪線的問題,因為缺少資源。Fixed issue where the use of RS3 UWP projects produced squiggles in the markups due to missing resources.
  • 修正當使用者按一下 [取消] 之後按一下 [啟動] 按鈕時,所產生的安裝程式 UI 可靠性問題。Fixed installer UI reliability issue produced when a user clicks on the launch button after clicking on cancel.

發行日期:2017年5月10日-Visual Studio 2017 Preview 版本 15.3 (26507.0-預覽) Release Date: May 10, 2017 - Visual Studio 2017 Preview version 15.3 (26507.0 - Preview)

本版更新摘要Summary of Updates in this Release

本版修正的前幾個主要問題Top Issues Fixed in this Release

我們重視開發人員社群的意見反應。The Developer Community spoke and we listened. 此清單會提供收到最高票數並已在此版本中修正的問題。This list provides the issues that received your highest votes and were fixed in this release.


本版 Visual Studio 2017 版本 15.3.0 Preview 的新功能What's New in this Release of Visual Studio 2017 version 15.3.0 Preview

.NET Core .NET Core

  • 我們已新增 .NET Core 專案的即時單元測試支援。We added live Unit Testing support for .NET Core projects.
  • 您現在可以使用 Visual Basic 建立 .NET Core 主控台應用程式,以及 .NET Core 和 .NET Standard 類別庫。You can now create .NET Core console applications, and .NET Core and .NET Standard class libraries using Visual Basic.
  • 如果另外安裝 SDK,Visual Studio 現在支援建立及執行 .NET Core 2.0 應用程式。Visual Studio now supports creating and running .NET Core 2.0 apps if the SDK is installed separately. 安裝 .NET Core 2.0 SDK 的最新組建Install the latest builds of the .NET Core 2.0 SDK.

如需詳細資料,請參閱 .NET Core 2.0 部落格See .NET Core 2.0 blog for more details.

ASP.NET Core 工具 ASP.NET Core tooling

我們新增了容器化 ASP.NET Core 應用程式的支援做為 Windows Nano 映射。We added support for containerizing ASP.NET Core apps as Windows Nano images. 您現在可以選取 Nano 作為容器平台。You can now select Nano as the container platform. 對於 ASP.NET Core 專案,您可以在 [檔案]->[新增專案] 下執行這項作業。You can do this under File->New Project for ASP.NET Core projects. 對於您現有的專案,您可以使用 [專案] 操作功能表來新增。For your existing projects, it can be added using the Project Context Menu.


我們在 Application Insights 搜尋工具的搜尋查詢結果中新增了相關事件叢集。We added clusters of related events to the search query results in the Application Insights Search tool. 這些叢集可協助您探索應用程式行為中的意外模式,例如來自單一國家/地區、版本或使用者的大量例外狀況。These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


偵錯與診斷 Debugging and Diagnostics

  • >SETTHREADDESCRIPTION API現在支援使用開始偵錯工具進行偵錯工具 (F5) 或附加至進程 (Ctrl + Alt + P) 。The SetThreadDescription API is now supported while debugging using Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). 透過此 API 設定的執行緒名稱,現在會顯示在 [執行緒] 視窗和 [偵錯位置] 工具列的 [執行緒] 下拉式清單中。The thread names that are set via this API will now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. 目前不受傾印偵錯的支援。This is not currently supported while dump debugging.
  • [輸出] 視窗現在會顯示 Windows 容器中執行之應用程式在偵錯時的主控台輸出。The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • 我們為 Nano 伺服器架構的 Windows 容器中所執行的 .NET Core 應用程式新增偵錯支援。We added new support for debugging .NET Core apps you run inside Windows Containers based on Nano Server.

Visual Studio IDE 改進 Visual Studio IDE Improvements

IDE 改進IDE improvements

  • 我們已修正 Visual Studio 在其主視窗顯示前看似已停止回應的「隱藏視窗」BUG。We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • 我們已增加可點選目標區域,讓您更輕鬆地關閉通知提示。We increased the clickable target area to make it easier to dismiss notification tips.
  • 我們已在您的專案資料夾之外新增檔案萬用字元的支援。We added support for file globbing outside of your project folder.

.NET IDE 改善.NET IDE Improvements

  • 我們已新增數個新的重構和快速檢修,例如「解決合併衝突」、「新增 null 檢查」、「新增參數」等。We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. 若要查看完整清單,請瀏覽我們的文件Visit our documentation to see the full list.
  • 我們建議 IntelliSense 中的變數名稱,以協助您快速命名變數,例如 Person personWe suggest variable names in IntelliSense to help you name your variables quickly, e.g., Person person.
  • [編輯後繼續] 現在支援 C# 7.0 功能 (區域函式除外)。Edit and Continue now supports C# 7.0 features (except local functions).

登入及身分識別改善Sign in and identity improvements

  • 我們已修正帳戶選擇器控制項,讓「重新輸入認證」的運作更可靠。We fixed the account picker control so "Re-enter credentials" works more reliably.
  • 在某些情況下,帳戶選擇器會在重新輸入認證時清除帳戶。In some cases, the account picker would clear accounts upon re-entering credentials. 此修正應該會解決該問題。This fix should resolve that issue.

起始頁Start page

我們已增加起始頁最近使用項目「釘選」的可點選目標區域,讓您更輕鬆地將關注項目釘選到最近使用項目的頂端。We increased the clickable target area on Start Page MRU “pins” to make it easier to pin items you care about to the top of the MRU.

輕量型解決方案載入Lightweight solution load

  • 我們已提高建置速度和穩定性。We increased build speed and stability.
  • 我們已減少載入的專案數目。We reduced the number of loaded projects.
  • 我們提供了新的選項 ([圖 9]) 讓 Visual Studio 決定最適合此解決方案的內容。We provided a new option (Figure 9) to let Visual Studio decide what’s best for this solution.
Lightweight Solution Load Options
(圖 9) 輕量解決方案載入選項(Figure 9) Lightweight Solution Load Options

開啟資料夾Open folder

  • 我們已改善在資料夾與方案之間切換的穩定性。We improved stability for toggling between folder and solution.
  • 開啟資料夾擴充項可以將原始檔控制圖示新增至您的資料夾。Open folder extenders can add source control icon to your folders. 這可讓您在方案總管中快速查看檔案的原始檔控制狀態。This allows you to quickly see source control state of your files in Solution Explorer. 目前是由 SVN 實作。Currently implemented by SVN.

持續傳遞工具Continuous delivery tools

我們已將這些功能從 CD4VS 延伸模組移到 Visual Studio:We moved these features from the CD4VS extension into Visual Studio:

  • 為含有以 Azure App Service 為目標之 ASP.NET 專案的方案設定持續傳遞。Configure continuous delivery for solutions containing ASP.NET projects targeting an Azure App Service.
  • 為含有以 Azure App Service 為目標之 ASP.NET Core 專案的方案設定持續傳遞。Configure continuous delivery for solutions containing ASP.NET Core projects targeting an Azure App Service.

容器開發工具Container development tools

Visual Studio 2017 15.3 preview 現在支援在現有的 .NET Framework 應用程式中使用 Windows 容器開發的容器開發範圍,以及適用于 Windows 的 .NET Core,以及 Linux 支援。Visual Studio 2017 15.3 preview now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. 最近的新增包括執行 Nano 伺服器之容器中的 .NET Core 應用程式支援,以及容器中 .NET Framework 應用程式的偵錯改善。Recent additions include support for your .NET Core applications in containers running Nano server, as well as debugging improvements for .NET Framework applications in containers.

Service Fabric 工具Service fabric tools

此版本提供新的具狀態 ASP.NET Core 專案範本、Service Fabric 2.5 和 2.6 SDK (及對應執行階段) 的支援,以及數個 Bug 修正。This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.


Redgate Data Tools Redgate Data Tools

Redgate ReadyRoll Core:Redgate ReadyRoll Core:

我們已更新為版本 1.13.23.3402 並新增:We updated to version 1.13.23.3402 to add:

  • 具有高 DPI 支援並改善工具列回應性的圖示改善。Icon improvements with high-DPI support and better responsiveness in the toolbar.
  • [專案設定] 索引標籤的可用性改善。Usability Improvements to Project Settings Tab.
  • [使用者入門] 檢視、[部署摘要] 和 [登入] 視窗的可用性改善。Usability Improvements to Getting Started view, Deployment Summary, and Login Window.
  • 適用於目標資料庫不存在時的檢視。Added a view for when the target database doesn’t exist.
  • [工具] 功能表下的 ReadyRoll 項目。Added a ReadyRoll entry under the Tools menu.
  • 開啟 SSMS 時的 SQL 驗證支援。Added support for SQL Authentication when opening SSMS.

Redgate SQL Prompt Core:我們更新為版本7.5.1.1087,以改善 SQL Server 2016 的語法支援,以及修正了名稱限定性和 Azure 連線能力的相關問題。Redgate SQL Prompt Core: We updated to version 7.5.1.1087 to improve syntax support for SQL Server 2016, as well as fixed issues around name qualification, and with Azure connectivity.

Redgate SQL Search:我們更新為版本2.4.2.1321,以新增高 DPI 支援的圖示。Redgate SQL Search: We updated to version 2.4.2.1321 to add an icon for high-DPI support.


CMake 工具 CMake Tools

我們增強了 Visual Studio 的 CMake 工具,可讓您支援 CTest 整合和 Ninja 產生器,包括使用 IntelliSense 來建立、偵測和編輯的完整支援。We enhanced CMake tools for Visual Studio to provide you with support for CTest integration and the Ninja generator, including full support to build, debug, and edit with IntelliSense.


已知問題 Known Issues

以下是此 Preview 版特定的已知問題和可用因應措施。Here are the known issues and available workarounds specific to this Preview release.


.NET Core 問題 .NET Core Issues

如需 .NET Core 和 ASP.NET Core 2.0 的目前問題和因應措施清單,請參閱我們的 GitHub 頁面For a current list of issues and workarounds with .NET Core and ASP.NET Core 2.0 see our GitHub page.

測試工具問題 Testing Tools Issues

原生 C++ 單元測試程式碼涵蓋範圍Native C++ unit testing code coverage

  • 問題:Issue:

    原生 C++ 單元測試程式碼涵蓋範圍失敗,發生錯誤,指出未載入任何模組。Native C++ unit testing code coverage fails with an error stating that no modules were loaded.

  • 因應措施:Workaround:

    使用透過 /DEBUG:FULL 選項產生的偵錯資訊來重建您的程式碼。Rebuild your code with debugging information generated with the /DEBUG:FULL option. 您可以在 [專案屬性] | [組態屬性] | [連結器] | [偵錯] 下找到此設定。The setting can be found under "project properties | Configuration Properties | Linker | Debugging".

.NET Core 單元測試程式碼涵蓋範圍.NET Core unit testing code coverage

建立 IntelliTest 專案選項Create IntelliTest project options

  • 問題:Issue:

    當 [輕量型解決方案載入] 作用中時,[建立 IntelliTest] 對話方塊中的 [測試專案] 下拉式清單可能不會列出所有可用的測試專案。When Lightweight Solution Load is in effect, the 'Test Project' dropdown in the Create IntelliTest dialog may not list all available test projects.

  • 因應措施:Workaround:

    尚未載入的專案將不會顯示。Projects that are not already loaded will not be shown. 從方案總管載入相關的專案,以確保在此顯示。Load the relevant projects from the Solution Explorer to ensure that are shown here.

偵錯和診斷問題 Debugging and Diagnostics Issues

Visual Studio 2017 Preview 遠端工具無法使用Remote Tools for Visual Studio 2017 Preview are not available

F # 工具 F# Tools

F # 工具和 .NET Core 專案有多個問題。There are multiple issues the F# tools and .NET Core projects. 這些問題大多已解決,但由於 .NET Core 和 Visual Studio 不會在其版本中對齊,除非您在電腦上安裝正確版本的 .NET Core SDK,否則無法使用這些修正程式。These issues have mostly been addressed, but due to the fact that .NET Core and Visual Studio do not align in their releases, these fixes cannot be used unless you install the correct version of the .NET Core SDK on your machine.

簡而言之,請下載並安裝 這個版本的 .NET Core CLIIn short, download and install this release of the .NET Core CLI. 您必須安裝此項,否則您將會遇到多個已解決的問題。You must install this, otherwise you will come across multiple issues which have already been addressed.

目前正在處理下列問題:The following issues are currently being worked on:

  • 問題:Issue:

    無法透過 Visual Studio 的功能表系統建立專案。Cannot create a project through Visual Studio's menu system.

  • 因應措施:Workaround:

    使用 .NET CLI 建立專案。Create projects with the .NET CLI. 這些可以在 Visual Studio 2017 中開啟。These can be opened in Visual Studio 2017.

  • 問題:Issue:

    Visual Studio 無法辨識新檔案的定義順序、其他專案的參考,或是來自 NuGet 或 Paket 的參考。Visual Studio does not recognize new files in their defined ordering, references from other projects, or references from NuGet or Paket. 不過,建立和執行專案也適用。However, building and running the project works.

  • 因應措施:Workaround:

    此問題目前沒有因應措施。There is no workaround at this time. 如前所述,這些專案仍應建立和執行。As mentioned, these projects should still build and run.

其他問題 Other Issues

  • 問題:Issue:

    當您開啟含有一個 VC 專案的資料夾時,NavigateTo 搜尋不會傳回外部檔案。When you open a folder with a VC project, NavigateTo search does not return external files.

  • 因應措施:Workaround:

    在啟用 [輕量型解決方案載入] 時開啟資料夾,關閉解決方案,然後重新開啟資料夾。Open the folder with Lightweight Solution Load on, close the solution, and reopen the folder.

Glob 使用正斜線 (ie: " */ .cs" ) 在以 CPS 為基礎的專案中不支援 ( .Net Core 和 Cordova) 。Globs with forward slashes (ie: "*/.cs") are not supported in CPS based projects (.NET Core and Cordova).

  • 問題:Issue:

    CPS 專案不支援使用正斜線作為萬用字元,這樣做將會造成非嚴重錯誤。Globs with forward slashes are not supported in CPS projects and will cause a non-fatal error.

  • 因應措施:Workaround:

    目前沒有因應措施。No workaround at this time.

無法建立 Team 專案或更新流程範本Cannot create team projects or update process templates

  • 問題:Issue:

    客戶無法建立新的 team 專案,或上傳或編輯流程範本,Visual Studio 2017 15.3 Preview 1 版。Customers cannot create new team projects or upload or edit process templates from Visual Studio 2017, version 15.3 Preview 1. 從 Web 存取建立專案會繼續運作。Project creation from web access continues to work.

  • 因應措施:Workaround:

    這將在下一個預覽中修正。This will be fixed in the next preview. 目前,如果您需要從 Visual Studio 建立 Team 專案或上傳流程範本,請使用已發行的 Visual Studio 2017 版本 15.2 或舊版。At this time, please use the released Visual Studio 2017, version 15.2 or earlier, if you need to create team projects or upload process templates from Visual Studio.

如果未安裝 C# 和 Visual Basic 元件,開啟資料夾時會發生錯誤Error when opening folder if C# and Visual Basic Component is not installed

  • 問題:Issue:

    如果未安裝 C# 和 Visual Basic 元件,開啟資料夾時會出現錯誤訊息:「引動過程的目標傳回例外狀況」。Error message "Exception thrown by the target of an invocation” when opening folder if C# and Visual Basic Component is not installed.

  • 因應措施:Workaround:

    安裝 C# 和 Visual Basic 元件。Install the C# and Visual Basic Component.

Microsoft Test Manager (MTM) 用戶端無法連線到 Team Foundation Server 或 Visual Studio Team ServicesMicrosoft Test Manager (MTM) client cannot connect to Team Foundation Server or Visual Studio Team Services

  • 問題:Issue:

    MTM 用戶端無法連線到 Team Foundation Server 或 Visual Studio Team Services,導致使用者無法建立及執行測試案例。MTM client cannot connect to Team Foundation Server or Visual Studio Team Services, blocking users from creating and running tests cases.

  • 因應措施Workaround

    這將在下一個預覽中修正。This will be fixed in the next preview. 目前,請使用下列因應措施:At this time, please use the following workaround:

在 [開始] 功能表中搜尋 mtm.exe,然後在右鍵功能表中選擇 [開啟檔案位置],以尋找 mtm.exe 安裝所在的資料夾。Find the folder in which mtm.exe is installed by searching for mtm.exe in the start menu and choosing 'Open file location' in the right click menu. 編輯相同資料夾中的 'mtm.exe.config' 檔案,在 configuration -> runtime 區段中新增下列區段:Edit the 'mtm.exe.config' file present in the same folder to add the following section in configuration -> runtime section:

  <dependentAssembly>
    <assemblyIdentity name="Microsoft.VisualStudio.Threading" publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
    <bindingRedirect oldVersion="10.0.0.0-15.0.0.0" newVersion="15.3.0.0"/>
  </dependentAssembly>

建置 DSL 專案失敗,發生 FileNotFoundExceptionBuilding a DSL project fails with FileNotFoundException

  • 問題:Issue:

    建置新建立的 DSL 專案失敗,發生 FileNotFoundException。Building a newly created DSL project fails with FileNotFoundException.

  • 因應措施:Workaround:

    在 MSBuild.exe.config 中 (位於 \MSBuild\15.0\Bin),將下列程式碼片段新增至 assemblyBinding 項目:Add the following snippet to assemblyBinding element in MSBuild.exe.config (in \MSBuild\15.0\Bin):

    <dependentAssembly>
      <assemblyIdentity name="Microsoft.VisualStudio.Zip.9.0" culture="neutral" publicKeyToken="b03f5f7f11d50a3a" />
      <codeBase version="9.0.0.0" href="..\..\..\Common7\IDE\PrivateAssemblies\Microsoft.VisualStudio.Zip.9.0.dll" />
    </dependentAssembly>

Visual Studio 2017 版本資訊記錄Visual Studio 2017 Release Notes History

如需舊版 Visual Studio 2017 的詳細資訊,請參閱 Visual Studio 2017 版本資訊歷程記錄頁面。For more information relating to past versions of Visual Studio 2017, see the Visual Studio 2017 Release Notes History page.


頁首
Top of Page