Visual Studio Icon Visual Studio 2019 for Mac 8.5 版的版本資訊Visual Studio 2019 for Mac version 8.5 Release Notes



開發人員社群 | 系統需求 | 相容性 | 可散發的程式碼 | 文件 | 部落格 | 服務Developer Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing


按一下這個按鈕以下載最新版的 Visual Studio 2019 for Mac。Click the button to download the latest version of Visual Studio 2019 for Mac. 如需系統需求的資訊,請參閱 Mac 系統需求Mac 平台目標及相容性指南。For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

如需安裝和更新 Visual Studio 2019 for Mac 的指示,請參閱安裝 Visual Studio for Mac 指南For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Download VS for Mac

若要深入了解其他相關下載,請參閱下載頁面To learn more about other related downloads, see the Downloads page.


Visual Studio 2019 for Mac 的新功能What's New in Visual Studio 2019 for Mac

Visual Studio 2019 for Mac 版本Visual Studio 2019 for Mac Releases

Visual Studio 2019 for Mac 部落格文章Visual Studio 2019 for Mac Blog Posts

Visual Studio 部落格 是 Visual Studio 工程小組提供產品見解的官方來源。The Visual Studio Blog is the official source of product insight from the Visual Studio Engineering Team. 您可以在下列文章中找到有關 Visual Studio 2019 for Mac 版本的深入資訊:You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:


版本焦點內容Release Highlights

在此版本的 Visual Studio 2019 for Mac 中,我們取代了舊有的 Git 實作、更新了調色盤與圖示,並解決了偵錯工具、測試工具及專案系統的許多問題。In this release of Visual Studio 2019 for Mac we replaced our old Git implementation, refreshed our color palette and icons, and we addressed a number of issues with the debugger, test tools, and project system.

已知問題Known Issues

請參閱已知問題一節。Refer to the Known Issues section.


Release Notes IconVisual Studio 2019 for Mac 8.5.6 版 (8.5.6.11)Visual Studio 2019 for Mac version 8.5.6 (8.5.6.11)

2020 年 5 月 14 日發行released May 14, 2020

殼層與工具Shell and Tools

Web 和 AzureWeb and Azure

  • 已更新至最新的 .NET Core 3.1.4 版本。We updated to the latest .NET Core 3.1.4 release.

Release Notes Icon Visual Studio 2019 for Mac 8.5.5 版 (8.5.5.7)Visual Studio 2019 for Mac version 8.5.5 (8.5.5.7)

2020 年 5 月 6 日發行released May 6, 2020

Visual Studio for Mac 8.5 服務第 5 版修正了少數已報告的嚴重錯誤。Visual Studio for Mac 8.5 Service Release 5 fixes a handful of fatal errors that were reported.

Release Notes Icon Visual Studio 2019 for Mac 8.5.4 版 (8.5.4.12)Visual Studio 2019 for Mac version 8.5.4 (8.5.4.12)

2020 年 4 月 21 日發行released April 21, 2020

Visual Studio for Mac 8.5 服務第 4 版解決了下列問題:Visual Studio for Mac 8.5 Service Release 4 addresses the following:

Release Notes Icon Visual Studio 2019 for Mac 8.3.5 版 (8.5.3.16)Visual Studio 2019 for Mac version 8.5.3 (8.5.3.16)

2020 年 4 月 14 日發行released April 14, 2020

Visual Studio for Mac 8.5 服務第 3 版解決了下列問題:Visual Studio for Mac 8.5 Service Release 3 addresses the following:

Release Notes Icon Visual Studio 2019 for Mac 8.5.2 版 (8.5.2.13)Visual Studio 2019 for Mac version 8.5.2 (8.5.2.13)

2020 年 4 月 7 日發行released April 7, 2020

Visual Studio for Mac 8.5 服務第 2 版解決了下列問題:Visual Studio for Mac 8.5 Service Release 2 addresses the following:

Release Notes Icon Visual Studio 2019 for Mac 8.5.1 版 (8.5.1.42)Visual Studio 2019 for Mac version 8.5.1 (8.5.1.42)

發行日期︰2020 年 4 月 1 日released April 1, 2020

此版本包括下列更新︰This release includes the following updates:

Release Notes Icon Visual Studio 2019 for Mac 8.5 版 (8.5.0.3183)Visual Studio 2019 for Mac version 8.5 (8.5.0.3183)

2020 年 3 月 23 日發行released March 23, 2020

新功能New Features

協助工具選項Accessibility

這一版 Visual Studio 2019 for Mac 引進重新整理的調色盤、新圖示,以及已更新的警告和錯誤狀態訊息。This release of Visual Studio 2019 for Mac brings a refreshed color palette, new icons, and updated warning and error status messages. 文字和圖示的色彩對比率已增加,用以改善清晰度。Color contrast ratios for text and icons have been increased to improve clarity. Visual Studio for Mac 現在也完全支援 macOS 高對比模式。Visual Studio for Mac also now fully suports macOS High Contrast Mode.

除了視覺效果變更之外,這一版的 Visual Studio 2019 for Mac 還進行了一些變更,用來增加 IDE 的整體存取範圍。In addition to the visual changes, this release of Visual Studio 2019 for Mac has made a number changes to increase overall accessibility of the IDE. 它們包括:These include:

  • 改善在偵錯工具 (NuGet 套件管理員) 和 [專案選項] 對話方塊中使用 VoiceOver 時的焦點順序和可見度。Improvements to focus order and visibility when using VoiceOver in the debugger, NuGet Package Manager and project options dialog.
  • 先前無法透過鍵盤瀏覽存取的區域 (例如釘選和眼睛圖示),現在可透過鍵盤來瀏覽。Areas previously inaccessible by keyboard navigation, such as the pin and eye icon, are now navigable by keyboard.
  • 增強了 VoiceOver 對偵錯工具狀態的意見反應。Enhanced feedback from VoiceOver for debugger staus.
  • 現在,在使用 [新增專案] 對話方塊建立專案之後,IDE 會準確向 VoiceOver 使用者播報「專案已建立」的狀態訊息。After creating a project using the New Project Dialog, the IDE now accurately announces “project created” status message to VoiceOver users.
  • 修正了 NuGet 套件管理員,以允許鍵盤存取 [瀏覽]、[安裝]、[更新] 和 [合併] 索引標籤。Fixes to the NuGet Package manager that allow keyboard access to the Browse, Installed, Update and Consolidate tabs.
  • VoiceOver 現在會在 [新版本] 下拉式清單中宣告選取的版本。VoiceOver now announces the selected version in the "New version" dropdown.
  • VoiceOver 現在會在使用版本控制、發佈至 Azure 功能,以及許多其他領域時,宣告詳細資訊。VoiceOver now announces more information when using version control, the publish to Azure feature, and in a number of additional areas.

版本控制Version Control

以正式 Git 命令列用戶端的包裝函式取代了舊 Git 實作 ( Visual Studio 在 Windows 上已使用該函式),以便改善 IDE 中 Git 支援的整體效能和可靠性。We replaced our old Git implementation with a wrapper around the official Git command line client, which is already used by Visual Studio on Windows, in order to improve the overall performace and reliability of Git support in the IDE. 新 Git 支援取決於官方的 git 用戶端。The new Git support depends on the official git client. 安裝 Git 的建議方式是透過在終端機應用程式中執行 xcode-select --install (不需要安裝 Xcode),將其安裝為 Xcode 命令列工具的一部分。The recommended way to install Git is to install it as part of the Xcode Command Line Tools by running xcode-select --install in the Terminal app (Xcode does not need to be installed).

偵錯工具Debugger

  • 現在可以編輯函式中斷點。Function breakpoints can now be edited.
  • 改善了 .NET Core 專案中的逐步執行效能。We have improved stepping performance in .NET Core projects.

編輯器Editor

  • 更新了更加匹配 Visual Studio 的淺色與深色主題。We updated Light & Dark themes to match Visual Studio.

InstallerInstaller

  • 我們為浮動切換新增了項目,讓使用者可以註冊 ASP.NET Core 提示。We added a new item to the carousel to allow users to sign up for ASP.NET Core tips.
  • 我們新增了支援以實作版本控制所需的 CLI 工具。We added support to implement CLI tools required by version control.
  • 我們整合了錯誤回報,以協助改進未來的品質。We integrated error reporting to aid in improving future quality.

Web 和 AzureWeb and Azure

  • 我們遇到最新的 .NET Core 版本。We bumped to the latest .NET Core release.
  • 在 ASP.NET Core 專案的 [新增專案] 對話方塊中新增了驗證支援。We added authentication support in the New Project Dialog for ASP.NET Core projects.
  • 新增了對 Azure Functions 執行階段 v2/v3 的支援。We added support for v2/v3 of Azure Functions runtime.

NuGetNuGet

  • 已將 NuGet 直接改成 5.4。We bumped NuGet to 5.4.

XamarinXamarin

  • 您現在可以在 [文件大綱] 窗格中看到 Xamarin.Forms 控制項階層。You can now see a hierarchy of your Xamarin.Forms controls in the Document Outline pane. 在 Windows 上,您可以使用 Ctrl + Alt + T ([檢視] > [其他 Windows] > [文件大綱]) 來加以開啟。On Windows, it can be opened with Ctrl+Alt+T (View > Other Windows > Document Outline). 在 Mac 上,您可以透過 [檢視] > [面板] > [文件大綱] 來加以開啟。On Mac, you can open it via Views > Pads > Document Outline.
  • 同時對多個專案進行偵錯時,您現在可以同時在這兩個目標上使用 XAML 熱重新載入。When debugging multiple projects at the same time, you can now use XAML Hot Reload simultaneously on both targets. 例如,您可以使用 XAML 熱重新載入來查看您 XAML 變更在 iOS 和 Android 手機上的樣子。For example, you can use XAML Hot Reload to see how your XAML change looks on both an iOS and Android phone at the same time. 如需有關多個程序偵錯的詳細資訊,請參閱 Visual Studio 2019 文件Learn more about debugging multiple process in the Visual Studio 2019 documentation.
XAML Hot Reload works simultaneously on multiple debug targets
  • 您現在可以在 Visual Studio for Mac 中設定預設的 iOS 設計工具。You can now set the default iOS Designer in Visual Studio for Mac. 在 Xcode 分鏡腳本設計工具中所做的任何變更,都會自動同步回 Visual Studio for Mac。Any changes made in the Xcode storyboard designer will be synchronized back to Visual Studio for Mac automatically.
Improved Xcode Storyboard Designer Integration
  • 您現在可以在執行階段使用「Android 套用變更」來套用 Android 資源變更。You can now apply Android resource changes at runtime using Android Apply Changes. 這項功能可讓您在 Android 裝置或模擬器上快速查看 Android 資源檔 (XML 版面配置和可繪製資源等) 上所做的變更,而不需要重新啟動應用程式。This feature allows you to quickly see changes made to your Android resource files (XML layouts, drawables, etc) on an Android device or emulator without requiring the application to be restarted.
Android Apply Changes
  • 現在,在 Android 應用程式中使用啟動追蹤時,可以產生您自己的自訂設定檔。You can now generate your own custom profiles when using startup tracing in your Android application. 這可提供您更高效能的啟動體驗,並將 APK 大小降到最低。This provides you an even more performant startup experience with a minimal increase to APK size.
  • 您現在可以針對 Kotlin 程式庫產生 Xamarin.Android 繫結。You can now generate Xamarin.Android bindings against Kotlin libraries.
  • 現在,在 Android 專案中合併 AndroidManifest.xml 檔案時,您可以使用 Google Manifest Merger。You can now use the Google Manifest Merger when merging AndroidManifest.xml files in your Android projects. 這可讓您自訂每個資訊清單和其內容的合併方式。This allows you to customize how each manifest and its contents will be merged. 如需可套用的規則詳細資訊,請參閱合併多個資訊清單檔For more details on rules that can be applied, please see Merge multiple manifest files.
  • 建立新的 Xamarin.Forms 應用程式時,已移除使用共用專案的選項。The option to use shared project has been removed when creating a new Xamarin.Forms app. 新的 Xamarin.Forms 應用程式現在會使用 .NET Standard,以確保獲得最佳的開發體驗。New Xamarin.Forms apps will now use .NET Standard to ensure the best development experience.

Bug 修正Bug Fixes

ShellShell

編輯器Editor

偵錯工具Debugger

  • 我們已修正值視覺化程式一律空白的問題。We fixed an issue where value visualizer is always blank.
  • 我們已修正導致檢查階層中巢狀變數所費時間超出預期的問題。We fixed an issue that caused inspecting nested variables in hierarchy to take longer than expected.
  • 修正了 iewing variables with async methods shows nothing (以非同步方法檢視變數時不會顯示任何項目) 的問題。We fixed an issue where viewing variables with async methods shows nothing.
  • 修正了偵錯工具不會正確顯示變數檢查圖示的問題。We fixed an issue where the debugger would not show variable inspection icons correctly.
  • 修正了無法使用退格鍵移除受監視運算式的問題。We fixed an issue that prevented watched expressions from being removed with the backspace key.
  • 修正了 Visual Studio for Mac 的中斷問題,其先前會在 .NET Core 專案的該未處理例外狀況行上中斷。We fixed an issue where Visual Studio for Mac does not break on the line of an unhandled exception in .NET Core projects.
  • 修正了 DataTip (變數檢查) 字型大小看起來太小的問題。We fixed an issue where the DataTip (variable inspect) font size looks small.
  • 修正了在偵錯開始時,PIN 變數圖示消失的問題。We fixed an issue where the pin variable icon during debugging is initially missing.
  • 修正了逐步執行的 UI 按鈕回應緩慢,使得逐步執行流程令人感到漫長的問題。We fixed an issue where the UI buttons for stepping are slow to respond and make stepping feel very slow.
  • 修正了可能無法從 [本機] 與 [監看式] 面板複製值的問題。We fixed an issue where values might not be able to be copied from the locals and watch pads.
  • 修正了 .NET Core 偵錯工具不會顯示 System.Drawing.Color 值的問題。We fixed an issue where the .NET Core debugger would not show System.Drawing.Color values.
  • 修正了 [附加至處理序] 對話方塊未顯示任何處理序的問題。We fixed an issue where the Attach to Process dialog shows no processes.
  • 修正了偵錯工具在未設定中斷點 (在多個啟始專案中) 之程式行中停止的問題。We fixed an issue where the Debugger stops on lines without a breakpoint set (in multiple startup projects).
  • 修正了在 [監看式] 面板中嘗試將已監看的運算式重新命名之後,會將其移除的問題。We fixed an issue where watched expressions are removed after trying to rename them in the Watch Pad.
  • 修正了在偵錯期間,從文字視覺化檢視儲存編輯時,變更並未儲存的問題。We fixed an issue where saving edits from the Text visualizer during debugging does not save changes.
  • 修正了在視覺化檢視中編輯變數值後,[本機] 面板並未更新的問題。We fixed an issue where the Locals pad is not updating after editing variable value in the visualizer.
  • 修正了在逐步執行程式碼時,可能會出現假性捲動的問題。We fixed an issue that could cause spurious scrolling when stepping through code.

專案Project

版本控制Version Control

  • 修正了 (部分) 版本控制檔案下拉式清單無法使用的問題。We fixed an issue where the version control file drop down is (partially) broken.
  • 修正了未簽署 libhostfxr dylib 的問題。We fixed an issue where libhostfxr.dylib is not signed.
  • 修正了在儲存或還原變更後,已修改檔案其狀態未更新的問題。We fixed an issue where the status of modified files was not updated after saving or reverting changes.
  • 修正了在 Git 存放庫中使用方案時,整體效能的問題。We fixed an issue with the overall performance when working with solutions inside a git repository.
  • 修正了 macOS 不斷提示安裝 Xcode 命令列工具的問題。We fixed an issue with macOS continously prompting to install Xcode command line tools.
  • 修正 Git「作者」錯誤地將第 1 行顯示為已修改的問題。We fixed an issue where Git "Authors" incorrectly shows the 1st line as modified.
  • 修正為檔案重新命名時可能會造成 UI 停止回應的問題。We fixed an issue where renaming a file can cause a UI hang.
  • 修正 [切換至分支] 功能表遺失的問題。We fixed an issue where Switch to Branch menu is missing.
  • 修正如果未手動新增或暫存新檔案,就不會在 [狀態檢視] 中顯示該檔案的問題。We fixed an issue where a new file was not shown in the Status View if it was not added/staged manually.
  • 修正在 [狀態檢視] 差異中 BOM 的問題。We fixed an issue where there are issues with BOM in the Status View diff.

Web 工具Web Tools

NuGetNuGet

測試工具Test Tools


已知問題 Known Issues

  • 若您遇到 ASP.NET Core React 和 Angular SPA 專案範本的 node-gyp 組建錯誤,請參閱 node-gyp 安裝注意事項以了解因應措施。If you run into node-gyp build errors with the ASP.NET Core React and Angular SPA project templates then see the node-gyp installation notes for workarounds.

意見反應與建議Feedback & Suggestions

我們很希望聽聽您的意見!We would love to hear from you! 您可以透過 Visual Studio for Mac IDE 中的 [回報問題] 選項來回報問題。You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. 您可在開發人員社群入口網站中追蹤您的意見反應。You can track your feedback, including suggestions, in the Developer Community portal.


頁首
Top of Page