聚合型 NIC 實體切換設定Physical Switch Configuration for Converged NIC

適用於:Windows Server(以每年次管道)、Windows Server 2016Applies To: Windows Server (Semi-Annual Channel), Windows Server 2016

設定您的實體參數,您可以為指導方針使用下列的各節。You can use the following sections as guidelines for configuring your physical switches.

這些是只命令與他們的使用。您必須在您的環境中判斷 Nic 的連接埠。These are only commands and their uses; you must determine the ports to which the NICs are connected in your environment.

重要

請確定的 VLAN 和無拖原則設定的 SMB 所設定的優先順序。Ensure that the VLAN and no-drop policy is set for the priority over which SMB is configured.

切換 arista \ (dcs-7050s-64,EOS-4.13.7M)Arista switch (dcs-7050s-64, EOS-4.13.7M)

  1. 短破折號 \(請移至系統管理員模式,password\ 通常會詢問)en (go to admin mode, usually asks for a password)
  2. 設定 \(將輸入設定 mode\)config (to enter into configuration mode)
  3. 顯示執行 ](顯示目前執行 configuration\)show run (shows current running configuration)
  4. 了解您 Nic 連接到的切換連接埠。find out switch ports to which your NICs are connected to. 在這些範例中,其為 14 日 1,15 日 1,16 日 1,17 日 1。In these example, they are 14/1,15/1,16/1,17/1.
  5. Int 式乙太網路 14 日 1,15 日 1,16 日 1,17 月 1 \(輸入這些 ports\ 組態模式)int eth 14/1,15/1,16/1,17/1 (enter into config mode for these ports)
  6. Dcbx 模式 ieeedcbx mode ieee
  7. 優先順序流量控制模式priority-flow-control mode on
  8. Switchport 主幹原生 vlan 225switchport trunk native vlan 225
  9. 允許 vlan 100-225 switchport 主幹switchport trunk allowed vlan 100-225
  10. Switchport 模式主幹switchport mode trunk
  11. 無放優先順序流量控制優先順序 3priority-flow-control priority 3 no-drop
  12. Qos 信任 cosqos trust cos
  13. 顯示執行 \(確認該設定正確 ports\ 上)show run (verify that configuration is setup correctly on the ports)
  14. Wr \(若要讓 [設定] 跨持續存在切換 reboot\)wr (to make the settings persists across switch reboot)

秘訣:Tips:

  1. 不 #command # 否定命令No #command# negates a command
  2. 如何新增新的 VLAN: int vlan 100 \(如果儲存網路上的 VLAN 100\)How to add a new VLAN: int vlan 100 (If storage network is on VLAN 100)
  3. 如何查看現有 Vlan:顯示 vlanHow to check existing VLANs : show vlan
  4. 如需有關設定 Arista 切換,搜尋 online: Arista EOS 手動For more information on configuring Arista Switch, search online for: Arista EOS Manual
  5. 使用這個命令來確認 PFC 設定:顯示優先順序流量控制計數器詳細資料Use this command to verify PFC settings: show priority-flow-control counters detail

Dell 切換 \ (S4810,FTOS 9.9 (0.0))Dell switch (S4810, FTOS 9.9 (0.0))

!
dcb enable
! put pfc control on qos class 3
configure
dcb-map dcb-smb
priority group 0 bandwidth 90 pfc on
priority group 1 bandwidth 10 pfc off
priority-pgid 1 1 1 0 1 1 1 1
exit
! apply map to ports 0-31
configure
interface range ten 0/0-31
dcb-map dcb-smb
exit

Cisco 切換 \ (關係 3132、版本 6.0(2)U6(1))Cisco switch (Nexus 3132, version 6.0(2)U6(1))

全球Global

class-map type qos match-all RDMA
match cos 3
class-map type queuing RDMA
match qos-group 3
policy-map type qos QOS_MARKING
class RDMA
set qos-group 3
class class-default
policy-map type queuing QOS_QUEUEING
class type queuing RDMA
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
class-map type network-qos RDMA
match qos-group 3
policy-map type network-qos QOS_NETWORK
class type network-qos RDMA
mtu 2240
pause no-drop
class type network-qos class-default
mtu 9216
system qos
service-policy type qos input QOS_MARKING
service-policy type queuing output QOS_QUEUEING
service-policy type network-qos QOS_NETWORK

特定的連接埠Port specific

switchport mode trunk
switchport trunk native vlan 99
switchport trunk allowed vlan 99,2000,2050   çuse VLANs that already exists
spanning-tree port type edge
flowcontrol receive on (not supported with PFC in Cisco NX-OS)
flowcontrol send on (not supported with PFC in Cisco NX-OS)
no shutdown
priority-flow-control mode on

本指南所有主題All topics in this guide

本指南包含下列主題。This guide contains the following topics.