Odebrání duplicitních složek v Outlook při připojení k Exchange Server poštovní schránce

Příznaky

V aplikaci Microsoft Outlook uvidíte duplicitní složky v poštovní schránce Microsoft Exchange Server při zobrazení seznamu složek Outlook nebo při zobrazení seznamu složek pomocí Outlook Web App (OWA).

Příčina

Mobilní zařízení nebo serverová aplikace třetí strany, která se synchronizuje s poštovní schránkou Exchange Server může neočekávaně zavést duplikaci. Nebo může být neočekávaná duplikace výsledkem údržby Exchange Server poštovní schránky nebo jiných změn provedených v počítači, na Exchange Server. K problému popsanému v části Příznaky tohoto článku by mohly přispět i další faktory.

Řešení

V následujících krocích může dojít ke ztrátě dat, pokud je nesledujete přesně tak, jak jste napsali. Před pokračováním v těchto Outlook doporučujeme zálohovat data nebo se ujistit, Exchange Server poštovní schránka zálohovaná.

Pokud chcete odstranit duplicitní položky, postupujte takto:

  1. Ukončete Outlook a zavřete OWA na všech pracovních stanic, které jsou připojené k poštovní schránce uživatele.

  2. K identifikaci duplicitních složek použijte KNIHOVNU MFCMapi. Postupujte takto:

    1. Stáhněte si KNIHOVNU MFCMAPI (posuňte se dolů a vyberte Nejnovější verze).
    2. Spusťte MFCMAPI.exe.
    3. Vyberte nabídku Nástroje a pak vyberte Možnosti.
    4. Povolte následující možnost:
      • Použití MDB_ONLINE při volání do OpenMsgStore
    5. Vyberte OK.
    6. V nabídce Relace vyberte Přihlásit.
    7. Pokud se zobrazí výzva k zadání profilu, vyberte název svého profilu a pak vyberte OK.
    8. V horním podokně najděte řádek, který odpovídá vaší poštovní schránce, a poklikejte na něj.
    9. V navigačním podokně (levé podokno) rozbalte Kořenový kontejner a potom rozbalte Horní část úložiště informací.
    10. Pokud chcete identifikovat duplicitní složku, vyberte jednu z duplicitních složek v levém podokně. V pravém podokně vyhledejte sloupec Hodnota vlastnosti PR_CREATION_TIME . Porovnejte tuto hodnotu s duplicitními složkami se stejným názvem. Duplicitní složka bude mít novější datum a čas vytvoření. Pracujte s jednou dvojicí složek najednou (například začněte se dvěma složkami kalendáře, které se zobrazí).
  3. Pomocí funkce MFCMAPI zkopírujte všechny položky z duplicitní složky do původní složky. Jedná se o položky vytvořené po vytvoření duplicitních složek. To může zahrnovat e-maily přijaté ve složce Doručená pošta, kontakty, které jste vytvořili, události kalendáře, které jste naplánovali, a schůzky, které jste přijali.

    1. V levém podokně knihovny MFCMAPI poklikejte na duplicitní složku, která má novější datum a čas vytvoření.

    2. V okně, které se otevře, vyberte horní podokno a stisknutím kombinace kláves CTRL+A vyberte všechny položky.

      Pokud se v horním podokně nezobrazí žádné položky, je složka už prázdná. přejděte ke kroku 7.

    3. Vyberte nabídku Akce a pak vyberte příkaz Kopírovat zprávy.

    4. Zavřete okno složky a poklikejte na původní složku, která má starší datum a čas vytvoření.

    5. Vyberte nabídku Akce a potom příkaz Vložit zprávy.

    6. Zaškrtněte políčko MESSAGE_MOVE a pak vyberte OK.

    7. Zavřete okno složky.

  4. V aplikaci MFCMAPI přepněte zpátky do duplicitní složky, která je teď prázdná. Odstraňte ji pomocí funkce MFCMAPI.

    1. Klikněte pravým tlačítkem myši na duplicitní složku a pak vyberte Odstranit složku.
    2. Povolte možnost Pevné odstranění a pak vyberte OK.
  5. Opakujte kroky 2 až 4 pro další běžné složky Outlook (Kontakty, Odstraněná pošta, Koncepty, Doručená pošta, Deník, Nevyžádaná pošta, Poznámky, Odeslaná pošta a Úkoly).

  6. Zavřete knihovnu MFCMAPI.

  7. Začněte Outlook s přepínačemresetfolders:

    1. Otevřete dialogové okno Spustit. K tomu použijte jeden z následujících postupů, který je vhodný pro vaši verzi Windows.

      Windows 10, Windows 8.1 a Windows 8: Stiskněte Windows +R.
      Windows 7 a Windows Vista: Vyberte tlačítko Start, přejděte na Všechny programy, vyberte Příslušenství a pak vyberte Spustit.
      Windows XP: Vyberte tlačítko Windows Start a pak vyberte Spustit.

    2. V dialogovém okně Spustit zadejte následující text a pak vyberte OK :

      Outlook.exe /resetfolders

Další informace

Další informace o přepínačích příkazového řádku v Outlook najdete v tématu Přepínače příkazového řádku pro Microsoft Office produkty