Nelze spravovat virtuální adresáře aplikace OWA, Exchange ActiveSync, ECP nebo OAB z konzoly pro správu Exchange v Exchange serveru 2010

Původní číslo KB:   977966

Příznaky

Zvažte následující příklad:

  • Pracujete v nativním prostředí Microsoft Exchange serveru 2010 nebo v prostředí smíšeného systému Exchange Server 2010 a Exchange Server 2007.
  • Z konzoly Exchange Management Console (EMC) se nedají spravovat následující virtuální adresáře:
    • Outlook Web App (OWA)
    • Exchange ActiveSync
    • Ovládací panel Exchange (ECP)
    • Offline adresář (OAB)
  • Když v systému EMC rozbalíte seznam konfigurace serveru, uvidíte na pravé straně seznam serverů pro klientský přístup (CAS).
  • Když se pokusíte vybrat server Exchange Server 2007 CAS nebo Exchange Server 2010 CAS, zjistíte, že je nedostupný.

V tomto scénáři se zobrazí chybová zpráva podobná této:

Úkol se nemůže připojit ke službě IIS na serveru <CAS server name> . Ujistěte se, že server existuje a je dostupný z počítače. Server RPC není k dispozici. Spustili jste příkaz Get-OwaVirtualDirectory.

Příčina

Když se pokusíte vybrat CAS v EMC, server Exchange Server 2010 spustí Get-OwaVirtualDirectory příkaz na pozadí serveru Exchange. Pokud ale tento příkaz neumožňuje přístup k žádnému serveru CAS serveru Exchange, nemůžete ale spravovat žádné virtuální adresáře serveru Exchange Server CAS.

Řešení

Tento problém vyřešíte tak, že počkáte, až Server Exchange Server CAS přestane reagovat, nebo pomocí prostředí Exchange Management Shell spravujte virtuální adresáře explicitně.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedené v části "platí pro".