Připomenutí kalendáře v Outlooku se nedají zavřít nebo se stále znovu zobrazují

Příznaky

Když se v Microsoft Outlooku pokusíte zavřít připomenutí kalendáře, zjistíte, že se nedají zavřít nebo se stále znovu zobrazovat.

Příčina

Složka připomenutí nebo zobrazení připomenutí jsou poškozené. Konflikt synchronizace také může outlooku zabránit v zavření připomenutí.

Řešení 1

Odstraňte položku pomocí příkazového řádku:

  1. Ukončete aplikaci Outlook.

  2. Ve Windows klikněte pravým tlačítkem na tlačítko Start a vyberte Spustit.

  3. V okně Spustit zadejte nebo vložte příkaz níže a vyberte Enter.

    outlook.exe /cleanreminders
    

Pokud tato metoda nefunguje, použijte Řešení 2.

Řešení 2

Odstraňte složku Reminders pomocí Microsoft Exchange Server MAPI Editor (MFCMAPI). Postupujte takto:

  1. Stáhněte si MFCMAPI z GitHubu (posuňte se dolů a klikněte na Nejnovější verze).

  2. Ukončete aplikaci Outlook.

  3. Otevřete MFCMAPI.

  4. V nabídce Nástroje klikněte na Možnosti, zaškrtněte obě následující políčka (pokud ještě nejsou zaškrtnutá) a potom klikněte na OK:

    • Při volání OpenMsgStore použijte příznak MDB_ONLINE
    • Při volání OpenEntry použijte příznak MAPI_NO_CACHE
  5. Klikněte na Relace, klikněte na Přihlásit, vyberte profil, který chcete změnit, a klikněte na OK.

  6. Poklikejte na úložiště poštovních schránek, které chcete otevřít.

  7. Rozbalte kořenový kontejner.

  8. Klikněte pravým tlačítkem na složku Připomenutí a potom klikněte na Odstranit složku.

    Poznámka

    Neodstraňovat jednotlivé položky ve složce Připomenutí. Složka Připomenutí je jenom zobrazení nadcházejících událostí v kalendáři. Pokud se položky ve složce odstraní, odeberou se z kalendáře.

  9. Outlook.exe /cleanreminders Spusťte příkazový řádek neboOutlook.exe /ResetFolders. (Tento krok znovu vytvoří složku Připomenutí a přidá všechny platné položky zpět.)

Řešení 3

Problém se synchronizací můžete vyřešit vymazáním všech offline položek ze složky Kalendář. Tím odeberete všechny položky z místní kopie, ale můžete je znovu stáhnout ze serveru.

  1. Klikněte pravým tlačítkem na ovlivněný kalendář a vyberte Vlastnosti>Vymazat offline položky>OK. Všechny položky v kalendáři budou odebrány.
  2. Výběrem možnosti Odeslat a přijmout>složku aktualizace na pásu karet vynuťte stahování položek.