Po odebrání certifikátu podepsaného svým držitelem z webu Exchange Back End nejde otevřít OWA, ECP nebo EMS

Původní číslo KB: 2779694

Příznaky

Pokud používáte Microsoft Exchange Server 2013 nebo Exchange Server 2016, zvažte následující scénář:

  • Certifikát Self-Signed serveru Microsoft Exchange odeberete z webu Exchange Back End pomocí certifikátů MMC, Remove-Exchangecertificatesprávce služby IIS nebo jiné metody.
  • Mezipaměť služby IIS vymažete restartováním nebo IISReset.

V tomto scénáři se několik klientských protokolů, jako jsou Exchange Ovládací panely (ECP), Outlook Web App (OWA), protokol Exchange ActiveSync a Exchange Management Shell (EMS), nemůže připojit. Může dojít k následujícím problémům:

  • OWA a ECP zobrazí prázdnou stránku.

  • protokol Exchange ActiveSync uživatelé nemůžou přijímat e-maily.

  • EMS se nemůže připojit a zobrazí následující chybu:

    New-PSSession : [xy.local.contoso.com] Processing data from remote server xy.local.contoso.com failed with the
    following error message: The WinRM Shell client cannot process the request. The shell handle passed to the WSMan Shell
    function is not valid. The shell handle is valid only when WSManCreateShell function completes successfully. Change
    the request including a valid shell handle and try again. For more information, see the about_Remote_Troubleshooting
    Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:
    

Příčina

Během procesu instalace je certifikát podepsaný svým držitelem s názvem Microsoft Exchange vázán na back-endový web Exchange na portu 444. Certifikát slouží ke komunikaci mezi výchozím webem a weby Exchange Back End. Po odebrání certifikátu nemůže výchozí web připojit proxy server k webu Exchange Back End.

Řešení

Pokud chcete tento problém vyřešit, přidejte certifikát zpět na web Exchange Back End vytvořením nového certifikátu podepsaného svým držitelem a pak ho svážete s webem Exchange Back End.

Poznámka

Tyto kroky byste měli provést u role serveru poštovních schránek Exchange.

  1. Na serveru poštovní schránky spusťte prostředí Management Shell.
  2. Zadejte New-ExchangeCertificate.

    Poznámka

    Pokud se zobrazí výzva k přepsání výchozího certifikátu, vyberte Ne.

  3. Na poštovním serveru spusťte Správce služby IIS .
  4. Rozbalte web, zvýrazněte Exchange Back End a v podokně Akce v pravém sloupci vyberte Vazby.
  5. Vyberte Typhttps na portu 444.
  6. Vyberte Upravit a vyberte certifikát Microsoft Exchange.
  7. Z příkazového řádku správce spusťte příkaz IISReset.