Chyba při odesílání e-mailů šifrovaných pomocí S/MIME z aplikace OWA: Aplikace Outlook Web Access nemůže najít vaše digitální ID pro šifrování

Původní číslo KB: 2497165

Příznaky

Uživatelé nemůžou odesílat podepsané nebo šifrované e-maily s rozšířením S/MIME (Secure/Multipurpose Internet Mail Extensions) v aplikaci Microsoft Office Outlook Web Access (OWA). V dialogovém okně se zobrazí následující chybová zpráva.

Outlook Web Access could not find your digital ID for encryption. If your digital ID is on a smart card, insert the card in the card reader, and then try to send the message again. You may also try sending the message unencrypted.

If your digital ID is not trusted by the Exchange server, you cannot use it to encrypt messages. For more information, contact technical support for your organization.

Příčina

Pole Předmět nebo Alternativní název předmětu certifikátu uživatele musí obsahovat adresu SMTP, která je uvedená v účtu použitém k přihlášení k OWA.

Pokud je ve výchozí instalaci Exchange Server 2007 nebo Exchange Server 2010 vystaven uživatelský certifikát na adresu SMTP, která není uvedená v účtu služby Active Directory, nebude OWA certifikát používat.

Poznámka

Chcete-li používat funkce S/MIME v aplikaci OWA, musíte používat Exchange Server 2007 Service Pack 1 (SP1) nebo novější verze serveru Exchange.

Řešení

Chcete-li tento problém vyřešit, musíte získat digitální ID.

Pokud máte digitální ID, které se dá použít pro e-maily S/MIME, ale adresa SMTP neodpovídá vašemu Exchange Server účtu poštovní schránky, správce Exchange může povolit následující hodnotu registru, která umožní výběr certifikátu uživatele. To umožňuje uživatelům vybrat certifikát, který se použije k podepisování odchozích zpráv. Klient OWA vynechá kontrolu názvu SMTP.

Pomocí následujícího postupu povolte tuto funkci OWA.

Upozornění

Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

  1. Klikněte na Spustit>, zadejte regedit a stiskněte Enter.
  2. Rozbalte HKLM\System\CurrentControlSet\services\MSExchangeOWA\SMIME.
  3. Klikněte pravým tlačítkem na klíč SMIME a klikněte na New>DWORD (32-bit).
  4. Pojmenujte novou hodnotu DWORD AllowUserChoiceOfSigningCertificate.
  5. Poklikejte na AllowUserChoiceOfSigningCertificate a nastavte hodnotu na 1.
  6. Zavřete editor registru.
  7. Klikněte na Spustit>, zadejte cmd a klikněte na Enter.
  8. Z příkazového řádku spusťte příkaz IISReset /noforce. Nebo můžete restartovat službu IIS Správa v Services.msc.

Po nakonfigurování klíče registru se uživateli v části Zabezpečení e-mailu v možnostech OWA zobrazí nová možnost. K dispozici bude nový oddíl, který uživateli umožní ručně vybrat podpisový certifikát.

  1. Přihlaste se k OWA a klikněte na Možnosti.
  2. Klikněte na Email zabezpečení.
  3. V části Vybrat certifikát pro podepisování pošty změňte přepínač na ruční výběr certifikátu.
  4. Klikněte na Zvolit podpisový certifikát.... Otevře se nové okno s dostupnými uživatelskými certifikáty.
  5. Vyberte příslušný certifikát a klikněte na OK.

Když uživatel odešle e-mail, podepíše se vybraným certifikátem. Proces výběru nekontroluje adresu SMTP uvedenou v rozšíření alternativního názvu subjektu nebo subjektu certifikátu oproti adresám SMTP uživatelského účtu ve službě Active Directory.

Další informace

S klientem Outlooku můžete pomocí klíče registru na straně klienta vypnout porovnávání e-mailů pro certifikáty. Úplné kroky pro klienta Aplikace Outlook jsou popsané v tématu Vypnutí porovnávání e-mailů pro certifikáty v aplikaci Outlook.

Další informace o správě nastavení S/MIME pro OWA najdete v následujících článcích na webu TechNet online.

Správa S/MIME pro aplikaci Outlook Web Access (Exchange Server 2007)

Správa S/MIME pro Outlook Web App (Exchange Server 2010)