Poštovní schránka veřejné složky nebyla nalezena v prostředí s více geografickým umístěním

Příznaky

Když se jako správce Serveru Microsoft Exchange pokusíte načíst nebo upravit veřejnou složku v tenantovi Exchange multi-geo, zobrazí se chybová zpráva podobná:

Poštovní schránka<mailbox GUID> se v místní doménové struktuře nenašla. Připojte se ke správné doménové struktuře pomocí ConnectionUri jako https://outlook.office365.com/powershell-liveid?email=<mailbox email address> při spuštění rutiny New-PSSession.

Při pokusu o vytvoření veřejné složky se zobrazí chybová zpráva podobná:

V této organizaci neexistují žádné veřejné složky. Než vytvoříte veřejnou složku, ujistěte se, že jste vytvořili aspoň jednu poštovní schránku veřejné složky. Pokud chcete vytvořit veřejnou složku, klikněte na Přidat +. Po vytvoření veřejné složky budete muset přiřadit oprávnění, aby k ní uživatelé měli přístup a mohli vytvářet podsložky.

Příčina

Poštovní schránka účtu správce a poštovní schránka pro veřejnou složku, se kterou se pokoušíte pracovat, jsou v různých geografických umístěních. Centrum pro správu Exchange (EAC) nepodporuje přístup k poštovním schránkám veřejných složek, které jsou v jiném geografickém umístění, než ve které je poštovní schránka účtu správce. Pokud používáte Exchange Online PowerShellu, možná jste relaci PowerShellu nepřipojili k poštovní schránce veřejné složky.

Poznámka

Geografické umístění může obsahovat několik doménových struktur. Doménové struktury jsou specifické pro geografické umístění. K tomuto problému může také dojít, pokud jsou poštovní schránka správce a poštovní schránka veřejné složky ve stejném geografickém umístění, ale v různých doménových strukturách.

Řešení

Chcete-li spravovat poštovní schránku veřejné složky, která existuje v jiném geografickém umístění, než ve které je poštovní schránka účtu správce, postupujte takto:

  1. Připojte se k Exchange Online PowerShellu a získejte primární adresu SMTP poštovní schránky veřejné složky. Kroky připojení fungují bez ohledu na to, jestli je povolené vícefaktorové ověřování (MFA):

    1. Načtěte modul powershellu Exchange Online spuštěním následujícího příkazu v okně PowerShellu:

      Import-Module ExchangeOnlineManagement
      
    2. Připojte se k Exchange Online PowerShellu pomocí moderního ověřování:

      Connect-ExchangeOnline
      

      Po zobrazení výzvy zadejte heslo k účtu správce. Pokud má účet povolené vícefaktorové ověřování, musíte také zadat bezpečnostní kód.

    3. Získejte primární adresu SMTP poštovní schránky veřejné složky pomocí rutiny Get-Mailbox . Pokud chybová zpráva určuje identifikátor GUID poštovní schránky, spusťte následující příkaz:

      Get-Mailbox -PublicFolder '<mailbox GUID>' | fl PrimarySmtpAddress
      

      Pokud chybová zpráva neurčí identifikátor GUID poštovní schránky, spusťte následující příkazy pro dotaz na poštovní schránku kořenové veřejné složky:

      $mailboxGuid = (Get-OrganizationConfig).RootPublicFolderMailbox.HierarchyMailboxGuid.Guid
      Get-Mailbox -PublicFolder $mailboxGuid | fl PrimarySmtpAddress
      
  2. Otevřete Exchange Online relaci PowerShellu, která se připojuje k poštovní schránce pro veřejnou složku, se kterou se pokoušíte pracovat:

    1. Připojte se k Exchange Online PowerShellu pomocí připojovací řetězec, který určuje primární adresu SMTP poštovní schránky veřejné složky, kterou jste získali v kroku 1:

      Connect-ExchangeOnline -UserPrincipalName <admin mailbox> -ConnectionUri https://outlook.office365.com/powershell?email=<mailbox smtp address>
      

      Pokud je admin@contoso.onmicrosoft.comnapříklad účet správce a adresa SMTP poštovní schránky veřejné složky je PFMBX1_3f15ace7@contoso.onmicrosoft.com, spusťte následující příkaz:

      Connect-ExchangeOnline -UserPrincipalName admin@contoso.onmicrosoft.com -ConnectionUri https://outlook.office365.com/powershell?email=PFMBX1_3f15ace7@contoso.onmicrosoft.com
      

      Po zobrazení výzvy zadejte heslo k účtu správce. Pokud má účet povolené vícefaktorové ověřování, musíte také zadat bezpečnostní kód.

    2. Opakujte příkaz, který vytvoří, načte nebo upraví veřejnou složku.

Další informace

  • Pokud chcete zkontrolovat geografické umístění a doménovou strukturu poštovní schránky správce, spusťte následující příkaz:

    Get-Mailbox <admin mailbox> | select MailboxLocations
    

    V následujícím příkladu výstup eurprd07 identifikuje geografické umístění a doménovou strukturu poštovní schránky správce. Geografická poloha je Evropa. Doménová struktura v rámci daného geografického umístění je označená hodnotou 07.

    MailboxLocations: {1; 1bfe328f-3be7-4262-a19d-9b136f993e88; Primární; eurprd07.prod.outlook.com; 40169cc4-ad05-42a4-a9cb-c49427346652}

  • Pokud chcete zkontrolovat geografické umístění a doménovou strukturu poštovní schránky veřejné složky, spusťte následující příkaz:

    Get-Mailbox -PublicFolder '<mailbox GUID>' | select MailboxLocations
    

    V následujícím příkladu výstup namprd07 identifikuje geografické umístění a doménovou strukturu. Geografické umístění je Severní Amerika. Doménová struktura v rámci daného geografického umístění je označená hodnotou 09.

    MailboxLocations: {1; b97dc6ee-4f88-4ff1-ab66-df87fe274b79; Primární; namprd09.prod.outlook.com; 1dac0c0d-7de1-476e-a2f5-e080237a3091}

  • Pokud chcete zkontrolovat výchozí geografické umístění vaší organizace, spusťte rutinu Get-OrganizationConfig následujícím způsobem:

    Get-OrganizationConfig | fl DefaultMailboxRegion
    
  • Poštovní schránka účtu správce a poštovní schránka veřejné složky se můžou nacházet v jiném geografickém umístění nebo doménové struktuře v následujících případech:

  • Další informace o správě Exchange Online poštovních schránek v prostředí s více geografickým umístěním najdete v tématu Připojení ke geografickému umístění v Exchange Online PowerShellu.