"Připojení-MsolService: Byla vyvolaná výjimka typu", když se pomocí connect-MSOLService připojíte k Office 365, Azure nebo Intune.

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Problém

Když se pokusíte použít rutinu connect-MSOLService v modulu Microsoft Azure Active Directory pro Windows PowerShell k připojení k cloudové službě Microsoftu, jako je Office 365, Azure nebo Microsoft Intune, pokus se nepovede. Může se zobrazit také následující chybová zpráva:

Connect-MsolService: Exception of type 'Microsoft.Online.Administration.Automation.MicrosoftOnlineException' was thrown.

Příčina

K tomuto problému může dojít z jednoho nebo více z následujících důvodů:

  • Modul Azure Active Directory pro Windows PowerShell se ke službě nemůže připojit bohatý klient. To je často důsledkem problémů s připraveností klientského počítače.
  • ID uživatele, které se používá k ověření, je povolené jednotné přihlašování (SSO) a problém s klientským počítačem brání komunikaci jednotného přihlašování se službou AD FS (Active Directory Federation Services), ověřovacím systémem Azure Active Directory nebo s oběma.

Řešení

Tento problém vyřešíte takto:

  1. Řešení Office 365 připojení klienta. Další informace najdete v tématu Řešení potíží s aplikacemi, které nejsou v prohlížeči a které se ne Office 365, Azure nebo Intune.
  2. Řešení běžných problémů s konfigurací klienta, které omezují ověřování jednotného přihlašování. Další informace najdete v článku Přihlášení Office 365, Azure nebo Intune pomocí jednotného přihlašování nefunguje z některých zařízení.

Další informace

Další informace o modulu Azure Active Directory pro Windows PowerShell najdete v tématu Azure Active Directory rutin.

Stále potřebujete pomoc? Přejděte na web Microsoft Community nebo Azure Active Directory fóra.