"Aplikaci nelze spustit. Kontaktujte dodavatele aplikace" při spuštění Office 365 Desktop Setup

Poznámka

Office 365 ProPlus se přejmenuje na Microsoft 365 Apps for enterprise. Pro další informace o této změně si přečtěte tento blog.

Problém

Když se pokusíte spustit aplikaci Microsoft Office 365 ClickOnce, jako je Office 365 Desktop Setup nebo nástroj Office 365 Desktop Readiness Tool, zobrazí se následující chybová zpráva:

Aplikaci nelze spustit. Obraťte se na dodavatele aplikace.

Snímek obrazovky s chybovou zprávou v dialogovém okně Nelze spustit aplikaci

Když kliknete na Podrobnosti, zobrazí se podrobná chybová zpráva podobná následující:

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of https://<NameOfDomain>/ClickOnceConnector/Office365DesktopSetup.application resulted in exception. Following failure messages were detected:
+ Unable to install this application because an application with the same identity is already installed. To install this application, either modify the manifest version for this application or uninstall the preexisting application.

Příčina

K tomuto problému dochází, pokud byla aplikace uložena do mezipaměti ClickOnce mezipaměti aplikace. Aby bylo možné aplikaci úspěšně spustit, musíte ji z mezipaměti odebrat.

Řešení

Pokud chcete vymazat ClickOnce mezipaměti aplikace, postupujte takto:

  1. Klikněte na Start, klikněte na Spustit, zadejte cmd a poté klikněte na OK.
  2. Zadejte následující příkaz a stiskněte Enter: rundll32 dfshim CleanOnlineAppCache

Pokud chcete zkontrolovat, jestli je problém vyřešený, postupujte takto:

Další informace

Další informace najdete v tématu ClickOnce nespravovaného rozhraní API.

Stále potřebujete pomoc? Přejděte na https://go.microsoft.com/fwlink/?linkid=2003907 web.