Řešení chyb hledání v eDiscovery (Standard)

Pokud narazíte na problém nebo chybu související s hledáním v Microsoft Purview eDiscovery (Standard), zkuste operaci zopakovat, abyste vyloučili přechodné problémy. V případě problémů, které přetrvávají, vyberte příslušný popis z následujícího seznamu:

Pokud se žádné z těchto řešení netýká vašeho problému s vyhledáváním, kontaktujte podpora Microsoftu. V závislosti na vašem problému shromážděte výstup pomocí rutiny PowerShellu Get-ComplianceSearch nebo Get-ComplianceSearchAction před vytvořením případu podpory. Informace o dalších diagnostických informacích, které podpora Microsoftu můžou potřebovat, najdete v tématu Shromažďování diagnostických informací eDiscovery.

Informace o problémech s blokováním eDiscovery najdete v tématu Řešení chyb blokování v eDiscovery (Standard).

Problém s vyhledáváním: Rozdíl mezi odhadovanými a staženými výsledky hledání

Příznaky

Když zobrazíte statistiku výsledků hledání v souboru .csvs časovým razítkem> souhrnu <exportu ve stažené složce výsledků hledání eDiscovery, zjistíte, že se statistiky odhadovaných a stažených výsledků hledání liší. Odhadované statistiky výsledků hledání se také zobrazují v podokně podrobností hledání v Portál dodržování předpisů Microsoft Purview a v nástroji pro export eDiscovery.

Příčina

Odhad výsledků hledání je jenom takový: Jedná se o odhad, nikoli skutečný počet položek, které splňují kritéria vyhledávacího dotazu. Další informace o tom, proč se odhadované a stažené výsledky hledání můžou lišit, najdete v tématu Rozdíly mezi odhadovanými a skutečnými výsledky hledání eDiscovery.

Zpět na začátek

Chyba hledání: Umístění je nejednoznačné

Příznaky

Při spuštění hledání eDiscovery se hledání nezdaří a vrátí následující chybovou zprávu:

Hledání dodržování předpisů obsahuje následující neplatná umístění: <identifikátor> poštovní schránky. Identifikátor> poštovní schránky umístění <je nejednoznačný.

Příčina

Umístění zadaná v chybové zprávě jsou neplatná. Identifikátor poštovní schránky pro každé neplatné umístění používají duplicitní nebo konfliktní objekty v Exchange Online Protection (EOP).

Řešení

Pro každé neplatné umístění postupujte takto:

  1. Připojte se k PowerShellu pro dodržování předpisů zabezpečení &.

  2. Vyhledejte duplicitní nebo konfliktní objekty, které používají identifikátor poštovní schránky. Provedete to spuštěním následujícího příkazu Get-Recipient :

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. Odeberte duplicitní nebo konfliktní objekt.

Zpět na začátek

Chyba hledání: Příjemce nebyl nalezen

Příznaky

Hledání eDiscovery selže a vrátí chybovou zprávu Příjemce nebyl nalezen.

Příčina

Systém nemůže najít jednoho z příjemců ve vyhledávání eDiscovery kvůli zpoždění synchronizace v Exchange Online Protection (EOP).

Řešení

  1. Připojte se k PowerShellu pro dodržování předpisů zabezpečení &.

  2. Pomocí rutiny Get-Recipient zkontrolujte, jestli jsou příjemci ve vyhledávacím dotazu synchronizovaní v EOP. Spusťte následující příkaz:

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. Pokud příkaz nevrátí objekt uživatele pro příjemce, počkejte 30 minut, než se synchronizace dokončí, a pak to znovu zkontrolujte.

  4. Po ověření, že se příjemce synchronizoval v EOP, zkuste hledání zopakovat.

Zpět na začátek

Chyba hledání: CS007

Příznaky

Hledání eDiscovery selže a vrátí CS007 kód chyby.

Příčina

Tuto chybu může způsobit některý z následujících problémů:

  • Přechodný problém

  • Vyhledávací dotaz, který vrací příliš mnoho výsledků pro zpracování systému. Například dotaz, který používá několik zástupných znaků, může vrátit velkou sadu výsledků.

Řešení

Zkuste hledání zopakovat. Pokud hledání stále selže, rozdělte hledání na menší hledání. Pokud chcete například vrátit menší sady výsledků, použijte rozsahy dat nebo omezte počet vyhledávacích umístění.

Chyba hledání: Došlo k vnitřní chybě serveru (500)

Příznaky

Hledání eDiscovery se nezdaří a vrátí chybovou zprávu Došlo k vnitřní chybě serveru (500).

Příčina

Mezi problémy, které můžou způsobit tuto chybu, patří:

  • Vyhledávací dotaz, který vrací příliš mnoho výsledků pro zpracování systému. Například dotaz, který používá několik zástupných znaků, může vrátit velkou sadu výsledků.

  • Jiné chyby hledání. Pokud chcete tyto chyby zkontrolovat, spusťte následující příkaz, abyste získali informace o hledání, a pak ve výstupu vyhledejte chybové zprávy:

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

Řešení

Zkuste hledání zopakovat. Pokud hledání stále selže, rozdělte hledání na menší hledání. Pokud chcete například vrátit menší sady výsledků, použijte rozsahy dat nebo omezte počet vyhledávacích umístění.

Zpět na začátek

Chyba hledání nebo exportu: Maximální počet úloh pro vaši organizaci je právě spuštěný

Příznaky

Při pokusu o hledání nebo export výsledků hledání eDiscovery se operace nezdaří a zobrazí se následující chybová zpráva:

Vaši žádost nejde spustit, protože je aktuálně spuštěný maximální počet úloh pro vaši organizaci.

Příčina

Vaše organizace dosáhla maximálního limitu 50 souběžných úloh. Vzhledem k tomu, že dokončení úloh exportu obvykle trvá déle než úlohy vyhledávání, je pravděpodobné, že úlohy exportu vyplní kvótu.

Řešení

Pomocí následujícího postupu zjistíte, které úlohy exportu jsou aktuálně spuštěné:

Poznámka

Pokud chcete použít následující postup, musíte být členem skupiny rolí eDiscovery Manager a být správcem eDiscovery v této skupině. Další informace o tom, jak zobrazit nebo přiřadit správce eDiscovery ve vaší organizaci, najdete v tématech Přiřazení oprávnění eDiscovery, Get-eDiscoveryCaseAdmin a Add-eDiscoveryCaseAdmin.

  1. Připojte se k PowerShellu pro dodržování předpisů zabezpečení &.

  2. Spusťte následující skript:

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

Pokud chcete tuto chybu vyřešit, použijte následující postup:

  1. Snižte počet spuštěných úloh. Použijte jeden nebo oba z následujících přístupů:

    • Počkejte, až se dokončí jedna nebo více spuštěných úloh.

    • Pomocí rutiny PowerShellu Remove-ComplianceSearchAction odeberte jednu nebo více spuštěných úloh, které už nepotřebujete.

  2. Zkuste operaci hledání nebo exportu zopakovat.

Zpět na začátek

Problém s exportem: Zdá se, že export je zastavený

Příznaky

Pokusíte se exportovat výsledky hledání eDiscovery, ale export se nedokončí a zdá se, že je zablokovaný.

Příčina

Přechodné problémy můžou proces exportu zmařit.

Řešení

Restartujte export.

Poznámka

Export výsledků hledání, které se vygenerovaly před více než sedmi dny, nemůžete restartovat. Místo toho znovu spusťte hledání a pak spusťte export.

Zpět na začátek

Chyba exportu: Položka se přesunula nebo odstranila nebo Nejde načíst položku kvůli vypršení časového limitu

Příznaky

Po stažení výsledků hledání eDiscovery se v souboru Upozornění exportu a Errors.csv ve stažené složce exportu zobrazí následující chyby:

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: Export se nezdařil s typem chyby FailedToExportItem. Zpráva: Položka byla přesunuta nebo odstraněna.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: Export se nezdařil s typem chyby FailedToExportItem. Zpráva: Položku nelze načíst kvůli vypršení časového limitu po několika opakováních.

Příčina

Tyto chybové zprávy "FailedToExportItem" indikují, že systém neexportoval všechny položky výsledků hledání. Nevyexportované položky jsou dočasné zálohy, které systém vytvořil během archivace poštovní schránky. I když eDiscovery dokáže prohledávat dočasné zálohované položky, tyto položky se nedají exportovat.

Řešení

Počkejte, až systém načte a vyexportuje původní položky poštovní schránky, které jsou přidružené k dočasným zálohám.

Zpět na začátek

Chyba exportu: Požadavek selhal se stavovým kódem 500 nebo vnitřní chyba serveru 500

Příznaky

Při pokusu o export nebo stažení výsledků hledání eDiscovery se zobrazí jedna z následujících chybových zpráv:

  • Požadavek selhal se stavovým kódem 500

  • Vnitřní chyba serveru 500

Příčina

K problému může dojít z některého z následujících důvodů.

Příčina 1

Nemáte roli Export. Role Export se automaticky přiřadí členům skupiny rolí eDiscovery Manager. Role Export se automaticky nepřiřazuje členům skupiny rolí Správa organizace.

Příčina 2

K této chybě dochází při pokusu o stažení exportovaných výsledků hledání, pokud nejste správce, který exportoval výsledky hledání.

Příčina 3

Filtry oprávnění pro váš uživatelský účet omezují poštovní schránky, umístění úložiště nebo obsah, který můžete prohledávat a exportovat.

Příčina 4

Objem exportovatelných dat pro vyhledávání přesahuje 2 TB. Maximální množství exportovatelných dat pro jedno hledání je 2 TB. Pokud chcete zjistit velikost exportovatelných dat, spusťte následující příkaz:

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

Řešení

Zvolte řešení, které odpovídá příslušné příčině.

Řešení 1

Pokud jste členem skupiny rolí Správa organizace, přidejte sami sebe do skupiny rolí eDiscovery Manager. Můžete to udělat na stránce Oprávnění v Portál dodržování předpisů Microsoft Purview nebo pomocí rutiny PowerShellu Add-eDiscoveryCaseAdmin.

Řešení 2

Požádejte správce, který export vytvořil, aby dokončil stahování. Pokud chcete tohoto správce najít, spusťte následující příkaz:

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

Řešení 3

U poštovních schránek a umístění úložiště, která chcete vyhledat a exportovat, zkontrolujte, jestli těmto akcím brání nějaké filtry oprávnění . V případě potřeby požádejte správce o konfiguraci filtrů oprávnění.

Řešení 4

Zmenšete velikost stahování rozdělením hledání na menší. Pokud chcete například vrátit menší sady výsledků, použijte rozsahy dat nebo omezte počet vyhledávacích umístění.

Pokud chcete zkontrolovat, jestli jsou k určenému účtu správce přiřazené role Prohledat, Exportovat nebo Preview, spusťte v Centrum pro správu Microsoftu 365 následující test. Abyste mohli použít následující postup, musíte mít oprávnění globálního správce nebo správce dodržování předpisů .

Poznámka

Tato diagnostika není dostupná pro prostředí GCC High nebo DoD ani pro Microsoft 365 provozovaný společností 21Vianet.

  1. V Centrum pro správu Microsoftu 365 vyberte tlačítko Kontrola Spustit testy: eDiscovery RBAC a vyplňte přidružený test:

  2. V části Spustit diagnostiku zadejte hlavní název uživatele (UPN) nebo e-mailovou adresu uživatele, který se pokouší spustit úlohu Hledání, Export nebo Náhled.

  3. Vyberte Spustit testy.

  4. Pokud uživatel nemá přiřazené potřebné role eDiscovery, přiřaďte je, aby uživatel mohl požadovanou úlohu spustit.

Zpět na začátek

Chyba exportu: Soubor se neexportoval, protože neexistuje nebo Soubor se nenašel

Příznaky

Po stažení výsledků hledání eDiscovery se ve stažené složce exportu zobrazí některé z následujících chybových zpráv ve stažené složce exportu upozornění a Errors.csv, vynecháno Items.csvnebo trace.log souborů:

  • Tento soubor se neexportoval, protože už neexistuje. Soubor byl zahrnut do počtu odhadovaných výsledků hledání, protože je stále uvedený v indexu. Soubor se nakonec odebere z indexu a v budoucnu nezpůsobí chybu.

  • FailedToExportItem_Failed ke stažení obsahu. Další diagnostické informace: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: Stažení z ID> dokumentu obsahu <typu Document se nezdařilo. ID korelace: <ID> korelace. ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: Soubor nebyl nalezen. v Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) ve společnosti Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- Konec trasování zásobníku vnitřní výjimky ---

Příčina

Tato chybová zpráva se může zobrazit, pokud hledání eDiscovery zahrnuje umístění Microsoft Office SharePoint Online nebo Microsoft OneDrive pro firmy. eDiscovery spoléhá na index SharePointu Online k identifikaci souborů v obou těchto umístěních. K této chybě dojde, pokud uživatel přejmenuje, přesune nebo odstraní soubor ve výsledcích hledání po dokončení hledání, ale předtím, než systém aktualizuje index SharePointu Online. Pokud chcete zkontrolovat, jestli se soubor přejmenoval, přesunul nebo odstranil, vyhledejte ho v příslušném SharePointu Online nebo OneDrive pro firmy umístění.

Řešení

Pokud chcete tento problém vyřešit, přeindexujte SharePoint Online nebo OneDrive pro firmy umístění pomocí některého z postupů uvedených v tématu Ruční žádost o procházení a přeindexování webu, knihovny nebo seznamu. Pokud chcete, aby výsledky hledání obsahovaly přejmenované nebo přesunuté soubory, spusťte hledání eDiscovery znovu.

Zpět na začátek

Problém se stahováním exportu: Pomalé stahování exportovaných výsledků hledání

Příznaky

Když stáhnete výsledky hledání eDiscovery, stahování trvá déle, než se čekalo.

Příčina

Mezi problémy, které můžou způsobit pomalé stahování, patří:

  • Velké množství exportovaných dat. Pokud chcete zjistit velikost stahování, spusťte následující příkaz:

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • Vyšší než obvyklé zatížení serverů poštovních schránek.

  • Jiné chyby stahování. Kontrola těchto chyb:

    • Spuštěním následujícího příkazu získejte informace o probíhajícím exportu. Ve výstupu příkazu vyhledejte chybové zprávy.

      Get-ComplianceSearchAction | FL Results
      
    • Vyhledejte chybové zprávy v souboru trace.log ve stažené složce exportu.

Řešení

Pokud chcete zmenšit velikost stahování, rozdělte hledání na menší. Pokud chcete například vrátit menší sady výsledků, použijte rozsahy dat nebo omezte počet vyhledávacích umístění.

Zpět na začátek

Problém se stahováním exportu: Nástroj pro export eDiscovery nestahuje žádné soubory

Příznaky

Spuštěním nástroje pro export eDiscovery stáhnete výsledky hledání eDiscovery. Po dokončení operace však pole Odhadovaný součet v okně nástroje ukazuje, že nebyly staženy žádné soubory.

Příčina

K problému může dojít z následujících důvodů:

  • Antivirový software v cílovém počítači blokuje stahování.

  • Vyberete jednotku pro stahování, která není místní jednotkou.

  • Vyberte cílovou složku, která je buď:

    • Složka pro stažení jiného exportu eDiscovery.

    • Nadřazená složka složky pro stahování jiného exportu eDiscovery. Vzhledem k tomu, že nástroj pro export ukládá soubory metadat do nadřazené složky, můžou se soubory metadat pro různá stahování vzájemně kolidovat.

Řešení

Vyzkoušejte každou z následujících metod v daném pořadí, dokud se problém nevyřeší:

  1. Pozastavte antivirový skener na cílovém počítači a pak zkuste stažení zopakovat.

  2. Stažení na místní disk V případě potřeby ji stáhněte do jiného klientského počítače.

  3. Vyberte cílovou složku, která není v konfliktu se souběžným exportem eDiscovery.

  4. Zakažte export do komprimované složky a zakažte odstranění duplicitních dat obsahu Exchange. Pokud tento krok problém vyřeší, příčinou je pravděpodobně antivirový software blokující stahování nebo pokus o stažení na vzdálenou jednotku.

Zpět na začátek

Chyba při exportu stahování: "Výsledek hledání se nestáhnul, protože se jedná o složku"

Příznaky

Po stažení výsledků hledání eDiscovery se v souboru Přeskočené Items.csv ve stažené složce exportu zobrazí následující chybová zpráva:

Tento výsledek hledání se nestáhnul, protože se jedná o složku nebo jiný artefakt, který nejde stáhnout sám o sobě. Stáhnou se všechny položky ve složce nebo knihovně.

Příčina

Tato chybová zpráva se může zobrazit, pokud hledání zahrnuje umístění Microsoft Office SharePoint Online nebo Microsoft OneDrive pro firmy. V souboru Vynecháno Items.csv jsou ve výsledcích hledání uvedeny všechny složky a další přeskočené položky. Chybová zpráva se obvykle zobrazuje vedle cest ke složkám, protože se nejedná o položky ke stažení.

Řešení

Není potřeba žádné řešení. Tuto chybovou zprávu můžete bezpečně ignorovat.

Zpět na začátek

Chyba při exportu stahování: Nelze získat přístup k souboru ExportData.db

Příznaky

Spuštěním nástroje pro export eDiscovery stáhnete výsledky hledání eDiscovery, ale stahování se zasekne nebo vytvoří soubory s nulovým bajtem. V souboru trace.log ve stažené složce exportu se zobrazí následující chybová zpráva:

Dojde k přípustné chybě, bude to opakovat: Proces nemá přístup k souboru "ExportData.db", protože ho používá jiný proces.

Příčina

K tomuto problému může dojít v následujících případech:

  • Antivirový software v cílovém počítači blokuje stahování.

  • Vyberete jednotku pro stahování, která není místní jednotkou.

  • Vyberte cílovou složku, která je buď:

    • Složka pro stažení jiného exportu eDiscovery.

    • Nadřazená složka složky pro stahování jiného exportu eDiscovery. Vzhledem k tomu, že nástroj pro export ukládá soubory metadat do nadřazené složky, můžou soubory metadat pro různá stahování kolidovat.

Řešení

Vyzkoušejte každou z následujících metod v daném pořadí, dokud se chyba nevyřeší:

  1. Pozastavte antivirový skener na cílovém počítači a pak zkuste stažení zopakovat.

  2. Stažení na místní disk V případě potřeby ji stáhněte do jiného klientského počítače.

  3. Vyberte cílovou složku, která není v konfliktu se souběžným exportem eDiscovery.

  4. Zakažte export do komprimované složky a zakažte odstranění duplicitních dat obsahu Exchange. Pokud tento krok problém vyřeší, příčinou je pravděpodobně antivirový software blokující stahování nebo pokus o stažení na vzdálenou jednotku.

Zpět na začátek