Nástroj pro migraci Power BI EmbeddedPower BI Embedded migration tool

Pomocí tohoto nástroje pro migraci můžete zkopírovat sestavy ze služby Power BI Embedded v Azure (PaaS) do služby Power BI (SaaS).This migration tool can be used to copy your reports from the Power BI Embedded Azure service (PaaS) to the Power BI service (SaaS).

Migraci obsahu ze své kolekce pracovních prostorů do služby Power BI můžete provést paralelně s aktuálním řešením, které při tom nemusíte zastavovat nebo odstavovat.Migrating your content from your workspace collections to the Power BI service can be done in parallel to your current solution and doesn't require any downtime.

OmezeníLimitations

  • Datové sady typu Push nejde stáhnout a bude je nutné znovu vytvořit pomocí rozhraní Power BI REST API pro službu Power BI.Pushed datasets cannot be downloaded and will need to be recreated using the Power BI REST APIs for the Power BI service.
  • Nejde stáhnout soubory PBIX importované před 26. listopadem 2016.PBIX files imported before November 26, 2016 will not be downloadable.

StáhnoutDownload

Ukázkový nástroj pro migraci si můžete stáhnout z GitHubu.You can download the migration tool sample from GitHub. Můžete si buď stáhnout zazipované úložiště, nebo ho můžete klonovat do místního počítače.You can either download a zip of the repository, or you can clone it locally. Po stažení můžete otevřít soubor powerbi-migration-sample.sln v sadě Visual Studio a sestavit a spustit nástroj pro migraci.Once downloaded, you can open powerbi-migration-sample.sln within Visual Studio to build and run the migration tool.

Plány migraceMigration Plans

Plán migrace jsou jenom metadata, která katalogizují obsah v rámci Power BI Embedded a určují, jak je chcete publikovat do služby Power BI.Your migration plan is just metadata that catalogs the content within Power BI Embedded and how you want to publish them to the Power BI service.

Vytvoření nového plánu migraceStart with a new migration plan

Plán migrace jsou metadata o položkách dostupných v Power BI Embedded, které chcete přesunout do služby Power BI.A migration plan is the metadata of the items available in Power BI Embedded that you then want to move over to the Power BI service. Plán migrace se ukládá jako soubor XML.The migration plan is stored as an XML file.

Asi budete chtít začít tím, že vytvoříte nový plán migrace.You will want to start by creating a new migration plan. Můžete to udělat následovně.To create a new migration plan, do the following.

  1. Vyberte File (Soubor) > New Migration Plan (Nový plán migrace).Select File > New Migration Plan.

    Vytvoření plánu

  2. V dialogovém okně Select Power BI Embedded Resource Group (Vybrat skupinu prostředků Power BI Embedded) vyberte rozevírací seznam Environment (Prostředí) a v něm položku prod.In the Select Power BI Embedded Resource Group dialog, you will want to select the Environment dropdown and select prod.

  3. Zobrazí se výzva, abyste se přihlásili.You will be prompted to sign in. Použijte přihlašovací jméno ke svému předplatnému Azure.You will use your Azure subscription login.

    Důležité

    To je něco jiného než účet vaší organizace, kterým se přihlašujete k Power BI.This is not your organizational account that you sign into Power BI with.

  4. Vyberte předplatné Azure, ve kterém máte uloženou svoji kolekci pracovních prostorů Power BI Embedded.Select the Azure subscription which stores your Power BI Embedded workspace collections.

    Skupina prostředků

  5. Pod seznamem předplatných vyberte v seznamu Resource Group skupinu prostředků, která obsahuje vaši kolekci pracovních prostorů, a pak vyberte Select (Vybrat).Below the subscription list, select the Resource Group that contains your workspace collections and select Select.

    Výběr skupiny prostředků

  6. Vyberte Analyze (Analyzovat).Select Analyze. Tím získáte inventář položek v rámci vašeho předplatného Azure a budete moct začít s plánováním.This will get an inventory of the items within your Azure subscription for you to begin your plan.

    Analýza skupiny

    Poznámka

    V závislosti na počtu kolekcí pracovních prostorů a velikosti jejich obsahu může proces analýzy trvat i několik minut.The analyze process could take several minutes depending on the number of Workspace collections and how much content exists in the workspace collection.

  7. Po dokončení analýzy se zobrazí výzva k uložení plánu migrace.When Analyze is complete, it will prompt you to save your migration plan.

V tomto bodě máte svůj plán migrace připojený ke svému předplatnému Azure.At this point, you have connected your migration plan to your Azure subscription. Další kroky při práci s plánem migrace jsou vysvětlené níže.Read below to understand the flow of how to work with your migration plan. Patří mezi ně analýza a naplánování migrace, stažení, vytvoření skupin a nahrání.This includes Analyze & Plan Migration, Download, Create Groups and Upload.

Uložení plánu migraceSave your migration plan

Plán migrace si můžete uložit pro pozdější použití.You can save your migration plan for use later. Vytvoří se tím soubor XML obsahující všechny informace z plánu migrace.This will create an XML file that contained all the information in your migration plan.

Plán migrace můžete uložit následovně.To save your migration plan, do the following.

  1. Vyberte File (Soubor) > Save Migration Plan (Uložit plán migrace).Select File > Save Migration Plan.

    Uložení plánu

  2. Zadejte název souboru nebo použijte vygenerovaný název a vyberte Save (Uložit).Give your file a name or use the generated file name and select Save.

Otevření existujícího plánu migraceOpen an existing migration plan

Uložený plán migrace můžete otevřít a pokračovat v dalších krocích migrace.You can open a saved migration plan to continue working on your migration.

Existující plán migrace můžete otevřít následovně.To open your existing migration plan, do the following.

  1. Vyberte File (Soubor) > Open Existing Migration Plan (Otevřít existující plán migrace).Select File > Open Existing Migration Plan.

    Otevření plánu

  2. Vyberte soubor plánu migrace a pak vyberte Open (Otevřít).Select your migration file and select Open.

Krok 1: Analyze & Plan MigrationStep 1: Analyze & Plan Migration

Karta Analyze & Plan Migration (Analýza a naplánování migrace) vám ukáže, co máte aktuálně ve své skupině prostředků v rámci předplatného Azure.The Analyze & Plan Migration tab gives you a view of what is currently in your Azure subscription's resource group.

Karta Analyze & Plan Migration (Analýza a naplánování migrace)

Jako příklad využijeme skupinu prostředků SampleResourceGroup (UkázkováSkupinaProstředků).We will look at the SampleResourceGroup as an example.

Topologie PaaSPaaS Topology

Zobrazená topologie má strukturu Skupina prostředků > Kolekce pracovních prostorů > Pracovní prostory.This is a listing of your Resource Group > Workspace collections > Workspaces. Pro skupinu prostředků a kolekce pracovních prostorů se zobrazí popisné názvy.The resource group and workspace collections will show a friendly name. Pro pracovní prostory se zobrazí identifikátory GUID.The workspaces will show a GUID.

Položky v seznamu se také zobrazují v různých barvách a je u nich číslo ve formátu (#/#).The items in the list will also display a color and a number in the format of (#/#). To označuje počet sestav, které se dají stáhnout.This indicates the number of reports that can be downloaded. Černá barva znamená, že se dají stáhnout všechny sestavy.A black color means that all reports can be downloaded.

Červená barva znamená, že některé sestavy se stáhnout nedají.A red color means that some reports cannot be downloaded. Levé číslo označuje celkový počet sestav, které se dají stáhnout.The left number will indicate the total number of reports that can be downloaded. Pravé číslo označuje celkový počet sestav v rámci seskupení.The number on the right indicates the total number of reports within the grouping.

Když vyberete položku v rámci topologie PaaS, zobrazí se příslušné sestavy v oddílu se sestavami.You can select an item within the PaaS topology to display the reports in the reports section.

SestavyReports

V oddílu se sestavami se zobrazuje seznam dostupných sestav společně s informacemi, jestli se dají stáhnout nebo ne.The reports section will list out the reports available and indicates whether it can be downloaded or not.

Sestavy analýzy

Cílová strukturaTarget structure

V oddílu Target structure (Cílová struktura) můžete nastavit, kam má nástroj položky stahovat a jak se budou nahrávat.The Target structure is where you tell the tool where things will be downloaded to and how to upload them.

Karta Download Plan (Plán stahování)Download Plan

Na této kartě se automaticky vytvoří cesta.A path will automatically be created for you. Pokud chcete, můžete ji změnit.You can change this path if you wish. Pokud cestu změníte, budete muset vybrat Update paths (Aktualizovat cesty).If you do change the path, you will need to select Update paths.

Poznámka

Tímto krokem se neprovádí samotné stažení.This does not actually perform the download. Jenom se jím určuje struktura, do které se budou sestavy stahovat.This is only specifying the structure of where the reports will be downloaded to.

Upload PlanUpload Plan

Tady můžete zadat předponu, která se má použít pro pracovní prostory, jež se vytvoří v rámci služby Power BI.Here you can specify a prefix to be used for the workspaces that will be created within the Power BI service. Za předponou bude identifikátor GUID pracovního prostoru, který existoval v Azure.After the prefix will be the GUID for the workspace that existed in Azure.

Plán nahrávání

Poznámka

Tímto krokem se ještě nevytvoří skupiny v rámci služby Power BI.This does not actually create the groups within the Power BI service. Jenom se jím definuje struktura názvů skupin.This only defines the naming structure for the groups.

Pokud předponu změníte, budete muset vybrat Generate Upload Plan (Generovat plán nahrávání).If you change the prefix, you will need to select Generate Upload Plan.

Pokud chcete, můžete kliknout pravým tlačítkem na skupinu a vybrat možnost pro její přejmenování přímo v plánu nahrávání.You can right click on a group and choose to rename the group within the Upload plan directly, if desired.

Sestava nahrávání a přejmenování položky

Poznámka

Název skupiny nesmí obsahovat mezery nebo neplatné znaky.The name of the group must not contain spaces or invalid characters.

Krok 2: StáhnoutStep 2: Download

Na kartě Download (Stažení) se zobrazí seznam sestav a přidružená metadata.On the Download tab, you will see the list of reports and associated metadata. Najdete tu také stav exportu a stav předchozího exportu.You can see what the export status is along with the previous export status.

stáhnout

Máte dvě možnosti.You have two options.

  • Vybrat konkrétní sestavy a zvolit Download Selected (Stáhnout vybrané)Select specific reports and select Download Selected
  • Zvolit Download All (Stáhnout vše)Select Download All.

Možnosti stahování

Po úspěšném stažení se zobrazí stav Done (Hotovo) a informace, že soubor PBIX existuje.For a successful download, you will see a status of Done and it will reflect that the PBIX file exists.

Po dokončení stahování vyberte kartu Create Groups (Vytvoření skupin).After the download is completed, select the Create Groups tab.

Krok 3: Create GroupsStep 3: Create Groups

Po stažení dostupných sestav můžete přejít na kartu Create Groups (Vytvoření skupin). Na této kartě vytvoříte pracovní prostory v rámci služby Power BI podle plánu migrace, který jste vytvořili.After you have downloaded the reports that are available, you can go to the Create Groups tab. This tab will create the workspaces within the Power BI service based on the migration plan that you created. Pracovní prostor se vytvoří s názvem, který jste zadali na kartě Upload Plan (Plán nahrávání) v rámci karty Analyze & Plan Migration (Analýza a naplánování migrace).It will create the workspace with the name you provided on the Upload tab within Analyze & Plan Migration.

Vytvoření skupin

Pokud chcete vytvořit pracovní prostory, můžete vybrat Create Selected Groups (Vytvořit vybrané skupiny) nebo Create All Missing Groups (Vytvořit všechny chybějící skupiny).To create the workspaces, you can select either Create Selected Groups or Create All Missing Groups.

V obou případech se zobrazí výzva k přihlášení.When you select either of these options, you will be prompted to sign in. Použijte svoje přihlašovací údaje pro účet služby Power BI, ve kterém chcete pracovní prostory vytvořit.You will want to use your credentials for the Power BI service that you want to create the workspaces on.

Přihlášení pro vytvoření skupin

Tímto se vytvoří pracovní prostor v rámci služby Power BI.This will create the workspace within the Power BI service. V tomto kroku se do pracovního prostoru ještě nenahrají sestavy.This does not upload the reports to the workspace.

Vytvoření pracovního prostoru můžete ověřit tak, že se přihlásíte k Power BI a zkontrolujete, jestli tam pracovní prostor existuje.You can verify that the workspace was created by signing into Power BI and validating that the workspace exists. Můžete si všimnout, že pracovní prostor je zatím prázdný.You will notice that nothing is in the workspace.

Pracovní prostor

Po vytvoření pracovního prostoru můžete přejít na kartu Upload (Nahrání).After the workspace is created, you can move onto the Upload tab.

Krok 4: NahrátStep 4: Upload

Na kartě Upload (Nahrání) můžete nahrát sestavy do služby Power BI.On the Upload tab, this will upload the reports to the Power BI service. Uvidíte tu seznam sestav, které jste stáhli na kartě Download (Stažení), společně s názvem cílové skupiny podle plánu migrace.You will see a list of the reports that we downloaded on the Download tab along with the target group name based on your migration plan.

Karta Upload (Nahrání)

Můžete nahrát vybrané sestavy nebo všechny.You can upload selected reports, or you could upload all the reports. Můžete také resetovat stav nahrávání a nahrát položky znovu.You can also reset the upload status to re-upload items.

Dá se tu také vybrat, co se má udělat, pokud už existuje sestava se stejným názvem.You also have the option of selecting what to do if a report with the same name exists. K dispozici jsou možnosti Abort (Přerušit), Ignore (Ignorovat) a Overwrite (Přepsat).You can choose between Abort, Ignore and Overwrite.

Nahrání sestavy se stejným názvem

Možnost Upload Selected (Nahrát vybrané)

Duplicitní názvy sestavDuplicate report names

Pokud máte sestavu, která má stejný název, ale vy víte, že je to jiná sestava, budete pro ni muset změnit TargetName (CílovýNázev).If you have a report that has the same name, but you know it is a different report, you will need to change the TargetName of the report. Název můžete změnit ruční úpravou souboru XML s plánem migrace.You can change the name by manually editing the migration plan XML.

Abyste mohli tuto změnu provést, budete muset nástroj pro migraci zavřít. Po provedení změny nástroj znovu otevřete a otevřete v něm znovu plán migrace.You will need to close the migration tool to make the change and then re-open the tool and the migration plan.

Ve výše uvedeném příkladu došlo u jedné z klonovaných sestav k chybě se zprávou, že sestava se stejným názvem už existuje.In the above example, one of the cloned reports failed indicating a report with the same name existed. Pokud se podíváme do souboru XML s plánem migrace, uvidíme následující.If we go look at the migration plan XML, we will see the following.

<ReportMigrationData>
    <PaaSWorkspaceCollectionName>SampleWorkspaceCollection</PaaSWorkspaceCollectionName>
    <PaaSWorkspaceId>4c04147b-d8fc-478b-8dcb-bcf687149823</PaaSWorkspaceId>
    <PaaSReportId>525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe</PaaSReportId>
    <PaaSReportLastImportTime>1/3/2017 2:10:19 PM</PaaSReportLastImportTime>
    <PaaSReportName>cloned</PaaSReportName>
    <IsPushDataset>false</IsPushDataset>
    <IsBoundToOldDataset>false</IsBoundToOldDataset>
    <PbixPath>C:\MigrationData\SampleResourceGroup\SampleWorkspaceCollection\4c04147b-d8fc-478b-8dcb-bcf687149823\cloned-525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe.pbix</PbixPath>
    <ExportState>Done</ExportState>
    <LastExportStatus>OK</LastExportStatus>
    <SaaSTargetGroupName>SampleMigrate</SaaSTargetGroupName>
    <SaaSTargetGroupId>6da6f072-0135-4e6c-bc92-0886d8aeb79d</SaaSTargetGroupId>
    <SaaSTargetReportName>cloned</SaaSTargetReportName>
    <SaaSImportState>Failed</SaaSImportState>
    <SaaSImportError>Report with the same name already exists</SaaSImportError>
</ReportMigrationData>

Název položky, u které došlo k chybě, můžete změnit v tagu SaaSTargetReportName.For the failed item, we can change the name of the SaaSTargetReportName.

<SaaSTargetReportName>cloned2</SaaSTargetReportName>

Pak můžeme znovu otevřít plán v nástroji pro migraci a nahrát danou sestavu.We can then re-open the plan, in the migration tool, and upload the failed report.

Po návratu do Power BI uvidíte, že sestavy a datové sady se nahrály do pracovního prostoru.Going back to Power BI, we can see that the reports and datasets have been uploaded in the workspace.

Nahrání pracovního prostoru

Nahrání místního souboru PBIXUpload a local PBIX file

Můžete nahrát místní verzi souboru aplikace Power BI Desktop.You can upload a local version of a Power BI Desktop file. Budete muset zavřít nástroj, upravit soubor XML a zadat úplnou cestu k vašemu místnímu souboru PBIX do vlastnosti PbixPath.You will have to close the tool, edit the XML and put the full path to your local PBIX in the PbixPath property.

<PbixPath>[Full Path to PBIX file]</PbixPath>

Po úpravě souboru XML znovu otevřete plán v nástroji pro migraci a nahrajte danou sestavu.After you have edited the xml, re-open the plan within the migration tool and upload the report.

Sestavy DirectQueryDirectQuery reports

Pro sestavy DirectQuery budete muset aktualizovat připojovací řetězec.You will need to update to update the connection string for DirectQuery reports. Můžete to udělat na webu powerbi.com nebo můžete programově zadat dotaz na připojovací řetězec z Power BI Embedded (PaaS).This can be done within powerbi.com, or you can programmatically query the connection string from Power BI Embedded (PaaS). Příklad najdete tady: Extrakce připojovacího řetězce DirectQuery ze sestavy PaaS.For an example, see Extract DirectQuery connection string from PaaS report.

Potom můžete aktualizovat připojovací řetězec pro datovou sadu v rámci služby Power BI (SaaS) a nastavit přihlašovací údaje pro zdroj dat.You can then update the connection string for the dataset within the Power BI service (SaaS) and set the credentials for the data source. Ukázku tohoto postupu najdete v následujících příkladech.You can look at the following examples to see how to do this.

VkládáníEmbedding

Po dokončení migrace sestav ze služby Power BI Embedded v rámci Azure do služby Power BI můžete aktualizovat svoji aplikaci a začít vkládat sestavy do pracovního prostoru.Now that your reports have been migrated from the Power BI Embedded Azure service to the Power BI service, you can now update your application and begin embedding the reports in this workspace.

Další informace najdete v článku Jak migrovat obsah kolekce pracovních prostorů z Power BI Embedded do Power BI.For more information, see How to migrate Power BI Embedded workspace collection content to Power BI.

Další krokyNext steps

Vkládání pomocí Power BIEmbedding with Power BI
Jak migrovat obsah kolekce pracovních prostorů z Power BI Embedded do Power BIHow to migrate Power BI Embedded workspace collection content to Power BI
Co je Power BI Premium?Power BI Premium - what is it?
Úložiště Git pro rozhraní API jazyka JavaScriptJavaScript API Git repo
Úložiště Git pro kódy C# služby Power BIPower BI C# Git repo
Ukázka vložení pomocí JavaScriptuJavaScript embed sample
Power BI Premium – dokument white paperPower BI Premium whitepaper

Máte další otázky?More questions? Zkuste se zeptat v komunitě Power BI.Try asking the Power BI Community