Přidání obrazovky umožňující posouvání v PowerAppsAdd a scrolling screen in PowerApps

Vytvořte obrazovku, která uživatelům umožní posouvání, aby si zobrazili různé položky.Create a screen that users can scroll to show different items. Například můžete vytvořit aplikaci, která zobrazí data ve sloupcovém a spojnicovém grafu.For example, you might want to create an app that displays data in a column chart and line chart. Když přidáte obrazovku umožňující posouvání, můžete na ni přidat několik ovládacích prvků, které si uživatelé mohou zobrazit posunutím.By adding a scrolling screen, you can add multiple controls, which users can display if they scroll.

Když do sekce přidáte více ovládacích prvků, ovládací prvky si v dané sekci udrží svá relativní umístění bez ohledu na to, zda jde o aplikaci pro telefon nebo tablet.When you add multiple controls in a section, the controls maintain their relative positions within that section, regardless if it's a phone app or a tablet app. Všimněte si, že velikost a orientace obrazovky může určovat uspořádání sekcí.Note that the screen size and orientation may determine how the sections are arranged.

 

PožadavkyPrerequisites

Vytvoření obrazovky umožňující posouváníCreate a scrolling screen

  1. Na kartě Domů klikněte nebo klepněte na možnost Nová obrazovka:On the Home tab, click or tap New screen:

    Možnost přidání obrazovky do aplikace

  2. Na kartě Domů klikněte nebo klepněte na Rozvržení a potom klikněte nebo klepněte na možnost pro přidání nekonečného posuvného plátna:On the Home tab, click or tap Layouts, and then click or tap the option to add an infinite scrolling canvas:

    Možnost přidání nekonečného posuvného plátna

    Přidané plátno:The canvas is added:

    Obrazovka s nekonečným posuvným plátnem ve výchozím zobrazení

Přidání prvkůAdd elements

Nyní na plátno přidejte nějaké ovládací prvky, abyste viděli, jak obrazovka umožňující posouvání funguje.Now, let's add some controls to the canvas to see how the scrolling screen works.

  1. Na přidaném plátně klikněte nebo klepněte na Přidat položku ze záložky Vložení.In the canvas you added, click or tap Add an item from the Insert tab.

  2. Na kartě Vložení klikněte nebo klepněte na Grafy a potom klikněte nebo klepněte na Sloupcový graf.On the Insert tab, click or tap Charts, and then click or tap Column Chart.

    Možnost přidání sloupcového grafu

    Na první kartě obrazovky se zobrazí sloupcový graf:A column chart appears in the first card on the screen:

    Výchozí sloupcový graf

  3. Na kartě Vložení klikněte nebo klepněte na Text a potom klikněte nebo klepněte na Psaní perem:On the Insert tab, click or tap Text, and then click or tap Pen input:

    Možnost přidání ovládacího prvku Psaní perem

  4. Přesuňte ovládací prvek Psaní perem pod graf a změňte jeho velikost, aby pokryl dolní část karty:Move the pen control below the chart, and resize the pen control to cover the bottom of the card:

    Přesunutí a změna velikost ovládacího prvku Psaní perem

Přidání sekceAdd a section

Nyní přidejte další kartu s dalším ovládacím prvkem.Now, let's add another card with another control.

  1. V dolní části obrazovky klikněte nebo klepněte na Přidat sekci:Near the bottom of the screen, click or tap Add section:

    Možnost přidání sekce

    Přidání nové karty na obrazovku:A new card is added to the screen:

    Nová karta pod výchozí sekcí

  2. Když máte kartu stále vybranou, přejděte na kartu Vložení, klikněte nebo klepněte na Grafy a potom klikněte nebo klepněte na Spojnicový graf.With the card still selected, go to the Insert tab, click or tap Charts, and then click or tap Line chart.

    Nový graf je příliš velký na to, aby se na obrazovce zobrazil s dalšími prvky:The new chart is too big to appear on the screen with the other controls:

    Přidání spojnicového grafu do dolní části nové karty

  3. Stisknutím F5 otevřete režim náhledu (případně klikněte nebo klepněte na ikonu přehrávání v pravém horním rohu).Open Preview mode by pressing F5 (or by clicking or tapping the play icon near the upper-right corner).

    Otevření režimu náhledu

  4. Nový spojnicový graf se zobrazí, když se přesunete dolů.Scroll down to display the new line chart.

    Náhled zobrazující spojnicový graf