Vytvoření databáze a přidání tabulek v aplikaci Visual StudioCreate a database and add tables in Visual Studio

Můžete použít Visual Studio k vytvoření a aktualizaci místního databázového souboru v SQL Server Express LocalDB.You can use Visual Studio to create and update a local database file in SQL Server Express LocalDB. Databázi můžete vytvořit také spuštěním příkazů jazyka Transact-SQL v okně nástroje Průzkumník objektů systému SQL Server v aplikaci Visual Studio.You can also create a database by executing Transact-SQL statements in the SQL Server Object Explorer tool window in Visual Studio. V tomto tématu vytvoříme soubor . mdf a přidáte tabulky a klíče pomocí Návrháře tabulky.In this topic, we'll create an .mdf file and add tables and keys by using the Table Designer.

PožadavkyPrerequisites

K dokončení tohoto Názorného postupu budete potřebovat úlohy pro vývoj desktopových aplikací pro .NET a ukládání a zpracování dat, které jsou nainstalované v aplikaci Visual Studio.To complete this walkthrough, you'll need the .NET desktop development and Data storage and processing workloads installed in Visual Studio. Pokud je chcete nainstalovat, otevřete instalační program pro Visual Studio a klikněte na tlačítko Upravit (nebo Další > Upravit) vedle verze sady Visual Studio, kterou chcete upravit.To install them, open Visual Studio Installer and choose Modify (or More > Modify) next to the version of Visual Studio you want to modify.

Vytvoření projektu a lokálního databázového souboruCreate a project and a local database file

  1. Vytvořte nový projekt aplikace model Windows Forms a pojmenujte ho SampleDatabaseWalkthrough.Create a new Windows Forms App project and name it SampleDatabaseWalkthrough.

  2. Na panelu nabídek vyberte projekt > Přidat novou položku.On the menu bar, select Project > Add New Item.

  3. V seznamu šablon položek přejděte dolů a vyberte možnost databáze na základě služby.In the list of item templates, scroll down and select Service-based Database.

    Šablony položek – dialogové okno

  4. Pojmenujte databázi SampleDatabasea pak klikněte na Přidat.Name the database SampleDatabase, and then click Add.

Přidat zdroj datAdd a data source

  1. Pokud není okno zdroje dat otevřené, otevřete ho stisknutím klávesy Shift +ALT +D nebo výběrem možnosti Zobrazit > jiné zdroje dat > Windows na řádku nabídek.If the Data Sources window isn't open, open it by pressing Shift+Alt+D or selecting View > Other Windows > Data Sources on the menu bar.

  2. V okně zdroje dat vyberte Přidat nový zdroj dat.In the Data Sources window, select Add New Data Source.

    Přidat nový zdroj dat v aplikaci Visual Studio

    Otevře se Průvodce konfigurací zdroje dat .The Data Source Configuration Wizard opens.

  3. Na stránce Zvolte typ zdroje dat zvolte možnost databáze a pak klikněte na tlačítko Další.On the Choose a Data Source Type page, choose Database and then choose Next.

  4. Na stránce výběr databázového modelu přijměte výchozí nastavení (datová sada) kliknutím na tlačítko Další .On the Choose a Database Model page, choose Next to accept the default (Dataset).

  5. Na stránce Vyberte datové připojení vyberte v rozevíracím seznamu soubor SampleDatabase. mdf a klikněte na tlačítko Další.On the Choose Your Data Connection page, select the SampleDatabase.mdf file in the drop-down list, and then choose Next.

  6. Na stránce Uložit připojovací řetězec do konfiguračního souboru aplikace klikněte na tlačítko Další.On the Save the Connection String to the Application Configuration File page, choose Next.

  7. Na stránce Výběr databázových objektů se zobrazí zpráva oznamující, že databáze neobsahuje žádné objekty.On the Choose your Database Objects page, you'll see a message that says the database doesn't contain any objects. Klikněte na tlačítko Dokončit.Choose Finish.

Zobrazit vlastnosti datového připojeníView properties of the data connection

Připojovací řetězec pro soubor SampleDatabase. mdf můžete zobrazit otevřením okno Vlastnosti datového připojení:You can view the connection string for the SampleDatabase.mdf file by opening the Properties window of the data connection:

  • Výběrem zobrazit > Průzkumník objektů systému SQL Server otevřete okno Průzkumník objektů systému SQL Server .Select View > SQL Server Object Explorer to open the SQL Server Object Explorer window. Rozbalte (LocalDB) \MSSQLLocalDB > databázea potom klikněte pravým tlačítkem na SampleDatabase. mdf a vyberte vlastnosti.Expand (localdb)\MSSQLLocalDB > Databases, and then right-click on SampleDatabase.mdf and select Properties.

  • Případně můžete vybrat možnost zobrazit > Průzkumník serveru, pokud toto okno ještě není otevřené.Alternatively, you can select View > Server Explorer, if that window isn't already open. Otevřete okno Vlastnosti rozbalením uzlu datová připojení , kliknutím pravým tlačítkem myši na SampleDatabase. mdfa následným výběrem vlastností.Open the Properties window by expanding the Data Connections node, right-clicking on SampleDatabase.mdf, and then selecting Properties.

    Tip

    Pokud nemůžete rozšířit uzel datová připojení, nebo není uvedené připojení SampleDatabase. mdf, vyberte na panelu nástrojů Průzkumník serveru tlačítko připojit k databázi .If you can't expand the Data Connections node, or the SampleDatabase.mdf connection is not listed, select the Connect to Database button in the Server Explorer toolbar. V dialogovém okně Přidat připojení se ujistěte, že je v části zdroj datvybraná možnost Microsoft SQL Server databázový soubor , a pak vyhledejte a vyberte soubor SampleDatabase. mdf.In the Add Connection dialog box, make sure that Microsoft SQL Server Database File is selected under Data source, and then browse to and select the SampleDatabase.mdf file. Kliknutím na tlačítko OKdokončete přidání připojení.Finish adding the connection by selecting OK.

Vytváření tabulek a klíčů pomocí Návrháře tabulkyCreate tables and keys by using Table Designer

V této části vytvoříte dvě tabulky, primární klíč v každé tabulce a několik řádků ukázkových dat.In this section, you'll create two tables, a primary key in each table, and a few rows of sample data. Také vytvoříte cizí klíč k určení způsobu, jakým budou záznamy v jedné tabulce odpovídat záznamům v druhé tabulce.You'll also create a foreign key to specify how records in one table correspond to records in the other table.

Vytvoření tabulky CustomersCreate the Customers table

  1. V Průzkumník serverurozbalte uzel datová připojení a poté rozbalte uzel SampleDatabase. mdf .In Server Explorer, expand the Data Connections node, and then expand the SampleDatabase.mdf node.

    Pokud nemůžete rozšířit uzel datová připojení, nebo není uvedené připojení SampleDatabase. mdf, vyberte na panelu nástrojů Průzkumník serveru tlačítko připojit k databázi .If you can't expand the Data Connections node, or the SampleDatabase.mdf connection is not listed, select the Connect to Database button in the Server Explorer toolbar. V dialogovém okně Přidat připojení se ujistěte, že je v části zdroj datvybraná možnost Microsoft SQL Server databázový soubor , a pak vyhledejte a vyberte soubor SampleDatabase. mdf.In the Add Connection dialog box, make sure that Microsoft SQL Server Database File is selected under Data source, and then browse to and select the SampleDatabase.mdf file. Kliknutím na tlačítko OKdokončete přidání připojení.Finish adding the connection by selecting OK.

  2. Klikněte pravým tlačítkem na tabulky a vyberte Přidat novou tabulku.Right-click on Tables and select Add New Table.

    Návrhář tabulky otevře a zobrazí mřížku s jedním výchozím řádkem, který představuje jeden sloupec v tabulce, kterou vytváříte.The Table Designer opens and shows a grid with one default row, which represents a single column in the table that you're creating. Přidáním řádků do mřížky přidáte další sloupce v tabulce.By adding rows to the grid, you'll add columns in the table.

  3. V mřížce přidejte řádek pro každou z následujících položek:In the grid, add a row for each of the following entries:

    Název sloupceColumn name Datový typData type Povolit hodnoty NULLAllow nulls
    CustomerID nchar(5) Nepravda (nezaškrtnuto)False (cleared)
    CompanyName nvarchar(50) Nepravda (nezaškrtnuto)False (cleared)
    ContactName nvarchar (50) Pravda (zaškrtnuto)True (selected)
    Phone nvarchar (24) Pravda (zaškrtnuto)True (selected)
  4. Klikněte pravým tlačítkem na řádek CustomerID a pak vyberte nastavit primární klíč.Right-click on the CustomerID row, and then select Set Primary Key.

  5. Klikněte pravým tlačítkem na výchozí řádek (Id) a pak vyberte Odstranit.Right-click on the default row (Id), and then select Delete.

  6. Pojmenujte tabulku Zákazníci prostřednictvím aktualizace prvního řádku v podokně se skriptem tak, aby odpovídala následující ukázce:Name the Customers table by updating the first line in the script pane to match the following sample:

    CREATE TABLE [dbo].[Customers]
    

    Mělo by se zobrazit něco podobného:You should see something like this:

    Návrhář tabulky

  7. V levém horním rohu Návrháře tabulkyvyberte aktualizovat.In the upper-left corner of Table Designer, select Update.

  8. V dialogovém okně Náhled aktualizací databáze vyberte aktualizovat databázi.In the Preview Database Updates dialog box, select Update Database.

    Tabulka Customers (zákazníci) se vytvoří v souboru místní databáze.The Customers table is created in the local database file.

Vytvoření tabulky OrdersCreate the Orders table

  1. Přidejte další tabulku a potom přidejte řádek pro každou položku v následující tabulce:Add another table, and then add a row for each entry in the following table:

    Název sloupceColumn name Datový typData type Povolit hodnoty NULLAllow nulls
    OrderID int Nepravda (nezaškrtnuto)False (cleared)
    CustomerID nchar(5) Nepravda (nezaškrtnuto)False (cleared)
    OrderDate datetime Pravda (zaškrtnuto)True (selected)
    OrderQuantity int Pravda (zaškrtnuto)True (selected)
  2. Jako primární klíč nastavte ČísloObjednávky a pak výchozí řádek odstraňte.Set OrderID as the primary key, and then delete the default row.

  3. Pojmenujte tabulku Objednávky prostřednictvím aktualizace prvního řádku v podokně se skriptem tak, aby odpovídala následující ukázce:Name the Orders table by updating the first line in the script pane to match the following sample:

    CREATE TABLE [dbo].[Orders]
    
  4. V levém horním rohu Návrháře tabulkyvyberte aktualizovat.In the upper-left corner of the Table Designer, select Update.

  5. V dialogovém okně Náhled aktualizací databáze vyberte aktualizovat databázi.In the Preview Database Updates dialog box, select Update Database.

    Tabulka Orders (objednávky) se vytvoří v souboru místní databáze.The Orders table is created in the local database file. Pokud rozbalíte uzel tabulky v Průzkumník serveru, zobrazí se tyto dvě tabulky:If you expand the Tables node in Server Explorer, you see the two tables:

    Uzel Tables se rozšířil v Průzkumník serveru.

Vytvoření cizího klíčeCreate a foreign key

  1. V kontextovém podokně na pravé straně mřížky Návrháře tabulky pro tabulku objednávky klikněte pravým tlačítkem na cizí klíče a vyberte Přidat nový cizí klíč.In the context pane on the right side of the Table Designer grid for the Orders table, right-click on Foreign Keys and select Add New Foreign Key.

    Přidání cizího klíče v Návrháři tabulky v aplikaci Visual Studio

  2. Do textového pole, které se zobrazí, nahraďte text ToTable zákazníky.In the text box that appears, replace the text ToTable with Customers.

  3. V podokně T-SQL aktualizujte poslední řádek tak, aby odpovídal následující ukázce:In the T-SQL pane, update the last line to match the following sample:

    CONSTRAINT [FK_Orders_Customers] FOREIGN KEY ([CustomerID]) REFERENCES [Customers]([CustomerID])
    
  4. V levém horním rohu Návrháře tabulkyvyberte aktualizovat.In the upper-left corner of the Table Designer, select Update.

  5. V dialogovém okně Náhled aktualizací databáze vyberte aktualizovat databázi.In the Preview Database Updates dialog box, select Update Database.

    Je vytvořen cizí klíč.The foreign key is created.

Naplnění tabulek datyPopulate the tables with data

  1. V Průzkumník serveru nebo Průzkumník objektů systému SQL Serverrozbalte uzel pro ukázkovou databázi.In Server Explorer or SQL Server Object Explorer, expand the node for the sample database.

  2. Otevřete místní nabídku pro uzel tabulky , vyberte aktualizovata potom rozbalte uzel tabulky .Open the shortcut menu for the Tables node, select Refresh, and then expand the Tables node.

  3. Otevřete místní nabídku tabulky Customers a potom vyberte možnost Zobrazit data tabulky.Open the shortcut menu for the Customers table, and then select Show Table Data.

  4. Přidejte libovolná data, která chcete pro některé zákazníky.Add whatever data you want for some customers.

    Jako ID zákazníka můžete zadat libovolných pět znaků, ale vyberte alespoň jedno ID takové, které si zapamatujete, abyste je mohli použít později v tomto postupu.You can specify any five characters you want as the customer IDs, but choose at least one that you can remember for use later in this procedure.

  5. Otevřete místní nabídku tabulky Orders a pak vyberte možnost Zobrazit data tabulky.Open the shortcut menu for the Orders table, and then select Show Table Data.

  6. Přidejte data pro některé objednávky.Add data for some orders.

    Important

    Zajistěte, aby všechny ID objednávek a množství objednávek byly celá čísla a aby každé ID zákazníka odpovídalo hodnotě, kterou jste zadali ve sloupci KódZákazníka tabulky Customers.Make sure that all order IDs and order quantities are integers and that each customer ID matches a value that you specified in the CustomerID column of the Customers table.

  7. Na řádku nabídek vyberte soubor > Uložit vše.On the menu bar, select File > Save All.

Viz také:See also