Vítejte v prostředí IDE sady Visual StudioWelcome to the Visual Studio IDE

Visual Studio integrovaného vývojového prostředí je creative odrazový, můžete použít k úpravám, ladit a sestavovat kód a pak publikujete aplikaci.The Visual Studio integrated development environment is a creative launching pad that you can use to edit, debug, and build code, and then publish an app. Integrované vývojové prostředí (IDE) je plně funkční program, který lze použít pro mnoho aspektů vývoje softwaru.An integrated development environment (IDE) is a feature-rich program that can be used for many aspects of software development. Kromě standardní editor a ladicího programu, že většina integrovanými vývojovými prostředími poskytnout, Visual Studio obsahuje kompilátory, nástroje dokončování kódu, grafičtí návrháři pro a mnoho dalších funkcí, které usnadňují proces vývoje softwaru.Over and above the standard editor and debugger that most IDEs provide, Visual Studio includes compilers, code completion tools, graphical designers, and many more features to ease the software development process.

Visual Studio je k dispozici pro Windows a Mac.Visual Studio is available for Windows and Mac. Visual Studio pro Mac má mnoho stejných funkcí jako Visual Studio 2017 a je optimalizovaná pro vývoj multiplatformní a mobilní aplikace.Visual Studio for Mac has many of the same features as Visual Studio 2017, and is optimized for developing cross-platform and mobile apps. Tento článek se týká Windows verze sady Visual Studio 2017.This article focuses on the Windows version of Visual Studio 2017.

Existují 3 edicích sady Visual Studio 2017: Community, Professional a Enterprise.There are three editions of Visual Studio 2017: Community, Professional, and Enterprise. V tématu porovnání Visual Studio 2017 integrovanými vývojovými prostředími Další informace o funkcích, které jsou podporované v každé edici.See Compare Visual Studio 2017 IDEs to learn about which features are supported in each edition.

Tomto přehledovém článku vás seznámí s základní funkce integrovaného vývojového prostředí.This overview article introduces you to the basic features of the IDE. Provedeme některé kroky můžete provést pomocí sady Visual Studio, včetně vytváření Jednoduchý projekt pomocí IntelliSense jako podpory kódování a ladění aplikace zobrazíte hodnotu proměnné během provádění programu.We'll walk through some things you can do with Visual Studio, including creating a simple project, using IntelliSense as a coding aid, and debugging an app to see the value of a variable during the program's execution. Provedeme také si na různá okna nástrojů.We'll also take a tour of the various tool windows.

Instalace sady Visual Studio IDEInstall the Visual Studio IDE

Abyste mohli začít, Stáhnout Visual Studio 2017 a nainstalovat do vašeho systému.To get started, download Visual Studio 2017 and install it on your system.

Modulární instalačního programu umožňuje vybrat a nainstalovat úlohy, což jsou skupiny funkce potřebné pro programovací jazyk nebo platformu dáváte přednost.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Postupovat podle kroků pro vytvoření programu, je nutné vybrat vývoj pro různé platformy .NET Core úloh během instalace.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Úlohy pro vývoj pro různé platformy .NET core v instalační program sady Visual Studio

Při prvním spuštění aplikace Visual Studio, můžete volitelně přihlášení pomocí účtu Microsoft nebo pracovní nebo školní účet.When you start Visual Studio for the first time, you can optionally sign in using your Microsoft account, or your work or school account.

Prohlídka integrovaného vývojového prostředíTour of the IDE

Získáte základní vizuální přehled o Visual Studio, následující obrázek ukazuje Visual Studio s otevřít projekt a několika okny nástrojů klíče, které budete pravděpodobně používat:To give you a high-level visual overview of Visual Studio, the following image shows Visual Studio with an open project and several key tool windows you'll likely use:

Prostředí IDE sady Visual Studio

  • Průzkumník řešení (vpravo nahoře) umožňuje zobrazit, přejděte a spravovat soubory kódu.Solution Explorer (top right) lets you view, navigate, and manage your code files. Průzkumník řešení pomáhá organizovat kód seskupením soubory do řešení a projekty.Solution Explorer can help organize your code by grouping the files into solutions and projects.

  • Okno editoru (System center), kde budete pravděpodobně tráví většinu svého času zobrazí obsah souboru.The editor window (center), where you'll likely spend a majority of your time, displays file contents. Toto je, kde můžete upravit kódu nebo navrhnout uživatelské rozhraní, jako je například okno s tlačítka a textová pole.This is where you can edit code or design a user interface such as a window with buttons and text boxes.

  • Okno výstup (dole uprostřed) je, kde sada Visual Studio odešle oznámení, jako jsou ladění a chybové zprávy, upozornění kompilátoru, publikování stavové zprávy a další.The Output window (bottom center) is where Visual Studio sends notifications such as debugging and error messages, compiler warnings, publishing status messages, and more. Každý zdroj zprávy má svůj vlastní kartu.Each message source has its own tab.

  • Team Explorer (vpravo dole) umožňuje sledování pracovních položek a sdílet s ostatními kód pomocí technologie pro řízení verze, například Git a Team Foundation verze ovládacího prvku (TFVC).Team Explorer (bottom right) lets you track work items and share code with others using version control technologies such as Git and Team Foundation Version Control (TFVC).

Mezi oblíbené funkce v sadě Visual Studio, které vám umožní být produktivnější při vývoji softwaru, patří:Some of the popular features in Visual Studio that help you to be more productive as you develop software include:

  • RefactoringRefactoring

    Refaktoring zahrnuje operace, jako jsou inteligentní přejmenováním proměnné, extrahování jeden nebo více řádků kódu do nové metody, změna pořadí parametrů metod a dalších.Refactoring includes operations such as intelligent renaming of variables, extracting one or more lines of code into a new method, changing the order of method parameters, and more.

    Refaktoring v sadě Visual Studio

  • IntelliSenseIntelliSense

    Technologie IntelliSense je termín pro sadu funkcí, která zobrazí informace o kódu přímo v editoru a v některých případech může zapisovat malé části kódu za vás.IntelliSense is a term for a set of features that displays information about your code directly in the editor and, in some cases, write small bits of code for you. Je to jako mít základní dokumentaci vložené v editoru, což vám ušetří nebudou muset vyhledat informace o typu jinde.It's like having basic documentation inline in the editor, which saves you from having to look up type information elsewhere. Funkce technologie IntelliSense se liší podle jazyka.IntelliSense features vary by language. Další informace najdete v tématu jazyka C# IntelliSense, Visual C++ IntelliSense, technologie IntelliSense jazyka JavaScript, a jazyka Visual Basic IntelliSense.For more information, see C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense, and Visual Basic IntelliSense. Následující obrázek znázorňuje, jak technologie IntelliSense zobrazí seznam členů pro typ:The following illustration shows how IntelliSense displays a member list for a type:

    Seznam členů sady Visual Studio

  • Snadné spuštěníQuick Launch

    Visual Studio, může to působit příliš složitě čas od času s tolika nabídky, možnosti a vlastnosti.Visual Studio can seem overwhelming at times with so many menus, options, and properties. Snadné spuštění vyhledávacího pole je skvělý způsob, jak rychle najít, co potřebujete, v sadě Visual Studio.The Quick Launch search box is a great way to rapidly find what you need in Visual Studio. Když začnete psát název něco, co hledáte, Visual Studio obsahuje výsledky, které dostanete, přesně, kde potřebujete přejít.When you start typing the name of something you're looking for, Visual Studio lists results that take you exactly where you need to go. Pokud chcete přidat funkce do sady Visual Studio, například pro přidání podpory pro další programovací jazyk, Snadné spuštění poskytuje výsledky, které otevřete instalační program sady Visual Studio k instalaci úloh nebo jednotlivých komponent.If you need to add functionality to Visual Studio, for example to add support for an additional programming language, Quick Launch provides results that open Visual Studio Installer to install a workload or individual component.

    Rychlé spuštění vyhledávacího pole v sadě Visual Studio

  • Podtržení vlnovkou a rychlé akceSquiggles and Quick Actions

    Podtržení vlnovkou jsou podtržení vlnovkou, které vás upozorní na chyby nebo potenciální problémy v kódu při psaní.Squiggles are wavy underlines that alert you to errors or potential problems in your code as you type. Tyto vizuální záchytné body umožňují opravit problémy okamžitě bez čekání na chyby mají být zjišťované, a během sestavování nebo při spuštění programu.These visual clues enable you to fix problems immediately without waiting for the error to be discovered during build or when you run the program. Pokud najedete myší vlnovka, zobrazí se další informace o této chybě.If you hover over a squiggle, you see additional information about the error. Žárovky může také zobrazit na levém okraji s akcemi, známé jako rychlých akcí, chcete-li vyřešit chybu.A light bulb may also appear in the left margin with actions, known as Quick Actions, to fix the error.

    Podtržení vlnovkou v sadě Visual Studio

  • Hierarchie voláníCall Hierarchy

    Hierarchie volání okno zobrazuje metody, které volají vybrané metody.The Call Hierarchy window shows the methods that call a selected method. To může být užitečné informace, pokud uvažujete o změně nebo odebrání metodu, nebo když se snažíte vysledování chybu.This can be useful information when you're thinking about changing or removing the method, or when you're trying to track down a bug.

    Hierarchie volání – okno

  • CodeLensCodeLens

    CodeLens vám pomůže najít odkazy na kód, změny kódu, propojené chyby, pracovní položky, revize kódu a testy jednotek, to vše bez opuštění editoru.CodeLens helps you find references to your code, changes to your code, linked bugs, work items, code reviews, and unit tests, all without leaving the editor.

    Funkce CodeLens

  • Přejít k definiciGo To Definition

    Funkce Přejít k definici přejdete přímo do umístění, kde je funkce nebo typ definován.The Go To Definition feature takes you directly to the location where a function or type is defined.

    Přejít k definici

  • Náhled definicePeek Definition

    Definice operace Peek okno zobrazuje definici metody nebo typ bez nutnosti otevřít ve skutečnosti samostatný soubor.The Peek Definition window shows the definition of a method or type without actually opening a separate file.

    Náhled definice

Vytvoření programuCreate a program

Pojďme začít a vytvořit nový, jednoduchý program.Let's dive in and create a new, simple program.

  1. Otevřít Visual Studio.Open Visual Studio. V nabídce zvolte souboru > nový > projektu.On the menu, choose File > New > Project.

    Soubor > Nový projekt v řádku nabídek

  2. Nový projekt dialogové okno zobrazí několik projektů šablony.The New Project dialog box shows several project templates. Šablona obsahuje základní souborů a nastavení potřebných pro typ daného projektu.A template contains the basic files and settings needed for a given project type. Zvolte .NET Core kategorie v části Visual C# a klikněte na tlačítko Konzolová aplikace (.NET Core) šablony.Choose the .NET Core category under Visual C#, and then choose the Console App (.NET Core) template. V název textového pole, typ HelloWorlda pak vyberte OK tlačítko.In the Name text box, type HelloWorld, and then select the OK button.

    Šablona aplikace .NET core

    Visual Studio vytvoří projekt.Visual Studio creates the project. To je jednoduchá aplikace "Hello World", která volá Console.WriteLine() metodu pro zobrazení řetězcový literál "Hello World!"It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" v okně konzoly (výstup programu).in the console (program output) window.

    Note

    Pokud se nezobrazí .NET Core kategorie, je nutné nainstalovat vývoj pro různé platformy .NET Core pracovního vytížení.If you don't see the .NET Core category, you need to install the .NET Core cross-platform development workload. Chcete-li to provést, zvolte otevřít instalační program Visual Studio odkaz v levé dolní části nový projekt dialogového okna.To do this, choose the Open Visual Studio Installer link on the bottom left of the New Project dialog. Jakmile se instalační program sady Visual Studio otevře, posuňte se dolů a vyberte vývoj pro různé platformy .NET Core úlohy a pak vyberte změnit.After Visual Studio Installer opens, scroll down and select the .NET Core cross-platform development workload, and then select Modify.

    Po chvíli, by měl vypadat přibližně takto:Shortly, you should see something like the following:

    Visual Studio – sada IDE

    Kód jazyka C# pro vaši aplikaci se zobrazí v okně editoru, což zabírá většinu prostoru.The C# code for your application shows in the editor window, which takes up most of the space. Všimněte si, že text je automaticky barevně zvýrazněné k označení různých částí kódu, jako jsou klíčová slova a typy.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Kromě toho malé, svislé přerušované čáry v kódu označují, které složené závorky odpovídat mezi sebou a čísla řádků vám pomohou vyhledat kód později.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Můžete také malé, zabalený mínus bloky kódu rozbalíte nebo sbalíte.You can choose the small, boxed minus signs to collapse or expand blocks of code. Tento kód funkce osnovy vám umožňuje skrýt kód, který už nebudete potřebovat, a usnadnit tak minimalizovat zbytečné soubory na obrazovce.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Soubory projektu jsou uvedeny na pravé straně v okně Průzkumníka řešení.The project files are listed on the right side in a window called Solution Explorer.

    Visual Studio integrované vývojové prostředí s červená pole

    K dispozici další nabídky a panely nástrojů, ale teď přejdeme teď.There are other menus and tool windows available, but let's move on for now.

  3. Nyní spusťte aplikaci.Now, start the app. To lze provést výběrem spustit bez ladění z ladění nabídky na řádku nabídek.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Můžete také stisknout klávesu Ctrl+F5.You can also press Ctrl+F5.

    Ladit > Spustit bez ladění nabídky

    Visual Studio vytvoří aplikaci a otevře se okno konzoly se zprávou Hello World!.Visual Studio builds the app, and a console window opens with the message Hello World!. Nyní máte funkční aplikaci.You now have a running app!

    Okno konzoly

  4. Zavřete okno konzoly stisknutím libovolné klávesy na klávesnici.To close the console window, press any key on your keyboard.

  5. Přidejme do aplikace další kód.Let's add some additional code to the app. Přidejte následující kód jazyka C# před řádek, který říká Console.WriteLine("Hello World!");:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Tento kód zobrazí jak se jmenuješ? v okně konzoly a potom počká, dokud uživatel zadá nějaký text, za nímž následuje Enter klíč.This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  6. Změňte řádek, který říká Console.WriteLine("Hello World!"); v následujícím kódu:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  7. Znovu spusťte aplikaci tak, že vyberete ladění > spustit bez ladění nebo stisknutím klávesy Ctrl+F5.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Visual Studio znovu sestaví aplikaci a otevře se okno konzoly a vás vyzve k zadání název vaší.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  8. Zadejte název v okně konzoly a stisknutím klávesy Enter.Enter your name in the console window and press Enter.

    Vstup okno konzoly

  9. Stisknutím jakékoli klávesy zavřete okno konzoly a zastavit spuštěný program.Press any key to close the console window and stop the running program.

Refaktoring a technologie IntelliSenseUse refactoring and IntelliSense

Podívejme se na několik způsobů, jak, který refaktoring a IntelliSense může pomoct kód efektivněji.Let's look at a couple of the ways that refactoring and IntelliSense can help you code more efficiently.

Nejprve přejmenujme name proměnné:First, let's rename the name variable:

  1. Dvakrát klikněte name proměnnou, která ho vyberte.Double-click the name variable to select it.

  2. Zadejte nový název proměnné, uživatelské jméno.Type in the new name for the variable, username.

    Všimněte si, že šedé pole se zobrazí kolem proměnnou a žárovky se zobrazí na okraji.Notice that a gray box appears around the variable, and a light bulb appears in the margin.

  3. Vyberte ikonu žárovky k zobrazení dostupných rychlé akce.Select the light bulb icon to show the available Quick Actions. Vyberte přejmenovat "název" na "username".Select Rename 'name' to 'username'.

    Přejmenujte akci v sadě Visual Studio

    Proměnná je přejmenovat v projektu, který v našem případě je pouze dvě místa.The variable is renamed across the project, which in our case is only two places.

    Animovaný obrázek gif zobrazující refaktoring pro přejmenování v sadě Visual Studio

  4. Nyní Pojďme se podívat na IntelliSense.Now let's take a look at IntelliSense. Pod řádek, který říká Console.WriteLine($"\nHello {username}!");, typ data a času nyní = data a času..Below the line that says Console.WriteLine($"\nHello {username}!");, type DateTime now = DateTime..

    Pole zobrazuje jako objekty její členové DateTime třídy.A box displays the members of the DateTime class. Popis aktuálně vybraného člena se navíc zobrazí v rámci samostatného pole.In addition, the description of the currently selected member displays in a separate box.

    Seznam členů IntelliSense v sadě Visual Studio

  5. Vyberte člena s názvem nyní, což je vlastnost třídy, dvojitým kliknutím na ni nebo stisknutím klávesy kartu. Dokončení řádek kódu tak, že přidáte středníkem ;.Select the member named Now, which is a property of the class, by double-clicking on it or pressing Tab. Complete the line of code by adding a semi-colon ;.

  6. Pod ním zadejte nebo zkopírujte následující řádky kódu:Below that, type in or copy the following lines of code:

    int dayOfYear = now.DayOfYear;
    
    Console.Write("Day of year: ");
    Console.WriteLine(dayOfYear);
    

    Tip

    Console.Write se mírně liší na Console.WriteLine v tom, že po vytiskne nepřidá znakem ukončení řádku.Console.Write is a little different to Console.WriteLine in that it doesn't add a line terminator after it prints. To znamená, že další část textu, které je odesláno výstup vytiskne na stejném řádku.That means that the next piece of text that's sent to the output will print on the same line. Myší nad každá z těchto metod v kódu zobrazíte jejich popis.You can hover over each of these methods in your code to see their description.

  7. V dalším kroku použijeme refaktoring znovu provést trochu stručnější kód.Next, we'll use refactoring again to make the code a little more concise. Klikněte na proměnnou now v řádku DateTime now = DateTime.Now;.Click on the variable now in the line DateTime now = DateTime.Now;.

    Všimněte si, že malou ikonu šroubovák se zobrazí na okraji na daném řádku.Notice that a little screwdriver icon appears in the margin on that line.

  8. Klikněte na ikonu šroubovák návrhy, které nabízí Visual Studio.Click the screwdriver icon to see what suggestions Visual Studio has available. V takovém případě se zobrazuje dočasná proměnná na řádku odebrat jediného řádku kódu bez změny chování celkový refaktorování:In this case, it's showing the Inline temporary variable refactoring to remove a line of code without changing the overall behavior:

    Vložené dočasné proměnné refaktoring v sadě Visual Studio

  9. Klikněte na tlačítko dočasná proměnná na řádku Refaktorovat kód.Click Inline temporary variable to refactor the code.

  10. Spusťte program znovu stisknutím klávesy Ctrl+F5.Run the program again by pressing Ctrl+F5. Výstup bude vypadat přibližně takto:The output looks something like this:

Okno konzoly s výstup programu

Ladění kóduDebug code

Při psaní kódu, musíte ji spustit a otestovat pro chyby.When you write code, you need to run it and test it for bugs. Ladění systému Visual Studio vám umožní krokovat kód jeden příkaz najednou a kontrolovat proměnné, co využijete.Visual Studio's debugging system lets you step through code one statement at a time and inspect variables as you go. Můžete nastavit zarážky , který svém vyvolání zastaví provádění kódu na konkrétní řádek.You can set breakpoints that stop execution of the code at a particular line. Můžete sledovat, jak hodnota proměnné změny jako kód spustí a další.You can observe how the value of a variable changes as the code runs, and more.

Pojďme nastavit zarážku pro její hodnota username proměnné při "v cestě" program.Let's set a breakpoint to see the value of the username variable while the program is "in flight".

  1. Vyhledejte řádek kódu, který říká Console.WriteLine($"\nHello {username}!");.Find the line of code that says Console.WriteLine($"\nHello {username}!");. Nastavit zarážku na tomto řádku kódu, to znamená, aby program pozastaví provádění na tomto řádku, klikněte v levém okraji editoru.To set a breakpoint on this line of code, that is, to make the program pause execution at this line, click in the far left margin of the editor. Můžete také kliknout na libovolné místo na řádek kódu a stiskněte klávesu F9.You can also click anywhere on the line of code and then press F9.

    V levém okraji se zobrazí červený kruh a kód se zvýrazní červeně.A red circle appears in the far left margin, and the code is highlighted in red.

    Zarážku na řádek kódu v sadě Visual Studio

  2. Spuštění ladění tak, že vyberete ladění > spustit ladění nebo stisknutím klávesy F5.Start debugging by selecting Debug > Start Debugging or by pressing F5.

  3. Když v okně konzoly se zobrazí a vyzve k zadání vaše jméno, zadejte jej a stiskněte klávesu Enter.When the console window appears and asks for your name, type it in and press Enter.

    Všimněte si, že se fokus vrátí do editoru kódu sady Visual Studio a na řádek kódu se zarážkou je zvýrazněn žlutě.Notice that the focus returns to the Visual Studio code editor and the line of code with the breakpoint is highlighted in yellow. To znamená, že se jedná o další řádek kódu, který se spustí program.This signifies that it's the next line of code that the program will execute.

  4. Najeďte myší username proměnnou můžete zobrazit její hodnotu.Hover your mouse over the username variable to see its value. Alternativně je můžete kliknout pravým tlačítkem na username a vyberte Přidat kukátko chcete přidat proměnnou Watch okno, kde můžete také zobrazit její hodnotu.Alternatively, you can right-click on username and select Add Watch to add the variable to the Watch window, where you can also see its value.

    Hodnota proměnné během ladění v sadě Visual Studio

  5. Aby mohl program dokončen, stiskněte klávesu F5 znovu.To let the program run to completion, press F5 again.

Pokud chcete získat další informace o ladění v sadě Visual Studio, naleznete v tématu prohlídka funkcí ladicího programu.To get more details about debugging in Visual Studio, see Debugger feature tour.

Přizpůsobení sady Visual StudioCustomize Visual Studio

Uživatelské rozhraní sady Visual Studio, včetně změn si můžete přizpůsobit výchozí barevný motiv.You can personalize the Visual Studio user interface, including change the default color theme. Chcete-li změnit na tmavě motivu:To change to the Dark theme:

  1. V panelu nabídky zvolte nástroje > možnosti otevřít možnosti dialogového okna.On the menu bar, choose Tools > Options to open the Options dialog.

  2. Na prostředí > Obecné stránka Možnosti, změna barevný motiv výběru tmavěa klikněte na tlačítko OK.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    Barva motivu pro celý integrovaného vývojového prostředí se změní na tmavě.The color theme for the entire IDE changes to Dark.

    Visual Studio v tmavém motivu

Další informace o dalších způsobech mohli přizpůsobit integrovaného vývojového prostředí, najdete v článku přizpůsobení sady Visual Studio.To learn about other ways you can personalize the IDE, see Personalize Visual Studio.

Další krokyNext steps

Prozkoumejte další Visual Studio na základě společně s některou z těchto úvodní články:Explore Visual Studio further by following along with one of these introductory articles:

Pokud jste připraveni začít do další kód, jeden z následujících šablon rychlý start specifické pro jazyk je dobré další krok:If you're ready to dive into more coding, one of the following language-specific quickstarts is a good next step:

Viz také:See also