Visual Studio pro Mac pro Windows uživatele

Migrace z jednoho operačního systému do jiného může být záhrouce. V aplikacích pro více platforem jsou často drobné rozdíly, od uživatelského rozhraní až po kategorizaci položek nabídky. Tady se dozvíte o nejběžnějších rozdílech mezi Visual Studio pro Mac a Visual Studio pro Windows. Naučíte se také několik různých konvencí mezi macOS a Windows.

Klávesové zkratky

Jako vývojáři budete mnozí z vás zvyklí používat klávesnici pro své úkoly a navigaci. Některé klávesy na klávesnici jsou společné mezi počítači Mac Windows počítači. Možná si myslíte, že akce klávesnice, jako je kopírování a vložení, používají stejné kombinace kláves. To není vždy případ. Naštěstí můžete změnit své klíčové vazby v Visual Studio pro Mac tak, aby přesně odpovídaly těm z Visual Studio v Windows.

Při prvním spuštění Visual Studio pro Mac se zobrazí okno pro výběr klávesových  zkratek: Okno Klávesové zkratky

Pokud budete chtít změnit klíčové vazby později, najdete nastavení v předvolbách:  Předvolby klávesových vazeb

Je důležité si uvědomit, že macOS používá k práci různé klávesové zkratky pro Windows. Změna předvoleb vazby klíčů vám umožní používat známé Windows klávesové zkratky v Visual Studio pro Mac. V jiných oblastech macOS ale budete muset být obeznámeni se zkratkami macOS.

Modifikační klíč příkazu pro macOS (⌘) může často nahradit řídicí klíč v Windows. Tady je několik příkladů a dalších běžně používaných zkratek:

Úkol Windows Zástupce Zástupce pro macOS
Kopírovat Ctrl + C ⌘ + C
Vložit Ctrl + V ⌘ + V
Vyjmout Ctrl + X ⌘ + X
Zpět Ctrl + Z ⌘ + Z
Opakovat Ctrl + Shift + Z ⌘ + Shift + Z
Odstranění zprava kurzoru Delete fn + Backspace
Odstranění slova Ctrl + Delete fn + ⌥ + Backspace

Tip

Úplný seznam zástupců pro macOS najdete na webu podpory Apple.

Nabídky v macOS jsou uspořádané jinak než nabídky v Windows. Visual Studio pro Mac není výjimkou. Některé z nejběžnějších možností nabídky najdete tady:

Úkol Visual Studio (Windows) Visual Studio pro Mac
Předvolby (možnosti) Nástroje > možnosti... Visual Studio > předvolby...
Rozšíření Rozšíření > správu rozšíření Visual Studio > rozšíření...
Rozložení Okno > použít rozložení > [Vybrat rozložení] Zobrazení > rozložení > [Vybrat rozložení]
Aktualizace Pomoc > kontrole aktualizací Visual Studio > Vyhledat aktualizace...
Správce balíčků NuGet Nástroje > NuGet Správce balíčků > spravovat NuGet balíčky nebo řešení... Project > Spravovat NuGet balíčky...
Vyhledání nástrojů Upravit > najít a nahradit > [nástroj Select] Search > [Select tool]
O sadě Visual Studio Help > About Microsoft Visual Studio Visual Studio > informace o Visual Studio

Poznámka

Přehled nejběžnějších funkcí najdete v tématu Visual Studio pro Mac integrovaného vývojového prostředí (IDE).