Práce s jazykem R v aplikaci Visual StudioWork with R in Visual Studio

R je vysoce rozšiřitelný jazyk a prostředí pro statistické výpočty a grafiku.R is a highly extensible language and environment for statistical computing and graphics. Je distribuována zdarma v rámci obecné veřejné licence GNU, nabízí silnou podporu komunity a je známo, že má schopnost vytvářet publikace kvality publikace, včetně matematických symbolů a vzorců.It's distributed for free under the GNU General Public License, enjoys strong community support, and is known for its ability to produce publication-quality plots including mathematical symbols and formulae. Další informace o jazyce R najdete na adrese r-Project.org a Úvod do jazyka r.You can learn more about R at r-project.org and An Introduction to R.

Nástroje R pro Visual Studio (RTVS) je bezplatné Open Source rozšíření pro visual Studio 2017 a visual Studio 2015 Update 3 (nebo vyšší) vydané v rámci licence MIT.R Tools for Visual Studio (RTVS) is a free, open-source extension for Visual Studio 2017 and Visual Studio 2015 Update 3 (or higher), released under the MIT license. (Druhá Open-Source komponenta s názvem RHost, která odkazuje na binární soubory překladače R, je vydaná ve veřejné licenci GNU v2.)(A second open-source component called RHost, which links to the R interpreter binaries, is released under the GNU Public License V2.)

Note

RTVS je v současné době podporován pouze v aplikaci Visual Studio 2017 ve Windows a Visual Studio pro Mac.RTVS is presently supported only in Visual Studio 2017 on Windows and not Visual Studio for Mac. Není k dispozici pro Visual Studio 2019.It is not available for Visual Studio 2019.

Pro prostředí jazyka R v aplikaci Visual Studio:To experience R in Visual Studio:

Potom postupujte podle odkazů níže a získejte další informace o funkcích souvisejících s R a také o obecných funkcích aplikace Visual Studio.Then follow the links below to learn more about R-related features as well as the general capabilities of Visual Studio itself.

FunkceFeature PopisDescription Obecná dokumentace k sadě Visual StudioGeneral Visual Studio Documentation
Systém projektu sady Visual StudioVisual Studio project system Uspořádejte a spravujte související soubory ve vhodné struktuře a využijte výhod užitečných šablon pro položky, jako je kód R, dokumentace R, R Markdown, dotazy SQL a uložené procedury.Organize and manage related files in a convenient structure, and take advantage of useful templates for items such as R code, R documentation, R Markdown, SQL queries, and stored procedures. Také užívejte Správce balíčků a SQL Server integraci.Also enjoy the package manager and SQL Server integration. Řešení a projekty v sadě Visual StudioSolutions and Projects in Visual Studio
StejnýchWorkspace RTVS se může navazovat na místní a vzdálené pracovní prostory, což vám umožní vyvíjet kód R místně s menšími datovými sadami a potom snadno spustit kód v výkonnějších cloudových počítačích s mnohem většími datovými sadami.RTVS can bind to local and remote workspaces, allowing you to develop R code locally with smaller data sets, then easily run the code on more powerful cloud-based computers with much larger data sets. není k dispozicin/a
Možnosti nástrojů RR Tools options Řízení různých aspektů RTVS.Control various aspects of RTVS. Dialogové okno MožnostiOptions dialog box
Bohatě upravené úpravy, technologie IntelliSense a fragmenty kóduRich editing, IntelliSense, and code snippets Zahrnuje barevné zvýrazňování syntaxe, IntelliSense napříč celým kódem a knihovnami, formátování kódu, help signatura, přejít na definici, najít všechny odkazy, fragmenty kódua další.Includes syntax coloring, IntelliSense across all your code and libraries, code formatting, signature help, Go to Definition, Find All References, code snippets, and more. Funkce editoru kóduFeatures of the code editor
R MarkdownR Markdown R Markdown dokumenty vám pomůžou sdílet výsledky dat s integrovaným kódem R uvnitř bloků kódu Markdownu.R Markdown documents help you share your data results, with integrated R code inside markdown code blocks. není k dispozicin/a
Interaktivní oknoInteractive Window Poskytuje plnohodnotné prostředí REPL pro R s možností snadného spuštění kódu ve zdrojovém souboru v interaktivním okně.Provides a full REPL experience for R with the ability to easily run code in a source file in the interactive window. není k dispozicin/a
Vizualizace datVisualizing data Vykreslení je nedílnou součástí prostředí jazyka R a RTVS podporuje několik nezávislých oken vykreslení, z nichž každá má svou vlastní historii a možnost přesouvat zobrazení mezi okny.Plotting is an integral part of the R experience, and RTVS supports multiple, independent plot windows, each with their own history and the ability to move plots between windows. Vykreslení lze uložit do rastrových souborů a souborů PDF nebo zkopírovat do schránky jako rastrový obrázek nebo metasoubor.Plots can be saved to bitmap and PDF files, or copied to the clipboard as a bitmap or metafile. není k dispozicin/a
Průzkumník proměnnýchVariable Explorer Prohlédněte si proměnné v globálním nebo specifickém oboru pro konkrétní balíčky a možnost zobrazit tabulky s možností řazení a exportovat do sdíleného svazku clusteru.Examine variables in the global or package-specific scopes, with the ability to view sortable tables and export to CSV. není k dispozicin/a
Plně funkční laděníFull-featured debugging Zahrnuje integraci s interaktivním oknem.Includes integration with the interactive window. Ladění v sadě Visual StudioDebugging in Visual Studio

Seznamte se také s nejčastějšími dotazy.Also see Frequently asked questions.

ikona filmové kamery pro videomovie camera icon for video Podívejte se na video (YouTube.com) , kde můžete zobrazit přehled nástroje R pro Visual Studio (12m 36s).Watch a video (youtube.com) for an overview of R Tools for Visual Studio (12m 36s). Podívejte se také na Další videa k nástrojům R.Also see more R Tools videos.

Pošlete nám svůj názor.Send us your feedback!

  1. Problémy GitHubu: nejlepší způsob, jak se spojit s týmem RTVS, je nahlásit problém na GitHubunebo pomocí nabídky nástroje R > Zpětná vazba .GitHub issues: The best way to reach the RTVS team is by filing an issue on GitHub, or by using the R Tools > Feedback menu.

  2. Odeslat smajlíka/zamračení: nabídka R nástroje > Zpětná vazba představuje rychlý způsob, jak odeslat zpětnou vazbu a připojit soubory protokolu RTVS, které vám pomůžou diagnostikovat váš problém.Send a Smile / Frown: The R Tools > Feedback menu is a quick way to send feedback and attach RTVS log files to assist in the diagnosis of your issue. (Protokoly se zapisují do % TEMP%/RTVSlogs.zip pro případ, že je budete chtít poslat samostatně.) Protokolování je zakázané, pokud jste se k telemetrie sady Visual Studio rozhodli prostřednictvím příkazu nabídky Nastavení > > Feedback nebo během instalace.(Logs are written into %temp%/RTVSlogs.zip in case you want to send them separately.) Logging is disabled if you've opted out of Visual Studio telemetry through the Help > Feedback > Settings menu command, or during installation.

  3. E-mail: můžete poslat přímý názor týmu na adrese rtvsuserfeedback (at) Microsoft.com.Email: You can send direct feedback to the team at rtvsuserfeedback (at) microsoft.com.