Arbeiten mit R in Visual Studio

R ist eine hochgradig erweiterbare Sprache und Umgebung für die statistische Berechnungen und Grafiken. Die Sprache wird kostenlos unter der GNU General Public License (GNU GPL) bereitgestellt, wird von einer starken Community unterstützt und ist für ihre Fähigkeit bekannt, hochwertige Plots einschließlich mathematischer Symbole und Formeln zu erzeugen. Weitere Informationen zu R erhalten Sie unter r-project.org und An Introduction to R (Einführung in R).

R Tools für Visual Studio (RTVS) ist eine kostenlose Open Source-Erweiterung für Visual Studio 2017 und Visual Studio 2015 Update 3 (oder höher) und wurde unter der MIT-Lizenz veröffentlicht. (Eine zweite Open Source-Komponente namens RHost, die eine Verknüpfung mit den Binärdateien des R-Interpreters bietet, wurde unter der GNU Public License V2 veröffentlicht.)

Hinweis

RTVS wird derzeit nur in Visual Studio 2017 unter Windows und nicht in Visual Studio für Mac unterstützt. Die Erweiterung steht für Visual Studio 2019 nicht zur Verfügung.

Gehen Sie folgendermaßen vor, um mit R in Visual Studio zu arbeiten:

Folgen Sie anschließend den unten stehenden Links, um mehr über R-Funktionen sowie über die allgemeinen Features von Visual Studio selbst zu erfahren.

Funktion Beschreibung Allgemeine Visual Studio-Dokumentation
Visual Studio-Projektsystem Organisieren und verwalten Sie verknüpfte Dateien in einer praktischen Struktur, und profitieren Sie von nützlichen Vorlagen für Elemente wie R-Code, R-Dokumentation, R Markdown, SQL-Abfragen und gespeicherte Prozeduren. Nutzen Sie zudem den Paket-Manager und die SQL Server-Integration. Projektmappen und Projekte in Visual Studio
Arbeitsbereich RTVS kann in lokale und Remotearbeitsbereiche eingebunden werden – so können Sie R-Code lokal mit kleineren Datasets entwickeln, den Code dann auf leistungsfähigeren cloudbasierten Computern mit wesentlich größeren Datasets ausführen.
Optionen für R Tools Steuern Sie verschiedene Aspekte von RTVS. Optionen (Dialogfeld)
Vielfältige Bearbeitungsfunktionen, IntelliSense und Codeausschnitte Umfasst Syntaxfarben, IntelliSense über den gesamten Code und allen Bibliotheken hinweg, Codeformatierung, Signaturhilfe, „Gehe zu Definition“, „Alle Verweise suchen“, Codeausschnitte und vieles mehr. Features des Code-Editors
R Markdown Mit R Markdown-Dokumenten können Sie Ihre Datenergebnisse mit integriertem R-Code in Markdowncodeblöcken freigeben.
Interaktives Fenster Dieses Fenster bietet eine vollständige REPL-Oberfläche für R, mit der Sie Code in einer Quelldatei im interaktiven Fenster ausführen können.
Visualisieren von Daten Plotting ist ein wesentlicher Bestandteil von R, und RTVS unterstützt mehrere, voneinander unabhängige Plotfenster. Jedes Fenster bietet einen eigenen Verlauf, und Sie können Plots zwischen Fenstern verschieben. Plots können in Bitmap- und PDF-Dateien gespeichert oder als Bitmap- oder Metadatei in die Zwischenablage kopiert werden.
Variablen-Explorer Untersuchen Sie Variablen auf globaler oder paketspezifischer Ebene, zeigen Sie sortierbare Tabellen an, und exportieren Sie diese in das CSV-Format.
Vollständige Debugfeatures Umfasst die Integration in das interaktive Fenster. Debuggen in Visual Studio

Weitere Informationen finden Sie auch unter Häufig gestellte Fragen.

Videos zur Verwendung von R Tools in Visual Studio finden Sie unter Videos zu R Tools.

Senden Sie uns Feedback

  1. GitHub-Probleme: Sie erreichen das RTVS-Team am besten, indem Sie ein Problem auf GitHub melden oder das Menü R Tools > Feedback verwenden.

  2. Ein Lächeln oder ein Stirnrunzeln senden: Das Menü R Tools > Feedback bietet eine schnelle Möglichkeit, Feedback zu senden und RTVS-Protokolldateien anzufügen, die bei der Diagnose Ihres Problems helfen können. (Protokolle werden in %temp%/RTVSlogs.zip geschrieben, falls Sie sie separat senden möchten.) Die Protokollierung ist deaktiviert, falls Sie die Visual Studio-Telemetrie über den Menübefehl Hilfe > Feedback > Einstellungen oder während der Installation deaktiviert haben.

  3. E-Mail: Sie können unter rtvsuserfeedback (at) microsoft.com direktes Feedback an das Team senden.