Erste Schritte mit .NET Core unter macOS mit Visual Studio für MacGetting started with .NET Core on macOS using Visual Studio for Mac

Visual Studio für Mac bietet eine umfassende integrierte Entwicklungsumgebung (IDE) für die Entwicklung von .NET Core-Anwendungen.Visual Studio for Mac provides a full-featured Integrated Development Environment (IDE) for developing .NET Core applications. Dieses Thema führt Sie durch die Erstellung einer einfachen Konsolenanwendung mit Visual Studio für Mac und .NET Core.This topic walks you through building a simple console application using Visual Studio for Mac and .NET Core.

Hinweis

Ihr Feedback ist uns sehr wichtig.Your feedback is highly valued. Es gibt zwei Möglichkeiten, wie Sie Feedback für das Entwicklungsteam von Visual Studio für Mac bereitstellen können:There are a two ways you can provide feedback to the development team on Visual Studio for Mac:

  • Klicken Sie in Visual Studio für Mac auf Hilfe > Ein Problem melden im Menü oder auf Ein Problem melden auf der Willkommensseite. Dadurch wird ein Fenster für das Ablegen eines Fehlerberichts geöffnet.In Visual Studio for Mac, select Help > Report a Problem from the menu or Report a Problem from the Welcome screen, which will open a window for filing a bug report. Sie können Ihr Feedback im Portal der Entwicklercommunity verfolgen.You can track your feedback in the Developer Community portal.
  • Um einen Vorschlag zu machen, klicken Sie auf Hilfe > Vorschlag senden im Menü oder auf Vorschlag senden auf der Willkommensseite. Dadurch gelangen Sie zur Visual Studio for Mac UserVoice webpage (UserVoice-Webseite von Visual Studio für Mac).To make a suggestion, select Help > Provide a Suggestion from the menu or Provide a Suggestion from the Welcome screen, which will take you to the Visual Studio for Mac UserVoice webpage.

Erforderliche KomponentenPrerequisites

Weitere Informationen finden Sie unter dem Thema Voraussetzungen für .NET Core unter Mac.See the Prerequisites for .NET Core on Mac topic.

Erste SchritteGetting started

Wenn Sie bereits die erforderlichen Komponenten und Visual Studio für Mac installiert haben, überspringen Sie diesen Abschnitt, und fahren Sie mit Erstellen eines Projekts fort.If you've already installed the prerequisites and Visual Studio for Mac, skip this section and proceed to Creating a project. Um die erforderlichen Komponenten und Visual Studio für Mac zu installieren, gehen Sie wie folgt vor:Follow these steps to install the prerequisites and Visual Studio for Mac:

Laden Sie den Visual Studio für Mac-Installer herunter.Download the Visual Studio for Mac installer. Führen Sie den Installer aus.Run the installer. Lesen und akzeptieren Sie die Lizenzbedingungen.Read and accept the license agreement. Während der Installation haben Sie die Möglichkeit zum Installieren von Xamarin, einer plattformübergreifenden mobilen App-Entwicklungstechnologie.During the install, you're provided the opportunity to install Xamarin, a cross-platform mobile app development technology. Das Installieren von Xamarin und den zugehörigen Komponenten ist für die Entwicklung mit .NET Core optional.Installing Xamarin and its related components is optional for .NET Core development. Eine exemplarische Vorgehensweise für den Visual Studio für Mac-Installationsvorgang finden Sie unter Introducing Visual Studio for Mac (Einführung in Visual Studio für Mac).For a walk-through of the Visual Studio for Mac install process, see Introducing Visual Studio for Mac. Wenn die Installation abgeschlossen ist, starten Sie Visual Studio für Mac-IDE.When the install is complete, start the Visual Studio for Mac IDE.

Erstellen eines ProjektsCreating a project

  1. Wählen Sie Neues Projekt auf der Willkommensseite aus.Select New Project on the Welcome screen.

    Schaltfläche für „Neues Projekt“ auf der Willkommensseite von Visual Studio für Mac

  2. Wählen Sie im Dialogfeld Neues Projekt unter dem Knoten .NET Core App aus.In the New Project dialog, select App under the .NET Core node. Wählen Sie die Konsolenanwendung-Vorlage und anschließend Weiter aus.Select the Console Application template followed by Next.

    Liste neuer Projektvorlagen

  3. Geben Sie „HelloWorld“ als Projektname ein.Type "HelloWorld" for the Project Name. Wählen Sie Erstellen aus.Select Create.

    Dialogfeld „Konfigurieren Sie Ihre neue Konsolenanwendung“

  4. Warten Sie, während die Abhängigkeiten des Projekts wiederhergestellt werden.Wait while the project's dependencies are restored. Das Projekt enthält eine einzelne C#-Datei, Program.cs, mit einer Program-Klasse mit einer Main-Methode.The project has a single C# file, Program.cs, containing a Program class with a Main method. Die Console.WriteLine-Anweisung wird „Hello World!“The Console.WriteLine statement will output "Hello World!" in der Konsole ausgeben, wenn die App ausgeführt wird.to the console when the app is run.

    Hauptfenster mit der geöffneten Datei „Program.cs“

Ausführen der AnwendungRun the application

Führen Sie diese Anwendung durch Drücken von F5 im Debugmodus oder durch Drücken von STRG+F5 im Releasemodus aus.Run the app in Debug mode using F5 or in Release mode using CTRL+F5.

Der Ausgabebereich der Anwendung zeigt „Hello World!“ an

Nächster SchrittNext step

Das Thema Building a complete .NET Core solution on macOS using Visual Studio for Mac (Erstellen einer vollständigen .NET Core-Projektmappe unter macOS mit Visual Studio für Mac) veranschaulicht Ihnen, wie Sie eine vollständige .NET Core-Projektmappe erstellen, die eine wiederverwendbare Bibliothek und Komponententests enthält.The Building a complete .NET Core solution on macOS using Visual Studio for Mac topic shows you how to build a complete .NET Core solution that includes a reusable library and unit testing.