Erste Schritte mit C# und Visual Studio CodeGet Started with C# and Visual Studio Code

.NET Core ist eine schnelle und modulare Plattform zum Erstellen von Anwendungen, die unter Windows, Linux und macOS ausgeführt werden..NET Core gives you a fast and modular platform for creating applications that run on Windows, Linux, and macOS. Verwenden Sie Visual Studio Code mit der C#-Erweiterung, um von leistungsfähigen Bearbeitungsfunktionen mit vollständiger Unterstützung für C# IntelliSense (intelligente Codevervollständigung) und Debugging zu erzielen.Use Visual Studio Code with the C# extension to get a powerful editing experience with full support for C# IntelliSense (smart code completion) and debugging.

Erforderliche KomponentenPrerequisites

  1. Installieren Sie Visual Studio Code.Install Visual Studio Code.
  2. Installieren Sie das .NET Core SDK.Install the .NET Core SDK.
  3. Installieren Sie die C#-Erweiterung für Visual Studio Code.Install the C# extension for Visual Studio Code. Weitere Informationen zum Installieren von Erweiterungen für Visual Studio Code finden Sie unter VS Code Extension Marketplace (Marketplace für VS Code-Erweiterungen).For more information about how to install extensions on Visual Studio Code, see VS Code Extension Marketplace.

Hello WorldHello World

Beginnen wir mit einem einfachen „Hello World“-Programm in .NET Core:Let's get started with a simple "Hello World" program on .NET Core:

  1. Öffnen Sie ein Projekt:Open a project:

    • Öffnen Sie Visual Studio Code.Open Visual Studio Code.
    • Klicken Sie im linken Menü auf das Explorer-Symbol, und klicken Sie dann auf Ordner öffnen.Click on the Explorer icon on the left menu and then click Open Folder.
    • Klicken Sie im Hauptmenü auf Datei > Open Folder (Ordner öffnen), um den Ordner zu öffnen, in dem Sie Ihr C#-Projekt speichern möchten, und klicken Sie auf Ordner auswählen.Select File > Open Folder from the main menu to open the folder you want your C# project to be in and click Select Folder. Für dieses Beispiel wird ein Ordner namens HelloWorld für das Projekt erstellt.For our example, we're creating a folder for our project named HelloWorld.

      VSCodeOpenFolder

  2. Initialisieren Sie ein C#-Projekt:Initialize a C# project:

    • Öffnen Sie das integrierte Terminal von Visual Studio Code, indem Sie im Hauptmenü auf Ansicht > Integriertes Terminal klicken.Open the Integrated Terminal from Visual Studio Code by selecting View > Integrated Terminal from the main menu.
    • Geben Sie im Terminalfenster dotnet new console ein.In the terminal window, type dotnet new console.
    • Durch diesen Befehl wird eine Program.cs-Datei in Ihrem Ordner erstellt, die ein bereits geschriebenes einfaches „Hallo Welt“-Programm enthält. Zusätzlich wird eine C#-Projektdatei namens HelloWorld.csproj erstellt.This command creates a Program.cs file in your folder with a simple "Hello World" program already written, along with a C# project file named HelloWorld.csproj.

      Der Befehl „dotnet new“

  3. Lösen Sie die Buildobjekte auf:Resolve the build assets:

    • Geben Sie für .NET Core 1.x den Befehl dotnet restore ein.For .NET Core 1.x, type dotnet restore. Durch Ausführen von dotnet restore erhalten Sie Zugriff auf die erforderlichen .NET Core-Pakete, die Sie zum Erstellen Ihres Projekts benötigen.Running dotnet restore gives you access to the required .NET Core packages that are needed to build your project.

      Der Befehl „dotnet restore“

      Hinweis

      Starting with .NET Core 2.0, you don't have to run dotnet restore because it's run implicitly by all commands that require a restore to occur, such as dotnet new, dotnet build and dotnet run. It's still a valid command in certain scenarios where doing an explicit restore makes sense, such as continuous integration builds in Visual Studio Team Services or in build systems that need to explicitly control the time at which the restore occurs.

  4. Führen Sie das „Hello World“-Programm aus:Run the "Hello World" program:

    • Geben Sie dotnet run ein.Type dotnet run.

      Der Befehl „dotnet run“

Um weitere Unterstützung beim Setup zu erhalten, können Sie sich auch ein kurzes Videotutorial zu Windows, macOS oder Linux ansehen.You can also watch a short video tutorial for further setup help on Windows, macOS, or Linux.

DebugDebug

  1. Öffnen Sie Program.cs, indem Sie darauf klicken.Open Program.cs by clicking on it. Wenn Sie eine C#-Datei zum ersten Mal in Visual Studio Code öffnen, wird OmniSharp im Editor geladen.The first time you open a C# file in Visual Studio Code, OmniSharp loads in the editor.

    Öffnen der Datei „Program.cs“

  2. Visual Studio Code fordert Sie dazu auf, die fehlenden Objekte zum Erstellen und Debuggen Ihrer App hinzuzufügen.Visual Studio Code should prompt you to add the missing assets to build and debug your app. Wählen Sie Ja.Select Yes.

    Aufforderung bei fehlenden Objekten

  3. Um die Debugansicht zu öffnen, klicken Sie im Menü auf der linken Seite auf das Debugsymbol.To open the Debug view, click on the Debugging icon on the left side menu.

    Öffnen der Registerkarte „Debuggen“

  4. Suchen Sie den grünen Pfeil am oberen Rand des Fensters.Locate the green arrow at the top of the pane. Stellen Sie sicher, dass in der Dropdownliste die Option .NET Core Launch (console) ausgewählt ist.Make sure the drop-down next to it has .NET Core Launch (console) selected.

    Auswählen von .NET Core

  5. Fügen Sie einen Breakpoint zu Ihrem Projekt hinzu, indem Sie neben Zeile 9 auf den Rand des Editors (der Bereich links neben den Zeilennummern im Editor) klicken.Add a breakpoint to your project by clicking on the editor margin, which is the space on the left of the line numbers in the editor, next to line 9.

    Festlegen eines Haltepunkts

  6. Drücken Sie F5, oder klicken Sie auf den grünen Pfeil, um das Debuggen zu starten.To start debugging, select F5 or the green arrow. Der Debugger hält die Ausführung des Programms an, wenn der Haltepunkt erreicht wird, den Sie im vorherigen Schritt festgelegt haben.The debugger stops execution of your program when it reaches the breakpoint you set in the previous step.

    • Während des Debuggens können Sie Ihre lokalen Variablen im oberen linken Bereich oder in der Debugkonsole anzeigen.While debugging, you can view your local variables in the top left pane or use the debug console.

    Ausführen und Debuggen

  7. Wählen Sie im oberen Bereich den grünen Pfeil aus, um das Debuggen fortzusetzen, oder klicken Sie auf das rote Quadrat, um das Debuggen zu beenden.Select the green arrow at the top to continue debugging, or select the red square at the top to stop.

Tipp

Weitere Informationen und Tipps zur Problembehandlung beim .NET Core-Debuggen mit OmniSharp in Visual Studio Code finden Sie unter Instructions for setting up the .NET Core debugger (Anleitung zum Einrichten des .NET Core-Debuggers).For more information and troubleshooting tips on .NET Core debugging with OmniSharp in Visual Studio Code, see Instructions for setting up the .NET Core debugger.

Siehe auchSee also

Einrichten von Visual Studio Code Setting up Visual Studio Code
Debuggen in Visual Studio CodeDebugging in Visual Studio Code