Proxyadressenkonflikt beim Hinzufügen einer E-Mail-Adresse in Exchange Online

Symptome

Wenn Sie versuchen, einem neuen oder vorhandenen E-Mail-Empfänger in Exchange Online eine Proxyadresse zuzuweisen, erhalten Sie eine Fehlermeldung, die einem der folgenden Beispiele ähnelt.

Fehler 1

Die Proxyadresse "SMTP:SMTP:<SMTP-Adresse> mit Konflikt" wird bereits von "<domain.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>" verwendet. Wählen Sie eine andere Proxyadresse aus.

Fehler 2

Es wurde ein Microsoft Entra ID Aufruf ausgeführt, um das Objekt zwischen Microsoft Entra ID und Exchange Online synchron zu halten. Es ist jedoch nicht erfolgreich. Ausführliche Fehlermeldung: Ein weiteres Objekt mit demselben Wert für die Eigenschaft proxyAddresses ist bereits vorhanden. ConflictingObject: PublicFolder_<GUID>.

Beispiele für einen E-Mail-Empfänger sind ein E-Mail-Benutzer, ein Benutzerpostfach, ein freigegebenes Postfach, eine Verteilergruppe, eine Microsoft 365-Gruppe und ein E-Mail-aktivierter öffentlicher Ordner (MEPF).

Ursache

Ursache 1

Die erste Fehlermeldung tritt auf, wenn ein E-Mail-aktiviertes Objekt in Exchange Online die Proxyadresse verwendet, die Sie zuweisen möchten.

Ursache 2

Die zweite Fehlermeldung tritt auf, wenn ein MEPF-Objekt, das nur in Microsoft Entra ID vorhanden ist, die Proxyadresse verwendet, die Sie zuweisen möchten.

Lösung

Die Lösung für den ersten Fehler besteht darin, alle in Konflikt stehenden Proxyadressen in Exchange Online zu überprüfen und zu entfernen.

Die Lösung für den zweiten Fehler besteht darin, alle in Konflikt stehenden Proxyadressen in Exchange Online zu überprüfen und zu entfernen und nach in Konflikt stehenden Proxyadressen in Microsoft Entra ID zu suchen und zu entfernen.

Verwenden Sie abhängig von der erhaltenen Fehlermeldung die entsprechende Auflösung. Versuchen Sie dann erneut, die Proxyadresse zuzuweisen.

Überprüfen und entfernen Sie alle in Konflikt stehenden Proxyadressen in Exchange Online

Führen Sie die folgenden Schritte aus, um in Exchange Online nach vorhandenen E-Mail-aktivierten Objekten zu suchen, die die in Konflikt stehende Proxyadresse verwenden.

  1. Stellen Sie eine Verbindung mit Exchange Online PowerShell her.

  2. Führen Sie den folgenden Befehl aus, um alle E-Mail-Empfänger aufzulisten, die die in Konflikt stehende SMTP-Adresse verwenden:

    Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
    

    Wenn Sie die genaue SMTP-Adresse nicht kennen, führen Sie stattdessen den folgenden Befehl aus:

    Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<partial conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
    
  3. Eine Proxyadresse kann jeweils nur einem Objekt zugewiesen werden. Nachdem Sie ermittelt haben, welches Objekt in Konflikt steht, entfernen oder ändern Sie die Proxyadresse, die diesem Objekt zugeordnet ist.

Überprüfen und entfernen Sie alle in Konflikt stehenden Proxyadressen in Microsoft Entra ID

Wichtig

Für diese Lösung ist ein lokaler Server erforderlich, auf dem Microsoft Entra Connect installiert ist. Wenn Ihre lokale Infrastruktur außer Betrieb genommen wird, wenden Sie sich an Microsoft-Support.

Führen Sie die folgenden Schritte aus, um nach Microsoft Entra allen MEPFs zu suchen und daraus zu entfernen, die die in Konflikt stehende Proxyadresse verwenden. Diese Schritte erfordern einen lokalen Server, auf dem Microsoft Entra Connect Version 2.0 oder höher ausgeführt wird.

  1. Suchen Sie in allen lokalen MEPFs nach der in Konflikt stehenden Proxyadresse, indem Sie den folgenden Befehl in der lokalen Exchange-Verwaltungsshell (EMS) ausführen:

    Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"}
    
  2. Entfernen Sie für jedes lokale MEPF, das in Schritt 1 identifiziert wird, die in Konflikt stehende SMTP-Adresse, indem Sie den folgenden Befehl im lokalen EMS ausführen:

    Set-MailPublicFolder -Identity <public folder name or GUID> -EmailAddresses @{remove="<conflicting SMTP address>"} -EmailAddressPolicyEnabled:$false
    

    Mit diesem Schritt werden alle Proxyadressenkonflikte auf der lokalen Seite entfernt, um sicherzustellen, dass sie nicht mit Microsoft Entra ID oder Exchange Online synchronisiert werden.

  3. Wenn Sie in Schritt 2 eine in Konflikt stehende SMTP-Adresse aus einem lokalen MEPF entfernt haben, warten Sie, bis die nächste geplante Synchronisierung auf dem Microsoft Entra Connect-Server ausgeführt wird, oder starten Sie manuell einen Synchronisierungszyklus, indem Sie den folgenden PowerShell-Befehl ausführen:

    Start-ADSyncSyncCycle -PolicyType Delta
    

    Die Synchronisierung sollte die in Konflikt stehende SMTP-Adresse aus Microsoft Entra ID entfernen.

  4. Wenn Sie die in Konflikt stehende SMTP-Adresse in keinem lokalen MEPF gefunden haben oder die in Konflikt stehende SMTP-Adresse nicht aus Microsoft Entra ID entfernt wurde, suchen Sie Microsoft Entra ID nach MEPFs mit der in Konflikt stehenden SMTP-Adresse. Um in Microsoft Entra ID nach MEPFs zu suchen, verwenden Sie das PowerShell-Cmdlet Get-ADSyncToolsAadObject auf dem Microsoft Entra Connect-Server. Bei der Suche wird die Groß-/Kleinschreibung nicht beachtet. Fügen Sie das Präfix "smtp:" ein, wenn Sie die SMTP-Adresse angeben.

    $mailEnabledPublicFolders = Get-ADSyncToolsAadObject -SyncObjectType "PublicFolder" -Credential (Get-Credential)
    
    $conflictingSmtpAddress = "smtp:<conflicting SMTP address>"
    
    $mailEnabledPublicFolders | Where-Object {$_.ProxyAddresses -icontains $conflictingSmtpAddress} | Select SourceAnchor
    

    Die Suchergebnisse enthalten den SourceAnchor für jeden MEPF, der die Suchkriterien erfüllt.

  5. Entfernen Sie für jeden MEPF, der in Schritt 4 identifiziert wird, den MEPF aus Microsoft Entra ID, indem Sie das Cmdlet Remove-ADSyncToolsAadObject verwenden. Geben Sie den SourceAnchor Wert des MEPF im Base64-Format an.

    $conflictingSourceAnchor= "SourceAnchor value"
    
    Remove-ADSyncToolsAadObject -SourceAnchor $conflictingSourceAnchor -SyncObjectType "PublicFolder" -Credentials (Get-Credential)
    

    Ein Beispiel für die Cmdlet-Verwendung finden Sie unter Remove-ADSyncToolsAadObject– Beispiel 2.

  6. Führen Sie die Microsoft Entra ID Suche aus Schritt 4 erneut aus. Dieses Mal sollten die Suchergebnisse keine MEPFs zurückgeben.