Querladen von Office-Add-Ins auf dem iPad und Mac zu TestzweckenSideload Office Add-ins on iPad and Mac for testing

Wenn Sie sehen möchten, wie Ihr Add-In in Office unter iOS ausgeführt wird, können Sie das Manifest Ihres Add-Ins mithilfe von iTunes auf ein iPad oder direkt in Office auf einem Mac querladen. Dies ermöglicht Ihnen zwar nicht, Haltepunkte festzulegen und den Code Ihres Add-Ins während der Ausführung zu debuggen, aber Sie können sehen, wie sich das Add-In verhält und überprüfen, ob die Benutzeroberfläche nutzbar ist und ordnungsgemäß gerendert wird.To see how your add-in will run in Office for iOS, you can sideload your add-in's manifest onto an iPad using iTunes, or sideload your add-in's manifest directly in Office for Mac. This action won't enable you to set breakpoints and debug your add-in's code while it's running, but you can see how it behaves and verify that the UI is usable and rendering appropriately.

Voraussetzungen für Office unter iOSPrerequisites for Office for iOS

  • Ein Windows- oder Mac-Computer, auf dem iTunes installiert istA Windows or Mac computer with iTunes installed.

  • Ein iPad mit iOS 8.2 oder höher, auf dem Excel für iPad installiert ist, und ein Sync-KabelAn iPad running iOS 8.2 or later with Excel for iPad installed, and a sync cable.

  • Die Manifest-XML-Datei für das Add-In, das Sie testen möchtenThe manifest .xml file for the add-in you want to test.

Voraussetzungen für Office auf einem MacPrerequisites for Office for Mac

  • Ein Mac mit OS X v10.10 "Yosemite" oder höher, auf dem Office für Mac installiert ist.A Mac running OS X v10.10 "Yosemite" or later with Office for Mac installed.

  • Word für Mac, Version 15.18 (160109)Word for Mac version 15.18 (160109)

  • Excel für Mac, Version 15.19 (160206)Excel for Mac version 15.19 (160206)

  • PowerPoint für Mac, Version 15.24 (160614)PowerPoint for Mac version 15.24 (160614)

  • Die Manifest-XML-Datei für das Add-In, das Sie testen möchtenThe manifest .xml file for the add-in you want to test.

Querladen eines Add-Ins in Excel oder Word auf einem iPadSideload an add-in on Excel or Word for iPad

  1. Verwenden Sie Sync-Kabel, um Ihr iPad mit Ihrem Computer zu verbinden. Wenn Sie das iPad zum ersten Mal mit Ihrem Computer verbinden, wird die Eingabeaufforderungen Diesem Computer vertrauen? angezeigt. Wählen Sie Vertrauen um fortzufahren.Use a sync cable to connect your iPad to your computer. If you're connecting the iPad to your computer for the first time, you'll be prompted with Trust This Computer?. Choose Trust to continue.

  2. Wählen Sie in iTunes das iPad-Symbol unter der Menüleiste aus.In iTunes, choose the iPad icon below the menu bar.

  3. Klicken Sie unter Einstellungen auf der linken Seite von iTunes auf Apps.Under Settings on the left side of iTunes, choose Apps.

  4. Blättern Sie auf der rechten Seite von iTunes hinunter zu Dateifreigabe, und wählen Sie dann Excel oder Word in der Spalte Add-Ins aus.On the right side of iTunes, scroll down to File Sharing, and then choose Excel or Word in the Add-ins column.

  5. Klicken Sie am unteren Rand der Spalte Exceloder Word-Dokumente auf Datei hinzufügen, und wählen Sie dann die Manifest-XML-Datei des Add-Ins aus, das Sie querladen möchten.At the bottom of the Excel or Word Documents column, choose Add File, and then select the manifest .xml file of the add-in you want to sideload.

  6. Öffnen Sie die Excel- oder Word-App auf Ihrem iPad. Wenn die Excel- oder Word-App bereits ausgeführt wird, wählen Sie die Schaltfläche Start, schließen Sie die App, und starten Sie sie neu.Open the Excel or Word app on your iPad. If the Excel or Word app is already running, choose the Home button, and then close and restart the app.

  7. Öffnen Sie ein Dokument.Open a document.

  8. Wählen Sie Add-Ins auf der Registerkarte Einfügen aus. Ihr quergeladenes Add-In steht unter der Überschrift Entwickler in der Benutzeroberfläche Add-Ins zum Einfügen bereit.Choose Add-ins on the Insert tab. Your sideloaded add-in is available to insert under the Developer heading in the Add-ins UI.

    Einfügen von Add-Ins in die Excel-App

Querladen eines Add-Ins in Office auf einem MacSideload an add-in on Office for Mac

Hinweis

Informationen zum Querladen eines Outlook-Add-Ins auf einem Mac finden Sie unter Querladen von Outlook-Add-Ins zu Testzwecken.To sideload an Outlook add-in, see Sideload Outlook add-ins for testing.

  1. Öffnen Sie Terminal, und wechseln Sie zu einem der folgenden Ordner, in dem Sie die Manifestdatei Ihre Add-Ins speichern müssen. Wenn der Ordner wef nicht auf dem Computer vorhanden ist, erstellen Sie diesen.Open Terminal and go to one of the following folders where you'll save your add-in's manifest file. If the wef folder doesn't exist on your computer, create it.

    • Für Word: /Users/<username>/Library/Containers/com.microsoft.Word/Data/Documents/wefFor Word: /Users/<username>/Library/Containers/com.microsoft.Word/Data/Documents/wef
    • Für Excel: /Users/<username>/Library/Containers/com.microsoft.Excel/Data/Documents/wefFor Excel: /Users/<username>/Library/Containers/com.microsoft.Excel/Data/Documents/wef
    • Für PowerPoint: /Users/<username>/Library/Containers/com.microsoft.Powerpoint/Data/Documents/wefFor PowerPoint: /Users/<username>/Library/Containers/com.microsoft.Powerpoint/Data/Documents/wef
  2. Öffnen Sie den Ordner im Finder mithilfe des Befehls open . (einschließlich des Punkts). Kopieren Sie die Manifestdatei Ihres Add-Ins in diesen Ordner.Open the folder in Finder using the command open . (including the period or dot). Copy your add-in's manifest file to this folder.

    Wef-Ordner in Office auf einem Mac

  3. Öffnen Sie Word, und öffnen Sie dann ein Dokument. Starten Sie, wenn nichts bereits ausgeführt, Word neu.Open Word, and then open a document. Restart Word if it's already running.

  4. Wählen Sie in Word die Option Einfügen > Add-Ins > Meine Add-Ins (Dropdownmenü) aus, und wählen Sie dann Ihr Add-In aus.In Word, choose Insert > Add-ins > My Add-ins (drop-down menu), and then choose your add-in.

    Meine Add-Ins in Office auf einem Mac

    Wichtig

    Quergeladene Add-Ins werden im Dialogfeld „Meine Add-Ins“ nicht angezeigt. Sie werden nur im Dropdownmenü (kleiner Pfeil nach unten rechts neben „Meine Add-Ins“ auf derRegisterkarte Einfügen) angezeigt. Quergeladene Add-Ins werden in diesem Mneü unter Entwickler-Add-Ins aufgeführt.Sideloaded add-ins will not show up in the My Add-ins dialog box. They are only visible within the drop-down menu (small down-arrow to the right of My Add-ins on the Insert tab). Sideloaded add-ins are listed under the Developer Add-ins heading in this menu.

  5. Überprüfen Sie, ob Ihr Add-In in Word angezeigt wird.Verify that your add-in is displayed in Word.

    In Office auf einem Mac angezeigtes Office-Add-In

Löschen des Caches der Office-Anwendung auf einem MacClearing the Office application's cache on a Mac or iPad

Add-Ins werden aus Leistungsgründen häufig in Office für Mac zwischengespeichert.Add-ins are often cached in Office for Mac, for performance reasons. Normalerweise wird der Cache gelöscht, indem das Add-In neu geladen wird.Normally, the cache is cleared by reloading the add-in. Wenn mehr als ein Add-in im gleichen Dokument vorhanden ist, ist der Vorgang des automatischen Löschens des Caches beim erneuten Laden möglicherweise nicht zuverlässig.If more than one add-in exists in the same document, the process of automatically clearing the cache on reload might not be reliable.

Sie können den Cache löschen, indem Sie das Persönlichkeits Menü eines beliebigen Aufgabenbereich-Add-Ins verwenden.You can clear the cache by using the personality menu of any task pane add-in.

  • Wählen Sie das Menü Persönlichkeit aus.Choose the personality menu. Wählen Sie dann Clear-Webcacheaus.Then choose Clear Web Cache.

    Hinweis

    Sie müssen macOS-Version 10.13.6 oder höher ausführen, um das Persönlichkeits Menü anzuzeigen.You must run macOS version 10.13.6 or later to see the personality menu.

    Screenshot der Option "Clear-Webcache" im Menü "Persönlichkeit".

Sie können den Cache auch manuell löschen, indem Sie den Inhalt des ~/Library/Containers/com.Microsoft.OsfWebHost/Data/ Ordners löschen.You can also clear the cache manually by deleting the contents of the ~/Library/Containers/com.Microsoft.OsfWebHost/Data/ folder.

Hinweis

Wenn dieser Ordner nicht vorhanden ist, überprüfen Sie die folgenden Ordner, und wenn gefunden, löschen Sie den Inhalt des Ordners:If that folder doesn't exist, check for the following folders and if found, delete the contents of the folder:

  • ~/Library/Containers/com.microsoft.{host}/Data/Library/Caches/wo {host} ist der Office-Host (beispielsweise Excel)~/Library/Containers/com.microsoft.{host}/Data/Library/Caches/ where {host} is the Office host (e.g., Excel)
  • com.microsoft.Office365ServiceV2/Data/Caches/com.microsoft.Office365ServiceV2/

Siehe auchSee also